The NetBSD Project

CVS log for pkgsrc/editors/dte/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / editors / dte

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.6 / (download) - annotate - [select for diffs], Fri Jan 5 14:41:20 2024 UTC (3 months, 1 week ago) by bacon
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Changes since 1.5: +6 -4 lines
Diff to previous 1.5 (colored)

editors/dte: Update to 1.11.1

Packaging changes:
- Removed requirement for terminfo and curses as upstream now uses
  their own built-in support for terminals.

Changes from 1.11.0 -> 1.11.1:

Additions:
Fixes:
- Fixed a bug that was causing key bindings to not work properly when
  the Num Lock and/or Caps Lock modifiers were in effect in terminals
  supporting the [kitty keyboard protocol].
- Fixed the `save` command, to avoid breaking hard links when writing
  to existing files.
- Fixed an issue in the build system causing `make distcheck` to fail.

Other changes:
- Changed built-in filetype detection so that a `dot_` filename
  prefix isequivalent to a `.` prefix, or more specifically
  `dot_bashrc` is now treated the same way as `.bashrc`.
- Changed the `default` command in `dte-syntax` files to show an error
  if there are duplicate arguments.
- Removed the built-in `xsel` alias.


Changes from 1.10.0 -> 1.11.0:
Additions:
- Added 15 new command flags (see CHANGELOG.md)
- Added a new `exec` command.
- Added `overwrite` and `optimize-true-color` options.
- Added built-in `$RFILE`, `$FILEDIR` and `$COLNO` variables.
- Added `hi`, `msg` and `set` arguments to the `show` command.
- Added a _number_ argument to the `msg` command.
- Added support for 3-digit `#rgb` colors to the `hi` command.
- Added support for binding F13-F20 keys.
- Added support for parsing alternate encodings of F1-F4 keys
  (e.g. `CSI P`) sent by some terminals.
- Added support for the Kitty keyboard protocol.
- Added syntax highlighters for JSON, Go Module (`go.mod`), G-code
  and `.gitignore` files.
- Added support for binary literals and hex float literals to the C
  syntax highlighter.
- Added support for escaped newlines in string literals to the C
  syntax highlighter.
- Added support for `<<-EOF` heredocs to the shell syntax highlighter.
- Added support for template literals to the JavaScript syntax
  highlighter.
- Added support for terminal "synchronized updates" (both the
  DCS-based variant and the private mode `2026` variant).
- Added documentation for the `bookmark` command.
- Added `$PATH`, `$PWD`, `$OLDPWD` and `$DTE_VERSION` to the
  environment section of the `dte` man page.
- Added extended support for Contour and WezTerm terminals.
- Added an AppStream metadata file, which is installed by default when
  running `make install` (except on macOS).

Improvements:
- Updated Unicode support to version 15.
- Allowed `alias` and `errorfmt` entries to be removed, by running
  the commands with only 1 argument.
- Improved command auto-completion various commands.
- Improved documentation for various commands.
- Changed `quit -p quit` to display the number of modified/unsaved
  buffers in the dialog prompt.
- Excluded `.` and `..` from filename auto-completions.
- Allowed `-c <command>` options to be used multiple (up to 8) times.
- Allowed `+lineno,colno` command-line arguments.
- Extended `line` command to accept a `lineno,colno` argument.
- Limited the size of `.editorconfig` files to 32MiB.
- Enabled "enhanced" regex features on macOS, by using the
  `REG_ENHANCED` flag when calling `regcomp(3)`.
- Improved support for the `modifyOtherKeys` keyboard mode, by
  emitting the escape sequence to enable it at startup.
- Various improvements to built-in filetype detection.
- Various performance/efficiency improvements.

Fixes:
- Fixed a bug that caused searches started by `search -r search` to
  be incorrectly recorded by `macro record`.
- Fixed a bug that caused "broken pipe" errors to occur if the
  terminal was resized during certain long-running commands (e.g.
  `compile`).
- Fixed several regular expressions in built-in configs that were
  using non-portable regex features (`\s`, `\b` and `\w`) and causing
  errors on some systems.
- Fixed a portability issue that was causing execution of external
  commands to fail with "function not implemented" errors on some
  systems.

Breaking changes:
- Changed the default Ctrl+v key binding to `paste -a paste`.
- Removed the `display-invisible` global option.
- Removed the `-b` flag from the `select` command.
- Renamed the built-in `coffeescript` filetype to `coffee`.
- Made the `str` command in `dte-syntax` files produce an error if
  used with single-byte arguments (`char` should be used instead).
- The `pipe-from` `-s` flag was effectively renamed to `-n`, as part
  of the made for the new `exec` command.

Other changes:
- Increased the minimum GNU Make version requirement to 4.0.
- Increased the minimum GCC version requirement to 4.8.


Changes from 1.9.1 -> 1.10.0:
Additions:
- Added 7 new commands
- Added 12 new command flags
- Added 2 new global options
- Added an optional *exitcode* argument to the `quit` command.
- Added `color`, `command`, `env`, `errorfmt`, `ft`, `macro`,
  `option`, `search` and `wsplit` arguments to the `show` command.
- Added support for the `\e` escape sequence in double-quoted command
  arguments.
- Added syntax highlighting for Lisp and Scheme files.
- Added an Alt+Enter key binding to search mode, for performing
  plain-text searches.
- Added a Shift+Tab key binding to command mode, for iteratating
  auto-completions in reverse order.
- Added `%b`, `%N` and `%S` statusline format specifiers.
- Added a large confirmation dialog, shown when `quit -p quit` is
  run with unsaved changes.
- Added the ability to exclude individual commands from command
  history.

Improvements:
- Updated Unicode support to version 13.
- Bound Ctrl+c to `copy -k` by default.
- Re-introduced built-in support for rxvt Ctrl/Alt/Shift key
  combinations.
- Fixed the handling of optional capture groups in `errorfmt`
  patterns.
- Improved the legibility of the default color scheme on a wider range
  of terminals.
- Changed the `filter` and `pipe-from` commands to set
  `$LINES`/`$COLUMNS` to the current window height/width, before
  running the specified program.
- Clarified which command flags in the [`dterc`] man page are mutually
  exclusive (by separating them with `|`).
- Fixed signal handling, to allow interrupting unresponsive/deadlocked
  child processes with Ctrl+c.
- Fixed command-line auto-completion to work properly when option
  flags are present.
- Various syntax highlighting improvements.
- Various terminal compatibility improvements.
- Various performance improvements.

Breaking changes:
- Removed support for linking to the system terminfo library. The
  terminfo database has only been used as a last resort source of
  information for several releases now. Most terminals that people
  are likely to be using already have built-in support in the editor,
  including several capabilities not available from terminfo. This is
  listed as a breaking change because it may break support for a few
  archaic hardware terminals (primarily those that aren't ECMA-48
  compatible or whose terminfo strings contain mandatory padding).
- Removed support for vertical tab bars (the `tab-bar` option was
  changed from an enum to a Boolean).

Revision 1.5 / (download) - annotate - [select for diffs], Tue Oct 26 10:21:26 2021 UTC (2 years, 5 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

editors: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Revision 1.4 / (download) - annotate - [select for diffs], Thu Oct 7 13:47:37 2021 UTC (2 years, 6 months ago) by nia
Branch: MAIN
Changes since 1.3: +1 -2 lines
Diff to previous 1.3 (colored)

editors: Remove SHA1 hashes for distfiles

Revision 1.3 / (download) - annotate - [select for diffs], Mon Mar 23 20:00:47 2020 UTC (4 years ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

dte: Update to 1.9.1

v1.9.1 (latest release)
-----------------------

**Changes:**

* Fixed `make check` when running from a release tarball.

v1.9
----

**Additions:**

* Added a new `pipe-to` command, to complement the existing `pipe-from`
  and `filter` commands.
* Added a new `show` command, which can be used to introspect the
  current values of aliases and bindings.
* Added a `-k` flag to the `copy` command, to allow keeping the current
  selection after copying.
* Added a man page entry for the (previously undocumented) `eval`
  command.
* Added new `$FILETYPE` and `$LINENO` special variables.
* Added a `display-invisible` global option, to allow visible rendering
  of otherwise invisible Unicode characters.
* Added an `-s` command-line flag, for validating custom syntax files.
* Added a compile-time `ICONV_DISABLE=1` option, which disables linking
  to the system iconv library (but makes the editor UTF-8 only).
* Added a Desktop Entry file, which can be installed using
  `make install-desktop-file`.

**Improvements:**

* Updated Unicode support to version 12.1.
* Modified the `errorfmt` command, to allow sub-match groups in the
  regexp pattern to be ignored.
* Various improvements to syntax highlighting and filetype detection.
* Various performance optimizations.

**Fixes:**

* Fixed a bug that would sometimes cause files to be saved as UTF-8,
  even if another encoding was specified.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Apr 26 14:57:57 2019 UTC (4 years, 11 months ago) by bsiegert
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.1: +5 -5 lines
Diff to previous 1.1 (colored)

Update dte to 1.8.2.

From Craig Barnes via Github PR.

Closes NetBSD/pkgsrc#47.

v1.8.2 (latest release)
-----------------------

Released on 2019-04-23.

**Changes:**

* Fixed makefile to work with GNU Make 3.81 (which is still used
  by OS X and Ubuntu 14.04).


v1.8.1
------

Released on 2019-04-22.

**Fixes:**

* Fixed parsing of escaped special characters in command arguments
  (which was causing Lua syntax highlighting to fail).
* Removed use of `rep` (repeat character) control sequence, due to
  problems caused by certain terminal emulators that claim to be
  "xterm" but don't support the full set of features in the xterm
  `terminfo(5)` entry (notably, the FreeBSD 12 console).

**Additions:**

* Show a confirmation prompt if Ctrl+q (quit) is pressed with unsaved
  changes, instead of a cryptic error message.


v1.8
----

Released on 2019-04-18.

**Additions:**

* Added support for 24-bit RGB terminal colors.
* Added support for `strikethrough` terminal attribute.
* Added support for `alias` names containing multi-byte Unicode characters.
* Added `refresh` command (to force a full screen redraw).
* Added `dte -K` command-line option (for keycode debugging).
* Added support for reading a buffer from `stdin` at startup.
* Added support for binding Ctrl/Alt/Shift + F1-F12 on xterm-like terminals.
* Added `-s` flag to `bol` command, to allow moving to beginning of indented
  text, before moving to beginning of line (a.k.a "smart home").
* Added `-c` flag to all cursor movement commands, to allow selecting
  characters while moving.
* Added `-l` flag to `up`, `down`, `pgup` and `pgdown` commands, to
  allow selecting whole lines while moving.
* Added default bindings for various Shift+key combinations, for doing
  GUI-style text selections.
* Added key bindings to command mode for deleting/erasing whole words
  (Alt+Delete and Alt+Backspace).

**Improvements:**

* Optimized built-in filetype detection.
* Fixed cursor interaction with Unicode combining characters.
* Improved handling of Unicode whitespace and unprintable characters.
* Updated character class lookup tables to Unicode 11.
* Expanded documentation for `hi` and `compile` commands.
* Optimized code to reduce editor startup and input latency.

**Breaking changes:**

* Changed the `bind` command to be much more strict when parsing key
  strings and show an error message when invalid. The caret (`^`)
  modifier can now only be used alone (not in combination with other
  modifiers) and the `C-`, `M-` and `S-` modifiers *must* be
  uppercase.
* Removed support for chained key bindings (e.g. `bind '^X c' ...`).
  Commands that aren't bound to simple key combinations can just be
  accessed via command mode.
* Removed support for recognizing some Ctrl/Alt/Shift key combinations
  produced by the `rxvt` terminal emulator. The key codes produced by
  `rxvt` violate the [ECMA-48] specification. Users of such terminals
  are encouraged to configure the key codes to mimic `xterm` instead.


v1.7
----

Released on 2018-05-08.

**Changes:**

* Added support for opening multiple files using glob patterns
  (e.g. `open -g *.[ch]`).
* Added support for binding more xterm extended key combinations
  (Ctrl/Meta/Shift + PageUp/PageDown/Home/End).
* Improved compiler error parsing for newer versions of GCC.
* Improved handling of underline/dim/italic terminal attributes
  (including support for the `ncv` terminfo capability).
* Many other small bug fixes and code improvements.


v1.6
----

Released on 2017-12-20.

**Changes:**

* Added new, default `dark` color scheme.
* Added Ctrl+G key binding to exit command mode.
* Added Ctrl+H key binding for `erase` command.
* Added syntax highlighting for TeX and roff (man page) files.
* Improved syntax highlighting of Python numeric literals.
* Improved syntax highlighting for CSS files.
* Added `ft -b` command for detecting file types from file basenames.
* Converted user documentation to Markdown format.
* Created new [website] for online documentation.
* Added support for terminfo extended (or "user-defined") capabilities.
* Added built-in support for `st` and `rxvt` terminals.
* Fixed some built-in regex patterns to avoid non-portable features.
* Fixed compiler warnings on NetBSD.
* Removed tilde expansion of `~username` from command mode, in order to
  avoid using `getpwnam(3)` and thereby allow static linking with GNU
  libc on Linux.

Revision 1.1 / (download) - annotate - [select for diffs], Fri Nov 24 06:46:01 2017 UTC (6 years, 4 months ago) by kamil
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4

editors/dte: import dte-1.5

dte is a small and easy to use console text editor.

Features:

 - Multiple buffers/tabs
 - Unlimited undo/redo
 - Search and replace
 - Syntax highlighting
 - Customizable color schemes
 - Customizable key bindings
 - Command language with auto-completion
 - Jump to definition (using ctags)
 - Jump to compiler error

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>