[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / editors / TeXmacs

File: [cvs.NetBSD.org] / pkgsrc / editors / TeXmacs / Makefile (download)

Revision 1.70, Wed Sep 5 16:40:34 2007 UTC (16 years, 7 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2007Q3-base, pkgsrc-2007Q3
Changes since 1.69: +2 -3 lines

update to 1.0.6.11
changes:
-More control for developers over buffer and window management
-Started rewriting new TeXmacs file system in C++
-Rewrote secure peer to peer client/server connections in C++
-Continued reorganizations for the graphics mode
-Corrections of a few old bugs

# $NetBSD: Makefile,v 1.70 2007/09/05 16:40:34 drochner Exp $

DISTNAME=		TeXmacs-1.0.6.11-src
PKGNAME=		${DISTNAME:S/-src//}
CATEGORIES=		editors
MASTER_SITES=		ftp://ftp.texmacs.org/pub/TeXmacs/targz/
MASTER_SITES+=		http://www.texmacs.org/Download/ftp/targz/

MAINTAINER=		ghen@NetBSD.org
HOMEPAGE=		http://www.texmacs.org/
COMMENT=		GNU TeXmacs (free scientific text editor)

BUILD_TARGET=		TEXMACS

USE_TOOLS+=		gmake
USE_LANGUAGES=		c c++
GNU_CONFIGURE=		yes
TEX_ACCEPTED=		teTeX3

PYTHON_PATCH_SCRIPTS=	plugins/python/bin/tm_python

SUBST_CLASSES+=		init
SUBST_STAGE.init=	post-patch
SUBST_FILES.init=	plugins/python/progs/init-python.scm
SUBST_SED.init=		-e 's,@PYTHONBIN@,${PYTHONBIN},g'

REPLACE_INTERPRETER+=	bash
REPLACE.bash.old=	/bin/bash
REPLACE.bash.new=	${SH}
REPLACE_FILES.bash+=	plugins/dratex/bin/tm_dratex
REPLACE_FILES.bash+=	plugins/eukleides/bin/tm_eukleides
REPLACE_FILES.bash+=	plugins/gnuplot/bin/tm_gnuplot
REPLACE_FILES.bash+=	plugins/lisp/bin/tm_lisp
REPLACE_FILES.bash+=	plugins/lush/bin/tm_lush
REPLACE_FILES.bash+=	plugins/matlab/bin/tm_matlab
REPLACE_FILES.bash+=	plugins/maxima/bin/maxima_detect
REPLACE_FILES.bash+=	plugins/maxima/bin/tm_maxima
REPLACE_FILES.bash+=	plugins/mupad/bin/tm_mupad_help
REPLACE_FILES.bash+=	plugins/octave/bin/tm_octave
REPLACE_FILES.bash+=	plugins/reduce/bin/tm_reduce
REPLACE_FILES.bash+=	plugins/xypic/bin/tm_xypic

pre-install:
	${RM} -f ${WRKSRC}/TeXmacs/doc/devel/format/.log
	${FIND} ${WRKSRC}/plugins/ -name '*.orig' | ${XARGS} ${RM}

BUILDLINK_DEPMETHOD.libXt?=	build

.include "../../converters/libiconv/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../lang/guile/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../mk/tex.buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"