[BACK]Return to Makefile-example CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / doc

File: [cvs.NetBSD.org] / pkgsrc / doc / Makefile-example (download)

Revision 1.5, Sun Feb 22 15:57:32 2004 UTC (20 years, 2 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.4: +15 -7 lines

Sync with reality: add a paragraph for *_OVERRIDE variables and another one
for configure and make args/environment.  Ok'ed by agc@.

# $NetBSD: Makefile-example,v 1.5 2004/02/22 15:57:32 jmmv Exp $

# First paragraph - distfile and binary package data
# DISTNAME PKGNAME PKGREVISION SVR4_PKGNAME CATEGORIES MASTER_SITES
# DYNAMIC_MASTER_SITES MASTER_SITE_SUBDIR EXTRACT_SUFX DISTFILES
DISTNAME=		make-3.80
PKGNAME=		gmake-3.80	# only to be added if the package name is different from DISTNAME
#PKGREVISION=		2		# should be added/incremented for user-visible changes
CATEGORIES=		devel gnu	# multiple categories are allowed
MASTER_SITES=		${MASTER_SITE_GNU:=make/}
#EXTRACT_SUFX=		.tar.bz2	# .tar.gz is the default, only needed in unusual circumstances

# Second paragraph - MAINTAINER, HOMEPAGE and COMMENT
MAINTAINER=		tech-pkg@NetBSD.org	# set this to your email address, tech-pkg@ is the default
HOMEPAGE=		http://www.gnu.org/software/make/make.html
COMMENT=		GNU version of 'make' utility	# start with a capital, no articles at start

# Third paragraph - licensing information
# Please set RESTRICTED to the relevant reason, and use it to define NO_{SRC,BIN}_ON_{FTP,CDROM}
# Any specific licence should be added to the pkgsrc/licenses directory
RESTRICTED=		"Redistribution of unmodified source only; resale prohibited."
NO_SRC_ON_CDROM=	${RESTRICTED}
NO_BIN_ON_FTP=		${RESTRICTED}
NO_BIN_ON_CDROM=	${RESTRICTED}
LICENSE=		hptools-license

# Fourth paragraph - PKG_INSTALLATION_TYPES
PKG_INSTALLATION_TYPES=	overwrite pkgviews	# needed for package views-ready packages

# Fifth paragraph - all build definitions that describe things used by
# the package.  These include: WRKSRC, USE_BUILDLINK2, USE_BUILDLINK3,
# GNU_CONFIGURE, HAS_CONFIGURE, USE_PKGLOCALEDIR, USE_INSTALL, TEXINFO_REQD,
# USE_JAVA, USE_PERL5, INFO_FILES, DIST_SUBDIR, etc.
DIST_SUBDIR=		gmake
GNU_CONFIGURE=		yes
INFO_FILES=		make.info	# any info files, whitespace delimited
TEXINFO_REQD=		4.0		# version of texinfo which is necessary
USE_BUILDLINK3=		yes
USE_PKGLOCALEDIR=	yes
WRKSRC=			${WRKDIR}/src

# Sixth paragraph - file overrides; these are all *_OVERRIDE variables
LIBTOOL_OVERRIDE+=	build/unix/tools/libtool
PKGCONFIG_OVERRIDE+=	glib-2.0.pc.in

# Seventh paragraph - modification of configure and make environments
CONFIGURE_ARGS+=	--disable-gtk-doc
CONFIGURE_ENV+=		ac_cv_path_PYTHON="${PYTHONBIN}"
MAKE_ENV+=		PKG_SYSCONFDIR="${PKG_SYSCONFDIR}"

# Eighth paragraph - different targets
# ALL_TARGET, INSTALL_TARGET, TEST_TARGET
TEST_TARGET=		check

# always include bsd.prefs.mk before any .if or .ifdef statements
.include "../../mk/bsd.prefs.mk"

.if defined(GNU_PROGRAM_PREFIX)
# indent nested "if" by 2 spaces please
.  if ${GNU_PROGRAM_PREFIX} == "g"
CONFIGURE_ARGS+=	--program-prefix=${GNU_PROGRAM_PREFIX}
.  endif
.endif
PLIST_SUBST+=		GNU_PROGRAM_PREFIX=${GNU_PROGRAM_PREFIX}
BUILD_DEFS+=		GNU_PROGRAM_PREFIX

# buildlink[23] files should come after all variables have been set,
# sorted alphabetically.
.include "../../devel/gettext-lib/buildlink3.mk"

# The section that handles pthreads should come after all other buildlink[23]
# files have been included.
.include "../../mk/pthread.buildlink3.mk"
.if ${PTHREAD_TYPE} == "none"
CONFIGURE_ARGS+=	--disable-threads
.endif

# Makefile targets should occur after all the other definitions in the file
post-install:
	${CHMOD} g-s ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
	${CHGRP} ${BINGRP} ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
.if !defined(GNU_PROGRAM_PREFIX) || ${GNU_PROGRAM_PREFIX} != "g"
	# Solaris's "ln -fs" is not the same as on *BSD - use an explicit rm(1) instead
	${RM} -f ${PREFIX}/bin/gmake
	${LN} -s ${GNU_PROGRAM_PREFIX}make ${PREFIX}/bin/gmake
.endif

# Finally, please include bsd.pkg.mk
.include "../../mk/bsd.pkg.mk"