[BACK]Return to Makefile-example CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / doc

Annotation of pkgsrc/doc/Makefile-example, Revision 1.8

1.8     ! rillig      1: # $NetBSD: Makefile-example,v 1.7 2004/11/11 06:05:55 minskim Exp $
1.1       agc         2:
                      3: # First paragraph - distfile and binary package data
                      4: # DISTNAME PKGNAME PKGREVISION SVR4_PKGNAME CATEGORIES MASTER_SITES
                      5: # DYNAMIC_MASTER_SITES MASTER_SITE_SUBDIR EXTRACT_SUFX DISTFILES
                      6: DISTNAME=              make-3.80
                      7: PKGNAME=               gmake-3.80      # only to be added if the package name is different from DISTNAME
                      8: #PKGREVISION=          2               # should be added/incremented for user-visible changes
1.3       agc         9: CATEGORIES=            devel gnu       # multiple categories are allowed
1.1       agc        10: MASTER_SITES=          ${MASTER_SITE_GNU:=make/}
                     11: #EXTRACT_SUFX=         .tar.bz2        # .tar.gz is the default, only needed in unusual circumstances
                     12:
                     13: # Second paragraph - MAINTAINER, HOMEPAGE and COMMENT
                     14: MAINTAINER=            tech-pkg@NetBSD.org     # set this to your email address, tech-pkg@ is the default
                     15: HOMEPAGE=              http://www.gnu.org/software/make/make.html
1.2       agc        16: COMMENT=               GNU version of 'make' utility   # start with a capital, no articles at start
1.1       agc        17:
1.3       agc        18: # Third paragraph - licensing information
                     19: # Please set RESTRICTED to the relevant reason, and use it to define NO_{SRC,BIN}_ON_{FTP,CDROM}
                     20: # Any specific licence should be added to the pkgsrc/licenses directory
                     21: RESTRICTED=            "Redistribution of unmodified source only; resale prohibited."
                     22: NO_SRC_ON_CDROM=       ${RESTRICTED}
                     23: NO_BIN_ON_FTP=         ${RESTRICTED}
                     24: NO_BIN_ON_CDROM=       ${RESTRICTED}
                     25: LICENSE=               hptools-license
                     26:
                     27: # Fourth paragraph - PKG_INSTALLATION_TYPES
1.1       agc        28: PKG_INSTALLATION_TYPES=        overwrite pkgviews      # needed for package views-ready packages
                     29:
1.5       jmmv       30: # Fifth paragraph - all build definitions that describe things used by
1.6       wiz        31: # the package.  These include: WRKSRC, USE_BUILDLINK3, GNU_CONFIGURE,
                     32: # HAS_CONFIGURE, USE_PKGLOCALEDIR, USE_INSTALL, TEXINFO_REQD, USE_JAVA,
                     33: # USE_PERL5, INFO_FILES, DIST_SUBDIR, etc.
1.3       agc        34: DIST_SUBDIR=           gmake
                     35: GNU_CONFIGURE=         yes
                     36: INFO_FILES=            make.info       # any info files, whitespace delimited
                     37: TEXINFO_REQD=          4.0             # version of texinfo which is necessary
                     38: USE_BUILDLINK3=                yes
                     39: USE_PKGLOCALEDIR=      yes
1.1       agc        40: WRKSRC=                        ${WRKDIR}/src
                     41:
1.5       jmmv       42: # Sixth paragraph - file overrides; these are all *_OVERRIDE variables
                     43: LIBTOOL_OVERRIDE+=     build/unix/tools/libtool
                     44: PKGCONFIG_OVERRIDE+=   glib-2.0.pc.in
                     45:
                     46: # Seventh paragraph - modification of configure and make environments
                     47: CONFIGURE_ARGS+=       --disable-gtk-doc
                     48: CONFIGURE_ENV+=                ac_cv_path_PYTHON="${PYTHONBIN}"
                     49: MAKE_ENV+=             PKG_SYSCONFDIR="${PKG_SYSCONFDIR}"
                     50:
                     51: # Eighth paragraph - different targets
1.8     ! rillig     52: # BUILD_TARGET, INSTALL_TARGET, TEST_TARGET
1.1       agc        53: TEST_TARGET=           check
                     54:
                     55: # always include bsd.prefs.mk before any .if or .ifdef statements
                     56: .include "../../mk/bsd.prefs.mk"
                     57:
                     58: .if defined(GNU_PROGRAM_PREFIX)
1.3       agc        59: # indent nested "if" by 2 spaces please
                     60: .  if ${GNU_PROGRAM_PREFIX} == "g"
1.1       agc        61: CONFIGURE_ARGS+=       --program-prefix=${GNU_PROGRAM_PREFIX}
1.3       agc        62: .  endif
1.1       agc        63: .endif
                     64: PLIST_SUBST+=          GNU_PROGRAM_PREFIX=${GNU_PROGRAM_PREFIX}
                     65: BUILD_DEFS+=           GNU_PROGRAM_PREFIX
                     66:
1.7       minskim    67: # buildlink3 files should come after all variables have been set,
1.4       jlam       68: # sorted alphabetically.
                     69: .include "../../devel/gettext-lib/buildlink3.mk"
                     70:
                     71: # The section that handles pthreads should come after all other buildlink[23]
                     72: # files have been included.
                     73: .include "../../mk/pthread.buildlink3.mk"
                     74: .if ${PTHREAD_TYPE} == "none"
                     75: CONFIGURE_ARGS+=       --disable-threads
                     76: .endif
                     77:
1.1       agc        78: # Makefile targets should occur after all the other definitions in the file
                     79: post-install:
                     80:        ${CHMOD} g-s ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
                     81:        ${CHGRP} ${BINGRP} ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
                     82: .if !defined(GNU_PROGRAM_PREFIX) || ${GNU_PROGRAM_PREFIX} != "g"
1.3       agc        83:        # Solaris's "ln -fs" is not the same as on *BSD - use an explicit rm(1) instead
                     84:        ${RM} -f ${PREFIX}/bin/gmake
                     85:        ${LN} -s ${GNU_PROGRAM_PREFIX}make ${PREFIX}/bin/gmake
1.1       agc        86: .endif
                     87:
                     88: # Finally, please include bsd.pkg.mk
                     89: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>