[BACK]Return to Makefile-example CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / doc

Annotation of pkgsrc/doc/Makefile-example, Revision 1.24

1.24    ! rillig      1: # $NetBSD: Makefile-example,v 1.23 2014/10/09 14:06:32 wiz Exp $
1.1       agc         2:
                      3: # First paragraph - distfile and binary package data
1.22      wiz         4: # DISTNAME PKGNAME PKGREVISION CATEGORIES MASTER_SITES
1.14      jlam        5: # MASTER_SITE_SUBDIR EXTRACT_SUFX DISTFILES
1.1       agc         6: DISTNAME=              make-3.80
                      7: PKGNAME=               gmake-3.80      # only to be added if the package name is different from DISTNAME
                      8: #PKGREVISION=          2               # should be added/incremented for user-visible changes
1.3       agc         9: CATEGORIES=            devel gnu       # multiple categories are allowed
1.1       agc        10: MASTER_SITES=          ${MASTER_SITE_GNU:=make/}
                     11: #EXTRACT_SUFX=         .tar.bz2        # .tar.gz is the default, only needed in unusual circumstances
                     12:
1.18      agc        13: # Second paragraph - MAINTAINER/OWNER, HOMEPAGE and COMMENT, and LICEN[CS]E
1.12      jlam       14: MAINTAINER=            pkgsrc-users@NetBSD.org # set this to your email address, pkgsrc-users@ is the default
1.1       agc        15: HOMEPAGE=              http://www.gnu.org/software/make/make.html
1.2       agc        16: COMMENT=               GNU version of 'make' utility   # start with a capital, no articles at start
1.20      is         17: LICENSE=               hptools-license # Licenses should be added to the pkgsrc/licenses directory.
1.1       agc        18:
1.24    ! rillig     19: # Paragraph for any build or run dependencies -- not libraries,
1.19      wiz        20: # those should be handled using buildlink3.mk files.
                     21: # Not needed for gmake, just an example:
                     22: # BUILD_DEPENDS+=      automoc4-[0-9]*:../../devel/automoc4
                     23:
1.15      gdt        24: # Set RESTRICTED to a very short explanation (typically "No permission to
                     25: # redistribute for a fee.").  NO_*_ON_* may only be set to ${RESTRICTED}.
1.3       agc        26: RESTRICTED=            "Redistribution of unmodified source only; resale prohibited."
                     27: NO_SRC_ON_CDROM=       ${RESTRICTED}
                     28: NO_BIN_ON_FTP=         ${RESTRICTED}
                     29: NO_BIN_ON_CDROM=       ${RESTRICTED}
                     30:
1.21      asau       31: # if the package has to be created with root privileges
                     32: #PKG_DESTDIR_SUPPORT=  destdir
                     33: # if the package has to be installed directly
                     34: #PKG_DESTDIR_SUPPORT=  none
1.1       agc        35:
1.19      wiz        36: # Sixth paragraph - all build definitions that describe things used by
1.9       tv         37: # the package.  These include: WRKSRC, GNU_CONFIGURE,
1.6       wiz        38: # HAS_CONFIGURE, USE_PKGLOCALEDIR, USE_INSTALL, TEXINFO_REQD, USE_JAVA,
1.10      jlam       39: # INFO_FILES, DIST_SUBDIR, etc.
1.3       agc        40: DIST_SUBDIR=           gmake
                     41: GNU_CONFIGURE=         yes
1.13      jlam       42: INFO_FILES=            # defined if the package installs info files
1.3       agc        43: TEXINFO_REQD=          4.0             # version of texinfo which is necessary
                     44: USE_PKGLOCALEDIR=      yes
1.1       agc        45: WRKSRC=                        ${WRKDIR}/src
                     46:
1.19      wiz        47: # Seventh paragraph - file overrides; these are all *_OVERRIDE variables
1.5       jmmv       48: LIBTOOL_OVERRIDE+=     build/unix/tools/libtool
                     49: PKGCONFIG_OVERRIDE+=   glib-2.0.pc.in
                     50:
1.19      wiz        51: # Eighth paragraph - modification of configure and make environments
1.5       jmmv       52: CONFIGURE_ARGS+=       --disable-gtk-doc
                     53: CONFIGURE_ENV+=                ac_cv_path_PYTHON="${PYTHONBIN}"
                     54: MAKE_ENV+=             PKG_SYSCONFDIR="${PKG_SYSCONFDIR}"
                     55:
1.19      wiz        56: # Ninth paragraph - different targets
1.8       rillig     57: # BUILD_TARGET, INSTALL_TARGET, TEST_TARGET
1.1       agc        58: TEST_TARGET=           check
                     59:
                     60: # always include bsd.prefs.mk before any .if or .ifdef statements
                     61: .include "../../mk/bsd.prefs.mk"
                     62:
                     63: .if defined(GNU_PROGRAM_PREFIX)
1.3       agc        64: # indent nested "if" by 2 spaces please
                     65: .  if ${GNU_PROGRAM_PREFIX} == "g"
1.1       agc        66: CONFIGURE_ARGS+=       --program-prefix=${GNU_PROGRAM_PREFIX}
1.3       agc        67: .  endif
1.1       agc        68: .endif
                     69: PLIST_SUBST+=          GNU_PROGRAM_PREFIX=${GNU_PROGRAM_PREFIX}
                     70: BUILD_DEFS+=           GNU_PROGRAM_PREFIX
                     71:
1.7       minskim    72: # buildlink3 files should come after all variables have been set,
1.4       jlam       73: # sorted alphabetically.
                     74: .include "../../devel/gettext-lib/buildlink3.mk"
                     75:
1.11      wiz        76: # The section that handles pthreads should come after all other buildlink3
1.4       jlam       77: # files have been included.
                     78: .include "../../mk/pthread.buildlink3.mk"
                     79: .if ${PTHREAD_TYPE} == "none"
                     80: CONFIGURE_ARGS+=       --disable-threads
                     81: .endif
                     82:
1.1       agc        83: # Makefile targets should occur after all the other definitions in the file
                     84: post-install:
                     85:        ${CHMOD} g-s ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
                     86:        ${CHGRP} ${BINGRP} ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
                     87: .if !defined(GNU_PROGRAM_PREFIX) || ${GNU_PROGRAM_PREFIX} != "g"
1.3       agc        88:        # Solaris's "ln -fs" is not the same as on *BSD - use an explicit rm(1) instead
                     89:        ${RM} -f ${PREFIX}/bin/gmake
                     90:        ${LN} -s ${GNU_PROGRAM_PREFIX}make ${PREFIX}/bin/gmake
1.1       agc        91: .endif
                     92:
                     93: # Finally, please include bsd.pkg.mk
                     94: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>