[BACK]Return to STATUS CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / doc

File: [cvs.NetBSD.org] / pkgsrc / doc / Attic / STATUS (download)

Revision 1.38, Wed May 14 15:27:41 2008 UTC (12 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.37: +2 -2 lines

Use python25 instead of removed python22.

$NetBSD: STATUS,v 1.38 2008/05/14 15:27:41 wiz Exp $

Below is a list of packages known to build on various non-NetBSD
platforms.  Currently, there are three categories.  If all packages in a given
category build, install, run and uninstall without any problems, then that
platform satisfies the conditions for this category and may be labeled
appropriately.


'supported' means that pkgsrc on this platform is more than just
experimental and can actually be used to provide a reliable environment
for the average user.  Note that by their requirements, these packages pull in
virtually all _essential_ packages that are not explicitly mentioned.


A 'fully supported' platform supports virtually all packages (if
available for that platform) and can reliably be used in a production
environment.


'yowza' finally adds a handful of packages that are known to be very
complex and may not even be fully functional under NetBSD on platforms
other than i386.


You are strongly encouraged to add leaf packages which are known to
build on certain platforms.

Some packages need only minor modifications to build on non-NetBSD
platforms. Please attempt to fix any packages which are broken, or
submit PRs if you are unable to.

Please add/correct entries as appropriate.


Legend:
Y	-	Builds and installs perfectly
N	-	Fails to configure, build or link
X	-	Builds successfully but has installation or PLIST problems
N/A	-	Not applicable (package not available for that platform)
blank	-	Unknown
[nnn]	-	associated pkg PR number
*	-	see footnote

---------------------------------------------------------------------------
Package                 Darwin   FreeBSD   IRIX   Linux   OpenBSD   Solaris
---------------------------------------------------------------------------
audio/mpg123               Y*       Y        Y      Y                  Y
devel/cvs                  Y        Y        Y      Y        Y         Y
devel/gettext              Y        Y        Y      Y        Y         Y
devel/libtool              Y        Y        Y      Y        Y         Y
devel/ncurses              Y        Y        Y      Y        X*        Y
editors/vim                Y        Y        Y      Y                  Y
editors/xemacs             Y                        Y
editors/emacs                                Y      Y
graphics/xfig              Y                        Y
graphics/xv                Y                        Y
lang/perl5                 Y        Y        Y      Y        Y         Y
mail/mutt                  Y        Y        Y      Y                  Y
meta-pkgs/XFree86	            Y		    Y
misc/screen                Y        Y        Y      Y                  Y
net/wget                   Y        Y        Y      Y
news/slrn                  Y        Y        Y      Y        Y
print/gv                   Y                 Y      Y
print/teTeX                Y                        Y
print/xpdf                 Y                        Y
security/openssh           Y                 Y      Y                  Y
security/openssl           Y                 Y      Y        N         Y
shells/tcsh                Y        Y        Y      Y        Y         Y
wm/blackbox                Y        Y        Y      Y
www/apache                 Y        Y        Y      Y        Y         Y
www/firefox-gtk2		    Y		    Y
www/links                  Y        Y        Y      Y                  Y
www/lynx                   Y        Y        N*     Y                  Y
---------------------------------------------------------------------------
'supported'                                         Y
---------------------------------------------------------------------------
notes:

Darwin/mpg123: no darwin support in mpg123, but mpg123-esound works
OpenBSD/ncurses: does not install a shared libncurses++ library.
IRIX/lynx: only builds without "--enable-nls"



---------------------------------------------------------------------------
Package                 Darwin   FreeBSD   IRIX   Linux   OpenBSD   Solaris
---------------------------------------------------------------------------
audio/xmms                          Y               Y                  Y
devel/gdb                                    Y      Y                  Y
editors/abiword
graphics/mplayer                    Y               Y                  N
lang/gcc                N/A                         Y                  Y
lang/gcc3               N/A                  Y      Y                  Y
lang/python25                                        
lang/ruby                                    Y      Y
lang/sun-j*                                         Y
lang/wonka
math/gnumeric
meta-pkgs/XFree86		    Y               Y
meta-pkgs/xorg			    Y		    Y
misc/openoffice
www/mozilla 			    Y               Y                  Y
www/opera7							       Y*
---------------------------------------------------------------------------
'fully supported'
---------------------------------------------------------------------------
notes:

Solaris/mplayer: depends on cdparanoia.
Solaris/mozilla: depends on net/ORBit (broken buildlink3/libtool libpthread
handling).
Solaris/opera7: spell checking with textproc/aspell not tested



---------------------------------------------------------------------------
Package                 Darwin   FreeBSD   IRIX   Linux   OpenBSD   Solaris
---------------------------------------------------------------------------
meta-pkgs/gnome			    Y[*]
misc/koffice
x11/kde3
---------------------------------------------------------------------------
'yowza'
---------------------------------------------------------------------------
notes:

[*] meta-pkgs/gnome FreeBSD: it builds cleanly, but there is a problem with
    gnome-session or any dependent library, which we'll fix soon. [xtraeme]