The NetBSD Project

CVS log for pkgsrc/devel/tomlplusplus/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / tomlplusplus

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.6: download - view: text, markup, annotated - select for diffs
Thu Oct 19 13:10:19 2023 UTC (16 months, 4 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
tomlplusplus: update to 3.4.0.

## v3.4.0

#### Fixes

-   fixed `value_flags` not being preserved correctly when inserting into tables and arrays (#108) (@LebJe)
-   fixed `toml::value::flags()` not being cleared when `std::move`-ing a value
-   fixed error in README (#195) (@andrewkcorcoran)
-   fixed compiler error when using NVCC (#198) (@thompsonnoahe)
-   fixed `noexcept(...)` sometimes being incorrectly derived on `for_each()`
-   fixed `for_each()` compilation error on GCC <= 7 (#197) (@sagi-ottopia, @damirbarr)
-   fixed `FLT_RADIX` check getting broken by Intel MKL headers (#202) (@iago-lito)
-   fixed keys containing `\t` incorrectly formatting as bare keys (@jasmine-zhu, @arp242)
-   fixed keys containing `\t` and `\n` not round-tripping correctly (@arp242)

#### Additions

-   added support for using enums with `value_or()`

#### Changes:

-   renamed header files to have `.hpp` extension (`toml.h` is still present for backwards-compatibility)

#### Build system:

-   fixed meson builds with `-Ddefault_library=static` having hidden symbols on GNU compilers (#201) (@vlad0x00)

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Apr 26 19:57:06 2023 UTC (22 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -4 lines
tomlplusplus: update to 3.3.0.

Now installs a library.

## v3.3.0

#### Fixes:

-   fixed null pointer dereference in parser when exceptions are disabled (#169) (@ncaklovic)
-   fixed spurious warnings in MSVC 19.34
-   fixed `toml::parse_file()` on windows for non-ASCII paths
-   fixed a spurious table redefinition error (#187) (@jorisvr)
-   fixed UB edge-case in integer parsing (#188) (@jorisvr)
-   fixed some build issues with Apple-flavoured Clang (#189) (@eddelbuettel)

#### Additions:

-   added `toml::format_flags::terse_key_value_pairs`
-   added `TOML_ENABLE_FLOAT16` config (#178) (@Scrumplex)

#### Removals:

-   removed automatic detection of `_Float16` (you must explicitly set `TOML_ENABLE_FLOAT16` to enable it) (#186) (@benthetechguy)

#### Build system:

-   re-wrote the meson scripts to fix a number of issues (#185, #186) (@Tachi107, @benthetechguy)
-   increased the minimum required meson version to `0.61.0`

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Sep 9 15:04:37 2022 UTC (2 years, 6 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +4 -4 lines
tomlplusplus: update to 3.2.0.

## v3.2.0

#### Fixes:
- fixed `[dotted.table]` source columns sometimes being off by one (#152) (@vaartis)
- fixed spurious `Wnull-dereference` warning on GCC (#164) (@zaporozhets)
- fixed `print_to_stream` ambiguity for `size_t` (#167) (@acronce)

#### Additions:
- added value type deduction to `emplace()` methods
- added `toml::path` utility type (#153, #156, #168) (@jonestristand, @kcsaul)
- added config option `TOML_CALLCONV`
- added missing relational operators for `source_position`

#### Changes:
- relaxed cvref requirements of `is_homogeneous()`, `emplace()`, `emplace_back()`, `emplace_hint()`
- relaxed mantissa and digits10 requirements of extended float support

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed May 4 06:44:12 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +4 -4 lines
tomlplusplus: update to 3.1.0.

## [v3.1.0]

#### Fixes:
- Fixed potential segfault when calling `at_path()` with an empty string
- Fixed UB in internal unicode machinery (#144) (@kchalmer)
- Fixed a number of spurious warnings with Clang 10 (#145, #146) (@chronoxor)

#### Additions:
- Added `toml::array::for_each()`
- Added `toml::table::for_each()`
- Added config options `TOML_EXPORTED_CLASS`, `TOML_EXPORTED_MEMBER_FUNCTION`, `TOML_EXPORTED_STATIC_FUNCTION` & `TOML_EXPORTED_FREE_FUNCTION`
- Added support for escape sequence `\e` when using `TOML_ENABLE_UNRELEASED_FEATURES`
- Added support for more unicode in bare keys when using `TOML_ENABLE_UNRELEASED_FEATURES`

#### Removals/Deprecations:
- Deprecated old `TOML_API` option in favour new `TOML_EXPORTED_X` options
	(it will continue to work as it did before if none of the new function export options are defined)

#### Build system:
- Meson: Added `compile_library` option (@Tachi107)
- Meson: Added `ubsan_tests` and `ubsan_examples` options
- Meson: Use system dependencies where available when building tests (@Tachi107)

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Mar 8 08:51:49 2022 UTC (3 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +4 -4 lines
tomlplusplus: update to 3.0.1.

## 3.0.1

This is a single-bugfix release to fix an ODR issue for people using header-only mode in multiple
translation units. If you aren't seeing linker errors because of `toml::array::insert_at()`,
this release holds nothing of value over v3.0.0.

## 3.0.0


This release will be a major version bump, so it's ABI breaks all around.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Thu Dec 9 16:28:33 2021 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
devel/tomlplusplus: import tomlplusplus-2.5.0

TOML library for C++

Features

* Supports the latest TOML release (v1.0.0), plus optional support
  for some unreleased TOML features
* Supports serializing to JSON
* Proper UTF-8 handling (incl. BOM)
* C++17 (plus some C++20 features where available, e.g. experimental
  support for char8_t strings)
* Header-only (optional!)
* Doesn't require RTTI
* Works with or without exceptions

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>