File:  [cvs.NetBSD.org] / pkgsrc / devel / tomlplusplus / Makefile
Revision 1.9: download - view: text, annotated - select for diffs
Thu Oct 19 13:10:19 2023 UTC (18 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
tomlplusplus: update to 3.4.0.

## v3.4.0

#### Fixes

-   fixed `value_flags` not being preserved correctly when inserting into tables and arrays (#108) (@LebJe)
-   fixed `toml::value::flags()` not being cleared when `std::move`-ing a value
-   fixed error in README (#195) (@andrewkcorcoran)
-   fixed compiler error when using NVCC (#198) (@thompsonnoahe)
-   fixed `noexcept(...)` sometimes being incorrectly derived on `for_each()`
-   fixed `for_each()` compilation error on GCC <= 7 (#197) (@sagi-ottopia, @damirbarr)
-   fixed `FLT_RADIX` check getting broken by Intel MKL headers (#202) (@iago-lito)
-   fixed keys containing `\t` incorrectly formatting as bare keys (@jasmine-zhu, @arp242)
-   fixed keys containing `\t` and `\n` not round-tripping correctly (@arp242)

#### Additions

-   added support for using enums with `value_or()`

#### Changes:

-   renamed header files to have `.hpp` extension (`toml.h` is still present for backwards-compatibility)

#### Build system:

-   fixed meson builds with `-Ddefault_library=static` having hidden symbols on GNU compilers (#201) (@vlad0x00)

# $NetBSD: Makefile,v 1.9 2023/10/19 13:10:19 wiz Exp $

DISTNAME=	tomlplusplus-3.4.0
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GITHUB:=marzer/}
GITHUB_TAG=	v${PKGVERSION_NOREV}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://marzer.github.io/tomlplusplus/
COMMENT=	TOML library for c++
LICENSE=	mit

USE_CMAKE=	yes
USE_LANGUAGES=	c c++
MESON_ARGS+=	--datadir=lib

USE_CXX_FEATURES+=	c++17

.include "../../devel/meson/build.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>