[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / subversion

File: [cvs.NetBSD.org] / pkgsrc / devel / subversion / Makefile (download)

Revision 1.64, Sun Dec 15 15:38:57 2019 UTC (21 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.63: +2 -1 lines

Bump PKGREVISION by change of default Ruby version

Bump PKGREVISION by change of default Ruby version from 2.4.x to 2.6.x.
These packages are depends on Ruby in some ways.

# $NetBSD: Makefile,v 1.64 2019/12/15 15:38:57 taca Exp $

PKGNAME=	subversion-${SVNVER}
PKGREVISION=	1
COMMENT=	Version control system, meta-package

META_PACKAGE=	yes

.include "../../devel/subversion/Makefile.common"

DEPENDS+=	subversion-base-${SVNVER}{,nb[0-9]*}:../../devel/subversion-base
DEPENDS+=	${APACHE_PKG_PREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../www/ap2-subversion
DEPENDS+=	p5-subversion-${SVNVER}{,nb[0-9]*}:../../devel/p5-subversion
DEPENDS+=	${PYPKGPREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../devel/py-subversion
DEPENDS+=	${RUBY_PKGPREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../devel/ruby-subversion

.if !empty(PKG_OPTIONS:Mjava)
# The standard implementation of java is non-portable and non-free, so
# we do not depend on it by default.
DEPENDS+=	java-subversion-${SVNVER}{,nb[0-9]*}:../../devel/java-subversion
.endif

CATEGORIES+=	meta-pkgs

.include "../../lang/python/pyversion.mk"
.include "../../lang/ruby/rubyversion.mk"
.include "../../mk/apache.mk"
.include "../../mk/bsd.pkg.mk"