The NetBSD Project

CVS log for pkgsrc/devel/spdlog/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / spdlog

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.26: download - view: text, markup, annotated - select for diffs
Sat Feb 1 18:26:12 2025 UTC (13 days, 23 hours ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.25: preferred, colored
Changes since revision 1.25: +2 -2 lines
spdlog: updated to 1.15.1

1.15.1

Update bundled fmt version to 11.1.3
Use fwrite_unlocked() if available
On-demand truncation for basic file sinks
Allow manual rotation of rotating_file_sink
Make null_sink final
Fix: Add explicit fmt:: and std:: to avoid ambiguous calls
Fix: Pass /utf-8 only when the compiler is MSVC
Fix: Support bin_to_hex() when using std::format
Support custom environment variables for load_env_levels
Fix: Added a lock to rotate_now()
Fix: Update to_string_view function for fmt 11.1
Fix: Remove unused to_string_view overload in fmt >= 11.1
Fix: Use string_view_literals to resolve issues
Fix: Added a lock to set_color_mode(..) in ansicolor_sink
Fix: Corrected comment in daily_file_sink
Fix: Compatibility with fmtlib 11.1.1

Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Nov 10 19:57:53 2024 UTC (3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +5 -7 lines
spdlog: updated to 1.15.0

1.15.0

Update bundled fmt to 11.0.2
Add wide character formatting and output support to console in wincolor_sink.
Allow customization of syslog_sink
make example compatible with fmt 11
Fix building with FMT_ENFORCE_COMPILE_STRING
fix: set /Zc:__cplusplus and /MP to MSVC only
V1.x : fixed "suggest override" errors for gcc 8.5 and gcc 9.1
Add info about max_files in the docstrings of hourly/daily file sinks
use std::lock_guard instead of std::unique_lock
fix/issue-3101: fix the issue where mdc ignores SPDLOG_NO_TLS
Update mdc.h error message
[docs] Update conan install command in README
Update CMakeLists.txt, Fix spelling errors
Fix warning - extra ';' for -Wextra-semi
Improve Cross-Platform Build Instructions in Documentation
Exchange promise for condition_variable when flushing (fixes #3221)
Ensure flush callback gets called in move-assign operator
Make flush async again in async logger to prevent crashes and hangs
Update README.md
utf8_to_wstrbuf now handles invalid utf8 sequences
Added tsan option to CMake and CI

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sun Aug 25 06:18:38 2024 UTC (5 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +3 -3 lines
*: replace CMAKE_ARGS with CMAKE_CONFIGURE_ARGS

Revision 1.23: download - view: text, markup, annotated - select for diffs
Tue Jul 16 10:02:01 2024 UTC (7 months ago) by prlw1
Branches: MAIN
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -1 lines
Revbump for fmtlib 11.0.1
Pointed out by David Gutteridge on pkgsrc-changes

Revision 1.22: download - view: text, markup, annotated - select for diffs
Tue Apr 30 18:09:09 2024 UTC (9 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
spdlog: updated to 1.14.1

Version 1.14.1

Fixed compatibility issue between c++17 and c++11
Fixed creating folders under windows when full path with drive letter is given
Added mdc sample. Note: mdc is not supported in async loggers.

Revision 1.21: download - view: text, markup, annotated - select for diffs
Fri Apr 26 17:20:24 2024 UTC (9 months, 3 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
spdlog: updated to 1.14.0

Version 1.14.0

Updated bundled fmt to version 10.2.1.
Mapped Diagnostic Context (MDC) support
MDC is a simple map of key->string values stored in thread local storage whose content will be printed by the loggers.
Usage example:
#include "spdlog/mdc.h"
..
spdlog::mdc::put("mdc_key_1", "mdc_value_1");
spdlog::info("Hello, {}", "World!");  // => [2024-04-26 02:08:05.040] [info] [mdc_key_1:mdc_value_1] Hello, World!
Add milliseconds support to stopwatch
Add std::string_view overloads for logger accessor
Make async_logger::flush() synchronous - wait for the flush operation to complete before returning
Use _stat() on Windows to be more UTF8 friendly
Add details about how compile time macros work
Fix typos found by codespell
Expose the flusher thread object to user in order to allow setting of thread name and thread affinity when needed
Fix the problem of compilation failure under MINGW
Add missing include in circular_q.h
Don't remove previous defaullt logger from registry in set_default_logger.
Remove the legacy AnalyzeTemporaryDtors option from .clang-tidy.
Updated INSTALL.md has to better reflect compiler info
Fixed README.md example

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Jan 12 11:48:47 2024 UTC (13 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -3 lines
spdlog: updated to 1.13.0

Version 1.13.0

Enhancements

Qt Sink: Allow for darker colors for light backgrounds
Set CMAKE_BUILD_TYPE only for single-config generators
Provide spdlog_header_only in build directory export
Add SPDLOG_TO_VERSION to compare spdlog version
Support async_overflow_policy::discard_new
Make syslog_sink.h's syslog_prio_from_level protected
Fix OS availability check of pthread_threadid_np for iOS
Add .git-blame-ignore-revs to ignore clang-format related commits
Match SPDLOG_CONSTEXPR_FUNC to FMT_CONSTEXPR

Bug Fixes

Check fd_ is not nullptr in file_helper to prevent possible crash if disk is full
Fix encoding issue in qt_sinks
Fix wrong thread_id (TID) in systemd_sink.h
Update example.cpp to fix the vector issue in bin_example
Fix MSVC compile flag for no exceptions
Fix bug in circular_q::size()
Fix link to fmt license file

Maintenance

Added and updated various tests for circular_q.
Removed obsolete part from CMake configuration files
Removed policy_max from cmake_minimum_required(..).
Updated clang-format to google style and updated various formatting scripts.
Bumped to catch2 v3.5.0.

Revision 1.19: download - view: text, markup, annotated - select for diffs
Mon Aug 14 05:24:16 2023 UTC (18 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
*: recursive bump for Python 3.11 as new default

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sat Jul 22 12:15:22 2023 UTC (18 months, 3 weeks ago) by nia
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +5 -2 lines
spdlog: Set USE_CXX_FEATURES.

Do not set USE_LANGUAGES to c++11, it sets it itself.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Jul 18 04:59:01 2023 UTC (19 months ago) by adam
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -3 lines
spdlog: updated to 1.12.0

1.12.0

Support for external fmtlib versions 10.x
Better support for std::format
Added new qt color sink. Logs to QTextEdit widget with some nice colors.
Update #include to a deprecated fmt header
Fixes and impovements to dup_filter_sink
Fix unnecessary empty backtrace begin/end logs
Fixed variable name in msvc_sink
Add system includes (SPDLOG_SYSTEM_INCLUDES) cmake option
Improve dequeue of the async queue
Fix tcp_client sink for FreeBSD
Support linux/musl libc
Support newlib C library configurations without tm_gmtoff field
Fix type of event id in win_eventlog_sink
Fix -Wshadow warnings in spdlog::sinks::dist_sink
Spelling corrections
Add sync() function to file_helper
Add a trivial callback_sink
Fix unexpected delimiter at start of line in to_hex formatter
Fix MinGW build issue on example
Add optional TID definition to the systemd sink
Added apply_logger_env_levels()
Support utf8 in msvc_sink
Better handling of utf to wchar (66407f5).
Use catch v3 for tests
New kafka sink
Fix os namespace in systemd_sink.h
Enable systemd_sink tests in linux pipeline
Fix stdout_sink_base::log's fflush() behaviour inconsistency
Fix for missing pthread_threadid_np in macOS < 10.6 and PowerPC
Fix ringbuffer_sink moving warning
Update INSTALL doc
Fix warning in qt_sinks.h
Remove IPv4 limitation from tcp_client
Fix android sink when message is not loggable

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue May 16 21:20:49 2023 UTC (21 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
*: PKGREVISION bump for fmtlib shlib major bump

Revision 1.15: download - view: text, markup, annotated - select for diffs
Tue Jan 24 18:36:24 2023 UTC (2 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -8 lines
*: convert to cmake/build.mk

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Nov 26 13:47:13 2022 UTC (2 years, 2 months ago) by nia
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +5 -1 lines
spdlog: Fix building of dependent packages (e.g. nxengine-evo)

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Nov 12 15:06:06 2022 UTC (2 years, 3 months ago) by ryoon
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +7 -1 lines
spdlog: Fix shared library symlink name

And do not build in source directory for easier debugging.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Fri Nov 11 18:36:47 2022 UTC (2 years, 3 months ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -3 lines
spdlog: updated to 1.11.0

Version 1.11.0
Update to fmt lib version 9.1.0.
Fix template instantiation warning.
Event handlers improvements.
Allow modifying the used Android buffer ID.
Fix clone in async test.
Custom formatting optimization.
Fix C++14 builds for gcc 4.x.
Add minor version to CMake's SOVERSION
Allow compilation with FMT_ENFORCE_COMPILE_STRING.
Fix pkg-config generation.
Remove unused code from null_mutex.
Fix redundant std::move.
Remove the empty file if in first period in hourly logger.
Add reset_overrun_counter() function to the async logging
Set C++20 in CMake when SPDLOG_USE_STD_FORMAT option is turned on.
Fix mingw test.
Support for any std::chrono::duration type in flush_every(..).
Fix implicit casting of level_enum.
Comment fix.
Fix gcc 4.x build.
Add openSUSE installation instructions.
Fixed missing include file in stopwatch.h.
Support for omitting source info by defining SPDLOG_NO_SOURCE_LOC.
Added SPDLOG_BUILD_PIC build option to CMake.
Fix include windows.h.
Workaround gcc 12 warnings.
Migrate to Github Actions CI.
Replace iterator difference with std::distance
Export targets file to build directory at configure time.
MongoDB sink improvements.
Fix shadow warning in dist_sink.
Fixed msvc warning C4800 in win_eventlog_sink
Check IsDebuggerPresent() in msvc_sink before doing actual work. To use old behavior pass false to the msvc_sink constructor.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Mon Oct 10 12:46:32 2022 UTC (2 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +18 -32 lines
spdlog: use external fmtlib to avoid conflict between fmtlib v8 and v9; remove dylb madness; bump revision

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sun Apr 24 19:53:22 2022 UTC (2 years, 9 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +3 -1 lines
spdlog: needs -lsocket on SunOS

Revision 1.9: download - view: text, markup, annotated - select for diffs
Wed Apr 20 20:42:45 2022 UTC (2 years, 9 months ago) by wiz
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
spdlog: update to 1.10.0.

    Bump fmt to version 8.1.1.
    Added file event handlers #2165, #2169 Thanks @seker.
    You can get callbacks from spdlog before/after log file has been opened or closed.
    This is useful for cleanup procedures or for adding something to the start/end of the log files.
    Fixed rotating file sink: when disk is full log rotation resulted zero size log files. #2261. (thanks @kishorekrd for reporting).
    Added new udp_sink #2090. Thanks @CJLove
    (Experimental) Option to depend on std::format instead of fmtlib (set SPDLOG_USE_STD_FORMAT and use C++20). #2170 Thanks @sylveon .
    Improved file name for hourly file sink #2047. Thanks @seker .
    Added code location information for error handler #2048. Thanks @D-r-P-3-p-p-3-r .
    Fixed qt_sinks ctor #2056. Thanks @mguludag .
    List Debian instructions in the README #2057. Thanks @mr-c ,
    Updated to latest Travis CI Build Status #2094. Thanks @jspraul .
    Fixed unhandled errors in udp sink. #2096. Thanks @mmarkeloff .
    CMake improvement regarding cmake_minimum_required and policy. #2098. Thanks @reddwarf69 .
    Fixed mongo_sink compile in older gcc versions #2102 . Thanks @yzz-ihep .
    Remove mutable keyword from mutex_ member in of sinks. #2140 . Thanks @sunlong169 .
    Fix typos #2171. Thanks @rex4539 .
    Fixed udp sink build on FreeBSD #2172. Thanks @keith-dev .
    Avoid c-style casting in stdout sinks. #2179. Thanks @ibmibmibm .
    Fixed tweakme.h compile error under msvcs when SPDLOG_FUNCTION is defined #2182. Thanks @Light3039 .
    Fixed compiling errors on AIX #2181. Thanks @lisr .
    Fixed runtime when build with -fsanitize=cfi #1972. Thanks @bansan85 .
    Remove extraneous semicolon #2190. Thanks @sylveon.
    Added example how to replace default logger. #2194. Thanks @rioki .
    Fixed usage of ranges and to_hex in the same compile unit #2195. Thanks @patrickroocks .
    Reduce warnings with pedantic compiler -Wuseless-cast #2216. Thanks @vnepogodin .
    Support using std::span in to_hex #2228. Thanks @timblechmann .
    Reset current size if rotated files on open #2234. Thanks @SpriteOvO .
    Allow forward-declaration of level_enum #2245. Thanks @daverigby .
    Call localtime() only if pattern_formatter really needs it #2246. Thanks @doug1234 .
    Removed unneeded spaces from code. #2249. Thanks @PixelParas .
    Added a few missing files/directories to the gitignore #2255. Thanks @LeonBrands .
    Fixed issue #2201 (Pattern width is not applied for missing source information). #2269. Thanks @kyuheon-kr .
    Limit max number of rotating files to 200000. (Fixed #1905). Thanks @surfycui (#2273)
    pattern_formatter: fix reorder-ctor warning #2278. Thanks @adriweb .
    Fixed spdlogConfig.cmake when built with SPDLOG_FMT_EXTERNAL_HO #2300. Thanks @adamcalhoon .
    Fixed fopen_s(..) error handling when PREVENT_CHILD_FD is defined #2305. Thanks @nUl1.
    Fixed compiler error when building on Windows with #define UNICODE #2317. Thanks @risa2000 .
    Added option to enable formatting of systemd sink #2324, #2320. Thanks @Delgan .
    Added optional "ident" argument to systemd sink constructor #2328. Thanks @Delgan .

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Jan 25 04:12:41 2022 UTC (3 years ago) by mef
Branches: MAIN
CVS tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -3 lines
(devel/spdlog) Updated 1.8.5 to 1.9.2

(https://github.com/gabime/spdlog/releases/tag/v1.9.2)
Version 1.9.2 Latest
@gabime gabime released this Aug 13, 2021
 175 commits to v1.x since this release
v1.9.2
eb32206

    Fixed clang compiler errors when using spdlog in c++20. Thanks @dkavolis (#2037, #2034).
    Fixed the Qt sinks to accurately trim the newline chars. Thanks @MadMax411 (#2015).
    Improved and simplified Qt sinks implementation. Thanks @mguludag (#2016, #2018).
    Fixed macro SPDLOG_LEVEL_NAME_xxx to always translate to the spdlog namespace.
       Thanks @ashley-b for reporting (#2022).
    Fixed typo in readme. Thanks @p-ranav (#2024).
    Fixed the MongoDB sink compilation in c++11. Thanks @jabartek (#2025).
    Fixed double include of same file in thread_pool.h . Thanks @hbwang15 (#2026).
    Ensure that the CMake exported package is relocatable. Thanks @daverigby (#2029).
    Remove std::distance usage for possible performance gain. Thanks @neheb (#2030).
    Support of inclusion of bin_to_hex.h in any order with spdlog.h. Thanks @dmerkushov (#2035).
    Fixed install instructions for "header only" dir. Thanks @madeso (#2036).

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jan 18 14:17:22 2022 UTC (3 years ago) by tnn
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +20 -2 lines
spdlog: build as dynamic library instead of static

Got relocation errors while linking gnuradio on Linux with the static
library due to missing -fPIC.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Fri Apr 2 08:32:57 2021 UTC (3 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
spdlog: update to 1.8.5.

1.8.5

Fix compiling with C++17: remove constexpr on level_string_views. Thanks @stevenlunt (#1889).

1.8.4

Remove version requirement from find_package when searching external fmt. #1890. Thanks @prince-chrismc

1.8.3

New hourly file sink . Creates new file every hour. Can be limited to retain only the last N files. Thanks @BVonk (#1763).
New daily sink filename custom formatting. Users now can pass custom strftime pattern to the log filename. For example: daily_logger_format_mt("loggername", "log-%Y%m%d:%H:%M.txt", hours, minutes);. Thanks @fawdlstty (#1847).
Fix windows event sink log compilation with UNICODE preprocessor. Thanks @iko1 (#1760).
Add SPDLOG_DISABLE_DEFAULT_LOGGER as a CMake option. Thanks @shimaowo (#1765, #1766).
Improve color terminal detection. Thanks @dominicpoeschko (#1768).
Prevent windows color sink to leak windows headers into user code Thanks @Ryan-rsm-McKenzie (#1771).
Ensure SPDLOG_FMT_EXTERNAL is honored in the bench program. Thanks @Ryan-rsm-McKenzie (#1773).
Skip CMake module mode when finding fmt. Thanks @Ryan-rsm-McKenzie (#1774).
Better support for "/" separators on Windows, and improve wchar filename test coverage. Thanks @sylveon (#1787).
Open files with "ab" mode even if truncating to better support logrotate(8). Thanks @graydon (#1795).
Fix compiling error and typo in hourly file sink. Thanks @sillykelvin (#1805).
Add constexpr to SPDLOG_LEVEL_NAMES declaration. Thanks @gv-me (#1798).
Initializer list style consistency. Thanks @ChristianPanov (#1807).
Fix call to non-constexpr function (#1811).
Better numeric_limits<>::max/min fix when SPDLOG_WCHAR_TO_UTF8_SUPPORT is defined. Thanks @NukeULater (#1819).
Fix to prevent MSVC warning flags to propagate to CUDA. Thanks @prateek9623 (#1825, #1829).
Fix windows stdout_sink raising exception when used GUI Windows Apps that lack a console. Thanks @dgehri for reporting (#1828).
Simplified wincolor sink code and intensify the red and yellow colors.
Set default value to registry::err_handler_ to resolve Klocwork warning. . Thanks @jneruda (#1835).
Formatter bench: Fix compilation by avoiding function name decay mechanics. Thanks @MathiasMagnus (#1846).
Add build2 package support in readme. Thanks @Klaim (#1851).
Make sure __cplusplus is defined under msvc CMakeLists.txt
Fixed VS2019 W4 cast warning (#1876).
Fix warning whe the compilation flag -Wswitch-default is present. Thanks @imsherlock (#1882).

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Jan 4 12:03:24 2021 UTC (4 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
spdlog: update to 1.8.2.

    Bump fmt to version 7.1.3
    Download automatically googlebenchmark for bench tests (#1709) Thanks @kitattyor.
    Add CPack debian package settings (#1712) and fix typo in comment (#1711). Thanks @ChristofKaufmann.
    Perfect forwarding fmt arguments (#1726). Thanks @dkavolis.
    Fix dup_filter_sink to log current log call's level, instead of the filtered log call's level (#1710). Thanks @Tridacnid for reporting.
    Ability to get size of messages queue of async thread pool (#1735) Thanks @o2gy84.
    Add missing include (#1742). Thanks @jwittbrodt.
    Updated bin_to_hex example in the readme (#1744). Thanks @ArnaudBienner.
    Fix async periodic flush test (#1749). Thanks @bluescarni.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Oct 6 09:25:26 2020 UTC (4 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
spdlog: update to 1.8.1.

1.8.1

    Fixed load_env_levels() and load_argv_levels() #1680 (thanks @Tridacnid ).
    Fixed stdout sink that produced extra carriage returns on Windows #1675 (thanks @chris-t-w ).
    Fixed msvc_sink including windows.h #1667 (thanks @Ryan-rsm-McKenzie).
    Fixed stopwatch's clock to use chrono::steady_clock #1676 (thanks @SuperWig).
    Added support for Rcpp (R cpp compiler) #1685 (thanks @eddelbuettel).

1.8.0

    Upgraded bundled fmt to version 7.0.3.
    New stopwatch utility for quick & easy logging of elapsed time.
    Raised CMake requirement to 3.10 and cleanup CMakeLists.txt (#1624). Thanks @tambry.
    Added get_level() and should_log() functions to the spdlog:: namespace (#1628). Thanks @eyalroz.
    Fixed tcp_client for macOS (#1640). Thanks @dkruempe.
    Fixed cfg::load_env_levels() function declaration (#1651). Thanks @bareya.
    Updated Fedora install info in the readme (#1653). Thanks @gk6k6k.
    Fixed #1617 (aligned function pattern flag is broken). Thanks @VelocityRa for reporting.
    Fixed #1581 (compiling under msys in win10).

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Aug 24 08:44:56 2020 UTC (4 years, 5 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
spdlog: update to 1.7.0.

* Support for using external fmt version 7.x (bundled version is 6.2.1). Thanks @candrews .(22bee81).
* Fixed to_hex segmentation fault (#1611, 19f2804). Thanks @vitaut, @xvitaly, @kekePower and @lgbaldoni.
* Support for FMT_STRING compile time checking. Thanks @Tridacnid (30ee690).
* Fixed shared library building failure on Windows with non MSVC. Thanks @podsvirov (fe97a03).
* Fixed mingw testcase. Thanks @podsvirov (075dcee).
* Clean CMakeLists.txt. Thanks @Pospelove (cf55e5d).

Revision 1.2: download - view: text, markup, annotated - select for diffs
Fri Jun 5 11:22:44 2020 UTC (4 years, 8 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +5 -6 lines
spdlog: Update to 1.6.1

Changelog:
1.6.1
    Fixed deadlock in daily_file_sink that happened while cleaning older files. Thanks @IIFE for reporting(#1570) and for fixing(#1571).

    Fixed ringbuffer_sink::last_raw() and ringbuffer_sink::last_formatted() that didn't return latest elements. Thanks @vekkuli for reporting and fixing (#1563).

    Fixed missing symbol wstr_to_utf8buf(..) in windows dll build. Thanks @haquocviet for reporting (#1569).

    Bumped bundled fmt to version 6.2.1.

1.6.0
What's new

    Load log levels from environment variable SPDLOG_LEVEL :

#include "spdlog/cfg/env.h"
...
spdlog::cfg::load_env_levels();

$ # set log level to debug
$  SPDLOG_LEVEL=debug && ./example

$ # set to info except for mylogger which is set to trace:
$ SPDLOG_LEVEL=info,mylogger=trace  && ./example

$ # turn off all logging except for mylogger which is set to debug::
$ SPDLOG_LEVEL=off,mylogger=debug && ./example

    Load log levels from argv (e.g. ./example SPDLOG_LEVEL=debug):

#include "spdlog/cfg/argv.h"
...
spdlog::cfg::load_argv_levels(argc, argv);

    New windows eventlog sink . Thanks @ban-dana (#1418).

    New tcp sink that sends log messages in tcp to a remote server. Thanks @Proheeler (#1426).

    Extend spdlog with your own flags in the log pattern. See wiki for details.

    Support for building spdlog as dll under windows. Thanks vejmartin (#1467, 3b73278, 5b3a183).

    Bump the bundled fmt version to 6.2.0 .

Fixes and Improvements

    Prevent race condition when SPDLOG_PREVENT_CHILD_FD is defined. Thanks @dominicpoeschko (#1423).

    Fix race condition in the filename() function in the file sinks. Thanks @tt4g (#1430, #1431).

    Fix ansicolor_sink::set_color(..) - can cause memory violation if user provides a custom color code that points to stack memory (#1540, 0b36d4e). Thanks @caizongchao for reporting.

    Fix potential buffer overflow in color_sinks if creating multiple color sinks in the same logger and one of them has a pattern without color flags (#1452, 64de880). Thanks @dominicpoeschko for reporting.

    Optimize cases when string_view is passed to the logger to avoid unnecessary fmt::format. Thanks dominicpoeschko (#1424) .

    Support for max files in daily logger - delete oldest files after creating the daily file. Thanks @ruoshui1314 (#1394).

    Fix deprecated warning with C++14 and external fmt lib (#1439). Thanks @ClausKlein for reporting.

    Optimize colos sinks to use std::array instead of map to find color codes (695912c, 4b7c059). Thanks @qis for the suggestion.

    Fix Win32 event log sink compilation. Thanks @Crunkle (#1444).

    Don't include windows.h in common.h. Thanks @ghost (#1453).

    Resolve erroneous clang-tidy warning about using a moved from pointer. Thanks @Ruffel (#1457).

    Fixed numerous clang-tidy warnings.

    Added options to to_hex to output hex like hexdump. Thanks @ngugcx (#1472).

    Fix Windows setenv check. Thanks @Crunkle (#1475).

    Removed the 'SPDLOG_NO_NAME` macro in tweakme.h and cmake.

    Added a forward declaration header spdlog\fwd.h . Thanks @horenmar for the suggestion (#1481).

    Moved throw to dedicated function to optimize compile-time and runtime-performance. Thanks @horenmar for the suggestion (#1483).

    Fix a build issue when SPDLOG_PREVENT_CHILD_FD is defined. Thanks @Naios (#1487).

    Fix issue with using external fmt (#1480). Thanks @nalinigans for reporting.

    Minor performance optimizations in pattern formatter (ca9c83f, 76389e0, 7766bc2, d38bd13)

    Fixed on Android compilation #1527. Thanks @Bizyroth for reporting.

    Add log function to the logger API to allow logging with custom timepoint. #1521 - Thanks @ron003 .

    Fix missing exported symbol when building spdlog.dll in windows (#1535, 348c438). Thanks @plmzod for reporting.

    Dropped meson support.

    Fix typos and tabs in the code. Thanks @waywardmonkeys (#1536) .

    CMake: Fix GNUInstallDirs include location Thanks @vitlav (#1407).

    CMake: workaround for Unknown extension ".c" for file issue . Thanks @niamster (#1442).

    CMake: Support CPack RPM generation. Thanks @tcraigtyler (#1451).

    CMake: Disabled extra warnings generation by default. Use SPDLOG_BUILD_WARNINGS=ON to enable again. Thanks @Glamhoth (#1503 02802af, 6440733, 1f7f1c1)

    CMake: Support for precompiled headers with SPDLOG_ENABLE_PCH flag. Thanks @OlivierLDff (#1484).

    CMake: Add /WX MSVC compiler option for only if mscv compiler is used. Thanks @trondhe (#1495).

    CMake: Set minimum version of fmt to 5.3.0. Thanks @Montellese (#1525).

    CMake: Fix tabs, whitespaces and eol. Thanks @waywardmonkeys (#1537).

    Tests: removed duplicate entry for count_lines(). Thanks @emmenlau (#1417).

    Tests: don't run spdlog-utests and spdlog-utests-ho in parallel. Thanks @tt4g (#1421).

    Tests: Enable running the tests against an installed copy of spdlog. Thanks @mr-c (#1422).

    Tests: Support empty SPDLOG_EOL. Thanks @emmenlau (#1414).

    README: add conda as a supported package manager . Thanks @avrahamshukron (#1473).

    README: Replace yaourt with yay` pacakge manage for archlinux. Thanks @zyansheep (#1494).

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Feb 5 13:32:27 2020 UTC (5 years ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
devel/spdlog: import spdlog-1.5.0

Very fast, header-only/compipled, C++ logging library.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>