[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby2ruby

File: [cvs.NetBSD.org] / pkgsrc / devel / ruby2ruby / Makefile (download)

Revision 1.17, Sun Mar 12 14:31:24 2017 UTC (6 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.16: +6 -3 lines

Update ruby2ruby to 2.3.2.

=== 2.3.2 / 2016-11-30

* 5 bug fixes:

  * FINALLY fixed a problem with escaping in dstrs. (nex3)
  * Fix using match3 on LHS of call. (eqv)
  * Fixed handling defn that starts w/ begin+rescue+other stuff. (eqv)
  * Fixed return expressions with complex RHS. (eqv)
  * Tweaked sexp_processor dependency to ~> 4.6 to sync them better

# $NetBSD: Makefile,v 1.17 2017/03/12 14:31:24 taca Exp $

DISTNAME=	ruby2ruby-2.3.2
CATEGORIES=	devel

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/seattlerb/ruby2ruby
COMMENT=	Pure Ruby code from Ruby S-expressions
LICENSE=	mit

DEPENDS+=	${RUBY_PKGPREFIX}-sexp-processor>=4.6<5:../../devel/ruby-sexp-processor
DEPENDS+=	${RUBY_PKGPREFIX}-parser>=3.1<4:../../devel/ruby-parser

RUBYGEM_OPTIONS+=	--format-executable

pre-build:
	${CHMOD} 0755 ${WRKSRC}/bin/r2r_show

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"