Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-thrift
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.14 / (download) - annotate - [select for diffs], Wed Sep 18 11:27:52 2019 UTC (4 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3,
pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4,
pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
HEAD
Changes since 1.13: +9 -9
lines
Diff to previous 1.13 (colored)
thrift: updated to 0.12.0 and split into language modules Thrift 0.12.0 New Languages * Common LISP (cl) * Swift * Typescript (nodets) Deprecated Languages * Cocoa Breaking Changes (since 0.11.0) * Rust enum variants are now camel-cased instead of uppercased to conform to Rust naming conventions * Support for golang 1.6 and earlier has been dropped. * PHP now uses the PSR-4 loader by default instead of class maps. * method signatures changed in the compiler's t_oop_generator. * The C (GLib) compiler's handling of namespaces has been improved. Known Issues (Blocker or Critical) * build: use a single build system for thrift * build: bootstrap.sh is missing from source tarball * csharp: socket exhaustion in csharp implementation * cocoa: Getters for fields defined with uppercase names do not work * cocoa: Extended services aren't subclasses in generated Cocoa * cocoa: Thrift de-capitalizes the name of IsSet property in Cocoa * cpp: the http implementation is not standard; interop with other languages is spotty at best * cpp: Impossible to build Thrift C++ library for Android (NDK) * cpp: Using multiple async services simultaneously is not thread-safe * haskell: Defaulted struct parameters on a service generates invalid Haskell * nodejs: Exception swallowed by deserialization function * nodejs: map<i64,value> key treated as hex value in JavaScript * nodejs: ERROR in ./node_modules/thrift/lib/nodejs/lib/thrift/connection.js Module not found: Error: Can't resolve 'child_process' * nodejs: Sequence numbering for multiplexed protocol broken * php: sequence and reconnection management issues * php: Error during deserialization int64 on 32-bit architecture * php: thrift type i64 java to php serialize/deserealize not working * php: PHP gets stuck in infinite loop * python: sending int or float in a double field breaks the connection * python: unix sockets can get stuck forever * python: generated code is out of order and causes load issues * py3: UnicodeDecideError in Python3 Build Process * D language docker images need demios for libevent and openssl fixed to re-enable make cross on dlang * Use Ubuntu Bionic (18.04 LTS) for CI builds instead of Artful (17.10) * Define CI operating system coverage rules for the project and (hopefully) simplify CI a little more * ubuntu install instructions broken on 16.04 * Appveyor builds are failing due to a haskell / cabal update in chocolatey * optimize Dockerfile (only onetime apt-get update) * rm `build/docker/ubuntu-trusty/Dockerfile.orig` * Ubuntu Artful doesn't appear to be compatible with Thrift and Haxe 3.4.2 * DLang Client Pool Test fails sporadically * CL tutorial build fails sporadically * Make haxelib download quiet so it doesn't blow up the build log * bootstrap.sh fails if automake=1.16.1 c_glib * The C (GLib) compiler's handling of namespaces has been improved. * glibC compilation issue * c glib is unable to handle client close unexpectedly cl (new language support in 0.12.0) * Common Lisp support csharp * reserved Csharp keywords are not escaped in some cases * C# async mode generates incorrect code with inherited services * IAsyncResult style methods not being supported by certain transports leads to issues in mixed ISync/IAsync use cases * Allow TBufferedTransport to be used as base class * XML docs; code cleanup (tabs->spaces; String->string) * protected ExceptionType type member of TApplicationException cannot be accessed * JSONProtocol Base64 Encoding Trims Padding * Missing dispose calls in ThreadedServer & ThreadpoolServer * keep InnerException wherever appropriate * IAsyncResult not supported by layered transports (buffered/framed) cpp * Typecasting problem on list items * TNonblockingServer throwing THRIFT LOGGER: TConnection::workSocket(): THRIFT_EAGAIN (unavailable resources) * TBufferTransports.h does not compile under Visual Studio 2017 * TNonblockingServer crash because of limitation of select() * TZlibTransport.cpp doesn't ensure that there is enough space for the zlib flush marker in the buffer. * ZeroMQ contrib library needs a refresh * TSSLServerSocket incorrectly prints errors * Move `TAsyncProtocolProcessor` into main thrift library * evhttp_connection_new is deprecated; use evhttp_connection_base_new compiler * Compiler cannot be compiled on macOS(maybe also on other platforms with clang) * Thrift generates wrong Python code for immutable structures with optional members * thrift generated code is not stable for constants * Avoid updating Thrift compiler generated code if the output has not changed * Visual Studio Compiler project should link runtime statically in release builds * plugin.thrift t_const_value is not used as a union in C++ code -- fix this * Dealing with language keywords in Thrift (e.g. service method names) * repeated runs of compiler produce different binary output at plugin interface dlang * Thrift will not build with dlang 2.078 or later * dlang servers logError on normal client disconnection * D language docker images need demios for libevent and openssl fixed to re-enable make cross on dlang dart * Effective Dart and Exceptions * Shouldn't download dart.deb directly. delphi * Calling wrong exception CTOR leads to "call failed: unknown result" instead of the real exception being thrown * uncompileable code with member names that are also types under specific conditions * Add Async implementation via IFuture * Possible invalid ptr AV with overlapped read/write on pipes * Thrift exceptions should derive from TException * buffered transport broken when trying to re-open a formerly closed transport * Move Thrift.Console.pas out of the Library * Allow a default service as fallback for multiplex processors connected by old clients * Large writes/reads may cause range check errors in debug mode * Compiler directive should match Delphi XE4 * First line in Console duplicated * FPU ctrl word settings may cause an unexpected "denormalized" error erlang * Erlang records should use map() for map type * Erlang records should allow 'undefined' for non-required fields * Fix erlang tutorial unpack on Windows * Ubuntu Xenial erlang 18.3 "make check" fails golang * Support for golang 1.6 and earlier has been dropped. * Go generator assigns strings to field in const instead of pointers. * Unions Field Count Does Not Consider Binary * Golang: Panic on p.c.Call when using deprecated initializers * Required field incorrectly marked as set when fieldType does not match * Golang: -remote.go client cleanup * TSimpleServer can exit Accept loop with lock still acquired * Add support for go 1.10 * golang tests rely on gomock, which has change behaviour, causing tests to fail * Communication crash when using binary/compact protocol and zlib transport * golang race detected when closing listener socket haskell * Haskell builds with older cabal cannot reconcile complex version requirements java * Thrift does not compile due to Ant Maven task errors * Compiling Thrift from source: Class org.apache.tools.ant.taskdefs.ConditionTask doesn't support the nested "typefound" element * proposal: add nullability annotations to generated Java code * Generate missing @Nullable annotations for Java iterator getters * Getter of binary field in Java creates unnecessary copy * libthrift is deployed on central with pom packaging instead of jar * Java Configure Fails for Ant >= 1.10 * Java libraries missing from package when using cmake * pom files are not generated or provided in the build * Maven can't download resource from central when behind a proxy and won't use local repository * Optional rethrow of unhandled exceptions in java processor * Able to set keyStore and trustStore as InputStream in the TSSLTransportFactory.TSSLTransportParameters * Pass message of unhandled exception to optional rethrow. * Remove assertion in Java SASL code that would be ignored in release builds * Include popular IDE file templates to gitignore * Make TThreadPoolServer.executorService_ available in inherited classes and refactor methods to be able customization * Fix logic of THRIFT-2268 * Increase Java Socket Buffer Size * Remove Magic Number In TFIleTransport js * JavaScript: Use modern Promise implementations * let / const variable decorators for es6 compiler * ES6 Classes * JS: readI32 performance on large arrays is very poor in Chrome * js and nodejs libraries need to be refreshed with current libraries * thrift.js: Incorrect usage of 'this' in TWebSocketTransport.__onOpen * Deserialization of nested list discards content * JS WebSocket client callbacks invoked twice on parallel requests * Duplicate declaration of InputBufferUnderrunError in lib/nodejs/lib/thrift/json_protocol.js * Add prettier for consistent JS code formatting lua * lua client uses two write() calls per framed message send * Can't "make install" Lua Library netcore * .NET Core Server doesn't close properly when cancelled * Update .NET Core components, add tests for .Net Core library and .Net Core compiler, fix bugs and build process * JSONProtocol Base64 Encoding Trims Padding node.js * Error handling malformed arguments leaks memory, corrupts transport buffers causing next RPC to fail * Memory leak while calling oneway method * add typescript directory support * TBufferedTransport can leave corrupt data in the buffer * Node.js Fileserver webroot path * Unix domain socket support for NodeJS client * node.js json_protocol throws error in skip function * NodeJS: Expose Int64 from browser.js for consumption by browser * NodeJS warning on binary_protocol writeMessageEnd when seqid = 0 perl * Replace the use of Perl Indirect Object Syntax calls to new() * Thrift CPAN release is missing Makefile.PL and the clients are unable to build the module * Perl CPAN Packaging Improvements php * PHP generator use PSR-4 default * PHP generated code match PSR-2 * Extending Thrift class results in "Attempt serialize from non-Thrift object" * TSocket block on read * migrate php library to psr-4 * infinite loop in latest PHP library * TBufferedTransport must have underlying transport * lib/php/test should be checked for PSR-2 * add phpcs back * php library use PSR-2 * TCurlClient doesn't check for HTTP status code * TCurlClient: show actual error message when throwing TTransportException * Add stream context support into PHP/THttpClient * reduce php library directory depth python * Twisted, slots, and void method fails with "object has no attribute 'success'" * Potentially server-crashing typo in Python TNonblockingServer * Supporting TBinaryProtocolAccelerated protocol when using TMultiplexedProcessor in Python * Outdated cipher string in python unit test * python build on Vagrant Windows boxes fails * THeader for Python * make socket backlog configurable for python * Python: cleanup socket timeout settings ruby * Thrift RSpec test suite fails with Ruby 2.4.x due to Fixnum deprecation * Support ruby rspec 3 * Add ssl socket option to ruby cross tests * Add seek support to TCompactInputProtocol in Rust * Codegen Creates Invalid Ruby for Recursive Structs * Fix the genspec for ruby so it does not complain about an invalid license rust * Rust const string calls function at compile time * Rust enum name wrong case in generated structs * Avoid generating conflicting struct names in Rust code * Rust generation should include #![allow(non_snake_case)] or force conform to Rust style guidelines * Rust binary protocol and buffered transport cannot handle writes above 4096 bytes * Rust framed transport cannot handle writes above 4096 bytes * Rust's TBinaryInputProtocol fails when strict is false * Dart -> Rust Framed cross tests fail * Rust cannot create ReadHalf/WriteHalf to implement custom tranports swift (new language support in 0.12.0) * Swift Library test suite * Gracefully shutdown cross-test servers to fully test teardown * Add .NET Core to the make cross standard test suite * Add unix domain sockets in ruby to cross test - code exists typescript (new language support in 0.12.0) * add typescript directory support
Revision 1.13 / (download) - annotate - [select for diffs], Wed Apr 19 11:24:38 2017 UTC (6 years, 7 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2,
pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2
Changes since 1.12: +2 -2
lines
Diff to previous 1.12 (colored)
Reset MAINTAINER after tonnerre resigned.
Revision 1.12 / (download) - annotate - [select for diffs], Sat Mar 5 11:28:26 2016 UTC (7 years, 9 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
Bump PKGREVISION for security/openssl ABI bump.
Revision 1.11 / (download) - annotate - [select for diffs], Wed Feb 12 23:17:50 2014 UTC (9 years, 9 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1
Changes since 1.10: +2 -2
lines
Diff to previous 1.10 (colored)
Recursive PKGREVISION bump for OpenSSL API version bump.
Revision 1.10 / (download) - annotate - [select for diffs], Wed Feb 6 23:22:11 2013 UTC (10 years, 10 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
PKGREVISION bumps for the security/openssl 1.0.1d update.
Revision 1.9 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:43 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base,
pkgsrc-2012Q4
Changes since 1.8: +1 -3
lines
Diff to previous 1.8 (colored)
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Revision 1.8 / (download) - annotate - [select for diffs], Sun May 6 10:12:20 2012 UTC (11 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2
Changes since 1.7: +3 -1
lines
Diff to previous 1.7 (colored)
Add destdir support. (It was so easy that I can only infer that noone cares about these packages :) )
Revision 1.7 / (download) - annotate - [select for diffs], Tue Nov 8 15:37:34 2011 UTC (12 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4
Changes since 1.6: +2 -1
lines
Diff to previous 1.6 (colored)
* Remove .require_paths from PLIST * Bump PKGREVISION.
Revision 1.6 / (download) - annotate - [select for diffs], Mon Sep 12 16:04:49 2011 UTC (12 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base,
pkgsrc-2011Q3
Changes since 1.5: +3 -3
lines
Diff to previous 1.5 (colored)
Update ruby-thrift package to 0.7.0. (This is Ruby language binding for gem dependency.) Changes are too many to write here, please refer http://svn.apache.org/viewvc/thrift/tags/thrift-0.7.0/CHANGES in detail.
Revision 1.5 / (download) - annotate - [select for diffs], Sat Jun 18 02:01:06 2011 UTC (12 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base,
pkgsrc-2011Q2
Changes since 1.4: +3 -4
lines
Diff to previous 1.4 (colored)
Update ruby-thrift pacakge to 0.6.0. * pkgsrc change: Update HOMEPAGE since priveous one isn't available. * Catch up to libthrift-0.6.1.
Revision 1.2.4.1 / (download) - annotate - [select for diffs], Sun Feb 27 00:26:19 2011 UTC (12 years, 9 months ago) by tron
Branch: pkgsrc-2010Q4
Changes since 1.2: +2 -1
lines
Diff to previous 1.2 (colored) next main 1.3 (colored)
Pullup ticket #3361 - requested by taca archivers/ruby-libarchive: dependence update comms/ruby-termios: dependence update converters/ruby-uconv: dependence update databases/ruby-do_sqlite3: dependence update databases/ruby-ldap: dependence update databases/ruby-mysql: dependence update databases/ruby-odbc: dependence update databases/ruby-pg: dependence update databases/ruby-postgresql: dependence update databases/ruby-qdbm: dependence update databases/ruby-sqlite: dependence update databases/ruby-sqlite3: dependence update databases/ruby-tokyocabinet: dependence update devel/ruby-SDL: dependence update devel/ruby-debug-base: dependence update devel/ruby-eet: dependence update devel/ruby-eventmachine: dependence update devel/ruby-ffi: dependence update devel/ruby-gnome2-atk: dependence update devel/ruby-gnome2-bonobo: dependence update devel/ruby-gnome2-bonoboui: dependence update devel/ruby-gnome2-gconf: dependence update devel/ruby-gnome2-gio: dependence update devel/ruby-gnome2-glib: dependence update devel/ruby-gnome2-libglade: dependence update devel/ruby-gnome2-pango: dependence update devel/ruby-linecache: dependence update devel/ruby-memcache: dependence update devel/ruby-ncurses: dependence update devel/ruby-priority-queue: dependence update devel/ruby-racc: dependence update devel/ruby-rbtree: dependence update devel/ruby-rcov: dependence update devel/ruby-rcsparse: dependence update devel/ruby-subversion: dependence update devel/ruby-thrift: dependence update graphics/ruby-RMagick: dependence update graphics/ruby-clutter-cairo: dependence update graphics/ruby-clutter-core: dependence update graphics/ruby-clutter-gtk: dependence update graphics/ruby-gd: dependence update graphics/ruby-gnome2-gdkpixbuf: dependence update graphics/ruby-gnome2-gnomecanvas: dependence update graphics/ruby-gnome2-goocanvas: dependence update graphics/ruby-gnome2-gtkglext: dependence update graphics/ruby-gnome2-libart: dependence update graphics/ruby-gnome2-rsvg: dependence update graphics/ruby-imlib2: dependence update graphics/ruby-opengl: dependence update graphics/ruby-rcairo: dependence update inputmethod/ruby-zinnia: dependence update lang/ruby: dependence update lang/ruby18-base: security update lang/ruby19-base: security update mail/ruby-tmail: dependence update math/ruby-rb-gsl: dependence update multimedia/ruby-clutter-gst: dependence update multimedia/ruby-gnome2-gstreamer: dependence update multimedia/ruby-ming: dependence update print/ruby-gnome2-gnomeprint: dependence update print/ruby-gnome2-gnomeprintui: dependence update print/ruby-gnome2-poppler: dependence update security/ruby-password: dependence update security/ruby-tcpwrap: dependence update sysutils/ruby-quota: dependence update textproc/ruby-bluecloth: dependence update textproc/ruby-cabocha: dependence update textproc/ruby-eruby: dependence update textproc/ruby-ferret: dependence update textproc/ruby-hpricot: dependence update textproc/ruby-itex2MML: dependence update textproc/ruby-json: dependence update textproc/ruby-libxml: dependence update textproc/ruby-mecab: dependence update textproc/ruby-native-hyperestraier: dependence update textproc/ruby-nokogiri: dependence update textproc/ruby-oniguruma: dependence update textproc/ruby-redcloth: dependence update textproc/ruby-sary: dependence update textproc/ruby-xmlparser: dependence update textproc/ruby-xslt: dependence update textproc/ruby-yamcha: dependence update www/mongrel: dependence update www/ruby-clearsilver: dependence update www/ruby-fcgi: dependence update www/ruby-gnome2-gtkhtml2: dependence update www/ruby-gnome2-gtkmozembed: dependence update www/ruby-patron: dependence update www/thin: dependence update x11/ruby-gnome2-gnome: dependence update x11/ruby-gnome2-gtk: dependence update x11/ruby-gnome2-gtksourceview: dependence update x11/ruby-gnome2-gtksourceview2: dependence update x11/ruby-gnome2-panelapplet: dependence update x11/ruby-gnome2-vte: dependence update Revisions pulled up: - archivers/ruby-libarchive/Makefile 1.2 - comms/ruby-termios/Makefile 1.23 - converters/ruby-uconv/Makefile 1.19 - databases/ruby-do_sqlite3/Makefile 1.2 - databases/ruby-ldap/Makefile 1.7 - databases/ruby-mysql/Makefile 1.34 via patch - databases/ruby-odbc/Makefile 1.10 via patch - databases/ruby-pg/Makefile 1.6 - databases/ruby-postgresql/Makefile 1.37 - databases/ruby-qdbm/Makefile 1.12 - databases/ruby-sqlite/Makefile 1.3 - databases/ruby-sqlite3/Makefile 1.15 - databases/ruby-tokyocabinet/Makefile 1.24 - devel/ruby-SDL/Makefile 1.9 via patch - devel/ruby-debug-base/Makefile 1.7 - devel/ruby-eet/Makefile 1.8 - devel/ruby-eventmachine/Makefile 1.7 - devel/ruby-ffi/Makefile 1.3 - devel/ruby-gnome2-atk/Makefile 1.8 - devel/ruby-gnome2-bonobo/Makefile patch - devel/ruby-gnome2-bonoboui/Makefile patch - devel/ruby-gnome2-gconf/Makefile patch - devel/ruby-gnome2-gio/Makefile 1.3 via patch - devel/ruby-gnome2-glib/Makefile 1.11 - devel/ruby-gnome2-libglade/Makefile patch - devel/ruby-gnome2-pango/Makefile 1.18 via patch - devel/ruby-linecache/Makefile 1.5 - devel/ruby-memcache/Makefile 1.4 - devel/ruby-ncurses/Makefile 1.9 - devel/ruby-priority-queue/Makefile 1.6 - devel/ruby-racc/Makefile 1.18 - devel/ruby-rbtree/Makefile 1.6 - devel/ruby-rcov/Makefile 1.5 - devel/ruby-rcsparse/Makefile 1.10 - devel/ruby-subversion/Makefile 1.28 - devel/ruby-thrift/Makefile 1.4 via patch - graphics/ruby-RMagick/Makefile 1.76 via patch - graphics/ruby-clutter-cairo/Makefile 1.8 via patch - graphics/ruby-clutter-core/Makefile 1.11 via patch - graphics/ruby-clutter-gtk/Makefile 1.8 via patch - graphics/ruby-gd/Makefile 1.34 via patch - graphics/ruby-gnome2-gdkpixbuf/Makefile 1.20 via patch - graphics/ruby-gnome2-gnomecanvas/Makefile patch - graphics/ruby-gnome2-goocanvas/Makefile 1.12 via patch - graphics/ruby-gnome2-gtkglext/Makefile patch - graphics/ruby-gnome2-libart/Makefile patch - graphics/ruby-gnome2-rsvg/Makefile 1.21 va patch - graphics/ruby-imlib2/Makefile 1.24 va patch - graphics/ruby-opengl/Makefile 1.31 - graphics/ruby-rcairo/Makefile 1.22 via patch - inputmethod/ruby-zinnia/Makefile 1.3 - lang/ruby/buildlink3.mk 1.13 - lang/ruby/rubyversion.mk 1.58-1.59 - lang/ruby18-base/distinfo 1.47 - lang/ruby19-base/DEINSTALL 1.2 - lang/ruby19-base/Makefile 1.7 - lang/ruby19-base/PLIST 1.4 - lang/ruby19-base/distinfo 1.4 - lang/ruby19-base/patches/patch-string.c 1.1 - mail/ruby-tmail/Makefile 1.19 - math/ruby-rb-gsl/Makefile 1.9 - multimedia/ruby-clutter-gst/Makefile 1.9 via patch - multimedia/ruby-gnome2-gstreamer/Makefile 1.7 - multimedia/ruby-ming/Makefile 1.15 via patch - print/ruby-gnome2-gnomeprint/Makefile patch - print/ruby-gnome2-gnomeprintui/Makefile patch - print/ruby-gnome2-poppler/Makefile 1.19 via patch - security/ruby-password/Makefile 1.5 - security/ruby-tcpwrap/Makefile 1.18 - sysutils/ruby-quota/Makefile 1.21 - textproc/ruby-bluecloth/Makefile 1.5 - textproc/ruby-cabocha/Makefile 1.3 - textproc/ruby-eruby/Makefile 1.26 - textproc/ruby-ferret/Makefile 1.6 - textproc/ruby-hpricot/Makefile 1.8 - textproc/ruby-itex2MML/Makefile 1.7 - textproc/ruby-json/Makefile 1.9 - textproc/ruby-libxml/Makefile 1.7 - textproc/ruby-mecab/Makefile 1.6 - textproc/ruby-native-hyperestraier/Makefile 1.6 - textproc/ruby-nokogiri/Makefile 1.4 - textproc/ruby-oniguruma/Makefile 1.6 - textproc/ruby-redcloth/Makefile 1.14 - textproc/ruby-sary/Makefile 1.7 - textproc/ruby-xmlparser/Makefile 1.15 - textproc/ruby-xslt/Makefile 1.7 - textproc/ruby-yamcha/Makefile 1.3 - www/mongrel/Makefile 1.13 via patch - www/ruby-clearsilver/Makefile 1.15 - www/ruby-fcgi/Makefile 1.15 - www/ruby-gnome2-gtkhtml2/Makefile patch - www/ruby-gnome2-gtkmozembed/Makefile 1.17 via patch - www/ruby-patron/Makefile 1.5 - www/thin/Makefile 1.8 via patch - x11/ruby-gnome2-gtk/Makefile 1.25 via patch - x11/ruby-gnome2-gtksourceview/Makefile patch via 1.12 - x11/ruby-gnome2-gtksourceview2/Makefile patch - x11/ruby-gnome2-panelapplet/Makefile patch - x11/ruby-gnome2-vte/Makefile 1.16 via patch --- Module Name: pkgsrc Module Name: pkgsrc Committed By: taca Date: Mon Feb 21 14:31:06 UTC 2011 Modified Files: pkgsrc/lang/ruby: rubyversion.mk Log Message: * Start upate of ruby18 and ruby19 packags. * Remove redundant GEM_HOME definition from PLIST. --- Module Name: pkgsrc Module Name: pkgsrc Committed By: taca Date: Mon Feb 21 14:35:38 UTC 2011 Modified Files: pkgsrc/lang/ruby18-base: distinfo Log Message: Update ruby18-base package to 1.8.7.334 (Ruby 1.8.7p334). * The FileUtils Vulnerability http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/ * The $SAFE Vulnerability Fri Feb 18 21:18:55 2011 Shugo Maeda <shugo@ruby-lang.org> * test/ruby/test_exception.rb (TestException::test_to_s_taintness_propagation): Test for below. Fri Feb 18 21:18:55 2011 URABE Shyouhei <shyouhei@ruby-lang.org> * error.c (exc_to_s): untainted strings can be tainted via Exception#to_s, which enables attackers to overwrite sane strings. Reported by: Yusuke Endoh <mame at tsg.ne.jp>. * error.c (name_err_to_s): ditto. Fri Feb 18 21:17:22 2011 Shugo Maeda <shugo@ruby-lang.org> * lib/fileutils.rb (FileUtils::remove_entry_secure): there is a race condition in the case where the given path is a directory, and some other user can move that directory, and create a symlink while this method is executing. Reported by: Nicholas Jefferson <nicholas at pythonic.com.au> Fri Feb 18 19:46:46 2011 NAKAMURA Usaku <usa@ruby-lang.org> * win32/win32.c (init_stdhandle): backport mistake of r29382. some code are needless in ruby 1.8. [ruby-core:34579] Fri Feb 18 19:22:17 2011 URABE Shyouhei <shyouhei@ruby-lang.org> * configure.in: revert revision r29854. This revision introduced binary incompatibilities on some circumstances. The bug that revision was fixing gets reopened by this reversion. [ruby-dev:43152] cf. [Bug #2553] --- Module Name: pkgsrc Module Name: pkgsrc Committed By: taca Date: Mon Feb 21 14:44:11 UTC 2011 Modified Files: pkgsrc/lang/ruby19-base: DEINSTALL Makefile PLIST distinfo Added Files: pkgsrc/lang/ruby19-base/patches: patch-string.c Log Message: Update ruby19-base package to 1.9.2pl180 (Ruby 1.9.2 p180). * The FileUtils Vulnerability http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/ * Add a patch r30779 from repository; a bug of utf-8 string handling. For more detail changes of Ruby 1.9.2pl180, please refer: http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_180/ChangeLog --- Module Name: pkgsrc Module Name: pkgsrc Committed By: taca Date: Mon Feb 21 15:00:34 UTC 2011 Modified Files: pkgsrc/lang/ruby: buildlink3.mk rubyversion.mk Log Message: Introduce RUBY_ABI_VERSION and use it BUILDLINK_ABI_DEPENDS. There are ABI incompatibility amaong Ruby 1.8.7 patchlevel 302, 330 and 334, So it would be handle if such problem in future. --- Module Name: pkgsrc Module Name: pkgsrc Committed By: taca Date: Mon Feb 21 16:01:24 UTC 2011 Modified Files: pkgsrc/archivers/ruby-libarchive: Makefile pkgsrc/comms/ruby-termios: Makefile pkgsrc/converters/ruby-uconv: Makefile pkgsrc/databases/ruby-do_sqlite3: Makefile pkgsrc/databases/ruby-ldap: Makefile pkgsrc/databases/ruby-mysql: Makefile pkgsrc/databases/ruby-odbc: Makefile pkgsrc/databases/ruby-pg: Makefile pkgsrc/databases/ruby-postgresql: Makefile pkgsrc/databases/ruby-qdbm: Makefile pkgsrc/databases/ruby-sqlite: Makefile pkgsrc/databases/ruby-sqlite3: Makefile pkgsrc/databases/ruby-tokyocabinet: Makefile pkgsrc/devel/ruby-SDL: Makefile pkgsrc/devel/ruby-debug-base: Makefile pkgsrc/devel/ruby-eet: Makefile pkgsrc/devel/ruby-eventmachine: Makefile pkgsrc/devel/ruby-ffi: Makefile pkgsrc/devel/ruby-gnome2-atk: Makefile pkgsrc/devel/ruby-gnome2-gio: Makefile pkgsrc/devel/ruby-gnome2-glib: Makefile pkgsrc/devel/ruby-gnome2-pango: Makefile pkgsrc/devel/ruby-linecache: Makefile pkgsrc/devel/ruby-memcache: Makefile pkgsrc/devel/ruby-ncurses: Makefile pkgsrc/devel/ruby-priority-queue: Makefile pkgsrc/devel/ruby-racc: Makefile pkgsrc/devel/ruby-rbtree: Makefile pkgsrc/devel/ruby-rcov: Makefile pkgsrc/devel/ruby-rcsparse: Makefile pkgsrc/devel/ruby-subversion: Makefile pkgsrc/devel/ruby-thrift: Makefile pkgsrc/graphics/ruby-RMagick: Makefile pkgsrc/graphics/ruby-clutter-cairo: Makefile pkgsrc/graphics/ruby-clutter-core: Makefile pkgsrc/graphics/ruby-clutter-gtk: Makefile pkgsrc/graphics/ruby-gd: Makefile pkgsrc/graphics/ruby-gnome2-gdkpixbuf: Makefile pkgsrc/graphics/ruby-gnome2-goocanvas: Makefile pkgsrc/graphics/ruby-gnome2-rsvg: Makefile pkgsrc/graphics/ruby-imlib2: Makefile pkgsrc/graphics/ruby-opengl: Makefile pkgsrc/graphics/ruby-rcairo: Makefile pkgsrc/inputmethod/ruby-zinnia: Makefile pkgsrc/mail/ruby-tmail: Makefile pkgsrc/math/ruby-rb-gsl: Makefile pkgsrc/multimedia/ruby-clutter-gst: Makefile pkgsrc/multimedia/ruby-gnome2-gstreamer: Makefile pkgsrc/multimedia/ruby-ming: Makefile pkgsrc/print/ruby-gnome2-poppler: Makefile pkgsrc/security/ruby-password: Makefile pkgsrc/security/ruby-tcpwrap: Makefile pkgsrc/sysutils/ruby-quota: Makefile pkgsrc/textproc/ruby-bluecloth: Makefile pkgsrc/textproc/ruby-cabocha: Makefile pkgsrc/textproc/ruby-eruby: Makefile pkgsrc/textproc/ruby-ferret: Makefile pkgsrc/textproc/ruby-hpricot: Makefile pkgsrc/textproc/ruby-itex2MML: Makefile pkgsrc/textproc/ruby-json: Makefile pkgsrc/textproc/ruby-libxml: Makefile pkgsrc/textproc/ruby-mecab: Makefile pkgsrc/textproc/ruby-native-hyperestraier: Makefile pkgsrc/textproc/ruby-nokogiri: Makefile pkgsrc/textproc/ruby-oniguruma: Makefile pkgsrc/textproc/ruby-redcloth: Makefile pkgsrc/textproc/ruby-sary: Makefile pkgsrc/textproc/ruby-xmlparser: Makefile pkgsrc/textproc/ruby-xslt: Makefile pkgsrc/textproc/ruby-yamcha: Makefile pkgsrc/www/mongrel: Makefile pkgsrc/www/ruby-clearsilver: Makefile pkgsrc/www/ruby-fcgi: Makefile pkgsrc/www/ruby-gnome2-gtkmozembed: Makefile pkgsrc/www/ruby-patron: Makefile pkgsrc/www/thin: Makefile pkgsrc/x11/ruby-gnome2-gtk: Makefile pkgsrc/x11/ruby-gnome2-gtksourceview2: Makefile pkgsrc/x11/ruby-gnome2-vte: Makefile Log Message: Bump PKGREVISION due to ABI change of ruby18-base.
Revision 1.4 / (download) - annotate - [select for diffs], Mon Feb 21 16:01:16 2011 UTC (12 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base,
pkgsrc-2011Q1
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
Bump PKGREVISION due to ABI change of ruby18-base.
Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 11 21:22:02 2011 UTC (12 years, 10 months ago) by tnn
Branch: MAIN
Changes since 1.2: +2 -1
lines
Diff to previous 1.2 (colored)
revbump(1) for devel/libevent update.
Revision 1.2 / (download) - annotate - [select for diffs], Fri Sep 10 06:32:00 2010 UTC (13 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3
Branch point for: pkgsrc-2010Q4
Changes since 1.1: +3 -5
lines
Diff to previous 1.1 (colored)
* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk. * Add LICENSE. * Remove default value of GEM_BUILD. * Ajust new ruby package's framework.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Jun 11 22:50:40 2010 UTC (13 years, 6 months ago) by tonnerre
Branch: TNF
CVS Tags: pkgsrc-base,
pkgsrc-2010Q2-base,
pkgsrc-2010Q2
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Import the Thrift Ruby module, version 0.2.0.4. This is the Ruby implementation of the Thrift RPC protocol.
Revision 1.1 / (download) - annotate - [select for diffs], Fri Jun 11 22:50:40 2010 UTC (13 years, 6 months ago) by tonnerre
Branch: MAIN
Initial revision