File:  [cvs.NetBSD.org] / pkgsrc / devel / ruby-subversion / Makefile
Revision 1.98: download - view: text, annotated - select for diffs
Tue Dec 31 17:33:16 2024 UTC (2 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: HEAD
subversion: updated to 1.14.5

Apache Subversion 1.14.5. This is a stable bugfix and security release of the
Apache Subversion open source version control system. Among regular bug fixes,
this release fixes CVE-2024-46901: mod_dav_svn denial-of-service via control
characters in paths It has been discovered that the patch for CVE-2013-1968
was incomplete and unintentionally left mod_dav_svn vulnerable to control
characters in filenames. If a path or a revision-property which contains
control characters is committed to a repository then SVN operations served by
mod_dav_svn can be disrupted.

# $NetBSD: Makefile,v 1.98 2024/12/31 17:33:16 adam Exp $

PKGNAME=	${RUBY_PKGPREFIX}-subversion-${SVNVER}
COMMENT=	Ruby bindings for Subversion

.include "../../devel/subversion/Makefile.common"

TOOLS_BROKEN+=		perl
SHLIBTOOL_OVERRIDE=	# empty

REPLACE_RUBY_DIRS=	tools

CONFIGURE_ENV+=		RUBY=${RUBY:Q}
CONFIGURE_ARGS+=	--with-ruby-sitedir=${PREFIX}/${RUBY_VENDORLIB_BASE}

BUILD_TARGET=		swig-rb
INSTALL_TARGET=		install-swig-rb

TEST_TARGET=		check-swig-rb

INSTALLATION_DIRS+=	${SVNEXAMPLES:S/${PREFIX}\///}/ruby

post-patch:
	${RM} ${WRKSRC}/build-outputs.mk
	${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk

post-install:
	${RM} -f ${DESTDIR}${PREFIX}/${RUBY_VENDORARCHLIB}/svn/ext/*.la
	${INSTALL_DATA} ${WRKSRC}/tools/*/*.rb ${DESTDIR}${SVNEXAMPLES}/ruby

.include "../../devel/subversion-base/buildlink3.mk"
.include "../../lang/ruby/modules.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>