[BACK]Return to patch-ab CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-stream / patches

File: [cvs.NetBSD.org] / pkgsrc / devel / ruby-stream / patches / Attic / patch-ab (download)

Revision 1.2, Sun Sep 26 12:14:22 2010 UTC (7 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +26 -3 lines

Fix gemspec syntax to fix build problem with ruby19.
Ruby 1.8's gem (misc/rubygems) contains a patch to allow such a wrong
syntax of gemspec.  (I don't think this patch is a good idea now.)

Noted by joerg@ via private mail.

$NetBSD: patch-ab,v 1.2 2010/09/26 12:14:22 taca Exp $

Correct URL which is strictly checked by RubyGems.

--- ../stream-0.5.gemspec.orig	2010-09-26 02:08:31.000000000 +0000
+++ ../stream-0.5.gemspec
@@ -12,9 +12,12 @@ default_executable: 
 dependencies: 
 description: Module Stream defines an interface for external iterators.
 email: hd.at.clr@hduchene.de
-executables: 
-extensions: 
-extra_rdoc_files: 
+executables: []
+
+extensions: []
+
+extra_rdoc_files: []
+
 files: 
 - install.rb
 - Rakefile
@@ -27,7 +30,7 @@ files: 
 - examples/examples.rb
 - examples/streamtester.rb
 has_rdoc: true
-homepage: rgl.rubyforge.org
+homepage: http://rgl.rubyforge.org
 licenses: 
 post_install_message: 
 rdoc_options: 
@@ -41,5 +44,5 @@ rubygems_version: 1.3.7
 signing_key: 
 specification_version: -1
 summary: Stream - Extended External Iterators
-test_files: 
+test_files: []