File:  [cvs.NetBSD.org] / pkgsrc / devel / ruby-redmine-flatly-light-theme / Makefile
Revision 1.3: download - view: text, annotated - select for diffs
Wed Jan 4 23:05:12 2017 UTC (8 years ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, HEAD
Make Redmine great again too. General cleanup as well as updating all the
package to latest stable. There's a security issue with nokogiri that's
resolved with this update. This package was tested extensively not only
for build/install but also for functionality. If anyone has problems with
it, please let me know.

Full changelogs (very long) are here:

http://www.redmine.org/projects/redmine/wiki/Changelog_3_3
http://www.redmine.org/projects/redmine/wiki/Changelog_3_2
http://www.redmine.org/projects/redmine/wiki/Changelog_3_1

# $NetBSD: Makefile,v 1.3 2017/01/04 23:05:12 rodent Exp $
#

GITHUB_TAG=	v0.1.1
DISTNAME=	${GITHUB_TAG}
PKGNAME=	${RUBY_PKGPREFIX}-redmine-flatly-light-theme-${DISTNAME:S/v//1}
GITHUB_PROJECT=	flatly_light_redmine
MASTER_SITES=	${MASTER_SITE_GITHUB:=Nitrino/}
DIST_SUBDIR=	ruby-redmine-flatly-light-theme

MAINTAINER=	rodent@NetBSD.org
HOMEPAGE=	https://github.com/Nitrino/flatly_light_redmine
COMMENT=	Flatly light theme for Redmine
LICENSE=	mit

.include "../../meta-pkgs/ruby-redmine-themes/Makefile.common"

FLATLY_LIGHT_DIR=	${REDMINE_THEMEDIR}/flatly_light_redmine

INSTALLATION_DIRS+=	${FLATLY_LIGHT_DIR}/fonts ${FLATLY_LIGHT_DIR}/images
INSTALLATION_DIRS+=	${FLATLY_LIGHT_DIR}/javascripts
INSTALLATION_DIRS+=	${FLATLY_LIGHT_DIR}/stylesheets

do-install:
	for i in fonts javascripts stylesheets; do \
		${INSTALL_DATA} ${WRKSRC}/$$i/*.* \
			${DESTDIR}${PREFIX}/${FLATLY_LIGHT_DIR}/$$i; \
	done

.include "../../lang/ruby/rubyversion.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>