The NetBSD Project

CVS log for pkgsrc/devel/ruby-pkg-config/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-pkg-config

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.30 / (download) - annotate - [select for diffs], Sun Jan 10 15:44:14 2021 UTC (7 days, 19 hours ago) by taca
Branch: MAIN
CVS Tags: HEAD
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

devel/ruby-pkg-config: update to 1.4.4

== 1.4.4 - 2020-09-23

=== Fixes

  * Fixed a bug that NoMethodError instead of
    PackageConfig::NotFoundError is raised.
    [Fixed by kojix2][GitHub#21]

=== Thanks

  * kojix2

Revision 1.29 / (download) - annotate - [select for diffs], Sat Sep 19 13:30:36 2020 UTC (3 months, 4 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.28: +2 -2 lines
Diff to previous 1.28 (colored)

devel/ruby-pkg-config: update to 1.4.3

Update ruby-pkg-config package to 1.4.3.


1.4.3 (2020-09-14)

* Use PackageConfig::NotFoundError
* Remove needless implicit Bundler

Revision 1.28 / (download) - annotate - [select for diffs], Sun Sep 13 15:58:56 2020 UTC (4 months ago) by taca
Branch: MAIN
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

devel/ruby-pkg-config: update to 1.4.2

Update ruby-pkg-config package to 1.4.2.


== 1.4.2 - 2020-08-10

=== Improvements

  * Added support for detecting pkgconfig path on RubyInstaller
    without "ridk exec".

Revision 1.27 / (download) - annotate - [select for diffs], Sun Mar 8 14:52:54 2020 UTC (10 months, 1 week ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

devel/ruby-pkg-config: update to 1.4.1

Update ruby-pkg-config to 1.4.1.


== 1.4.1 - 2020-02-10

=== Improvements

  * Added support for cycled depended .pc such as freetype2.pc and
    harfbuzz.pc on PLD Linux.
    [Reported by Jakub Bogusz]

Revision 1.26 / (download) - annotate - [select for diffs], Wed Feb 5 15:00:46 2020 UTC (11 months, 1 week ago) by taca
Branch: MAIN
Changes since 1.25: +4 -2 lines
Diff to previous 1.25 (colored)

devel/ruby-pkg-config: update to 1.3.9

Update to ruby-pkg-config to 1.3.9.

== 1.3.9 - 2019-09-28

=== Improvements

  * Added support for absolute path in Requires.
    [GitHub#18][Reported by Josh Huckabee]

=== Thanks

  * Josh Huckabee

== 1.3.8 - 2019-08-13

=== Improvements

  * Added support for -framework on macOS.
    [GitHub:ruby-gnome2/ruby-gnome2#1287][Reported by Viko]

=== Thanks

  * Viko

Revision 1.25 / (download) - annotate - [select for diffs], Sat Sep 14 18:15:21 2019 UTC (16 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

ruby-pkg-config, ruby-native-package-installer: ruby-gnome2 -> ruby-gnome

Revision 1.24 / (download) - annotate - [select for diffs], Mon May 6 05:30:39 2019 UTC (20 months, 2 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

devel/ruby-pkg-config: update to 1.3.7

== 1.3.7 - 2019-03-17

=== Improvements

  * Added support for alphabet and _ only version.
    [GitHub#17][Reported by xiejiangzhi]

Revision 1.23 / (download) - annotate - [select for diffs], Sat Mar 9 13:13:01 2019 UTC (22 months, 1 week ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

ruby-pkg-config: update to 1.3.6.

Upstream changes (from NEWS):

== 1.3.6 - 2019-03-09

=== Improvements

  * Added support for Homebrew environment without pkg-config formula.

== 1.3.5 - 2019-03-08

=== Fixes

  * Fixed MSYS2 detection installed at non standard folder.
    [GitHub:ruby-gnome2/ruby-gnome2#1271][Reported by Simon Arnaud]

=== Thanks

* Simon Arnaud

Revision 1.22 / (download) - annotate - [select for diffs], Mon Feb 25 16:42:23 2019 UTC (22 months, 3 weeks ago) by taca
Branch: MAIN
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

devel/ruby-pkg-config: update to 1.3.4

== 1.3.4 - 2019-02-19

=== Fixes

  * Fixed 32bit MinGW Ruby detection.
    [GitHub:ruby-gnome2/ruby-gnome2#1274][Reported by noanoa07]

=== Thanks

  * noanoa07

== 1.3.3 - 2019-02-10

=== Improvements

  * Improved MSYS2 detection on Windows.
    [GitHub#16][Reported by dsisnero]

=== Thanks

  * dsisnero

Revision 1.21 / (download) - annotate - [select for diffs], Mon Dec 17 14:51:34 2018 UTC (2 years, 1 month ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

devel/ruby-pkg-config: update to 1.3.2

== 1.3.2 - 2018-11-03

=== Improvements

  * Added support for Ruby installed by RubyInstaller for Windows with
    MSYS2-Devkit.

Revision 1.20 / (download) - annotate - [select for diffs], Sun May 6 01:58:04 2018 UTC (2 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

devel/ruby-pkg-config: update to 1.3.1

== 1.3.1 - 2018-04-28

=== Improvements

  * Changed search order to find C flags.
    [GitHub#6][Reported by HIGUCHI Daisuke]
    * Before: Requires -> Requires.private
    * After: Requires.private -> Requires

=== Thanks

  * HIGUCHI Daisuke

== 1.3.0 - 2018-04-10

=== Improvements

  * Added Ruby 2.0 on Ubuntu Trusty again.

== 1.3.0 - 2018-04-10

=== Improvements

  * Added Ruby 2.0 on Ubuntu Trusty again.

Revision 1.19 / (download) - annotate - [select for diffs], Wed Mar 14 14:10:57 2018 UTC (2 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

devel/ruby-pkg-config: update to 1.2.9

== 1.2.9 - 2018-01-13

=== Improvements

  * Added more default paths for OpenBSD.
    [GitHub#15][Reported by clintpachl]

=== Thanks

  * clintpachl

== 1.2.8 - 2017-10-19

=== Improvements

  * Improved macOS environment detection.
    [Reported by Simeon Manolov]

Revision 1.18 / (download) - annotate - [select for diffs], Thu Aug 31 15:19:28 2017 UTC (3 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.17: +2 -2 lines
Diff to previous 1.17 (colored)

Update ruby-pkg-config to 1.2.7.

== 1.2.7 - 2017-08-16

=== Improvements

  * Improved Homebrew repository detection.
    [Reported by Wyatt Kirby]

=== Thanks

  * Wyatt Kirby

== 1.2.6 - 2017-08-13

=== Improvements

  * Improved Homebrew repository detection.

== 1.2.5 - 2017-08-10

=== Improvements

  * Supported Homebrew bundled .pc files.
    [GitHub:rcairo/rcairo#49][Reported by choboy11]

=== Thanks

  * choboy11

== 1.2.4 - 2017-08-07

=== Improvements

  * Added `pkg-config` 0.29 or later compatible result support.
    [GitHub#13][Reported by HIGUCHI Daisuke]

  * test: Updated expected value for the latest cairo.
    [GitHub#14][Patch by HIGUCHI Daisuke]

=== Thanks

  * HIGUCHI Daisuke

Revision 1.17 / (download) - annotate - [select for diffs], Sun Jun 4 15:56:52 2017 UTC (3 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.16: +2 -5 lines
Diff to previous 1.16 (colored)

Update ruby-pkg-config to 1.2.3.

== 1.2.3 - 2017-05-29

=== Fixes

  * Supported *-mingw32 Rubies without MSYS2 again.

== 1.2.2 - 2017-05-29

=== Improvements

  * Supported path normalization for MSYS2.

== 1.2.1 - 2017-05-29

=== Improvements

  * Supported MSYS2.

== 1.2.0 - 2017-04-25

=== Improvements

  * Supported x32 environment. [GitHub#12][Reported by Elan Ruusamäe]

=== Thanks

  * Elan Ruusamäe

== 1.1.9 - 2017-04-20

  * Supported C++ compiler.

== 1.1.8 - 2017-04-19

  * Stopped to require mkmf.

Revision 1.16 / (download) - annotate - [select for diffs], Sat Apr 22 16:29:27 2017 UTC (3 years, 8 months ago) by taca
Branch: MAIN
Changes since 1.15: +3 -4 lines
Diff to previous 1.15 (colored)

Update ruby-pkg-config to 1.1.9.

== 1.1.9 - 2017-04-20

  * Supported C++ compiler.

== 1.1.8 - 2017-04-19

  * Stopped to require mkmf.

Revision 1.15 / (download) - annotate - [select for diffs], Mon Jan 11 23:48:38 2016 UTC (5 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.14: +5 -6 lines
Diff to previous 1.14 (colored)

Switch to gem.mk. Bump PKGREVISION.

Revision 1.14 / (download) - annotate - [select for diffs], Wed Jan 6 15:28:31 2016 UTC (5 years ago) by taca
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Update ruby-pkg-config to 1.1.7.

== 1.1.7 - 2015-01-16

  * Added path for FreeBSD to default paths.
    [Reported by Hajime UMEMOTO]

Revision 1.13 / (download) - annotate - [select for diffs], Sun Mar 15 19:57:40 2015 UTC (5 years, 10 months ago) by hiramatsu
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Set MAINTAINER to pkgsrc-users.

Revision 1.12 / (download) - annotate - [select for diffs], Fri Nov 14 11:23:38 2014 UTC (6 years, 2 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Update ruby-pkg-config to 1.1.6.

= NEWS

== 1.1.6 - 2014/11/12

  * Supported Ruby 2.1.
    [GitHub:ruby-gnome2/ruby-gnome2#262][Reported by Steve Wills]

=== Thanks

  * Steve Wills

Revision 1.11 / (download) - annotate - [select for diffs], Tue Dec 31 11:32:04 2013 UTC (7 years ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.10: +3 -3 lines
Diff to previous 1.10 (colored)

Update ruby-pkg-config to 1.1.5.

* Add XQuartz's path for X11

Revision 1.10 / (download) - annotate - [select for diffs], Sat Apr 6 03:45:12 2013 UTC (7 years, 9 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Fixes:

 COMMENT should not be longer than 70 characters.
 COMMENT should not begin with 'A'.
 COMMENT should not begin with 'An'.
 COMMENT should not begin with 'a'.
 COMMENT should not end with a period.
 COMMENT should start with a capital letter.

pkglint warnings. Some files also got minor formatting, spelling, and style
corrections.

Revision 1.9 / (download) - annotate - [select for diffs], Thu Mar 14 13:42:57 2013 UTC (7 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

Update ruby-pkg-config to 1.1.4.
= NEWS

== 1.1.4 - 2012/08/02

  * Supported mswin64 as MSVC environment.

Revision 1.8 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:42 2012 UTC (8 years, 2 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.7: +1 -3 lines
Diff to previous 1.7 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.7 / (download) - annotate - [select for diffs], Wed Feb 1 12:48:17 2012 UTC (8 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1
Changes since 1.6: +4 -9 lines
Diff to previous 1.6 (colored)

Instead of SUBST, pass `vendor' directories to setup.rb as `site' directory.

Revision 1.6 / (download) - annotate - [select for diffs], Wed Feb 1 12:32:12 2012 UTC (8 years, 11 months ago) by obache
Branch: MAIN
Changes since 1.5: +15 -5 lines
Diff to previous 1.5 (colored)

Update ruby-pkg-config to 1.1.3.

== 1.1.3 - 2012/01/29

  * [GitHub #8] fix test broken by libpng version.
    (Patch by Bohuslav Kabrda.)
  * Used RbConfig instead of Config.


== 1.1.2 - 2011/07/04

  * [GitHub #2] fix test broken.
    (Reported by Mamoru Tasaka.)
  * [GitHub #4] update project descripton.
    (Patch by Antonio Terceiro.)
  * [GitHub #4] use setup.rb instead of extconf.rb.
    (Patch by Antonio Terceiro.)
  * [GitHub #3] add Copyright notice to README.
    (Suggested by Antonio Terceiro.)
  * [GitHub #7] supported non i386 and amd64 architectures.
    (Reported by Antonio Terceiro.)

Revision 1.5 / (download) - annotate - [select for diffs], Tue May 3 09:49:03 2011 UTC (9 years, 8 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2
Changes since 1.4: +3 -3 lines
Diff to previous 1.4 (colored)

Update ruby-pkg-config to 1.1.1.

== 1.1.1 - 2011/05/03

* [ruby-gnome-devel-en] add
  /usr/lib/i386-linux-gnu/pkgconfig to the default paths.
  (Reported by Andrea B.C.)

Revision 1.4 / (download) - annotate - [select for diffs], Mon Apr 4 09:28:03 2011 UTC (9 years, 9 months ago) by obache
Branch: MAIN
Changes since 1.3: +3 -3 lines
Diff to previous 1.3 (colored)

Update ruby-pkg-config to 1.1.0

== 1.1.0 - 2011/04/03

* [#3270846] add /usr/lib/x86_64-linux-gnu/pkgconfig to default paths.
  (Reported by Funky Bibimbap)

Revision 1.3 / (download) - annotate - [select for diffs], Sun Jan 30 12:10:30 2011 UTC (9 years, 11 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.2: +3 -3 lines
Diff to previous 1.2 (colored)

Update ruby-pkg-config to 1.0.8.

== 1.0.8 - 2011/01/30

* fix a bug that multiple PKGConfig.add_path doesn't work.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Oct 23 07:53:29 2010 UTC (10 years, 2 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4
Changes since 1.1: +3 -3 lines
Diff to previous 1.1 (colored)

Updte ruby-pkg-config to 1.0.7.

== 1.0.7 - 2010/09/30

* suppress warnings on Ruby 1.9.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Thu Sep 23 15:24:28 2010 UTC (10 years, 3 months ago) by obache
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Import ruby-pkg-config-1.0.6 as devel/ruby-pkg-config.

A pkg-config implementation by Ruby.

Revision 1.1 / (download) - annotate - [select for diffs], Thu Sep 23 15:24:28 2010 UTC (10 years, 3 months ago) by obache
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>