The NetBSD Project

CVS log for pkgsrc/devel/ruby-eventmachine/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-eventmachine

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.28 / (download) - annotate - [select for diffs], Tue Oct 24 22:08:58 2023 UTC (6 weeks, 4 days ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.27: +2 -2 lines
Diff to previous 1.27 (colored)

*: bump for openssl 3

Revision 1.27 / (download) - annotate - [select for diffs], Sun Feb 14 15:27:51 2021 UTC (2 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.26: +2 -2 lines
Diff to previous 1.26 (colored)

devel/ruby-eventmachine: fix build problem with Ruby 3.0

Change USE_LANGUAGES to contain c++11 instead of c++03 since
std::nullptr_t requires c++11.

Revision 1.26 / (download) - annotate - [select for diffs], Sat Jan 18 21:49:15 2020 UTC (3 years, 10 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.25: +2 -1 lines
Diff to previous 1.25 (colored)

*: Recursive revision bump for openssl 1.1.1.

Revision 1.25 / (download) - annotate - [select for diffs], Sun Sep 23 14:19:05 2018 UTC (5 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

devel/ruby-eventmachine: update to 1.2.7

## 1.2.7 (May 12, 2018)
* Fix segfault on large numbers of connections [#843]

Revision 1.24 / (download) - annotate - [select for diffs], Sat May 5 15:41:18 2018 UTC (5 years, 7 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

devel/ruby-eventmachine: update to 1.2.6

## 1.2.6 (April 30, 2018)
* *Fix segfault when an Exception is raised from unbind callback (for real this time!)*
* Fix race condition while initializing the machine [#756]
* Fix for newer compilers where bind() and std::bind() conflict [#830, #831]
* Be verbose about SSL connection errors [#807]
* Avoid explicitly calling class methods when in class scope
* Java: Add EM_PROTO_SSL/TLS definitions [#773, #791]
* Java: return zero when sending data to a closed connection [#475, #804]
* Pure Ruby: Connection::error? calls report_connection_error_status [#801]

Revision 1.23 / (download) - annotate - [select for diffs], Fri Jan 26 13:17:27 2018 UTC (5 years, 10 months ago) by jperkin
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

ruby-eventmachine: Specify c++03 to avoid conflicts with std::bind.

Revision 1.22 / (download) - annotate - [select for diffs], Mon Jul 31 14:09:47 2017 UTC (6 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

Update ruby-eventmachine to 1.2.5.

## 1.2.5 (July 27, 2017)
* Java: Use long for larger values in oneshot timer intervals [#784, #794]

## 1.2.4 (July 27, 2017)
* Java: Add EM_PROTO_SSL/TLS definitions [#773, #791]
* Fix IPv6 UDP get_peername [#788]
* Allow for larger values in oneshot timer intervals [#784, #793]
* Update extconf.rb to allow MinGW builds with OpenSSL 1.1.0 [#785]

Revision 1.21 / (download) - annotate - [select for diffs], Sun Mar 12 14:34:01 2017 UTC (6 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

Update ruby-eventmachine to 1.2.3.

# Changelog

## 1.2.3 (February 22, 2017)
* Pure Ruby: Add get_sockname [#308, #772]
* Fix segfault when an Exception is raised from unbind callback [#765, #766]
* Allow destructors to throw when compiling in >= C++11 [#767]

## 1.2.2 (January 23, 2017)
* Java: Fix Fixnum deprecated warning in Ruby 2.4+ [#759]
* Fix uncaught C++ exception in file watcher and raise InvalidSignature [#512, #757]
* Fix connection count off-by-one for epoll and kqueue [#750]
* Fix uninitialized variable warning in EM::P::HttpClient [#749]
* Fix missing initial value for EventableDescriptor NextHeartbeat [#748]
* Fix hostname resolution on Solaris, Ilumos, SmartOS, et al [#745, #746]
* Improve reliability of tests, reduce public Internet accesses in tests [#656, #666, #749]

## 1.2.1 (November 15, 2016)
* Throw strerror(errno) when getsockname or getpeername fail [#683]
* Use a single concrete implementation of getpeername/getsockname, the rest pure virtuals [#683]
* Use gai_strerror to get the failure string from getaddrinfo [#744]
* Fix deregistering descriptor when using KQUEUE [#728]
* Fix to enable to work an example code in EM::Pool [#731]
* LineText2: Add regular expression delimiter support [#706]
* Pure Ruby: EM rescue ECONNREFUSED on initial TCP connect [#741]
* Pure Ruby: EM SSL (working start_tls) [#712]
* Pure Ruby: EM fixes [#707]
* Java: Use Acceptors to get peer and sock names if not present in Connections [#743]

Revision 1.20 / (download) - annotate - [select for diffs], Wed Mar 16 13:04:18 2016 UTC (7 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

Update ruby-eventmachine to 1.2.0.1.

## 1.2.0.1 (March 15, 2016)
* Fix crash when accepting IPv6 connections due to struct sockaddr_in [#698, #699]

Revision 1.19 / (download) - annotate - [select for diffs], Tue Mar 15 17:07:03 2016 UTC (7 years, 8 months ago) by taca
Branch: MAIN
Changes since 1.18: +2 -3 lines
Diff to previous 1.18 (colored)

Update ruby-eventmachine to 1.2.0.

## 1.2.0 (March 15, 2016)
* Integrate work from the EventMachine-LE 1.1.x versions [#570]
* Add start_tls options :ecdh_curve, :dhparam, :fail_if_no_peer_cert [#195, #275, #399, #665]
* Add start_tls option :ssl_version for choosing SSL/TLS versions and ciphers [#359, #348, #603, #654]
* Add start_tls option :sni_hostname to be passed to TLS params [#593]
* Add method EM::Channel#num_subscribers to get the number of subscribers to a channel [#640]
* Add support for proc-sources in EM::Iterator [#639]
* Factor out method cleanup_machine to cleanup code from EM.run [#650]
* Replace Exception class with StandardError [#637]
* Close socket on close_connection even after close_connection_after_writing [#694]
* Allow reusing of datagram socket/setting bind device [#662]
* Handle deferred exceptions in reactor thread [#486]
* Reimplement Queue to avoid shift/push performance problem [#311]
* Windows: Switch from gethostbyname to getaddrinfo, support IPv6 addresses [#303, #630]
* Windows: Use rake-compiler-dock to cross-compile gems [#627]
* Windows: Add AppVeyor configuration for Windows CI testing [#578]
* Windows: Bump rake-compiler to version 0.9.x [#542]
* Fix compilation on AIX (w/ XLC) [#693]
* Fix build on OpenBSD [#690]
* Fix OpenSSL compile issue on AIX 7.1 [#678]
* Fix EventMachine.fork_reactor keeps the threadpool of the original process [#425]
* Fix to prevent event machine from stopping when a raise is done in an unbind [#327]

Revision 1.18 / (download) - annotate - [select for diffs], Sat Mar 5 11:28:26 2016 UTC (7 years, 9 months ago) by jperkin
Branch: MAIN
Changes since 1.17: +2 -1 lines
Diff to previous 1.17 (colored)

Bump PKGREVISION for security/openssl ABI bump.

Revision 1.17 / (download) - annotate - [select for diffs], Tue Feb 16 14:57:10 2016 UTC (7 years, 9 months ago) by taca
Branch: MAIN
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Update ruby-eventmachine to 1.0.9.1.

# Changelog

## 1.0.9.1 (January 14, 2016)
* Fix EPROTO not defined on Windows [#676]
* Fix missing cast to struct sockaddr * [#671]
* Fix bug in OpenSSL path detection [#675]

## 1.0.9 (January 13, 2016)
* Try more ways to detect OpenSSL [#602, #643, #661, #663, #668, #669]
* Use WSAGetLastError in pipe.cpp same as ed.cpp [#659]
* Test compiler flags with the C++ compiler and add them to CXXFLAGS [#634, #651]
* Restore silent-fail on unsupported EM.epoll and EM.kqueue [#638, #649]
* getDescriptorByFileno deprecated in JRuby 1.7.x, removed in JRuby 9000 [#642, #648]
* Add -Wno-address always-true because on Windows rb_fd_select [#578]
* Remove the WITHOUT_SSL constant [#578]
* Fix SSL error when the server replies a TLS Alert to our ClientHello [#544, #653]
* Use WSAStringToAddress in lieu of inet_pton for IPv6 address detection on Windows [#595, #632]
* Fix nasty TCP/IPv6 bug [#595, #632]
* Use select_large_fdset on Solaris [#611, #625]
* Detect the Solaris Studio compiler [#611, #625]
* Throw a message with strerror included [#136, #621]

Revision 1.16 / (download) - annotate - [select for diffs], Sun Sep 13 05:15:13 2015 UTC (8 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Update ruby-eventmachine to 1.0.8.

# Changelog

## 1.0.8 (August 6, 2015)
* fix kqueue assertion failed, postpone ArmKqueueWriter until all events are processed [#51, #176, #372, #401, #619]
* fix Rubinius GC, crank the machine from Ruby space when running Rubinius [#201, #202, #617]
* test to show that LineText2 preserves whitespace and newlines [#32, #622]
* bump up compiler warnings and resolve them [#616]
* fix Windows x64 use uintptr_t instead of unsigned long for binding pointers [#612, #615]
* fix linetext2 unroll tail recursion to avoid stack level too deep [#609]
* fix for compilation with SSL on windows [#601]
* open file descriptors and sockets with O_CLOEXEC where possible [#298, #488, #591]
* fix SmtpClient: send second EHLO after STARTTLS. [#589]
* fix nul-terminated strings in C, use StringValueCStr instead of StringValuePtr

Revision 1.15 / (download) - annotate - [select for diffs], Tue Feb 17 15:07:17 2015 UTC (8 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Update ruby-eventmachine to 1.0.7.

## 1.0.7 (February 10, 2015)
* fix delay in kqueue/epoll reactor shutdown when timers exist [#587]
* fix memory leak introduced in v1.0.5 [#586]
* expose EM.set_simultaneous_accept_count [#420]
* fix busy loop when EM.run and EM.next_tick are invoked from exception handler [#452]

Revision 1.14 / (download) - annotate - [select for diffs], Sat Feb 7 14:33:31 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Update ruby-eventmachine to 1.0.6.

## 1.0.6 (February 3, 2015)
* add support for Rubinius Process::Status [#568]
* small bugfixes for SmtpServer [#449]
* update buftok.rb [#547]
* fix assertion on Write() [#525]
* work around mkmf.rb bug preventing gem installation [#574]
* add pause/resume support to jruby reactor [#556]
* fix pure ruby reactor to use 127.0.0.1 instead of localhost [#439]
* fix compilation under macruby [#243]
* add chunked encoding to http client [#111]
* fix errors on win32 when dealing with pipes [1ea45498] [#105]

Revision 1.13 / (download) - annotate - [select for diffs], Tue Feb 3 13:39:22 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Update ruby-eventmachine to 1.0.5.

## 1.0.5 (February 2, 2015)
* use monotonic clocks on Linux, OS X, Solaris, and Windows [#563]
* use the rb_fd_* API to get autosized fd_sets [#502]
* add basic tests that the DNS resolver isn't leaking timers [#571]
* update to test-unit 2.x and improve various unit tests [#551]
* remove EventMachine_t::Popen code marked by ifdef OBSOLETE [#551]
* ruby 2.0 may fail at Queue.pop, so rescue and complain to $stderr [#551]
* set file handle to INVALID_HANDLE_VALUE after closing the file [#565]
* use `defined?` instead of rescuing NameError for flow control [#535]
* fix closing files and sockets on Windows [#564]
* fix file uploads in Windows [#562]
* catch failure to fork [#539]
* use chunks for SSL write [#545]

Revision 1.12 / (download) - annotate - [select for diffs], Sun Feb 1 13:57:38 2015 UTC (8 years, 10 months ago) by taca
Branch: MAIN
Changes since 1.11: +2 -4 lines
Diff to previous 1.11 (colored)

Update ruby-eventmachine to 1.0.4.

## 1.0.4 (December 19, 2014)
* add starttls_options to smtp server [#552]
* fix closesocket on windows [#497]
* fix build on ruby 2.2 [#503]
* fix build error on ruby 1.9 [#508]
* fix timer leak during dns resolution [#489]
* add concurrency validation to EM::Iterator [#468]
* add get_file_descriptor to get fd for a signature [#467]
* add EM.attach_server and EM.attach_socket_server [#465, #466]
* calling pause from receive_data takes effect immediately [#464]
* reactor_running? returns false after fork [#455]
* fix infinite loop on double close [edc4d0e6, #441, #445]
* fix compilation issue on llvm [#433]
* fix socket error codes on win32 [ff811a81]
* fix EM.stop latency when timers exist [8b613d05, #426]
* fix infinite loop when system time changes [1427a2c80, #428]
* fix crash when callin attach/detach in the same tick [#427]
* fix compilation issue on solaris [#416]

Revision 1.11 / (download) - annotate - [select for diffs], Wed Feb 12 23:17:50 2014 UTC (9 years, 9 months ago) by tron
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.10: +2 -1 lines
Diff to previous 1.10 (colored)

Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Mar 10 13:19:12 2013 UTC (10 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Changes since 1.9: +2 -3 lines
Diff to previous 1.9 (colored)

Update ruby-eventmachine to 1.0.3.

# Changelog

## 1.0.x
* EM.system was broken in 1.0.2 release [#413]

## 1.0.2 (March 8, 2013)
* binary win32 gems now include fastfilereader shim [#222]
* fix long-standing connection timeout issues [27fdd5b,
  igrigorik/em-http-request#222]
* http and line protocol cleanups [#193, #151]
* reactor return value cleanup [#225]
* fix double require from gemspec [#284]
* fix smtp server reset behavior [#351]
* fix EM.system argument handling [#322]
* ruby 1.9 compat in smtp server and stomp protocols [#349, #315]
* fix pause from post_init [#380]

## 1.0.1 (February 27, 2013)
* use rb_wait_for_single_fd() on ruby 2.0 to fix rb_thread_select() deprecation
* fix epoll/kqueue mode in ruby 2.0 by removing calls to rb_enable_interrupt()
  [#248, #389]
* fix memory leak when verifying ssl cerificates [#403]
* fix initial connection delay [#393, #374]

Revision 1.9 / (download) - annotate - [select for diffs], Wed Feb 6 23:22:10 2013 UTC (10 years, 10 months ago) by jperkin
Branch: MAIN
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

PKGREVISION bumps for the security/openssl 1.0.1d update.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Sep 16 06:18:08 2012 UTC (11 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.7: +2 -3 lines
Diff to previous 1.7 (colored)

Update ruby-eventmachine to 1.0.0.

Changes are unavailable.

Revision 1.6.4.1 / (download) - annotate - [select for diffs], Sun Feb 27 00:26:15 2011 UTC (12 years, 9 months ago) by tron
Branch: pkgsrc-2010Q4
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored) next main 1.7 (colored)

Pullup ticket #3361 - requested by taca
archivers/ruby-libarchive: dependence update
comms/ruby-termios: dependence update
converters/ruby-uconv: dependence update
databases/ruby-do_sqlite3: dependence update
databases/ruby-ldap: dependence update
databases/ruby-mysql: dependence update
databases/ruby-odbc: dependence update
databases/ruby-pg: dependence update
databases/ruby-postgresql: dependence update
databases/ruby-qdbm: dependence update
databases/ruby-sqlite: dependence update
databases/ruby-sqlite3: dependence update
databases/ruby-tokyocabinet: dependence update
devel/ruby-SDL: dependence update
devel/ruby-debug-base: dependence update
devel/ruby-eet: dependence update
devel/ruby-eventmachine: dependence update
devel/ruby-ffi: dependence update
devel/ruby-gnome2-atk: dependence update
devel/ruby-gnome2-bonobo: dependence update
devel/ruby-gnome2-bonoboui: dependence update
devel/ruby-gnome2-gconf: dependence update
devel/ruby-gnome2-gio: dependence update
devel/ruby-gnome2-glib: dependence update
devel/ruby-gnome2-libglade: dependence update
devel/ruby-gnome2-pango: dependence update
devel/ruby-linecache: dependence update
devel/ruby-memcache: dependence update
devel/ruby-ncurses: dependence update
devel/ruby-priority-queue: dependence update
devel/ruby-racc: dependence update
devel/ruby-rbtree: dependence update
devel/ruby-rcov: dependence update
devel/ruby-rcsparse: dependence update
devel/ruby-subversion: dependence update
devel/ruby-thrift: dependence update
graphics/ruby-RMagick: dependence update
graphics/ruby-clutter-cairo: dependence update
graphics/ruby-clutter-core: dependence update
graphics/ruby-clutter-gtk: dependence update
graphics/ruby-gd: dependence update
graphics/ruby-gnome2-gdkpixbuf: dependence update
graphics/ruby-gnome2-gnomecanvas: dependence update
graphics/ruby-gnome2-goocanvas: dependence update
graphics/ruby-gnome2-gtkglext: dependence update
graphics/ruby-gnome2-libart: dependence update
graphics/ruby-gnome2-rsvg: dependence update
graphics/ruby-imlib2: dependence update
graphics/ruby-opengl: dependence update
graphics/ruby-rcairo: dependence update
inputmethod/ruby-zinnia: dependence update
lang/ruby: dependence update
lang/ruby18-base: security update
lang/ruby19-base: security update
mail/ruby-tmail: dependence update
math/ruby-rb-gsl: dependence update
multimedia/ruby-clutter-gst: dependence update
multimedia/ruby-gnome2-gstreamer: dependence update
multimedia/ruby-ming: dependence update
print/ruby-gnome2-gnomeprint: dependence update
print/ruby-gnome2-gnomeprintui: dependence update
print/ruby-gnome2-poppler: dependence update
security/ruby-password: dependence update
security/ruby-tcpwrap: dependence update
sysutils/ruby-quota: dependence update
textproc/ruby-bluecloth: dependence update
textproc/ruby-cabocha: dependence update
textproc/ruby-eruby: dependence update
textproc/ruby-ferret: dependence update
textproc/ruby-hpricot: dependence update
textproc/ruby-itex2MML: dependence update
textproc/ruby-json: dependence update
textproc/ruby-libxml: dependence update
textproc/ruby-mecab: dependence update
textproc/ruby-native-hyperestraier: dependence update
textproc/ruby-nokogiri: dependence update
textproc/ruby-oniguruma: dependence update
textproc/ruby-redcloth: dependence update
textproc/ruby-sary: dependence update
textproc/ruby-xmlparser: dependence update
textproc/ruby-xslt: dependence update
textproc/ruby-yamcha: dependence update
www/mongrel: dependence update
www/ruby-clearsilver: dependence update
www/ruby-fcgi: dependence update
www/ruby-gnome2-gtkhtml2: dependence update
www/ruby-gnome2-gtkmozembed: dependence update
www/ruby-patron: dependence update
www/thin: dependence update
x11/ruby-gnome2-gnome: dependence update
x11/ruby-gnome2-gtk: dependence update
x11/ruby-gnome2-gtksourceview: dependence update
x11/ruby-gnome2-gtksourceview2: dependence update
x11/ruby-gnome2-panelapplet: dependence update
x11/ruby-gnome2-vte: dependence update

Revisions pulled up:
- archivers/ruby-libarchive/Makefile				1.2
- comms/ruby-termios/Makefile					1.23
- converters/ruby-uconv/Makefile				1.19
- databases/ruby-do_sqlite3/Makefile				1.2
- databases/ruby-ldap/Makefile					1.7
- databases/ruby-mysql/Makefile					1.34 via patch
- databases/ruby-odbc/Makefile					1.10 via patch
- databases/ruby-pg/Makefile					1.6
- databases/ruby-postgresql/Makefile				1.37
- databases/ruby-qdbm/Makefile					1.12
- databases/ruby-sqlite/Makefile				1.3
- databases/ruby-sqlite3/Makefile				1.15
- databases/ruby-tokyocabinet/Makefile				1.24
- devel/ruby-SDL/Makefile					1.9 via patch
- devel/ruby-debug-base/Makefile				1.7
- devel/ruby-eet/Makefile					1.8
- devel/ruby-eventmachine/Makefile				1.7
- devel/ruby-ffi/Makefile					1.3
- devel/ruby-gnome2-atk/Makefile				1.8
- devel/ruby-gnome2-bonobo/Makefile				patch
- devel/ruby-gnome2-bonoboui/Makefile				patch
- devel/ruby-gnome2-gconf/Makefile				patch
- devel/ruby-gnome2-gio/Makefile				1.3 via patch
- devel/ruby-gnome2-glib/Makefile				1.11
- devel/ruby-gnome2-libglade/Makefile				patch
- devel/ruby-gnome2-pango/Makefile				1.18 via patch
- devel/ruby-linecache/Makefile					1.5
- devel/ruby-memcache/Makefile					1.4
- devel/ruby-ncurses/Makefile					1.9
- devel/ruby-priority-queue/Makefile				1.6
- devel/ruby-racc/Makefile					1.18
- devel/ruby-rbtree/Makefile					1.6
- devel/ruby-rcov/Makefile					1.5
- devel/ruby-rcsparse/Makefile					1.10
- devel/ruby-subversion/Makefile				1.28
- devel/ruby-thrift/Makefile					1.4 via patch
- graphics/ruby-RMagick/Makefile				1.76 via patch
- graphics/ruby-clutter-cairo/Makefile				1.8 via patch
- graphics/ruby-clutter-core/Makefile				1.11 via patch
- graphics/ruby-clutter-gtk/Makefile				1.8 via patch
- graphics/ruby-gd/Makefile					1.34 via patch
- graphics/ruby-gnome2-gdkpixbuf/Makefile			1.20 via patch
- graphics/ruby-gnome2-gnomecanvas/Makefile			patch
- graphics/ruby-gnome2-goocanvas/Makefile			1.12 via patch
- graphics/ruby-gnome2-gtkglext/Makefile			patch
- graphics/ruby-gnome2-libart/Makefile				patch
- graphics/ruby-gnome2-rsvg/Makefile				1.21 va patch
- graphics/ruby-imlib2/Makefile					1.24 va patch
- graphics/ruby-opengl/Makefile					1.31
- graphics/ruby-rcairo/Makefile					1.22 via patch
- inputmethod/ruby-zinnia/Makefile				1.3
- lang/ruby/buildlink3.mk					1.13
- lang/ruby/rubyversion.mk					1.58-1.59
- lang/ruby18-base/distinfo					1.47
- lang/ruby19-base/DEINSTALL					1.2
- lang/ruby19-base/Makefile					1.7
- lang/ruby19-base/PLIST					1.4
- lang/ruby19-base/distinfo					1.4
- lang/ruby19-base/patches/patch-string.c			1.1
- mail/ruby-tmail/Makefile					1.19
- math/ruby-rb-gsl/Makefile					1.9
- multimedia/ruby-clutter-gst/Makefile				1.9 via patch
- multimedia/ruby-gnome2-gstreamer/Makefile			1.7
- multimedia/ruby-ming/Makefile					1.15 via patch
- print/ruby-gnome2-gnomeprint/Makefile				patch
- print/ruby-gnome2-gnomeprintui/Makefile			patch
- print/ruby-gnome2-poppler/Makefile				1.19 via patch
- security/ruby-password/Makefile				1.5
- security/ruby-tcpwrap/Makefile				1.18
- sysutils/ruby-quota/Makefile					1.21
- textproc/ruby-bluecloth/Makefile				1.5
- textproc/ruby-cabocha/Makefile				1.3
- textproc/ruby-eruby/Makefile					1.26
- textproc/ruby-ferret/Makefile					1.6
- textproc/ruby-hpricot/Makefile				1.8
- textproc/ruby-itex2MML/Makefile				1.7
- textproc/ruby-json/Makefile					1.9
- textproc/ruby-libxml/Makefile					1.7
- textproc/ruby-mecab/Makefile					1.6
- textproc/ruby-native-hyperestraier/Makefile			1.6
- textproc/ruby-nokogiri/Makefile				1.4
- textproc/ruby-oniguruma/Makefile				1.6
- textproc/ruby-redcloth/Makefile				1.14
- textproc/ruby-sary/Makefile					1.7
- textproc/ruby-xmlparser/Makefile				1.15
- textproc/ruby-xslt/Makefile					1.7
- textproc/ruby-yamcha/Makefile					1.3
- www/mongrel/Makefile						1.13 via patch
- www/ruby-clearsilver/Makefile					1.15
- www/ruby-fcgi/Makefile					1.15
- www/ruby-gnome2-gtkhtml2/Makefile				patch
- www/ruby-gnome2-gtkmozembed/Makefile				1.17 via patch
- www/ruby-patron/Makefile					1.5
- www/thin/Makefile						1.8 via patch
- x11/ruby-gnome2-gtk/Makefile					1.25 via patch
- x11/ruby-gnome2-gtksourceview/Makefile			patch via 1.12
- x11/ruby-gnome2-gtksourceview2/Makefile			patch
- x11/ruby-gnome2-panelapplet/Makefile				patch
- x11/ruby-gnome2-vte/Makefile					1.16 via patch
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:31:06 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: rubyversion.mk

Log Message:
* Start upate of ruby18 and ruby19 packags.
* Remove redundant GEM_HOME definition from PLIST.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:35:38 UTC 2011

Modified Files:
	pkgsrc/lang/ruby18-base: distinfo

Log Message:
Update ruby18-base package to 1.8.7.334 (Ruby 1.8.7p334).

* The FileUtils Vulnerability

	http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* The $SAFE Vulnerability

Fri Feb 18 21:18:55 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* test/ruby/test_exception.rb (TestException::test_to_s_taintness_propagation):
	  Test for below.

Fri Feb 18 21:18:55 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* error.c (exc_to_s): untainted strings can be tainted via
	  Exception#to_s, which enables attackers to overwrite sane strings.
	  Reported by: Yusuke Endoh <mame at tsg.ne.jp>.

	* error.c (name_err_to_s): ditto.

Fri Feb 18 21:17:22 2011  Shugo Maeda  <shugo@ruby-lang.org>

	* lib/fileutils.rb (FileUtils::remove_entry_secure): there is a
	  race condition in the case where the given path is a directory,
	  and some other user can move that directory, and create a
	  symlink while this method is executing.
	  Reported by: Nicholas Jefferson <nicholas at pythonic.com.au>

Fri Feb 18 19:46:46 2011  NAKAMURA Usaku  <usa@ruby-lang.org>

	* win32/win32.c (init_stdhandle): backport mistake of r29382.
	  some code are needless in ruby 1.8.
	  [ruby-core:34579]

Fri Feb 18 19:22:17 2011  URABE Shyouhei  <shyouhei@ruby-lang.org>

	* configure.in: revert revision r29854.	 This revision introduced
	  binary incompatibilities on some circumstances.  The bug that
	  revision was fixing gets reopened by this reversion.
	  [ruby-dev:43152] cf. [Bug #2553]
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 14:44:11 UTC 2011

Modified Files:
	pkgsrc/lang/ruby19-base: DEINSTALL Makefile PLIST distinfo
Added Files:
	pkgsrc/lang/ruby19-base/patches: patch-string.c

Log Message:
Update ruby19-base package to 1.9.2pl180 (Ruby 1.9.2 p180).

* The FileUtils Vulnerability

    http://www.ruby-lang.org/en/news/2011/02/18/fileutils-is-vulnerable-to-symlink-race-attacks/

* Add a patch r30779 from repository; a bug of utf-8 string handling.

For more detail changes of Ruby 1.9.2pl180, please refer:
	http://svn.ruby-lang.org/repos/ruby/tags/v1_9_2_180/ChangeLog
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 15:00:34 UTC 2011

Modified Files:
	pkgsrc/lang/ruby: buildlink3.mk rubyversion.mk

Log Message:
Introduce RUBY_ABI_VERSION and use it BUILDLINK_ABI_DEPENDS.

There are ABI incompatibility amaong Ruby 1.8.7 patchlevel 302, 330 and 334,
So it would be handle if such problem in future.
---
Module Name:	pkgsrc
Module Name:	pkgsrc
Committed By:	taca
Date:		Mon Feb 21 16:01:24 UTC 2011

Modified Files:
	pkgsrc/archivers/ruby-libarchive: Makefile
	pkgsrc/comms/ruby-termios: Makefile
	pkgsrc/converters/ruby-uconv: Makefile
	pkgsrc/databases/ruby-do_sqlite3: Makefile
	pkgsrc/databases/ruby-ldap: Makefile
	pkgsrc/databases/ruby-mysql: Makefile
	pkgsrc/databases/ruby-odbc: Makefile
	pkgsrc/databases/ruby-pg: Makefile
	pkgsrc/databases/ruby-postgresql: Makefile
	pkgsrc/databases/ruby-qdbm: Makefile
	pkgsrc/databases/ruby-sqlite: Makefile
	pkgsrc/databases/ruby-sqlite3: Makefile
	pkgsrc/databases/ruby-tokyocabinet: Makefile
	pkgsrc/devel/ruby-SDL: Makefile
	pkgsrc/devel/ruby-debug-base: Makefile
	pkgsrc/devel/ruby-eet: Makefile
	pkgsrc/devel/ruby-eventmachine: Makefile
	pkgsrc/devel/ruby-ffi: Makefile
	pkgsrc/devel/ruby-gnome2-atk: Makefile
	pkgsrc/devel/ruby-gnome2-gio: Makefile
	pkgsrc/devel/ruby-gnome2-glib: Makefile
	pkgsrc/devel/ruby-gnome2-pango: Makefile
	pkgsrc/devel/ruby-linecache: Makefile
	pkgsrc/devel/ruby-memcache: Makefile
	pkgsrc/devel/ruby-ncurses: Makefile
	pkgsrc/devel/ruby-priority-queue: Makefile
	pkgsrc/devel/ruby-racc: Makefile
	pkgsrc/devel/ruby-rbtree: Makefile
	pkgsrc/devel/ruby-rcov: Makefile
	pkgsrc/devel/ruby-rcsparse: Makefile
	pkgsrc/devel/ruby-subversion: Makefile
	pkgsrc/devel/ruby-thrift: Makefile
	pkgsrc/graphics/ruby-RMagick: Makefile
	pkgsrc/graphics/ruby-clutter-cairo: Makefile
	pkgsrc/graphics/ruby-clutter-core: Makefile
	pkgsrc/graphics/ruby-clutter-gtk: Makefile
	pkgsrc/graphics/ruby-gd: Makefile
	pkgsrc/graphics/ruby-gnome2-gdkpixbuf: Makefile
	pkgsrc/graphics/ruby-gnome2-goocanvas: Makefile
	pkgsrc/graphics/ruby-gnome2-rsvg: Makefile
	pkgsrc/graphics/ruby-imlib2: Makefile
	pkgsrc/graphics/ruby-opengl: Makefile
	pkgsrc/graphics/ruby-rcairo: Makefile
	pkgsrc/inputmethod/ruby-zinnia: Makefile
	pkgsrc/mail/ruby-tmail: Makefile
	pkgsrc/math/ruby-rb-gsl: Makefile
	pkgsrc/multimedia/ruby-clutter-gst: Makefile
	pkgsrc/multimedia/ruby-gnome2-gstreamer: Makefile
	pkgsrc/multimedia/ruby-ming: Makefile
	pkgsrc/print/ruby-gnome2-poppler: Makefile
	pkgsrc/security/ruby-password: Makefile
	pkgsrc/security/ruby-tcpwrap: Makefile
	pkgsrc/sysutils/ruby-quota: Makefile
	pkgsrc/textproc/ruby-bluecloth: Makefile
	pkgsrc/textproc/ruby-cabocha: Makefile
	pkgsrc/textproc/ruby-eruby: Makefile
	pkgsrc/textproc/ruby-ferret: Makefile
	pkgsrc/textproc/ruby-hpricot: Makefile
	pkgsrc/textproc/ruby-itex2MML: Makefile
	pkgsrc/textproc/ruby-json: Makefile
	pkgsrc/textproc/ruby-libxml: Makefile
	pkgsrc/textproc/ruby-mecab: Makefile
	pkgsrc/textproc/ruby-native-hyperestraier: Makefile
	pkgsrc/textproc/ruby-nokogiri: Makefile
	pkgsrc/textproc/ruby-oniguruma: Makefile
	pkgsrc/textproc/ruby-redcloth: Makefile
	pkgsrc/textproc/ruby-sary: Makefile
	pkgsrc/textproc/ruby-xmlparser: Makefile
	pkgsrc/textproc/ruby-xslt: Makefile
	pkgsrc/textproc/ruby-yamcha: Makefile
	pkgsrc/www/mongrel: Makefile
	pkgsrc/www/ruby-clearsilver: Makefile
	pkgsrc/www/ruby-fcgi: Makefile
	pkgsrc/www/ruby-gnome2-gtkmozembed: Makefile
	pkgsrc/www/ruby-patron: Makefile
	pkgsrc/www/thin: Makefile
	pkgsrc/x11/ruby-gnome2-gtk: Makefile
	pkgsrc/x11/ruby-gnome2-gtksourceview2: Makefile
	pkgsrc/x11/ruby-gnome2-vte: Makefile

Log Message:
Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.7 / (download) - annotate - [select for diffs], Mon Feb 21 16:01:13 2011 UTC (12 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Bump PKGREVISION due to ABI change of ruby18-base.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Sep 10 05:33:41 2010 UTC (13 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Branch point for: pkgsrc-2010Q4
Changes since 1.5: +2 -4 lines
Diff to previous 1.5 (colored)

* Use lang/ruby/gem.mk instead of misc/rubygems/rubygem.mk.
* Remove default value of GEM_BUILD.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Jan 17 12:02:15 2010 UTC (13 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Recursive PKGREVISION bump for jpeg update to 8.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Dec 10 19:26:22 2009 UTC (14 years ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.3: +2 -1 lines
Diff to previous 1.3 (colored)

Fix NetBSD build by expanding the pattern in patch-aa to two more cases.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Dec 4 15:57:47 2009 UTC (14 years ago) by fhajny
Branch: MAIN
Changes since 1.2: +3 -2 lines
Diff to previous 1.2 (colored)

Update ruby-eventmachine to 0.12.10.

More than a year worth of fixes and improvements.

Revision 1.2 / (download) - annotate - [select for diffs], Mon Sep 15 09:08:19 2008 UTC (15 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Update ruby-eventmachine to 0.12.0.

Changes are unknown.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Apr 4 15:16:56 2008 UTC (15 years, 8 months ago) by jlam
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Initial import of ruby18-eventmachine-0.10.0 as devel/ruby-eventmachine.

Ruby/EventMachine is a fast, simple event-processing library for Ruby
programs.  It lets you write network clients and servers without
handling sockets -- all you do is send and receive data.  Single-threaded
socket engine -- scalable and fast!

Revision 1.1 / (download) - annotate - [select for diffs], Fri Apr 4 15:16:56 2008 UTC (15 years, 8 months ago) by jlam
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>