The NetBSD Project

CVS log for pkgsrc/devel/ruby-backports/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-backports

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.25: download - view: text, markup, annotated - select for diffs
Sun Mar 10 15:01:46 2024 UTC (7 months, 3 weeks ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Diff to: previous 1.24: preferred, colored
Changes since revision 1.24: +2 -2 lines
devel/ruby-backports: update to 3.25.0

3.25.0 (2024-03-05)

Added

* MatchData#named_captures (with symbolize_keys option, Ruby 3.3)
* Range.reverse_each (Ruby 3.3)
* Range#overlap? (Ruby 3.3)

Revision 1.24: download - view: text, markup, annotated - select for diffs
Sat Apr 8 13:27:27 2023 UTC (18 months, 3 weeks ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Diff to: previous 1.23: preferred, colored
Changes since revision 1.23: +2 -2 lines
devel/ruby-backports: update to 3.24.1

3.24.1 (2023-04-05)

* Fix Data.new to accept let positional parameters than needed.  Add missing
  test [Fixes #187]

Revision 1.23: download - view: text, markup, annotated - select for diffs
Fri Mar 17 14:27:47 2023 UTC (19 months, 2 weeks ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.22: preferred, colored
Changes since revision 1.22: +2 -2 lines
devel/ruby-backports: update to 3.24.0

3.24.0 (2023-03-07)

Added

* Class#attached_object (Ruby 3.2)
* Data (Ruby 3.2)
* Enumerator.product and Enumerator::Product (Ruby 3.2)
* Hash#shift (with correct behavior when empty) (Ruby 3.2)
* Integer#ceildiv (Ruby 3.2)
* MatchData#byteoffset (Ruby 3.2)
* Symbol#start_with? (Ruby 2.7)

Fixed

* Class#descendants (removed, as it was not actually added in Ruby 3.1,
  sorry)

Revision 1.22: download - view: text, markup, annotated - select for diffs
Sat Feb 12 12:12:32 2022 UTC (2 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.21: preferred, colored
Changes since revision 1.21: +2 -2 lines
devel/ruby-backports: update to 3.23.0

3.23.0 (2021-12-28)

Added

* Integer.try_convert (Ruby 3.1)
* Symbol.end_with? (Ruby 2.7) [#171]

3.22.1 (2021-12-27)

Added

* Ruby 3.1 backports:

Array

* intersect?

Class

* descendants
* subclasses

Enumerable

* compact
* tally (with hash argument)

File

* dirname (with depth argument)

MatchData

* match
* match_length

Struct

* keyword_init?

Revision 1.21: download - view: text, markup, annotated - select for diffs
Tue May 4 07:45:53 2021 UTC (3 years, 6 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.20: preferred, colored
Changes since revision 1.20: +2 -2 lines
devel/ruby-backports: update to 3.21.0

3.21.0 - 2021-03-31

Added

* Added String#unpack1 (Ruby 2.4) [#166]

Revision 1.20: download - view: text, markup, annotated - select for diffs
Fri Feb 5 16:04:51 2021 UTC (3 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +2 -2 lines
devel/ruby-backports: update to 3.20.2

3.20.2 (2021-01-27)

* Fix a typo
* Namespace explicitly, but not Ractor
* Don't stop at ractor tests
* Tweak Ractor#inspect
* Ractor: implementation under Backports namespace
* Tweak for 2.2-
* Move filtered_queue
* Add magic constant
* Move backports dependencies out of `ractor/`; use RubyNext if need be

Revision 1.19: download - view: text, markup, annotated - select for diffs
Sun Jan 10 14:31:30 2021 UTC (3 years, 9 months ago) by taca
Branches: MAIN
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -2 lines
devel/ruby-backports: update to 3.20.1


## [3.20.1](https://github.com/marcandre/backports/compare/v3.20.0...v3.20.1) - 2021-01-03

### Fixed

* Added `Ractor.[]` and `[]=` [#161]
* `Ractor.current` fixed from threads [#161]

## [3.20.0](https://github.com/marcandre/backports/compare/v3.19.0...v3.20.0) - 2020-12-30

### Added

Ractor backport (all methods)

## [3.19.0](https://github.com/marcandre/backports/compare/v3.19.0...v3.18.2) - 2020-12-28

### Added

* Ruby 3.0 backports

  * Env
    * `except`

  * Hash
    * `except`
    * `transform_keys`, `transform_keys!` (with hash argument)

  * Symbol
    * `name`

* Ruby 2.3 backports

  * Queue
    * `close`, `closed?` (affects `push`, `pop` and aliases)

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sun Sep 13 15:16:07 2020 UTC (4 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +2 -2 lines
devel/ruby-backports: update to 3.18.2

Update ruby-backports to 3.18.2.


3.18.2 - 2020-08-26

* Require per ruby version now properly requiring 2.3.0 backports for
  String [#152]

3.18.1 - 2020-06-23

* Fixed Changelog URI in gem manifest

Revision 1.17: download - view: text, markup, annotated - select for diffs
Sun Aug 9 15:08:26 2020 UTC (4 years, 2 months ago) by taca
Branches: MAIN
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -2 lines
devel/ruby-backports: update to 3.18.1

Update ruby-backports to 3.18.1.


3.18.1 - 2020-06-23

* Update dependency

3.18.0 - 2020-06-22

* Require per ruby version / all requires now check RUBY_VERSION to be
  more efficient [#149]

Revision 1.16: download - view: text, markup, annotated - select for diffs
Mon May 25 13:22:13 2020 UTC (4 years, 5 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -2 lines
devel/ruby-backports: update to 3.17.2

Update ruby-backports to 3.17.2.


3.17.2 - 2020-04-09

Fixed

* Fix Range#cover (Ruby 2.6.0) [#148]

Revision 1.15: download - view: text, markup, annotated - select for diffs
Sun Apr 26 08:42:36 2020 UTC (4 years, 6 months ago) by taca
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +2 -2 lines
devel/ruby-backports: update to 3.17.1

Update ruby-backports to 3.17.1.


## [3.17.1](https://github.com/marcandre/backports/compare/v3.17.0...v3.17.1) - 2020-04-09

### Fixed

Fix Range#size (Ruby 2.0) on Ruby 1.8.7 [#144]

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Mar 8 13:28:18 2020 UTC (4 years, 7 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
devel/ruby-backports: update to 3.17.0

Update ruby-backports to 3.17.0.


## [3.17.0](https://github.com/marcandre/backports/compare/v3.16.1...v3.16.2) - 2020-03-06

### Added

* Ruby 2.6 backports

  * Range
    * `cover?` (with `Range` argument)

### Changed

Requiring features for a particular version of Ruby or `latest` is un-deprecated but
instead simply warned in verbose mode.

## [3.16.1](https://github.com/marcandre/backports/compare/v3.16.0...v3.16.1) - 2020-02-16

### Deprecated

Officially deprecate requiring features for a particular version of Ruby, `latest`, `std_lib` or `rails` backports

### Fixed

`matrix` library when loaded in 2.7.0 [#141]

## [3.16.0](https://github.com/marcandre/backports/compare/v3.15.0...v3.16.0) - 2020-02-06

### Added

* Ruby 2.7 backports

  * Array
    * `intersection`

  * Comparable
    * `clamp` (with range)

  * Complex
    * `<=>`

  * Enumerable
    * `filter_map`
    * `tally`

  * Enumerator
    * `produce` (class method)

  * Time
    * `floor`, `ceil`

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Oct 23 16:22:22 2019 UTC (5 years ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -2 lines
devel/ruby-backports: update to 3.15.0

Update ruby-backports to 3.15.0.

== Version 3.15.0 - May 15th, 2019

  * Proc / Method
    * +<<+, +>>+

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon May 6 05:19:26 2019 UTC (5 years, 6 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -2 lines
devel/ruby-backports: update to 3.14.0

== Version 3.14.0 - April 29th, 2019

  * Hash
    * +to_h+ (with block)

== Version 3.13.0 - April 5th, 2019

  * Hash
    * +merge+, +merge!+/+update+ (with multiple arguments)

== Version 3.12.0 - February 20th, 2019

* New Ruby version 2.6.0
  * Array
    * +difference+, +union+
    * +to_h+ (with block)
  * Enumerable
    * +chain+
    * +to_h+ (with block)
  * Enumerator::Chain (use Enumerable#chain)
  * Kernel
    * +then+

* Additional backports for 2.5.0:
  * String
    * +undump+

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun Sep 23 14:16:57 2018 UTC (6 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
devel/ruby-backports: update to 3.11.4

3.11.2 (2018/04/10)

* Remove link  to www.pledgie.com.
* Update Rails' try [#115]

3.11.3 (2018/04/16)

* Update readme [ci skip]
* Oops, fix try correctly

3.11.4 (2018/08/27)

* Tweak README [ci skip]
* SVG badges in README
* Add a note about performance of match? backports [#17]
* Fix match? [#117]
* Tweak for Enumerator::ArithmeticSequence

Revision 1.10: download - view: text, markup, annotated - select for diffs
Wed Feb 28 15:39:31 2018 UTC (6 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
devel/ruby-backports: update to 3.11.1

Version 3.11.0 - December 25th, 2017

* New Ruby version 2.5.0

	o Array

		- append, prepend

	o Dir

		- children, each_child

	o Enumerable

		- any?, all?, none?, one? (with pattern argument)

	o Hash

		- slice
		- transform_keys

	o Integer

		- sqrt
		- allbits?, anybits? and nobits?

	o Kernel

		- yield_self

	o Module

		- attr, attr_accessor, attr_reader, attr_writer (now public)
		- define_method, alias_method, undef_method, remove_method
		  (now public)

	o String

		- delete_prefix, delete_prefix!
		- delete_suffix, delete_suffix!

	o Struct

		- new (with keyword_init: true)

* require 'backports/latest' is now the right way to require everything

Version 3.10.0 - October 17, 2017

* Additional features of 2.4.0

	o Enumerable

		- uniq
		- sum

	o Hash

		- compact
		- transform_values

Version 3.9.0 - October 07, 2017

* From 2.4.0: dup for true, false, nil, Numeric

* From 2.2.0: Method#super_method

Version 3.8.0 - April 26, 2017

* From 2.4.0: String#match?, Regexp#match?

* From 2.3.0:

	o unary String#+, -
	o Numeric: positive?, negative?
	o Hash: to_proc, fetch_values, >, <, >=, <=
	o Enumerable: chunk_while, grep_v
	o {Array|Hash|Struct}#dig
	o Array#bsearch_index

* From 2.2.0:

	o Method#curry
	o String#unicode_normalize{|?|!}
	o Kernel#itself
	o Float: next_float, prev_float

Version 3.7.0 - March 28, 2017

* Initiate work on backports of 2.2, 2.3, 2.4

* From 2.4.0:

	o Comparable#clamp

* From 2.2.0:

	o Enumerable: slice_when, slice_after

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun Jul 30 22:32:17 2017 UTC (7 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Switch github HOMEPAGEs to https.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Tue Feb 16 14:47:26 2016 UTC (8 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
Update ruby-backports to 3.6.8.

* Rename internal method to avoid strange error in ruby 2.3.
* Update lib/prime.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Nov 29 12:36:44 2015 UTC (8 years, 11 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Update ruby-backports to 3.6.7.

* Fix pledgie image markup.
* Fix embarassing bug with bsearch for floats.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Sep 13 04:57:44 2015 UTC (9 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
Update ruby-backports to 3.6.6.

* Explicitly set license to MIT in backports.gemspec.
* Fix Bignum#bit_length.
* Fix Bignum#bit_length correctly.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Feb 1 13:56:35 2015 UTC (9 years, 9 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Update ruby-backports to 3.6.4.

Several bug fixes.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Mar 14 15:21:25 2014 UTC (10 years, 7 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Update ruby-backports to 3.6.0.

== Version 3.6.0 - February 14th, 2014

* Additional features of 2.1.0
  * Bignum#bit_length
  * Fixnum#bit_length
  * Module#include (now public)

== Version 3.5.0 - February 3rd, 2014

* Additional features of 2.0.0
  * Range#size

== Version 3.4.0 - December 29th, 2013

* Additional features of 2.1.0
  * Array#to_h, Enumerable#to_h

Revision 1.3: download - view: text, markup, annotated - select for diffs
Fri Sep 13 14:02:03 2013 UTC (11 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Update ruby-backports to 3.3.3.

= Backports --- History

== Version 3.2.0 - April 3rd, 2013

* Moved `Proc#yield` & `Hash#key` from 1.8.7 to 1.9.1

== Version 3.2.0 - April 2nd, 2013

* Moved `Dir.mktmpdir` to the stdlib 'tmpdir' for Ruby 1.8.7

* Removed `returning` as it is no longer part of Rails.

== Version 3.1.0 - March 5th, 2013

* Backports can now be loaded separately!

* Small tweaks and fixes for many methods to pass more RubySpecs

== Version 3.0.0 - February 24th, 2013

* Features of 2.0.0 are now required when requiring 'backports'.

* Additional features of 2.0.0
  * Struct#to_h, NilClass#to_h, Hash#to_h
  * Hash#default_proc = nil
  * OpenStruct lib

* 1.8.7's Enumerator#with_index (it wasn't in the 1.8.7 NEWS file...)

Revision 1.2: download - view: text, markup, annotated - select for diffs
Wed Feb 13 15:19:46 2013 UTC (11 years, 8 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Update ruby-backports to 2.8.2.

== Version 2.8.0 - February 3rd, 2013

* Added some features of 2.0.0 (must be required explicitly until official
  release):
  * Array#bsearch
  * Range#bsearch

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon Feb 11 07:54:32 2013 UTC (11 years, 8 months ago) by taca
Branches: MAIN
Add ruby-backports package version 2.7.1.

= Backports Library

* Yearning to use some of the new cool features in Ruby 2.0.0 while using
  1.8.6?
* One of your client is stuck with Ruby 1.8.6 but you want to use a gem using
  some features of 1.8.7?
* Can't remember if you can use Array#sample or String#each_char on a friend's
  box?

This gem is for you!

The goal of 'backports' is to make it easier to write ruby code that runs
across different versions of Ruby. All you need to bring any version of Ruby
up to today's standards:

  require 'backports'

This will bring in all the features of 1.8.7 (for Ruby 1.8.6) and many
features of Ruby 1.9.1 (for Ruby 1.8.x), Ruby 1.9.2 and Ruby 1.9.3 (for all
earlier versions)!

+Note+: Although I am a Ruby committer, this gem is a personal project and is
not endorsed by ruby-core.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>