The NetBSD Project

CVS log for pkgsrc/devel/ruby-activesupport70/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-activesupport70

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.9: download - view: text, markup, annotated - select for diffs
Sun Sep 10 14:19:00 2023 UTC (19 months, 1 week ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +3 -3 lines
www/ruby-rails70: update to 7.0.8

pkgsrc change: fix dependency of ruby-activestorage70

Active Support

* Fix TimeWithZone still using deprecated #to_s when ENV or config to
  disable it are set.  (Hartley McGuire)

* Fix CacheStore#write_multi when using a distributed Redis cache with a
  connection pool.  Fixes #48938.  (Jonathan del Strother)

Active Record

* Fix change_column not setting precision: 6 on datetime columns when using
  7.0+ Migrations and SQLite.  (Hartley McGuire)

* Fix unscope is not working in specific case

    Before:

    Post.where(id: 1...3).unscope(where: :id).to_sql # "SELECT `posts`.* FROM `posts` WHERE `posts`.`id` >= 1 AND `posts`.`id` < 3"

    After:

    Post.where(id: 1...3).unscope(where: :id).to_sql # "SELECT `posts`.* FROM `posts`"

 Fixes #48094.  (Kazuya Hatanaka)

* Fix associations to a STI model including a class_name parameter

    class Product < ApplicationRecord
      has_many :requests, as: :requestable, class_name: "ProductRequest", dependent: :destroy
    end

    # STI tables
    class Request < ApplicationRecord
      belongs_to :requestable, polymorphic: true

      validate :request_type, presence: true
    end

    class ProductRequest < Request
      belongs_to :user
    end

Accessing such association would lead to:

    table_metadata.rb:22:in `has_column?': undefined method `key?' for nil:NilClass (NoMethodError)

  (Romain Filinto)

* Fix change_table setting datetime precision for 6.1 Migrations
  (Hartley McGuire)

* Fix change_column setting datetime precision for 6.1 Migrations
  (Hartley McGuire)

Action View

* Fix form_for missing the hidden _method input for models with a namespaced
  route.  (Hartley McGuire)

* Fix render collection: @records, cache: true inside jbuilder templates

  The previous fix that shipped in 7.0.7 assumed template fragments are
  always strings, this isn't true with jbuilder.  (Jean Boussier)


Action Pack

* Fix HostAuthorization potentially displaying the value of the
  X_FORWARDED_HOST header when the HTTP_HOST header is being blocked.
  (Hartley McGuire, Daniel Schlosser)

Active Job

* Fix Active Job log message to correctly report a job failed to enqueue
  when the adapter raises an ActiveJob::EnqueueError.  (Ben Sheldon)

Railties

* Omit webdrivers gem dependency from Gemfile template (Sean Doyle)

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Mar 15 13:35:15 2023 UTC (2 years, 1 month ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +1 -2 lines
www/ruby-rails70: update to 7.0.4.3

7.0.4.3 (2023-03-13)

Active Support

* Implement SafeBuffer#bytesplice

  [CVE-2023-28120]

Action View

* Ignore certain data-* attributes in rails-ujs when element is
  contenteditable

  [CVE-2023-23913]

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Feb 20 13:30:43 2023 UTC (2 years, 2 months ago) by taca
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +3 -3 lines
devel/ruby-activesupport*: more strict dependency to ruby-concurrent-ruby

Restrict dependency for ruby-concurrent-ruby to below 1.2.

Reflects a report from wiz@, thanks much.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Feb 11 13:18:50 2023 UTC (2 years, 2 months ago) by taca
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
Bump PKGREVISION reflects ruby-concurrent-ruby's downgrade.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Mon Oct 10 03:36:48 2022 UTC (2 years, 6 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +1 -3 lines
Remove lines for Ruby 2.6.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sun Mar 27 06:43:11 2022 UTC (3 years ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +3 -1 lines
rails 7.0 wants ruby 2.7+, mark it as such

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Mar 27 06:31:56 2022 UTC (3 years ago) by wiz
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
*: fix typo in comment

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Mar 27 06:29:59 2022 UTC (3 years ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
ruby*: fix rails version in COMMENT

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Dec 19 05:45:22 2021 UTC (3 years, 4 months ago) by taca
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
devel/ruby-activesupport70: add package version 7.0.0

Active Support -- Utility classes and Ruby extensions from Rails

Active Support is a collection of utility classes and standard library
extensions that were found useful for the Rails framework.  These additions
reside in this package so they can be loaded as needed in Ruby projects
outside of Rails.

This is for Ruby on Rails 7.0.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>