The NetBSD Project

CVS log for pkgsrc/devel/ruby-SDL/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / ruby-SDL

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2008Q2


Revision 1.3 / (download) - annotate - [select for diffs], Wed Apr 23 17:03:49 2008 UTC (15 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.2: +3 -5 lines
Diff to previous 1.2 (colored)

Update devel/ruby-SDL to 2.0.1.  Changes from version 1.3.1 include:

+ Change MAINTAINER to pkgsrc-users@NetBSD.org on advice from <taca>
  in private email.

* raise SDL::Surface::VideoMemoryLost when video memory is lost when
  calling SDL::Surface.blit

* Remove Old SDL::Event, and rename SDL::Event2 to SDL::Event

Reorganize methods by moving them into modules/namesspaces that are
more relevant:
* GL_RED_SIZE -> GL::RED_SIZE
* GL_GREEN_SIZE -> GL::GREEN_SIZE
* GL_BLUE_SIZE -> GL::BLUE_SIZE
* GL_ALPHA_SIZE -> GL::ALPHA_SIZE
* GL_BUFFER_SIZE -> GL::BUFFER_SIZE
* GL_DOUBLEBUFFER -> GL::DOUBLEBUFFER
* GL_DEPTH_SIZE -> GL::DEPTH_SIZE
* GL_STENCIL_SIZE -> GL::STENCIL_SIZE
* GL_ACCUM_RED_SIZE -> GL::ACCUM_RED_SIZE
* GL_ACCUM_GREEN_SIZE -> GL::ACCUM_GREEN_SIZE
* GL_ACCUM_BLUE_SIZE -> GL::ACCUM_BLUE_SIZE
* GL_ACCUM_ALPHA_SIZE -> GL::ACCUM_ALPHA_SIZE
* SDL.get_GL_attr -> SDL::GL.get_attr
* SDL.set_GL_attr -> SDL::GL.set_attr
* SDL.GL_swap_buffers -> SDL::GL.swap_buffers
* SDL.auto_lock? -> SDL::Surface.auto_lock?
* SDL.auto_lock_on -> SDL::Surface.auto_lock_on
* SDL.auto_lock_off -> SDL::Surface.auto_lock_off
* SDL.transform_blit -> SDL::Surface#transform_blit
* SDL.blitSurface -> SDL::Surface.blit
* SDL.get_video_surface -> SDL::Screen.get
* SDL.set_video_mode -> SDL::Screen.open
* SDL.check_video_mode -> SDL::Screen.check_mode
* SDL.list_modes -> SDL::Screen.list_modes
* SDL.set_gamma -> SDL::Screen.set_gamma
* SDL.get_gamma_ramp -> SDL::Screen.get_gamma_ramp
* SDL.set_gamma_ramp -> SDL::Screen.set_gamma_ramp
* SDL.video_driver_name -> SDL::Screen.driver_name
* SDL.video_info -> SDL::Screen.info
* SDL::Surface#get_rgb -> SDL::PixelFormat#get_rgb
* SDL::Surface#get_rgba -> SDL::PixelFormat#get_rgba
* SDL::Surface#map_rgb -> SDL::PixelFormat#map_rgb
* SDL::Surface#map_rgba -> SDL::PixelFormat#map_rgba
* SDL::Surface#get_palette -> SDL::PixelFormat#palette
* SDL::Surface#bpp -> SDL::PixelFormat#bpp
* SDL::Surface#bytes_per_pixel -> SDL::PixelFormat#bytes_per_pixel
* SDL::Surface#[RGBA]mask -> SDL::PixelFormat#[RGBA]mask
* SDL::Surface#[RGBA]shift -> SDL::PixelFormat#[RGBA]shift
* SDL::Surface#[RGBA]loss -> SDL::PixelFormat#[RGBA]loss
* SDL::Surface#colorkey -> SDL::PixelFormat#colorkey
* SDL::Surface#alpha -> SDL::PixelFormat#alpha

Add following methods
* SDL::Surface#load_bmp_from_string
* SDL::Surface#load_from_string
* SDL::Mixer::Wave#load_from_string
* SDL::Mixer.playing_channels
* SDL::Surface#destroy
* SDL::Joystick#close
* SDL::Mixer#close
* SDL::Mixer::Wave#destroy
* SDL::Mixer::Music#destroy

Remove following methods
* SDL::Surface#draw_ellispe
* SDL::Surface#draw_filled_ellispe
* SDL::Surface#rotate_surface
* SDL::Surface#rotate_scaled_surface
* SDL.rotate
* SDL.rotate_blit
* SDL.rotate_scaled_blit
* SDL.rotate_xy_scaled

Change behavior of following methods
* SDL::Surface#draw_line
* SDL::Surface#draw_circle
* SDL::Surface#draw_rect
* SDL::Surface#draw_ellipse
* SDL::Surface#draw_bezier

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>