[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / readline

File: [cvs.NetBSD.org] / pkgsrc / devel / readline / Makefile (download)

Revision 1.36, Sat Dec 31 00:01:45 2005 UTC (18 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.35: +6 -2 lines

Update to 5.1:

This is a terse description of the new features added to readline-5.1 since
the release of readline-5.0.

1.  New Features in Readline

a.  The key sequence sent by the keypad `delete' key is now automatically
    bound to delete-char.

b.  A negative argument to menu-complete now cycles backward through the
    completion list.

c.  A new bindable readline variable:  bind-tty-special-chars.  If non-zero,
    readline will bind the terminal special characters to their readline
    equivalents when it's called (on by default).

d.  New bindable command: vi-rubout.  Saves deleted text for possible
    reinsertion, as with any vi-mode `text modification' command; `X' is bound
    to this in vi command mode.

e.  If the rl_completion_query_items is set to a value < 0, readline never
    asks the user whether or not to view the possible completions.

f.  New application-callable auxiliary function, rl_variable_value, returns
    a string corresponding to a readline variable's value.

g.  When parsing inputrc files and variable binding commands, the parser
    strips trailing whitespace from values assigned to boolean variables
    before checking them.

h.  A new external application-controllable variable that allows the LINES
    and COLUMNS environment variables to set the window size regardless of
    what the kernel returns.

# $NetBSD: Makefile,v 1.36 2005/12/31 00:01:45 wiz Exp $
#

DISTNAME=	readline-5.1
PKGNAME=	readline-5.1pl1
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GNU:=readline/}

PATCH_SITES=	${MASTER_SITE_GNU:=readline/readline-5.1-patches/}
PATCHFILES=	readline51-001

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
COMMENT=	GNU library that can recall and edit previous input

PKG_INSTALLATION_TYPES=	overwrite pkgviews

GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes

BUILD_TARGET=		all-libtool
INSTALL_TARGET=		install-libtool

INFO_FILES=		history.info readline.info rluserman.info

.include "../../mk/bsd.pkg.mk"