The NetBSD Project

CVS log for pkgsrc/devel/py-zconfig/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-zconfig

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.27 / (download) - annotate - [select for diffs], Tue Aug 29 11:15:50 2023 UTC (3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.26: +3 -3 lines
Diff to previous 1.26 (colored)

py-zconfig: updated to 4.0

4.0 (2023-05-05)
- Drop support for Python 2.7, 3.5, 3.6.

Revision 1.26 / (download) - annotate - [select for diffs], Sun Jun 18 12:00:13 2023 UTC (5 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

py-zope.testrunner: updated to 6.0; renamed from py-ZopeTestrunner

6.0 (2023-03-28)
- Drop support for Python 2.7, 3.5, 3.6.

5.6 (2022-12-09)
- Add support for Python 3.11.
- Inline a small part of ``random.Random.shuffle`` which was deprecated in
  Python 3.9 and removed in 3.11
- Don't trigger post mortem debugger for skipped tests.

Revision 1.25 / (download) - annotate - [select for diffs], Mon Jan 2 12:05:42 2023 UTC (11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.24: +7 -3 lines
Diff to previous 1.24 (colored)

py-zconfig: updated to 3.6.1

3.6.1 (2022-12-06)
==================
- Add support for Python 3.11.
- Drop support for Python 3.4.

Revision 1.24 / (download) - annotate - [select for diffs], Wed Jan 5 15:41:09 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.23: +4 -2 lines
Diff to previous 1.23 (colored)

python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:49 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
Changes since 1.22: +2 -1 lines
Diff to previous 1.22 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.22 / (download) - annotate - [select for diffs], Tue May 25 05:38:30 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-zconfig: updated to 3.6.0

3.6.0 (2021-05-19)
==================

- Added support for Python 3.8, 3.9 and 3.10.  This primarily involves
  avoiding the new-in-3.8 validation of the format string when using the
  'safe-template' format style, since that's not supported in the Python
  standard library.

- Added ``ZConfig.pygments`` module containing a lexer compatible with
  the ``pygments`` library.  Made discoverable via an entry point; use
  **zconfig** as the highlight language for ``code-block`` directives in
  Sphinx documents.

Revision 1.21 / (download) - annotate - [select for diffs], Tue Aug 13 10:55:19 2019 UTC (4 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.20: +4 -3 lines
Diff to previous 1.20 (colored)

py-zconfig: updated to 3.5.0

3.5.0:
- Add support for documenting schema files contained in packages to
  the Sphinx extension.

Revision 1.20 / (download) - annotate - [select for diffs], Mon Feb 18 12:48:58 2019 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.19: +4 -4 lines
Diff to previous 1.19 (colored)

py-zconfig: updated to 3.4.0

3.4.0:

Many changes have been made in the support for logging configurations:

- The log handler section types defined by the
  ZConfig.components.logger package support additional, optional
  parameters:

  style
      Used to configure alternate format styles as found in the Python 3
      standard library.  Four style values are supported:
      classic (the default), format (equivalent to style='{'
      in Python 3), template (equivalent to style='$'), and
      safe-template (similar to template, but using the
      string.Template method safe_substitute method).  A
      best-effort implementation is provided for Python 2.

  arbitrary-fields
      A Boolean defauting to False for backward compatibility,
      allows arbitrary replacement field names to be accepted in the
      format string (regardless of the style setting).  This
      supports applications where log records are known to be generated
      with additional string or numeric fields, at least for some
      loggers.  (An exception is still raised at format time if the
      additional fields are not provided, unless the style value
      safe-template is used.)

- The logfile section type defined by the ZConfig.components.logger
  package supports the optional delay and encoding parameters.
  These can only be used for regular files, not the special STDOUT
  and STDERR streams.

- More validation on the parameters to the logfile and
  email-notifier sections is performed early (at the construction of
  the factory, rather than at creation of the logging handler).
  This allows more checking of parameter combinations before any log
  files are opened.

- The ZConfig.components.logger.handlers.log_format data type
  function now supports formats that include numeric formatting for
  levelno, and accept funcName as a valid log record field
  (added in Python 2.6 and 3.1).

Revision 1.19 / (download) - annotate - [select for diffs], Tue Oct 23 09:46:43 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.18: +8 -9 lines
Diff to previous 1.18 (colored)

py-zconfig: updated to 3.3.0

3.3.0:
- Drop support for Python 3.3.
- Add support for Python 3.7.
- Drop support for 'python setup.py test'.
- Add support for example in section and multisection, and
  include those examples in generated documentation.
- Fix configuration loaders to decode byte data using UTF-8 instead of
  the default encoding (usually ASCII).

Revision 1.18 / (download) - annotate - [select for diffs], Wed Jan 24 10:17:03 2018 UTC (5 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.17: +19 -14 lines
Diff to previous 1.17 (colored)

py-zconfig: use ALTERNATIVES; clean-up

Revision 1.17 / (download) - annotate - [select for diffs], Sat Nov 25 12:39:16 2017 UTC (6 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.16: +7 -10 lines
Diff to previous 1.16 (colored)

py-zconfig: update to 3.2.0.

3.2.0 (2017-06-22)
------------------

- Drop support for Python 2.6 and 3.2 and add support for Python 3.6.

- Run tests with pypy and pypy3 as well.

- Host docs at https://zconfig.readthedocs.io

- BaseLoader is now an abstract class that cannot be instantiated.

- Allow ``nan``, ``inf`` and ``-inf`` values for floats in
  configurations. See
  https://github.com/zopefoundation/ZConfig/issues/16.

- Scripts ``zconfig`` (for schema validation) and
  ``zconfig_schema2html`` are ported to Python 3.

- A new ``ZConfig.sphinx`` `Sphinx extension
  <https://zconfig.readthedocs.io/en/latest/documenting-components.html#documenting-components>`_
  facilitates automatically documenting ZConfig components using their
  description and examples in Sphinx documentation. See
  https://github.com/zopefoundation/ZConfig/pull/25.

- Simplify internal schema processing of max and min occurrence
  values. See https://github.com/zopefoundation/ZConfig/issues/15.

- Almost all uses of ``type`` as a parameter name have been replaced
  with ``type_`` to avoid shadowing a builtin. These were typically
  not public APIs and weren't expected to be called with keyword
  arguments so there should not be any user-visible changes. See
  https://github.com/zopefoundation/ZConfig/issues/17

3.1.0 (2015-10-17)
------------------

- Add ability to do variable substitution from environment variables using
  $() syntax.

3.0.4 (2014-03-20)
------------------

- Added Python 3.4 support.


3.0.3 (2013-03-02)
------------------

- Added Python 3.2 support.


3.0.2 (2013-02-14)
------------------

- Fixed ResourceWarning in BaseLoader.openResource().


3.0.1 (2013-02-13)
------------------

- Removed an accidentally left `pdb` statement from the code.

- Fix a bug in Python 3 with the custom string `repr()` function.


3.0.0 (2013-02-13)
------------------

- Added Python 3.3 support.

- Dropped Python 2.4 and 2.5 support.


2.9.3 (2012-06-25)
------------------

- Fixed: port values of 0 weren't allowed.  Port 0 is used to request
  an ephemeral port.


2.9.2 (2012-02-11)
------------------

- Adjust test classes to avoid base classes being considered separate
  test cases by (at least) the "nose" test runner.


2.9.1 (2012-02-11)
------------------

- Make FileHandler.reopen thread safe.


2.9.0 (2011-03-22)
------------------

- Allow identical redefinition of ``%define`` names.
- Added support for IPv6 addresses.


2.8.0 (2010-04-13)
------------------

- Fix relative path recognition.
  https://bugs.launchpad.net/zconfig/+bug/405687

- Added SMTP authentication support for email logger on Python 2.6.


2.7.1 (2009-06-13)
------------------

- Improved documentation

- Fixed tests failures on windows.


2.7.0 (2009-06-11)
------------------

- Added a convenience function, ``ZConfig.configureLoggers(text)`` for
  configuring loggers.

- Relaxed the requirement for a logger name in logger sections,
  allowing the logger section to be used for both root and non-root
  loggers.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Sep 4 18:00:52 2017 UTC (6 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.15: +2 -2 lines
Diff to previous 1.15 (colored)

Comment out dead sites.

Revision 1.15 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:36 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Add python-3.6 to incompatible versions.

Revision 1.14 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:44 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.13 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:27 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:40 2015 UTC (8 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.11 / (download) - annotate - [select for diffs], Fri May 9 07:37:03 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.10 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:05 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.9: +3 -2 lines
Diff to previous 1.9 (colored)

Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:36 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.8: +1 -3 lines
Diff to previous 1.8 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Jan 23 11:19:03 2010 UTC (13 years, 10 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1
Changes since 1.7: +13 -7 lines
Diff to previous 1.7 (colored)

Update py-zconfig to 2.6.1.
Based on PR#42563 by Derouiche.

==========================
Change History for ZConfig
==========================

ZConfig 2.6.1 (2008/12/05)
--------------------------

- Fixed support for schema descriptions that override descriptions from a base
  schema.  If multiple base schema provide descriptions but the derived schema
  does not, the first base mentioned that provides a description wins.
  https://bugs.launchpad.net/zconfig/+bug/259475

- Fixed compatibility bug with Python 2.5.0.

- No longer trigger deprecation warnings under Python 2.6.


ZConfig 2.6.0 (2008/09/03)
--------------------------

- Added support for file rotation by time by specifying when and
  interval, rather than max-size, for log files.

- Removed dependency on setuptools from the setup.py.


ZConfig 2.5.1 (2007/12/24)
--------------------------

- Made it possible to run unit tests via 'python setup.py test' (requires
  setuptools on sys.path).

- Added better error messages to test failure assertions.

ZConfig 2.5 (31 Aug 2007)
-------------------------

  *A note on the version number:*

  Information discovered in the revision control system suggests that
  some past revision has been called "2.4", though it is not clear that
  any actual release was made with that version number.  We're going to
  skip revision 2.4 entirely to avoid potential issues with anyone using
  something claiming to be ZConfig 2.4, and go straight to version 2.5.

- Add support for importing schema components from ZIP archives (including
  eggs).

- Added a 'formatter' configuration option in the logging handler sections
  to allow specifying a constructor for the formatter.

- Documented the package: URL scheme that can be used in extending schema.

- Added support for reopening all log files opened via configurations using
  the ZConfig.components.logger package.  For Zope, this is usable via the
  ``zc.signalhandler`` package.  ``zc.signalhandler`` is not required for
  ZConfig.

- Added support for rotating log files internally by size.

- Added a minimal implementation of schema-less parsing; this is mostly
  intended for applications that want to read several fragments of ZConfig
  configuration files and assemble a combined configuration.  Used in some
  ``zc.buildout`` recipes.

- Converted to using ``zc.buildout`` and the standard test runner from
  ``zope.testing``.

- Added more tests.


ZConfig 2.3.1 (21 Aug 2005)
---------------------------

- Isolated some of the case-normalization code so it will at least be
  easier to override.  This remains non-trivial.


ZConfig 2.3 (18 May 2005)
-------------------------

- Added "inet-binding-address" and "inet-connection-address" to the
  set of standard datatypes.  These are similar to the "inet-address"
  type, but the default hostname is more sensible.  The datatype used
  should reflect how the value will be used.

- Alternate rotating logfile handler for Windows, to avoid platform
  limitations on renaming open files.  Contributed by Sidnei da Silva.

- For <section> and <multisection>, if the name attribute is omitted,
  assume name="*", since this is what is used most often.


ZConfig 2.2 (21 Apr 2004)
-------------------------

- More documentation has been written.

- Added a timedelta datatype function; the input is the same as for
  the time-interval datatype, but the resulting value is a
  datetime.timedelta object.

- Make sure keys specified as attributes of the <default> element are
  converted by the appropriate key type, and are re-checked for
  derived sections.

- Refactored the ZConfig.components.logger schema components so that a
  schema can import just one of the "eventlog" or "logger" sections if
  desired.  This can be helpful to avoid naming conflicts.

- Added a reopen() method to the logger factories.

- Always use an absolute pathname when opening a FileHandler.

- A fix to the logger 'format' key to allow the %(process)d expansion variable
  that the logging package supports.

- A new timedelta built-in datatype was added.  Similar to time-interval
  except that it returns a datetime.timedelta object instead.


ZConfig 2.1 (12 Apr 2004)
-------------------------

- Removed compatibility with Python 2.1 and 2.2.

- Schema components must really be in Python packages; the directory
  search has been modified to perform an import to locate the package
  rather than incorrectly implementing the search algorithm.

- The default objects use for section values now provide a method
  getSectionAttributes(); this returns a list of all the attributes of
  the section object which store configuration-defined data (including
  information derived from the schema).

- Default information can now be included in a schema for <key
  name="+"> and <multikey name="+"> by using <default key="...">.

- More documentation has been added to discuss schema extension.

- Support for a Unicode-free Python has been fixed.

- Derived section types now inherit the datatype of the base type if
  no datatype is identified explicitly.

- Derived section types can now override the keytype instead of always
  inheriting from their base type.

- <import package='...'/> makes use of the current prefix if the
  package name begins witha dot.

- Added two standard datatypes:  dotted-name and dotted-suffix.

- Added two standard schema components: ZConfig.components.basic and
  ZConfig.components.logger.


ZConfig 2.0 (27 Oct 2003)
-------------------------

- Configurations can import additional schema components using a new
  "%import" directive; this can be used to integrate 3rd-party
  components into an application.

- Schemas may be extended using a new "extends" attribute on the
  <schema> element.

- Better error messages when elements in a schema definition are
  improperly nested.

- The "zconfig" script can now simply verify that a schema definition
  is valid, if that's all that's needed.

Revision 1.7 / (download) - annotate - [select for diffs], Thu Jun 12 02:14:29 2008 UTC (15 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.6: +3 -1 lines
Diff to previous 1.6 (colored)

Add DESTDIR support.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Mar 4 21:29:28 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1, pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Feb 5 23:08:52 2006 UTC (17 years, 10 months ago) by joerg
Branch: MAIN
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.4 / (download) - annotate - [select for diffs], Mon Apr 11 21:45:37 2005 UTC (18 years, 7 months ago) by tv
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4, pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.3: +1 -2 lines
Diff to previous 1.3 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Jul 22 09:16:01 2004 UTC (19 years, 4 months ago) by recht
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1, pkgsrc-2004Q4-base, pkgsrc-2004Q4, pkgsrc-2004Q3-base, pkgsrc-2004Q3
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

add python as category
ok'd a while back at pkgsrcCon by agc and wiz

Revision 1.2 / (download) - annotate - [select for diffs], Tue Apr 27 04:59:43 2004 UTC (19 years, 7 months ago) by snj
Branch: MAIN
CVS Tags: pkgsrc-2004Q2-base, pkgsrc-2004Q2
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Convert to buildlink3.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Fri Jul 25 16:04:09 2003 UTC (20 years, 4 months ago) by drochner
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2004Q1-base, pkgsrc-2004Q1, pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

add ZConfig-1.0, a Python configuration library for those who don't like
the Windows-ini-file-like stuff which comes with the base pkg

Revision 1.1 / (download) - annotate - [select for diffs], Fri Jul 25 16:04:09 2003 UTC (20 years, 4 months ago) by drochner
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>