[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-traitlets

File: [cvs.NetBSD.org] / pkgsrc / devel / py-traitlets / Makefile (download)

Revision 1.9, Wed Sep 1 18:22:05 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.8: +2 -4 lines

py-traitlets: updated to 5.1.0

Traitlets 5.1
-------------

Traitlets 5.1 brings a couple of updates and changes to traitlets, and is
recommended for all users. What follow is a non-exhaustive list of changes:

 - Removal of the ``ipython_genutils`` dependency, this should remove any direct
   and indirect reliance on ``nose`` and prepare traitlets 5.1 for Python 3.10
   and above compatibility, some test suite changes also accommodate Python 3.10 changes.
   If you package traitlets downstream, make sure to remove this dependency.

 - Removal of ``ipython_genutils`` may have change the default encoding detected
   for the command line argument parsing when not utf-8. We expect this to
   affect a small portion of older windows version. If you encounter issue let
   us know.

 - Stop recommendation of ``CUnicode`` in some circumstances as it's
   deprecated.

 - Our test suite is now using GitHub action instead of travis CI. If you are
   packaging downstream using the git repository, you may have to exclude the
   ``.github`` folder now, and can remove exclusion of

 - It fixes a parsing issue for list of one single element on the CLI.

 - We reserve the right to remove official support for Python 3.7 in subsequent
   minor revisions.

# $NetBSD: Makefile,v 1.9 2021/09/01 18:22:05 adam Exp $

DISTNAME=	traitlets-5.1.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=t/traitlets/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://ipython.org/
COMMENT=	Traitlets Python config system
LICENSE=	modified-bsd

USE_LANGUAGES=	# none

# Traitlets 5.0+ supports Python 3.7 and above, following NEP 29.
# For any earlier version of Python use traitlets 4.x
PYTHON_VERSIONS_INCOMPATIBLE=	27 36

.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"