[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-traitlets

File: [cvs.NetBSD.org] / pkgsrc / devel / py-traitlets / Makefile (download)

Revision 1.14, Thu Jun 9 15:49:25 2022 UTC (22 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.13: +6 -5 lines

py-traitlets: updated to 5.2.2

5.2.2
- Make ``traitlets.__all__`` explicit and validate in test.
- Fix ``KeyError`` in ``Application.get_default_logging_config``.

5.2.1
- logging: Don't attempt to close handlers unless they have been opened.
  Fixes ``ValueError: Unable to configure formatter 'console'`` traceback.

5.2.0
Traitlets 5.2 brings a couple of updates and changes to traitlets, and is
recommended for all users. What follows is a non-exhaustive list of changes:

- Application: add logging_config trait.
- Disambiguate the use of the term value in the example.
- Add mypy typing support.
- DOC: Add log example.
- Internal cleanup: linters, autoformatters, CI.

# $NetBSD: Makefile,v 1.14 2022/06/09 15:49:25 adam Exp $

DISTNAME=	traitlets-5.2.2
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=t/traitlets/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/ipython/traitlets
COMMENT=	Traitlets Python config system
LICENSE=	modified-bsd

BUILD_DEPENDS+=	${PYPKGPREFIX}-hatchling>=0.25:../../devel/py-hatchling

USE_LANGUAGES=	# none

# Traitlets 5.0+ supports Python 3.7 and above, following NEP 29.
# For any earlier version of Python use traitlets 4.x
PYTHON_VERSIONS_INCOMPATIBLE=	27

.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"