[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-test

File: [cvs.NetBSD.org] / pkgsrc / devel / py-test / Makefile (download)

Revision 1.24, Mon Nov 14 14:18:55 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.23: +2 -2 lines

Updated py-test to 3.0.4.

3.0.4
=====

* Import errors when collecting test modules now display the full traceback (`#1976`_).
  Thanks `@cwitty`_ for the report and `@nicoddemus`_ for the PR.

* Fix confusing command-line help message for custom options with two or more ``metavar`` properties (`#2004`_).
  Thanks `@okulynyak`_ and `@davehunt`_ for the report and `@nicoddemus`_ for the PR.

* When loading plugins, import errors which contain non-ascii messages are now properly handled in Python 2 (`#1998`_).
  Thanks `@nicoddemus`_ for the PR.

* Fixed cyclic reference when ``pytest.raises`` is used in context-manager form (`#1965`_). Also as a
  result of this fix, ``sys.exc_info()`` is left empty in both context-manager and function call usages.
  Previously, ``sys.exc_info`` would contain the exception caught by the context manager,
  even when the expected exception occurred.
  Thanks `@MSeifert04`_ for the report and the PR.

* Fixed false-positives warnings from assertion rewrite hook for modules that were rewritten but
  were later marked explicitly by ``pytest.register_assert_rewrite``
  or implicitly as a plugin (`#2005`_).
  Thanks `@RonnyPfannschmidt`_ for the report and `@nicoddemus`_ for the PR.

* Report teardown output on test failure (`#442`_).
  Thanks `@matclab`_ or the PR.

* Fix teardown error message in generated xUnit XML.
  Thanks `@gdyuldin`_ or the PR.

* Properly handle exceptions in ``multiprocessing`` tasks (`#1984`_).
  Thanks `@adborden`_ for the report and `@nicoddemus`_ for the PR.

* Clean up unittest TestCase objects after tests are complete (`#1649`_).
  Thanks `@d_b_w`_ for the report and PR.

# $NetBSD: Makefile,v 1.24 2016/11/14 14:18:55 wiz Exp $

DISTNAME=	pytest-3.0.4
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/py//}
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_PYPI:=p/pytest/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://pypi.python.org/pypi/pytest
COMMENT=	Python testing tool
LICENSE=	mit

DEPENDS+=	${PYPKGPREFIX}-py>=1.4.29:../../devel/py-py
DEPENDS+=	${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
# TEST_DEPENDS
BUILD_DEPENDS+=	${PYPKGPREFIX}-yaml-[0-9]*:../../textproc/py-yaml
BUILD_DEPENDS+=	${PYPKGPREFIX}-hypothesis-[0-9]*:../../devel/py-hypothesis
USE_TOOLS+=	bash:build

USE_LANGUAGES=	# none

REPLACE_PYTHON+=	_pytest/standalonetemplate.py

post-install:
	cd ${DESTDIR}${PREFIX}/bin && \
		${MV} py.test py.test-${PYVERSSUFFIX} && \
		${MV} pytest pytest-${PYVERSSUFFIX}

.include "../../lang/python/application.mk"
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"