The NetBSD Project

CVS log for pkgsrc/devel/py-test-fixture-config/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-test-fixture-config

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:28:25 2024 UTC (3 days, 7 hours ago) by wiz
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.8: download - view: text, markup, annotated - select for diffs
Sun Nov 3 07:56:29 2024 UTC (11 days, 7 hours ago) by adam
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -5 lines
py-test-fixture-config: updated to 1.8.0

1.8.0
* All: Drop support for Python 2 and <3.6, removing compatibility code.
* All: Use stdlib unittest.mock instead of mock package.
* All: Removed usage of path.py and path in favour of pathlib.
* pytest-devpi-server: Run devpi-init for initialisation.
* pytest-server-fixtures: BREAKING CHANGE: Removed RethinkDB support, as the project is no longer maintained.
* pytest-server-fixtures: Allowed passing through HTTP headers to the server.
* pytest-server-fixtures: Fixed threading log debug messages.
* pytest-server-fixtures: Removed usage of deprecated Thread.setDaemon.
* pytest-server-fixtures: Explicitly close initial Mongo client.
* pytest-server-fixtures: Don't use context manager for CREATE DATABASE
* pytest-shutil: Removed contextlib2 requirement.
* pytest-shutil: Fixed forcing color through termcolor.
* pytest-shutil: Replaced deprecated imp module
* pytest-profiling: Added support to hide/show the full path of file.
* pytest-profiling: Fixed SVG file generation on Windows.
* pytest-profiling: Remove pinning of more-itertools.
* pytest-profiling: Add support to define element number for print_stats()
* pytest-profiling: Fix mock in test_writes_summary
* pytest-virtualenv: Modernised package.
* pytest-virtualenv: Fixed virtualenv creation on Windows.
* pytest-virtualenv: Added delete_workspace parameter to VirtualEnv.
* pytest-virtualenv: Removed extras_require.
* ci: Remove usage of deprecated distutils.
* ci: Disabled jenkins server tests on CircleCI to improve build time.
* ci: Fixed `collections` import for py 3.11 compatibility

Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun May 5 22:43:11 2024 UTC (6 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +7 -6 lines
py-test-fixture-config: convert to wheel.mk.

Bump PKGREVISION.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:41 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sat May 16 09:15:09 2020 UTC (4 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -2 lines
pytest from versioned depends

Revision 1.4: download - view: text, markup, annotated - select for diffs
Fri Jun 14 07:49:36 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -3 lines
py-test-fixture-config: updated to 1.7.0

1.7.0:
* All: Support pytest >= 4.0.0
* All: Support Python 3.7
* pytest-server-fixtures: if host not defined on your machine, default to localhost
* pytest-server-fixture: Pin to rethinkdb < 2.4.0 due to upstream API changes
* pytest-verbose-parametrize: Add support for revamped marker infrastructure
* pytest-verbose-parametrize: Fix integration tests to support pytest >= 4.1.0
* pytest-virtualenv: Add virtualenv as install requirement.
* pytest-webdriver: Fix RemovedInPytest4Warning using getfixturevalue
* circleci: Fix checks by skipping coverall submission for developer without push access
* wheels: Generate universal wheels installable with both python 2.x and 3.x
* dist: Remove support for building and distributing *.egg files
* VagrantFile: Install python 3.7 and initialize python 3.7 by default
* Fix DeprecationWarning warnings using "logger.warning()" function

1.6.2:
* pytest-server-fixtures: suppress stacktrace if kill() is called
* pytest-server-fixtures: fix random port logic in TestServerV2

1.6.1:
* pytest-server-fixtures: fix exception when attempting to access hostname while server is not started

1.6.0:
* pytest-server-fixtures: added previously removed TestServerV2.kill() function
* pytest-profiling: pin more-itertools==5.0.0 in integration tests, as that's a PY3 only release

1.5.1:
* pytest-verbose-parametrize: fixed unicode parameters when using @pytest.mark.parametrize

1.5.0:
* pytest-server-fixtures: made postgres fixtures and its tests optional, like all other fixtures
* pytest-server-fixtures: reverted a fix for pymongo deprecation warning, as this will break compatibility with pymongo 3.6.0
* pytest-server-fixtures: dropped RHEL5 support in httpd

1.4.1:
* pytest-server-fixtures: server fixture binary path specified in ENV now only affect server class 'thread'

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Jan 28 08:41:37 2019 UTC (5 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -1 lines
py-test-fixture-config: allow newer pytest

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Jan 15 19:02:07 2019 UTC (5 years, 10 months ago) by adam
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
py-test-fixture-config: updated to 1.4.0

1.4.0:
* Fixing python 3 compatibility in Simple HTTP Server fixture
* Fixed broken tests in pytest-profiling
* Pinned pytest<4.0.0 until all deprecation warnings are fixed.
* pytest-webdriver: replaced deprecated phantomjs with headless Google Chrome.
* Add Vagrantfile to project to make test environment portable.
* Add .editorconfig file to project.
* pytest-server-fixtures: add TestServerV2 with Docker and Kubernetes support.
* pytest-server-fixtures: fix for an issue where MinioServer is not cleaned up after use.
* pytest-server-fixtures: fix deprecation warnings when calling pymongo.
* pytest-server-fixtures: close pymongo client on MongoTestServer teardown.
* pytest-server-fixtures: upgrade Mongo, Redis and RethinkDB to TestServerV2.
* coveralls: fix broken coveralls

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sat Mar 24 06:47:00 2018 UTC (6 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
py-test-fixture-config: added version 1.3.0

Simple configuration objects for Py.test fixtures. Allows you to skip tests
when their required config variables aren't set.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>