The NetBSD Project

CVS log for pkgsrc/devel/py-test-benchmark/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-test-benchmark

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Sun Nov 3 19:35:13 2024 UTC (40 hours, 56 minutes ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +6 -12 lines
py-test-benchmark: updated to 5.1.0

5.1.0 (2024-10-30)

* Fixed broken hooks handling on pytest 8.1 or later (the ``TypeError: import_path() missing 1 required keyword-only argument: 'consider_namespace_packages'`` issue).
  Unfortunately this sets the minimum supported pytest version to 8.1.

5.0.1 (2024-10-30)

* Fixed bad fixture check that broke down then `nbmake <https://pypi.org/project/nbmake/>`_ was enabled.

5.0.0 (2024-10-29)

* Dropped support for now EOL Python 3.8. Also moved tests suite to only test the latest pytest versions (8.3.x).
* Fix generate parametrize tests benchmark csv report errors
* Added the ``--benchmark-time-unit`` cli option for overriding the measurement unit used for display.
* Fixes spelling in some help texts.
* Added new cprofile options:

  - ``--benchmark-cprofile-loops=LOOPS`` - previously profiling only ran the function once, this allow customization.
  - ``--benchmark-cprofile-top=COUNT`` - allows showing more rows.
  - ``--benchmark-cprofile-dump=[FILENAME-PREFIX]`` - allows saving to a file (that you can load in `snakeviz <https://pypi.org/project/snakeviz/>`_, `RunSnakeRun <https://pypi.org/project/RunSnakeRun/>`_ or other tools).
* Removed hidden dependency on `py.path <https://pypi.org/project/py/>`_ (replaced with pathlib).

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Nov 20 23:24:21 2022 UTC (23 months, 2 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +7 -8 lines
py-test-benchmark: updated to 4.0.0

4.0.0 (2022-10-26)
------------------
* Dropped support for legacy Pythons (2.7, 3.6 or older).
* Switched CI to GitHub Actions.
* Removed dependency on the ``py`` library (that was not properly specified as a dependency anyway).
* Fix skipping test in `test_utils.py` if appropriate VCS not available. Also fix typo.
* Added support for pytest 7.2.0 by using ``pytest.hookimpl`` and ``pytest.hookspec`` to configure hooks.
* Now no save is attempted if ``--benchmark-disable`` is used.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:08 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:40 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.3: download - view: text, markup, annotated - select for diffs
Fri Oct 1 12:47:27 2021 UTC (3 years, 1 month ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +9 -13 lines
py-test-benchmark: updated to 3.4.1

3.4.1 (2021-04-17)
------------------
* Republished with updated changelog.

  I intended to publish a ``3.3.0`` release but I messed it up because bumpversion doesn't work well with pre-commit
  apparently... thus ``3.4.0`` was set in by accident.


3.4.0 (2021-04-17)
------------------
* Disable progress indication unless ``--benchmark-verbose`` is used.
* Added Python 3.9, dropped Python 3.5.
* Changed the "cpu" data in the json output to include everything that cpuinfo outputs, for better or worse as cpuinfo 6.0 changed some
  fields. Users should now ensure they are an adequate cpuinfo package installed.
  **MAY BE BACKWARDS INCOMPATIBLE**
* Changed behavior of ``--benchmark-skip`` and ``--benchmark-only`` to apply early in the collection phase.
  This means skipped tests won't make pytest run fixtures for said tests unnecessarily, but unfortunately this also means
  the skipping behavior will be applied to any tests that requires a "benchmark" fixture, regardless if it would come from pytest-benchmark
  or not.
  **MAY BE BACKWARDS INCOMPATIBLE**
* Added ``--benchmark-quiet`` - option to disable reporting and other information output.
* Squelched unnecessary warning when ``--benchmark-disable`` and save options are used.
* ``PerformanceRegression`` exception no longer inherits ``pytest.UsageError`` (apparently a *final* class).

Revision 1.2: download - view: text, markup, annotated - select for diffs
Fri Nov 27 10:41:36 2020 UTC (3 years, 11 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -9 lines
py-test-benchmark: Unbreak bulk builds.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Mon May 18 12:45:25 2020 UTC (4 years, 5 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
devel/py-test-benchmark: import py-test-benchmark-3.2.3

A pytest fixture for benchmarking code. It will group the tests
into rounds that are calibrated to the chosen timer.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>