The NetBSD Project

CVS log for pkgsrc/devel/py-setuptools/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-setuptools

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.211 / (download) - annotate - [select for diffs], Thu Aug 24 20:23:12 2023 UTC (5 weeks, 5 days ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, HEAD
Changes since 1.210: +4 -4 lines
Diff to previous 1.210 (colored)

py-setuptools: update to 68.1.2.

v68.1.2
=======

Misc
----

- #4022, #4022


v68.1.1
=======

Bugfixes
--------

- Fix editable install finder handling of nested packages, by only handling 1
  level of nesting and relying on ``importlib.machinery`` to find the remaining
  modules based on the parent package path. (#4020)


v68.1.0
=======

Features
--------

- Removed code referencing bdist_wininst in install_scripts. (#3525)
- Promote ``pyproject.toml``'s ``[tool.setuptools]`` out of beta.
  Note that some fields are still considered deprecated and/or obsolete,
  and these might be removed in future versions (i.e., there is no guarantee
  for long term support and backward compatibility on those fields). (#3962)
- Automatically add files listed in ``Extension.depends`` to sdists,
  as long as they are contained in the project directory -- by :user:`RuRo` (#4000)
- Require Python 3.8 or later.


Bugfixes
--------

- Made imports in editable installs case-sensitive on case-insensitive filesystems -- by :user:`aganders3` (#3995)
- Use default encoding to create ``.pth`` files with ``editable_wheel``. (#4009)
- Detects (and complain about) ``scripts`` and ``gui-scripts`` set via ``setup.py``
  when ``pyproject.toml`` does not include them in ``dynamic``. (#4012)


Misc
----

- #3833, #3960, #4001, #4007

Revision 1.210 / (download) - annotate - [select for diffs], Wed Jun 28 09:10:40 2023 UTC (3 months ago) by wiz
Branch: MAIN
Changes since 1.209: +4 -4 lines
Diff to previous 1.209 (colored)

py-setuptools: update to 68.0.0.

v68.0.0
-------

Breaking Changes
^^^^^^^^^^^^^^^^
* #3948: Removed verification for existing ``depends.txt`` file (deprecated since v0.5a4).
* #3948: Remove autofixing of broken ``.egg-info`` directories containing the ``-``
  character in their base name (without suffix).
  They should no longer be produced by sufficiently new versions of ``setuptools``
  (warning introduced in 2005).
* #3948: Remove deprecated APIs in ``easy_install``: ``get_script_args``,
  ``get_script_header`` and ``get_writer``.
  The direct usage of ``easy_install`` has been deprecated since v58.3.0,
  and the warnings regarding these APIs predate that version.
* #3948: Removed ``egg_info.get_pkg_info_revision`` (deprecated since 2015).
* #3948: Removed ``setuptools.dist._get_unpatched`` (deprecated since 2016)
* #3948: Removed support for SVN in ``setuptools.package_index`` (deprecated since 2018).
* #3948: Removed support for invalid ``pyproject.toml`` files.
  During the implementation of PEP 621, it was identified that some users were
  producing invalid files. As a transitional measure, the validation was relaxed
  for a few use cases. The grace period, however, came to an end.

Changes
^^^^^^^
* #3760: Added symlink support to launcher for installed executables -- by :user:`eugene-sevostianov-sc`
* #3926: Updated vendored ``packaging`` version from 23.0 to 23.1 -- by :user:`MetRonnie`
* #3950: Implemented workaround for old versions of ``vswhere``, which miss the
  ``-requiresAny`` parameter, such as the ones distributed together with Visual Studio 2017 < 15.6.
* #3952: Changed ``DistutilsMetaFinder`` to skip ``spec_for_pip`` on Python >= 3.12.
* #3952: Removed ``_distutils_hack.remove_shim`` on Python >= 3.12
  (since ``distutils`` was removed from the standard library,
  ``DistutilsMetaFinder`` cannot be disabled on Python >= 3.12).

Misc
^^^^
* #3920: Add a link to deprecation warning in ``pkg_resources`` and improve
  ``stacklevel`` for better visibility.

Revision 1.209 / (download) - annotate - [select for diffs], Sun May 21 18:58:26 2023 UTC (4 months, 1 week ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.208: +4 -4 lines
Diff to previous 1.208 (colored)

py-setuptools: update to 67.8.0.

v67.8.0
-------

Changes
^^^^^^^
* #3128: In deprecated easy_install, reload and merge the pth file before saving.

Misc
^^^^
* #3915: Adequate tests to the latest changes in ``virtualenv`` for Python 3.12.

Revision 1.208 / (download) - annotate - [select for diffs], Wed Apr 26 13:34:30 2023 UTC (5 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.207: +4 -4 lines
Diff to previous 1.207 (colored)

py-setuptools: updated to 67.7.2

v67.7.2

Misc
* Fixed wrong URLs used in warnings and logs.


v67.7.1

Misc
* Fixes setuptools.dist:invalid_unless_false when value is false don't raise error


v67.7.0

Changes
* Overhaul warning system for better visibility.

Documentation changes
* Added a note about historical presence of wheel in build-system.requires, in pyproject.toml.
* Improved the documentation example regarding making a thin PEP 517 in-tree backend wrapper of setuptools.build_meta that is future-proof and supports PEP 660 hook too

Misc
* Add a stacklevel parameter to warnings.warn() to provide more information to the user.

Revision 1.207 / (download) - annotate - [select for diffs], Tue Apr 4 15:03:50 2023 UTC (6 months ago) by adam
Branch: MAIN
Changes since 1.206: +4 -4 lines
Diff to previous 1.206 (colored)

py-setuptools: updated to 67.6.1

v67.6.1

Misc

Fixed _WouldIgnoreField warnings for scripts and gui_scripts, when entry-points is not listed in dynamic.
Update code generated by validate-pyproject to use v0.12.2. This should fix default license patterns when pyproject.toml is used.

v67.6.0

Changes

Added caching for supported wheel tags.
Added pruning heuristics to PackageFinder based on exclude.

v67.5.1

Misc

Fixed interaction between setuptools' package auto-discovery and auto-generated htmlcov files.

Previously, the htmlcov name was ignored when searching for single-file modules, however the correct behaviour is to ignore it when searching for packages (since it is supposed to be a directory, see coverage config) -- by :user:`yukihiko-shinoda`.

Improved error messages for pyproject.toml validations.

Fixed pkg_resources errors caused when parsing metadata of packages that are already installed but do not conform with PEP 440.

v67.5.0

Changes

Although pkg_resources has been discouraged for use, some projects still consider pkg_resources viable for usage. This change makes it clear that pkg_resources should not be used, emitting a DeprecationWarning when imported.
v67.4.0

Changes

Update vendored importlib-metadata (to 6.0.0) and importlib-resources (to 5.10.2)

Revision 1.206 / (download) - annotate - [select for diffs], Tue Feb 21 06:19:44 2023 UTC (7 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.205: +4 -4 lines
Diff to previous 1.205 (colored)

py-setuptools: updated to 67.3.3

v67.3.3

Misc

* Restore quoted #include argument to has_function.

v67.3.2

Misc

* Improve deprecation warning message on pkg_resources.declare_namespace to display package name.

v67.3.1

Misc

* Fixes egg_info code path triggered during integration with pip.

v67.3.0

Deprecations

* Added deprecation warning for pkg_resources.declare_namespace. Users that wish to implement namespace packages, are recommended to follow the practice described in PEP 420 and omit the __init__.py file entirely.

Changes

* Reduced usage of pkg_resources in setuptools via internal restructuring and refactoring.

Misc

* Added debugging tips for "editable mode" and update related docs. Instead of using a custom exception to display the help message to the user, setuptools will now use a warning and re-raise the original exception.
* Added clarification about editable_wheel and dist_info CLI commands: they should not be called directly with python setup.py .... Instead they are reserved for internal use of setuptools (effectively as "private" commands). Users are recommended to rely on build backend APIs (PEP 517 and PEP 660) exposed by setuptools.build_meta.

Revision 1.205 / (download) - annotate - [select for diffs], Wed Feb 8 10:16:43 2023 UTC (7 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.204: +4 -4 lines
Diff to previous 1.204 (colored)

py-setuptools: updated to 67.2.0

v67.2.0

Changes

* Merge with distutils@8c3c3d29, including fix for sysconfig.get_python_inc(), fix for segfault on MinGW, and better has_function support.

v67.1.0

Changes

* Ensured that __file__ is an absolute path when executing setup.py as part of setuptools.build_meta.
Misc

* Updated validations for pyproject.toml using validate-pyproject==0.12.1 to allow stub packages (PEP 561) to be listed in tool.setuptools.packages and tool.setuptools.package-dir.

v67.0.0

Breaking Changes

* Removed patching of distutils._msvccompiler.gen_lib_options for compatibility with Numpy < 1.11.2 -- by :user:`mgorny`
* Bump vendored version of :pypi:`packaging` to 23.0 (:pypi:`pyparsing` is no longer required and was removed). As a consequence, users will experience a more strict parsing of requirements. Specifications that don't comply with PEP 440 and PEP 508 will result in build errors.

v66.1.1

Misc

* Fixed problem with file directive in tool.setuptools.dynamic (pyproject.toml) when value is a simple string instead of list.

v66.1.0

Changes

* Fix improper usage of deprecated/removed pkgutil APIs in Python 3.12+.
* Files referenced by file: in setup.cfg and by project.readme.file, project.license.file or tool.setuptools.dynamic.*.file in pyproject.toml are now automatically included in the generated sdists.

Misc

* Added note about using the --pep-517 flag with pip to workaround InvalidVersion errors for packages that are already installed in the system.

v66.0.0

Breaking Changes

* Support for PEP 440 non-conforming versions has been removed. Environments containing packages with non-conforming versions may fail or the packages may not be recognized.

Changes

* Replace 'appdirs' with 'platformdirs'.

Revision 1.204 / (download) - annotate - [select for diffs], Thu Nov 24 19:01:32 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.203: +4 -4 lines
Diff to previous 1.203 (colored)

py-setuptools: updated to 65.6.3

v65.6.3

Misc

Fix condition to patch distutils.dist.log to only apply when using distutils from the stdlib.

v65.6.2

No significant changes.

Revision 1.203 / (download) - annotate - [select for diffs], Wed Nov 23 17:58:14 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.202: +4 -4 lines
Diff to previous 1.202 (colored)

py-setuptools: updated to 65.6.1

v65.6.1

Documentation changes

* Documented that distutils.cfg might be ignored unless SETUPTOOLS_USE_DISTUTILS=stdlib.

Misc

* Improve clib builds reproducibility by sorting sources -- by :user:`danigm`
* Improved exception/traceback when invalid entry-points are specified.
* Fixed logging errors: 'underlying buffer has been detached'.
* Merge pypa/distutils@3e9d47e with compatibility fix for distutils.log.Log.
* Changed minor text details (spelling, spaces ...)
* Removed unnecessary coding: utf-8 annotations
* Fixed temporary build directories interference with auto-discovery.

Revision 1.202 / (download) - annotate - [select for diffs], Sun Nov 20 17:09:38 2022 UTC (10 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.201: +4 -4 lines
Diff to previous 1.201 (colored)

py-setuptools: updated to 65.6.0

v65.6.0

Changes

Sync with pypa/distutils@e0787fa, including pypa/distutils#183 updating distutils to use the Python logging framework.

Revision 1.201 / (download) - annotate - [select for diffs], Tue Nov 8 12:50:33 2022 UTC (10 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.200: +4 -4 lines
Diff to previous 1.200 (colored)

py-setuptools: updated to 65.5.1

v65.5.1

Misc
Drop a test dependency on the mock package, always use unittest.mock
Fixed REDoS vector in package_index.

Revision 1.200 / (download) - annotate - [select for diffs], Fri Oct 21 17:54:37 2022 UTC (11 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.199: +4 -4 lines
Diff to previous 1.199 (colored)

py-setuptools: updated to 65.5.0

v65.5.0
-------

Changes
* Fixed editable install for multi-module/no-package ``src``-layout projects.
* Minor refactorings to support distutils using stdlib logging module.

Documentation changes
* Updated the example version numbers to be compliant with PEP-440 on the "Specifying Your Project„ŗ—‘ Version" page of the user guide.

Misc
* Improved information about conflicting entries in the current working directory
  and editable install (in documentation and as an informational warning).
* Updated version of ``validate_pyproject``.

Revision 1.199 / (download) - annotate - [select for diffs], Wed Oct 5 20:51:53 2022 UTC (11 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.198: +4 -4 lines
Diff to previous 1.198 (colored)

py-setuptools: updated to 65.4.1

v65.4.1

Misc

Fixed encoding errors in expand.StaticModule when system default encoding doesn't match expectations for source files.
Merge with pypa/distutils@6852b20 including fix for pypa/distutils#181.

Revision 1.198 / (download) - annotate - [select for diffs], Mon Sep 26 18:46:59 2022 UTC (12 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.197: +4 -4 lines
Diff to previous 1.197 (colored)

py-setuptools: updated to 65.4.0

v65.4.0
-------

Changes
* Merge with pypa/distutils@d82d926 including support for DIST_EXTRA_CONFIG in pypa/distutils-177.


v65.3.0
-------

Changes
* Stop ``ConfigDiscovery.analyse_name`` from splatting the ``Distribution.name`` attribute -- by :user:`jeamland`

Documentation changes
* Changed requires to requests in the pyproject.toml example in the :ref:`Dependency management section of the Quickstart guide <userguide/quickstart:dependency-management>` -- by :user:`mfbutner`

Misc
* Fixed accidental name matching in editable hooks.


v65.2.0
-------

Changes
* Sync with pypa/distutils@22b9bcf, including fixed cross-compiling support and removing deprecation warning per pypa/distutils-169.


v65.1.1
-------

Misc
* Avoided circular imports in meta path finder for editable installs when a
  missing module has the same name as its parent.


v65.1.0
-------

Changes
* Remove monkeypatching of msvc9compiler.

Documentation changes
* Corrected documentation on how to use the `legacy-editable` mode.


v65.0.2
-------

Misc
* Restored distutils msvccompiler and msvc9compiler modules and marked as deprecated (pypa/distutils@c802880).


v65.0.1
-------

Documentation changes
* Added clarification to :doc:`/userguide/quickstart` about support
  to ``setup.py``.

Misc
* Fixed backward compatibility of editable installs and custom ``build_ext``
  commands inheriting directly from ``distutils``.
* Fixed ``buid_meta.prepare_metadata_for_build_wheel`` when
  given ``metadata_directory`` is ``"."``.


v65.0.0
-------

Breaking Changes
* Removed 'msvccompiler' and 'msvc9compiler' modules from distutils.
* Remove bdist_msi and bdist_wininst commands, which have been deprecated since Python 3.9. Use older Setuptools for these behaviors if needed.

Documentation changes
* Changed the note in ``keywords`` documentation regarding editable installations
  to specify which ``setuptools`` version require a minimal ``setup.py`` file or not.

Revision 1.197 / (download) - annotate - [select for diffs], Thu Aug 11 06:23:56 2022 UTC (13 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.196: +4 -4 lines
Diff to previous 1.196 (colored)

py-setuptools: updated to 63.4.3

v63.4.3
Misc
* Update to pypa/distutils@b65aa40 including more robust support for library/include dir handling in msvccompiler (pypa/distutils-153) and test suite improvements.

Revision 1.196 / (download) - annotate - [select for diffs], Mon Aug 8 07:21:14 2022 UTC (13 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.195: +4 -4 lines
Diff to previous 1.195 (colored)

py-setuptools: updated to 63.4.2

v63.4.2
-------
Misc
* Bump vendored version of :pypi:`pyparsing` to 3.0.9.
* Add warning for potential ``install_requires`` and ``extras_require``
  misconfiguration in ``setup.cfg``
* Modified ``pyproject.toml`` validation exception handling to
  make relevant debugging information easier to spot.

Revision 1.195 / (download) - annotate - [select for diffs], Thu Aug 4 12:28:27 2022 UTC (13 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.194: +4 -4 lines
Diff to previous 1.194 (colored)

py-setuptools: updated to 63.4.1

v63.4.1

Misc

Sync with pypa/distutils@274758f1c02048d295efdbc13d2f88d9923547f8, restoring compatibility shim in bdist.format_commands.

Revision 1.194 / (download) - annotate - [select for diffs], Wed Aug 3 11:44:19 2022 UTC (14 months ago) by adam
Branch: MAIN
Changes since 1.193: +4 -4 lines
Diff to previous 1.193 (colored)

py-setuptools: updated to 63.4.0

v63.4.0
-------
Changes
* ``upload_docs`` command is deprecated once again.
* Merge with pypa/distutils@129480b, including substantial delinting and cleanup, some refactoring around compiler logic, better messaging in cygwincompiler.

Documentation changes
* Installed ``sphinx-hoverxref`` extension to show tooltips on internal an external references.
* Installed ``sphinx-notfound-page`` extension to generate nice 404 pages.

Misc
* Merge with pypa/distutils@c397f4c

Revision 1.193 / (download) - annotate - [select for diffs], Mon Aug 1 07:25:44 2022 UTC (14 months ago) by adam
Branch: MAIN
Changes since 1.192: +4 -4 lines
Diff to previous 1.192 (colored)

py-setuptools: updated to 63.3.0

v63.3.0

Changes
* Remove the pip workaround in _distutils_hack.
* Merge with pypa/distutils@129480b, including substantial delinting and cleanup, some refactoring around compiler logic, better messaging in cygwincompiler

Revision 1.192 / (download) - annotate - [select for diffs], Thu Jul 14 08:58:25 2022 UTC (14 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.191: +4 -4 lines
Diff to previous 1.191 (colored)

py-setuptools: updated to 63.2.0

v63.2.0

Changes

* Included a performance optimization: setuptools.build_meta no longer tries to :func:`compile` the setup script code before :func:`exec`-ing it.

Misc

* Corrected issue in macOS framework builds on Python 3.9 not installed by homebrew

Revision 1.191 / (download) - annotate - [select for diffs], Wed Jul 6 07:25:58 2022 UTC (14 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.190: +4 -4 lines
Diff to previous 1.190 (colored)

py-setuptools: updated to 63.1.0

v63.1.0

Changes

Merge with pypa/distutils@152c13d including pypa/distutils#155 (improved compatibility for editable installs on homebrew Python 3.9), pypa/distutils#150 (better handling of runtime_library_dirs on cygwin), and pypa/distutils#151 (remove warnings for namespace packages).

v63.0.0

Breaking Changes

Drop setuptools' support for installing an entrypoint extra requirements at load time: - the functionality has been broken since v60.8.0. - the mechanism to do so is deprecated (fetch_build_eggs). - that use case (e.g. a custom command class entrypoint) is covered by making sure the necessary build requirements are declared.

Documentation changes

Updated the example pyproject.toml -- by :user:`jacalata`
This updates the documentation for the file_finders hook so that the logging recommendation aligns with the suggestion to not use distutils directly.
Fix reference for keywords to point to the Core Metadata Specification instead of PEP 314 (the live standard is kept always up-to-date and consolidates several PEPs together in a single document).
Reordered the User Guide's Table of Contents

Revision 1.190 / (download) - annotate - [select for diffs], Mon Jun 13 18:26:00 2022 UTC (15 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base, pkgsrc-2022Q2
Changes since 1.189: +4 -4 lines
Diff to previous 1.189 (colored)

py-setuptools: updated to 62.4.0

v62.4.0

Changes

* Added setuptools.command.build command to match distutils.command.build -- by :user:`isuruf`
* Merge with pypa/distutils@75ed79d including reformat using black, fix for Cygwin support, and improved support for cross compiling.

Documentation changes

* Changes to the User Guide's Entry Points page -- by :user:`codeandfire`

* Further minor corrections to the Entry Points page -- by :user:`codeandfire`

* Rework some documentation pages to de-emphasize distutils and the history of packaging in the Python ecosystem. The focus of these changes is to make the documentation easier to read for new users.

* Update documentation about dependency management, removing mention to the deprecated dependency_links and adding some small improvements.

* Extracted text about automatic resource extraction and the zip-safe flag from userguide/miscellaneous to deprecated/resource_extraction and deprecated/zip_safe.

Extracted text about additional metadata files from userguide/miscellaneous into the existing userguide/extension document.

Updated userguide/extension to better reflect the status of the setuptools project.

Removed userguide/functionalities_rewrite (a virtually empty part of the docs).

Revision 1.189 / (download) - annotate - [select for diffs], Wed Jun 8 07:43:41 2022 UTC (15 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.188: +4 -4 lines
Diff to previous 1.188 (colored)

py-setuptools: updated to 62.3.3

v62.3.3

Documentation changes

* Replaced single backticks with double ones in CHANGES.rst
* Fixed grammar/typos, modified example directory trees for src-layout and flat-layout
* Changes to code snippets and other examples in the Data Files page of the User Guide

Misc

* Modified test_setup_install_includes_dependencies to work with custom PYTHONPATH

Revision 1.188 / (download) - annotate - [select for diffs], Wed May 18 20:33:46 2022 UTC (16 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.187: +4 -4 lines
Diff to previous 1.187 (colored)

py-setuptools: updated to 62.3.2

v62.3.2
Misc
* Include a first line summary to some of the existing multi-line warnings.

Revision 1.187 / (download) - annotate - [select for diffs], Wed May 18 05:41:49 2022 UTC (16 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.186: +4 -4 lines
Diff to previous 1.186 (colored)

py-setuptools: updated to 62.3.1

v62.3.1

Misc
* Fixed typo which causes ``namespace_packages`` to raise an error instead of
  warning.

Revision 1.186 / (download) - annotate - [select for diffs], Tue May 17 07:44:07 2022 UTC (16 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.185: +4 -4 lines
Diff to previous 1.185 (colored)

py-setuptools: updated to 62.3.0

v62.3.0

Deprecations

* Formally added deprecation messages for namespace_packages. The methodology that uses pkg_resources and namespace_packages for creating namespaces was already discouraged by the :doc:`setuptools docs </userguide/package_discovery>` and the :doc:`Python Packaging User Guide <PyPUG:guides/packaging-namespace-packages>`, therefore this change just make the deprecation more official. Users can consider migrating to native/implicit namespaces (as introduced in PEP 420).

* Relying on include_package_data to ensure sub-packages are automatically added to the build wheel distribution (as "data") is now considered a deprecated practice.

This behaviour was controversial and caused inconsistencies.

Instead, projects are encouraged to properly configure packages or use discovery tools. General information can be found in :doc:`userguide/package_discovery`.

Changes

* Allowed recursive globs (**) in package_data. -- by :user:`nullableVoidPtr`
* Fixed behaviour when both install_requires (in setup.py) and dependencies (in pyproject.toml) are specified. The configuration in pyproject.toml will take precedence over setup.py (in accordance with PEP 621). A warning was added to inform users.

Documentation changes

* Added introduction to references/keywords Added deprecation tags to test kwargs Moved userguide/keywords to deprecated section Clarified in deprecated doc what keywords came from distutils and which were added or changed by setuptools

Misc

* Updated version of vendored pyparsing to 3.0.8 to avoid problems with upcoming deprecation in Python 3.11.
* Added warning about incompatibility with old versions of importlib-metadata.

Revision 1.185 / (download) - annotate - [select for diffs], Wed May 11 08:32:26 2022 UTC (16 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.184: +4 -4 lines
Diff to previous 1.184 (colored)

py-setuptools: updated to 62.2.0

v62.2.0

Changes
Optional metadata fields are now truly optional.

Misc
Added CI cache for setup.cfg examples used when testing setuptools.config.

Revision 1.184 / (download) - annotate - [select for diffs], Tue Apr 19 19:12:39 2022 UTC (17 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.183: +4 -4 lines
Diff to previous 1.183 (colored)

py-setuptools: updated to 62.1.0

v62.1.0

Changes
* Merge pypa/distutils@5229dad46b.

Misc
* Simplified package_dir obtained via auto-discovery.

Revision 1.183 / (download) - annotate - [select for diffs], Tue Apr 5 07:23:10 2022 UTC (17 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.182: +4 -4 lines
Diff to previous 1.182 (colored)

py-setuptools: updated to 62.0.0

v62.0.0
-------


Breaking Changes
^^^^^^^^^^^^^^^^
* Made ``setup.py develop --user`` install to the user site packages directory even if it is disabled in the current interpreter.

Changes
^^^^^^^
* When resolving requirements use both canonical and normalized names -- by :user:`ldaniluk`
* Honor unix file mode in ZipFile when installing wheel via ``install_as_egg`` -- by :user:`delijati`

Misc
^^^^
* Fixed duplicated tag with the ``dist-info`` command.
* Fixed problem preventing ``readme`` specified as dynamic in ``pyproject.toml``
  from being dynamically specified in ``setup.py``.


v61.3.1
-------


Misc
^^^^
* Included missing test file ``setupcfg_examples.txt`` in ``sdist``.
* Added script that allows developers to download ``setupcfg_examples.txt`` prior to
  running tests. By caching these files it should be possible to run the test suite
  offline.


v61.3.0
-------


Changes
^^^^^^^
* Disabled automatic download of ``trove-classifiers`` to facilitate reproducibility.

Misc
^^^^
* Updated ``pyproject.toml`` validation via ``validate-pyproject`` v0.7.1.
* New internal tool made available for updating the code responsible for
  the validation of ``pyproject.toml``.
  This tool can be executed via ``tox -e generate-validation-code``.


v61.2.0
-------


Changes
^^^^^^^
* Ignored a subgroup of invalid ``pyproject.toml`` files that use the ``[project]``
  table to specify only ``requires-python`` (**transitional**).

  .. warning::
     Please note that future releases of setuptools will halt the build process
     if a ``pyproject.toml`` file that does not match doc:`the PyPA Specification
     <PyPUG:specifications/declaring-project-metadata>` is given.
* Updated ``pyproject.toml`` validation, as generated by ``validate-pyproject==0.6.1``.
* Prevented builds from erroring if the project specifies metadata via
  ``pyproject.toml``, but uses other files (e.g. ``setup.py``) to complement it,
  without setting ``dynamic`` properly.

  .. important::
     This is a **transitional** behaviour.
     Future releases of ``setuptools`` may simply ignore externally set metadata
     not backed by ``dynamic`` or even halt the build with an error.
* Merge changes from pypa/distutils@e1d5c9b1f6

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* Fixed typo in ``pyproject.toml`` example in Quickstart -- by :user:`pablo-cardenas`.

Misc
^^^^
* Fixed missing requirements with environment markers when
  ``optional-dependencies`` is set in ``pyproject.toml``.


v61.1.1
-------


Misc
^^^^
* Fixed missing dependencies when running ``setup.py install``.
  Note that calling ``setup.py install`` directly is still deprecated and
  will be removed in future versions of ``setuptools``.
  Please check the release notes for :ref:`setup_install_deprecation_note`.


v61.1.0
-------


Deprecations
^^^^^^^^^^^^
* Changed ``setuptools.convert_path`` to an internal function that is not exposed
  as part of setuptools API.
  Future releases of ``setuptools`` are likely to remove this function.

Changes
^^^^^^^
* Changed behaviour of auto-discovery to not explicitly expand ``package_dir``
  for flat-layouts and to not use relative paths starting with ``./``.
* Prevented ``pyproject.toml`` parsing from overwriting
  ``dist.include_package_data`` explicitly set in ``setup.py`` with default
  value.
* Added a warning for non existing files listed with the ``file`` directive in
  ``setup.cfg`` and ``pyproject.toml``.
* Added a default value for dynamic ``classifiers`` in ``pyproject.toml`` when
  files are missing and errors being ignored.
* Disabled auto-discovery when distribution class has a ``configuration``
  attribute (e.g. when the ``setup.py`` script contains ``setup(...,
  configuration=...)``).  This is done to ensure extension-only packages created
  with ``numpy.distutils.misc_util.Configuration`` are not broken by the safe
  guard
  behaviour to avoid accidental multiple top-level packages in a flat-layout.

  .. note::
     Users that don't set ``packages``, ``py_modules``, or ``configuration`` are
     still likely to observe the auto-discovery behavior, which may halt the
     build if the project contains multiple directories and/or multiple Python
     files directly under the project root.

     To disable auto-discovery please explicitly set either ``packages`` or
     ``py_modules``. Alternatively you can also configure :ref:`custom-discovery`.


v61.0.0
-------


Deprecations
^^^^^^^^^^^^
* Deprecated ``setuptools.config.read_configuration``,
  ``setuptools.config.parse_configuration`` and other functions or classes
  from ``setuptools.config``.

  Users that still need to parse and process configuration from ``setup.cfg`` can
  import a direct replacement from ``setuptools.config.setupcfg``, however this
  module is transitional and might be removed in the future
  (the ``setup.cfg`` configuration format itself is likely to be deprecated in the future).

Breaking Changes
^^^^^^^^^^^^^^^^
* If you purposefully want to create an *"empty distribution"*, please be aware
  that some Python files (or general folders) might be automatically detected and
  included.

  Projects that currently don't specify both ``packages`` and ``py_modules`` in their
  configuration and contain extra folders or Python files (not meant for distribution),
  might see these files being included in the wheel archive or even experience
  the build to fail.

  You can check details about the automatic discovery (and how to configure a
  different behaviour) in :doc:`/userguide/package_discovery`.
* If the file ``pyproject.toml`` exists and it includes project
  metadata/config (via ``[project]`` table or ``[tool.setuptools]``),
  a series of new behaviors that are not backward compatible may take place:

  - The default value of ``include_package_data`` will be considered to be ``True``.
  - Setuptools will attempt to validate the ``pyproject.toml`` file according
    to PEP 621 specification.
  - The values specified in ``pyproject.toml`` will take precedence over those
    specified in ``setup.cfg`` or ``setup.py``.

Changes
^^^^^^^
* **[EXPERIMENTAL]** Added automatic discovery for ``py_modules`` and ``packages``
  -- by :user:`abravalheri`.

  Setuptools will try to find these values assuming that the package uses either
  the *src-layout* (a ``src`` directory containing all the packages or modules),
  the *flat-layout* (package directories directly under the project root),
  or the *single-module* approach (an isolated Python file, directly under
  the project root).

  The automatic discovery will also respect layouts that are explicitly
  configured using the ``package_dir`` option.

  For backward-compatibility, this behavior will be observed **only if both**
  ``py_modules`` **and** ``packages`` **are not set**.
  (**Note**: specifying ``ext_modules`` might also prevent auto-discover from
  taking place)

  If setuptools detects modules or packages that are not supposed to be in the
  distribution, please manually set ``py_modules`` and ``packages`` in your
  ``setup.cfg`` or ``setup.py`` file.
  If you are using a *flat-layout*, you can also consider switching to
  *src-layout*.
* **[EXPERIMENTAL]** Added automatic configuration for the ``name`` metadata
  -- by :user:`abravalheri`.

  Setuptools will adopt the name of the top-level package (or module in the case
  of single-module distributions), **only when** ``name`` **is not explicitly
  provided**.

  Please note that it is not possible to automatically derive a single name when
  the distribution consists of multiple top-level packages or modules.
* Added vendored dependencies for :pypi:`tomli`, :pypi:`validate-pyproject`.

  These dependencies are used to read ``pyproject.toml`` files and validate them.
* **[EXPERIMENTAL]** When using ``pyproject.toml`` metadata,
  the default value of ``include_package_data`` is changed to ``True``.
* **[EXPERIMENTAL]** Add support for ``pyproject.toml`` configuration
  (as introduced by :pep:`621`). Configuration parameters not covered by
  standards are handled in the ``[tool.setuptools]`` sub-table.

  In the future, existing ``setup.cfg`` configuration
  may be automatically converted into the ``pyproject.toml`` equivalent before taking effect
  (as proposed in 1688). Meanwhile users can use automated tools like
  :pypi:`ini2toml` to help in the transition.

  Please note that the legacy backend is not guaranteed to work with
  ``pyproject.toml`` configuration.

  -- by :user:`abravalheri`
* Implicit namespaces (as introduced in :pep:`420`) are now considered by default
  during :doc:`package discovery </userguide/package_discovery>`, when
  ``setuptools`` configuration and project metadata are added to the
  ``pyproject.toml`` file.

  To disable this behaviour, use ``namespaces = False`` when explicitly setting
  the ``[tool.setuptools.packages.find]`` section in ``pyproject.toml``.

  This change is backwards compatible and does not affect the behaviour of
  configuration done in ``setup.cfg`` or ``setup.py``.
* **[EXPERIMENTAL]** Added support for ``attr:`` and ``cmdclass`` configurations
  in ``setup.cfg`` and ``pyproject.toml`` when ``package_dir`` is implicitly
  found via auto-discovery.
* Postponed importing ``ctypes`` when hiding files on Windows.
  This helps to prevent errors in systems that might not have ``libffi`` installed.
* Merge with pypa/distutils@267dbd25ac

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* Added initial documentation about configuring ``setuptools`` via ``pyproject.toml``
  (using standard project metadata).

Misc
^^^^
* Refactored ``setuptools.config`` by separating configuration parsing (specific
  to the configuration file format, e.g. ``setup.cfg``) and post-processing
  (which includes directives such as ``file:`` that can be used across different
  configuration formats).


v60.10.0
--------


Changes
^^^^^^^
* Deprecated upload_docs command, to be removed in the future.
* Use samefile from stdlib, supported on Windows since Python 3.2.
* Adopt nspektr (vendored) to implement Distribution._install_dependencies.

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* Added documentation on using console_scripts from setup.py, which was previously only shown in setup.cfg  -- by :user:`xhlulu`
* Added clarifications about ``MANIFEST.in``, that include links to PyPUG docs
  and more prominent mentions to using a revision control system plugin as an
  alternative.
* Removed mention to ``pkg_resources`` as the recommended way of accessing data
  files, in favour of importlib.resources.
  Additionally more emphasis was put on the fact that *package data files* reside
  **inside** the *package directory* (and therefore should be *read-only*).

Misc
^^^^
* Added workaround for intermittent failures of backend tests on PyPy.
  These tests now are marked with `XFAIL
  <https://docs.pytest.org/en/stable/how-to/skipping.html>`_, instead of erroring
  out directly.
* Improved configuration for :pypi:`rst-linker` (extension used to build the
  changelog).
* Enhanced isolation of tests using virtual environments - PYTHONPATH is not leaking to spawned subprocesses  -- by :user:`befeleme`
* Added options to provide a pre-built ``setuptools`` wheel or sdist for being
  used during tests with virtual environments.
  Paths for these pre-built distribution files can now be set via the environment
  variables: ``PRE_BUILT_SETUPTOOLS_SDIST`` and ``PRE_BUILT_SETUPTOOLS_WHEEL``.

Revision 1.182 / (download) - annotate - [select for diffs], Mon Feb 21 08:20:53 2022 UTC (19 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.181: +4 -4 lines
Diff to previous 1.181 (colored)

py-setuptools: updated to 60.9.3

v60.9.3

Misc

* Repaired automated release process.

v60.9.2

Misc

* When loading distutils from the vendored copy, rewrite __name__ to ensure consistent importing from inside and out.

v60.9.1

Misc

* Prevent vendored importlib_metadata from loading distributions from older importlib_metadata.
* Fixed issue where string-based entry points would be omitted.
* Bump importlib_metadata to 4.11.1 addressing issue with parsing requirements in egg-info as found in PyPy.

v60.9.0

Changes

* In the build backend, allow single config settings to be supplied.
* Removed workaround in distutils hack for get-pip now that pypa/get-pip#137 is closed.
* Setuptools no longer relies on pkg_resources for entry point handling.
* Bump vendored packaging to 21.3.
* Removed bootstrap script.

Revision 1.181 / (download) - annotate - [select for diffs], Mon Feb 7 11:45:42 2022 UTC (19 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.180: +4 -4 lines
Diff to previous 1.180 (colored)

py-setuptools: updated to 60.8.1

v60.8.1

Misc
* When vendoring jaraco packages, ensure the namespace package is converted to a simple package to support zip importer.

v60.8.0

Changes
* Setuptools now vendors importlib_resources and importlib_metadata and jaraco.text. Setuptools no longer relies on pkg_resources for ensure_directory nor parse_requirements.

Revision 1.180 / (download) - annotate - [select for diffs], Thu Feb 3 08:04:50 2022 UTC (19 months, 4 weeks ago) by adam
Branch: MAIN
Changes since 1.179: +4 -4 lines
Diff to previous 1.179 (colored)

py-setuptools: updated to 60.7.1

v60.7.1

Misc
Remove lorem_ipsum from jaraco.text when vendored.

Revision 1.179 / (download) - annotate - [select for diffs], Wed Feb 2 18:55:46 2022 UTC (20 months ago) by adam
Branch: MAIN
Changes since 1.178: +4 -4 lines
Diff to previous 1.178 (colored)

py-setuptools: updated to 60.7.0

v60.7.0
-------
Changes
* Vendored jaraco.text and use line processing from that library in pkg_resources.

Misc
* Avoid AttributeError in easy_install.create_home_path when sysconfig.get_config_vars values are not strings.

Revision 1.178 / (download) - annotate - [select for diffs], Mon Jan 31 11:14:21 2022 UTC (20 months ago) by adam
Branch: MAIN
Changes since 1.177: +4 -4 lines
Diff to previous 1.177 (colored)

py-setuptools: updated to 60.6.0

v60.6.0

Changes
* Merge with pypa/distutils@bb018f1ac3 including consolidated behavior in sysconfig.get_platform.
* Don't include optional Home-page in metadata if no url is specified.
* Merge with pypa/distutils@b53a824ec3 including improved support for lib directories on non-x64 Windows builds.

Misc
* Used Py3 syntax super().__init__()

v60.5.4

Misc
* Remove filtering of distutils warnings.
* Suppress distutils replacement when building or testing CPython.

v60.5.3

Misc
* Honor sysconfig variables in easy_install.

v60.5.2

Misc
* In _distutils_hack, for get-pip, simulate existence of setuptools.

v60.5.1

Misc
* Correct support for Python 3 native loaders.

Revision 1.177 / (download) - annotate - [select for diffs], Sun Jan 23 09:11:07 2022 UTC (20 months, 1 week ago) by adam
Branch: MAIN
Changes since 1.176: +4 -4 lines
Diff to previous 1.176 (colored)

py-setuptools: updated to 60.5.0

v60.5.0

Changes

* Set the .origin attribute of the distutils module to the module's __file__.


v60.4.0

Changes

* Removed requires sorting when installing wheels as an egg dir.
* Fixed a bug that easy install incorrectly parsed Python 3.10 version string.
* Fixed startup performance issue of Python interpreter due to imports of costly modules in _distutils_hack -- by :user:`tiran`
Documentation changes

* Added link to additional resources on packaging in Quickstart guide
* "In-tree" Sphinx extension for "favicons" replaced with sphinx-favicon.
* SVG images (logo, banners, ...) optimised with the help of the scour package.

Misc

* Added integration tests that focus on building and installing some packages in the Python ecosystem via pip -- by :user:`abravalheri`

* Modified "vendoring" logic to keep license files.

* Improved isolation for some tests that where inadvertently using the project root for builds, and therefore creating directories (e.g. build, dist, *.egg-info) that could interfere with the outcome of other tests -- by :user:`abravalheri`.

* Introduced new test fixtures venv, venv_without_setuptools, bare_venv that rely on the jaraco.envs package. These new test fixtures were also used to remove the (currently problematic) dependency on the pytest_virtualenv plugin.

* Removed tmp_src test fixture. Previously this fixture was copying all the files and folders under the project root, including the .git directory, which is error prone and increases testing time.

Since tmp_src was used to populate virtual environments (installing the version of setuptools under test via the source tree), it was replaced by the new setuptools_sdist and setuptools_wheel fixtures (that are build only once per session testing and can be shared between all the workers for read-only usage).

Revision 1.176 / (download) - annotate - [select for diffs], Fri Jan 7 12:18:44 2022 UTC (20 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.175: +4 -4 lines
Diff to previous 1.175 (colored)

py-setuptools: updated to 60.3.1

v60.3.1

Misc
Suppress AttributeError when detecting get-pip.


v60.3.0

Changes
In _distutils_hack, bypass the distutils exception for pip when get-pip is being invoked, because it imports setuptools.

Misc
Merge with pypa/distutils@788cc159. Includes fix for config vars missing from sysconfig.

Revision 1.175 / (download) - annotate - [select for diffs], Thu Dec 30 16:20:11 2021 UTC (21 months ago) by wiz
Branch: MAIN
Changes since 1.174: +4 -4 lines
Diff to previous 1.174 (colored)

py-setuptools: update to 60.2.0.

v60.2.0
-------


Changes
^^^^^^^
* #2974: Setuptools now relies on the Python logging infrastructure to log messages. Instead of using ``distutils.log.*``, use ``logging.getLogger(name).*``.
* #2987: Sync with pypa/distutils@2def21c5d74fdd2fe7996ee4030ac145a9d751bd, including fix for missing get_versions attribute (#2969), more reliance on sysconfig from stdlib.

Misc
^^^^
* #2962: Avoid attempting to use local distutils when the presiding version of Setuptools on the path doesn't have one.
* #2983: Restore 'add_shim' as the way to invoke the hook. Avoids compatibility issues between different versions of Setuptools with the distutils local implementation.


v60.1.1
-------


Misc
^^^^
* #2980: Bypass distutils loader when setuptools module is no longer available on sys.path.


v60.1.0
-------


Changes
^^^^^^^
* #2958: In distutils_hack, only add the metadata finder once. In ensure_local_distutils, rely on a context manager for reliable manipulation.
* #2963: Merge with pypa/distutils@a5af364910. Includes revisited fix for pypa/distutils#15 and improved MinGW/Cygwin support from pypa/distutils#77.


v60.0.5
-------


Misc
^^^^
* #2960: Install schemes fall back to default scheme for headers.


v60.0.4
-------


Misc
^^^^
* #2954: Merge with pypa/distutils@eba2bcd310. Adds platsubdir to config vars available for substitution.


v60.0.3
-------


Misc
^^^^
* #2940: Avoid KeyError in distutils hack when pip is imported during ensurepip.


v60.0.2
-------


Misc
^^^^
* #2938: Select 'posix_user' for the scheme unless falling back to stdlib, then use 'unix_user'.


v60.0.1
-------


Misc
^^^^
* #2944: Add support for extended install schemes in easy_install.


v60.0.0
-------


Breaking Changes
^^^^^^^^^^^^^^^^
* #2896: Setuptools once again makes its local copy of distutils the default. To override, set SETUPTOOLS_USE_DISTUTILS=stdlib.


v59.8.0
-------


Changes
^^^^^^^
* #2935: Merge pypa/distutils@460b59f0e68dba17e2465e8dd421bbc14b994d1f.


v59.7.0
-------


Changes
^^^^^^^
* #2930: Require Python 3.7

Revision 1.174 / (download) - annotate - [select for diffs], Mon Dec 13 16:19:09 2021 UTC (21 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.173: +4 -4 lines
Diff to previous 1.173 (colored)

py-setuptools: updated to 59.6.0

v59.6.0

Changes
Merge with pypa/distutils@92082ee42c including introduction of deprecation warning on Version classes.

v59.5.0

Changes
Merge with pypa/distutils@8f2df0bf6.

Revision 1.173 / (download) - annotate - [select for diffs], Mon Nov 29 09:15:06 2021 UTC (22 months ago) by adam
Branch: MAIN
Changes since 1.172: +4 -4 lines
Diff to previous 1.172 (colored)

py-setuptools: updated to 59.4.0

v59.4.0
-------
Changes
* Restore deprecated support for newlines in the Summary field.

Revision 1.172 / (download) - annotate - [select for diffs], Fri Nov 26 21:34:45 2021 UTC (22 months, 1 week ago) by wiz
Branch: MAIN
Changes since 1.171: +4 -4 lines
Diff to previous 1.171 (colored)

py-setuptools: update to 59.3.0.

v59.3.0
-------

Changes
^^^^^^^
* #2902: Merge with pypa/distutils@85db7a41242.

Misc
^^^^
* #2906: In ensure_local_distutils, re-use DistutilsMetaFinder to load the module. Avoids race conditions when _distutils_system_mod is employed.

Revision 1.171 / (download) - annotate - [select for diffs], Tue Nov 23 10:32:17 2021 UTC (22 months, 1 week ago) by wiz
Branch: MAIN
Changes since 1.170: +4 -6 lines
Diff to previous 1.170 (colored)

py-setuptools: update to 59.2.0.

v59.2.0
-------


Changes
^^^^^^^
* #2875: Introduce changes from pypa/distutils@514e9d0, including
support for overrides from Debian and pkgsrc, unlocking the
possibility of making SETUPTOOLS_USE_DISTUTILS=local the default
again.


v59.1.1
-------


Misc
^^^^
* #2885: Fixed errors when encountering LegacyVersions.


v59.1.0
-------


Changes
^^^^^^^
* #2497: Update packaging to 21.2.
* #2877: Back out deprecation of setup_requires and replace instead
by a deprecation of setuptools.installer and fetch_build_egg. Now
setup_requires is still supported when installed as part of a PEP
517 build, but is deprecated when an unsatisfied requirement is
encountered.
* #2879: Bump packaging to 21.2.

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* #2867: PNG/ICO images replaced with SVG in the docs.
* #2867: Added support to SVG "favicons" via "in-tree" Sphinx extension.


v59.0.1
-------


Misc
^^^^
* #2880: Removed URL requirement for ``pytest-virtualenv`` in ``setup.cfg``.
  PyPI rejects packages with dependencies external to itself.
  Instead the test dependency was overwritten via ``tox.ini``


v59.0.0
-------


Deprecations
^^^^^^^^^^^^
* #2856: Support for custom commands that inherit directly from ``distutils`` is
  **deprecated**. Users should extend classes provided by setuptools instead.

Breaking Changes
^^^^^^^^^^^^^^^^
* #2870: Started failing on invalid inline description with line
breaks :class:`ValueError` -- by :user:`webknjaz`

Changes
^^^^^^^
* #2698: Exposed exception classes from ``distutils.errors`` via ``setuptools.errors``.
* #2866: Incorporate changes from pypa/distutils@f1b0a2b.

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* #2227: Added sphinx theme customisations to display the new logo in the sidebar and
  use its colours as "accent" in the documentation -- by :user:`abravalheri`
* #2227: Added new setuptools logo, including editable files and artwork documentation
  -- by :user:`abravalheri`
* #2698: Added mentions to ``setuptools.errors`` as a way of handling custom command
  errors.
* #2698: Added instructions to migrate from ``distutils.commands`` and
  ``distutils.errors`` in the porting guide.
* #2871: Added a note to the docs that it is possible to install
  ``setup.py``-less projects in editable mode with :doc:`pip v21.1+
  <pip:index>`, only having ``setup.cfg`` and ``pyproject.toml`` in
  project root -- by :user:`webknjaz`


v58.5.3
-------


Misc
^^^^
* #2849: Add fallback for custom ``build_py`` commands inheriting directly from
  :mod:`distutils`, while still handling ``include_package_data=True`` for
  ``sdist``.


v58.5.2
-------


Misc
^^^^
* #2847: Suppress 'setup.py install' warning under bdist_wheel.


v58.5.1
-------


Misc
^^^^
* #2846: Move PkgResourcesDeprecationWarning above implicitly-called
function so that it's in the namespace when version warnings are
generated in an environment that contains them.


v58.5.0
-------


Changes
^^^^^^^
* #1461: Fix inconsistency with ``include_package_data`` and ``packages_data`` in sdist
  by replacing the loop breaking mechanism between the ``sdist`` and
  ``egg_info`` commands -- by :user:`abravalheri`


v58.4.0
-------


Changes
^^^^^^^
* #2497: Officially deprecated PEP 440 non-compliant versions.

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* #2832: Removed the deprecated ``data_files`` option from the example in the
  declarative configuration docs -- by :user:`abravalheri`
* #2832: Change type of ``data_files`` option from ``dict`` to ``section`` in
  declarative configuration docs (to match previous example) -- by
  :user:`abravalheri`


v58.3.0
-------


Changes
^^^^^^^
* #917: ``setup.py install`` and ``easy_install`` commands are now
officially deprecated. Use other standards-based installers (like
pip) and builders (like build). Workloads reliant on this behavior
should pin to this major version of Setuptools. See `Why you
shouldn't invoke setup.py directly
<https://blog.ganssle.io/articles/2021/10/setup-py-deprecated.html>`_
for more background.
* #1988: Deprecated the ``bdist_rpm`` command. Binary packages
should be built as wheels instead.
  -- by :user:`hugovk`
* #2785: Replace ``configparser``'s ``readfp`` with ``read_file``,
deprecated since Python 3.2.
  -- by :user:`hugovk`
* #2823: Officially deprecated support for ``setup_requires``.
Users are encouraged instead to migrate to PEP 518
``build-system.requires`` in ``pyproject.toml``. Users reliant on
``setup_requires`` should consider pinning to this major version
to avoid disruption.

Misc
^^^^
* #2762: Changed codecov.yml to configure the threshold to be lower
  -- by :user:`tanvimoharir`


v58.2.0
-------


Changes
^^^^^^^
* #2757: Add windows arm64 launchers for scripts generated by easy_install.
* #2800: Added ``--owner`` and ``--group`` options to the ``sdist`` command,
  for specifying file ownership within the produced tarball (similarly
  to the corresponding distutils ``sdist`` options).

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* #2792: Document how the legacy and non-legacy versions are
compared, and reference to the `PEP 440
<https://www.python.org/dev/peps/pep-0440/>`_ scheme.


v58.1.0
-------


Changes
^^^^^^^
* #2796: Merge with pypa/distutils@02e9f65ab0


v58.0.4
-------


Misc
^^^^
* #2773: Retain case in setup.cfg during sdist.


v58.0.3
-------


Misc
^^^^
* #2777: Build does not fail fast when ``use_2to3`` is supplied but set to a false value.


v58.0.2
-------


Misc
^^^^
* #2769: Build now fails fast when ``use_2to3`` is supplied.


v58.0.1
-------


Misc
^^^^
* #2765: In Distribution.finalize_options, suppress known removed entry points to avoid issues with older Setuptools.


v58.0.0
-------


Breaking Changes
^^^^^^^^^^^^^^^^
* #2086: Removed support for 2to3 during builds. Projects should
port to a unified codebase or pin to an older version of Setuptools
using PEP 518 build-requires.

Documentation changes
^^^^^^^^^^^^^^^^^^^^^
* #2746: add python_requires example

Revision 1.170 / (download) - annotate - [select for diffs], Tue Oct 26 10:19:04 2021 UTC (23 months, 1 week ago) by nia
Branch: MAIN
Changes since 1.169: +2 -2 lines
Diff to previous 1.169 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.169 / (download) - annotate - [select for diffs], Thu Oct 7 13:43:43 2021 UTC (23 months, 3 weeks ago) by nia
Branch: MAIN
Changes since 1.168: +1 -2 lines
Diff to previous 1.168 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.168 / (download) - annotate - [select for diffs], Wed Sep 15 07:28:22 2021 UTC (2 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.167: +5 -5 lines
Diff to previous 1.167 (colored)

py-setuptools: updated to 57.5.0

v57.5.0

Changes

Added implicit globbing support for [options.data_files] values.

Documentation changes

fix various syntax and style errors in code snippets in docs

Revision 1.167 / (download) - annotate - [select for diffs], Tue Jul 27 08:09:45 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.166: +5 -5 lines
Diff to previous 1.166 (colored)

py-setuptools: updated to 57.4.0

v57.4.0
Added support for SETUPTOOLS_EXT_SUFFIX environment variable to override the suffix normally detected from the sysconfig module.

v57.3.0
Documentation is now published using the Furo theme.

Revision 1.166 / (download) - annotate - [select for diffs], Sat Jul 17 20:27:38 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.165: +5 -5 lines
Diff to previous 1.165 (colored)

py-setuptools: updated to 57.2.0

v57.2.0
* Added detection of Windows ARM64 build environments using the VSCMD_ARG_TGT_ARCH environment variable.

Revision 1.165 / (download) - annotate - [select for diffs], Mon Jul 5 08:21:54 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.164: +5 -5 lines
Diff to previous 1.164 (colored)

py-setuptools: updated to 57.1.0

v57.1.0

Changes

* Globs are now sorted in 'license_files' restoring reproducibility by eliminating variance from disk order.
* Update to distutils at pypa/distutils@e2627b7.
* Removed reliance on deprecated ssl.match_hostname by removing the ssl support. Now any index operations rely on the native SSL implementation.

Documentation changes

* Revamped the backward/cross tool compatibility section to remove some confusion. Add some examples and the version since when entry_points are supported in declarative configuration. Tried to make the reading flow a bit leaner, gather some informations that were a bit dispersed.

Revision 1.164 / (download) - annotate - [select for diffs], Thu Jun 24 17:19:54 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.163: +5 -5 lines
Diff to previous 1.163 (colored)

py-setuptools: updated to 57.0.0

v57.0.0
-------
Breaking Changes
* License files excluded via the ``MANIFEST.in`` but matched by either
  the ``license_file`` (deprecated) or ``license_files`` options,
  will be nevertheless included in the source distribution. - by :user:`cdce8p`

Changes
* Write long description in message payload of PKG-INFO file. - by :user:`cdce8p`
* Added ``License-File`` (multiple) to the output package metadata.
  The field will contain the path of a license file, matched by the
  ``license_file`` (deprecated) and ``license_files`` options,
  relative to ``.dist-info``. - by :user:`cdce8p`
* Moved Setuptools' own entry points into declarative config.
* Vendored `more_itertools <https://pypi.org/project/more-itertools>`_ for Setuptools.
* Setuptools own setup.py no longer declares setup_requires, but instead expects wheel to be installed as declared by pyproject.toml.

Misc
* Updated the docs build tooling to support the latest version of
  Towncrier and show the previews of not-yet-released setuptools versions
  in the changelog -- :user:`webknjaz`


v56.2.0
-------
Changes
* Fixed handling of multiline license strings. - by :user:`cdce8p`
* Setuptools will now always try to use the latest supported
  metadata version for ``PKG-INFO``. - by :user:`cdce8p`


v56.1.0
-------
Changes
* Incorporated assorted changes from pypa/distutils.
* Adopted docs from distutils.
* Added Visual Studio Express 2017 support -- by :user:`dofuuz`

Misc
* Fixed ``DeprecationWarning`` due to ``threading.Thread.setDaemon`` in tests -- by :user:`tirkarthi`
* Made the changelog generator compatible
  with Towncrier >= 19.9 -- :user:`webknjaz`
* Relax the deprecation message in the distutils hack.

Revision 1.163 / (download) - annotate - [select for diffs], Tue May 4 06:17:59 2021 UTC (2 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.162: +5 -5 lines
Diff to previous 1.162 (colored)

py-setuptools: updated to 56.0.0

v56.0.0

Deprecations

* The license_file option is now marked as deprecated. Use license_files instead.

Breaking Changes

* If neither license_file nor license_files is specified, the sdist option will now auto-include files that match the following patterns: LICEN[CS]E*, COPYING*, NOTICE*, AUTHORS*. This matches the behavior of bdist_wheel.

Changes

* The license_file and license_files options now support glob patterns.
* Implemented VendorImporter.find_spec() method to get rid of ImportWarning that Python 3.10 emits when only the old-style importer hooks are present

Documentation changes

* Added documentation for the license_files option.


v55.0.0

Breaking Changes

* Remove the deprecated bdist_wininst command. Binary packages should be built as wheels instead.

Revision 1.162 / (download) - annotate - [select for diffs], Sat Apr 3 07:32:26 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.161: +5 -6 lines
Diff to previous 1.161 (colored)

py-setuptools: updated to 54.2.0

v54.1.2

Misc
* Reduced scope of dash deprecation warning to Setuptools/distutils only -- by :user:`melissa-kun-li`

v54.1.1

Documentation changes
* Added sphinx-inline-tabs extension to allow for comparison of setup.py and its equivalent setup.cfg -- by :user:`amy-lei`

Misc
* Made option keys in the [metadata] section of setup.cfg case-sensitive. Users having uppercase option spellings will get a warning suggesting to make them to lowercase -- by :user:`melissa-kun-li`

v54.1.0

Changes
* Removed the conversion of dashes to underscores in the extras_require and data_files of setup.cfg to support the usage of dashes. Method will warn users when they use a dash-separated key which in the future will only allow an underscore. Note: the method performs the dash to underscore conversion to preserve compatibility, but future versions will no longer support it -- by :user:`melissa-kun-li`

v54.0.0

Breaking Changes
* Simplified build-from-source story by providing bootstrapping metadata in a separate egg-info directory. Build requirements no longer include setuptools itself. Sdist once again includes the pyproject.toml. Project can no longer be installed from source on pip 19.x, but install from source is still supported on pip < 19 and pip >= 20 and install from wheel is still supported with pip >= 9.

Changes
* Handled AttributeError by raising DistutilsSetupError in dist.check_specifier() when specifier is not a string -- by :user:`melissa-kun-li`
* Correctly parse cmdclass in setup.cfg.

Documentation changes
* Added userguide example for markers in extras_require -- by :user:`pwoolvett`

v53.1.0

Changes
* Preserved case-sensitivity of keys in setup.cfg so that entry point names are case-sensitive. Changed sensitivity of configparser. NOTE: Any projects relying on case-insensitivity will need to adapt to accept the original case as published. -- by :user:`melissa-kun-li`
* Fixed error in uploading a Sphinx doc with the upload_docs command. An html builder will be used. Note: upload_docs is deprecated for PyPi, but is supported for other sites -- by :user:`melissa-kun-li`

v53.0.0

Breaking Changes
* Removed bootstrap script. Now Setuptools requires pip or another pep517-compliant builder such as 'build' to build. Now Setuptools can be installed from Github main branch.

v52.0.0

Breaking Changes
* Remove fallback support for fetch_build_eggs using easy_install. Now pip is required for setup_requires to succeed.
* Removed 'easy_install' top-level model (runpy entry point) and 'easy_install' console script.
* Removed support for eggsecutables.

Changes
* Tests now run in parallel via pytest-xdist, completing in about half the time. Special thanks to :user:`webknjaz` for hard work implementing test isolation. To run without parallelization, disable the plugin with tox -- -p no:xdist.

Revision 1.161 / (download) - annotate - [select for diffs], Mon Jan 18 16:02:31 2021 UTC (2 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.160: +5 -5 lines
Diff to previous 1.160 (colored)

py-setuptools: updated to 51.3.3

v51.3.3

Misc
* Fix AttributeError in Description validation.


v51.3.2

Misc
* Validation of Description field now is more lenient, emitting a warning and mangling the value to be valid (replacing newlines with spaces).


v51.3.1

Misc
* Reverted tag deduplication handling.


v51.3.0

Changes
* Newlines in metadata description/Summary now trigger a ValueError.
* Define create_module() and exec_module() methods in VendorImporter to get rid of ImportWarning -- by :user:`hroncok`
* pkg_resources behavior for zipimport now matches the regular behavior, and finds .egg-info (previoulsy would only find .dist-info) -- by :user:`thatch`
* Fixed an issue where version tags may be added multiple times


v51.2.0

Changes
* Use importlib.import_module() rather than the deprectated loader.load_module() in pkg_resources namespace delaration -- by :user:`encukou`

Documentation changes
* Fix typo in the document page about entry point. -- by :user:`jtr109`

Misc
* Avoid hitting network during test_easy_install.


v51.1.2

Misc
* Disable inclusion of package data as it causes 'tests' to be included as data.


v51.1.1

Misc
* Avoid hitting network during test_virtualenv.test_test_command.


v51.1.0

Changes
* Project adopts jaraco/skeleton for shared package maintenance.

Misc
* Restore inclusion of rst files in sdist.
* Setuptools has replaced the master branch with the main branch.
* Fixed failing test when pip 20.3+ is present. -- by :user:`yan12125`
* Fix tests with pytest 6.2 -- by :user:`yan12125`


v51.0.0

Breaking Changes
* Require Python 3.6 or later.

Documentation changes
* Fixed inconsistent RST title nesting levels caused
* Fixed a typo in Sphinx docs that made docs dev section disappear

Misc
* Removed the tests that guarantee that the vendored dependencies can be built by distutils.

Revision 1.160 / (download) - annotate - [select for diffs], Tue Oct 27 18:10:49 2020 UTC (2 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.159: +5 -5 lines
Diff to previous 1.159 (colored)

py-setuptools: updated to 50.3.2

v50.3.2

Documentation changes
* Extended towncrier news template to include change note categories. This allows to see what types of changes a given version introduces
* Started enforcing strict syntax and reference validation in the Sphinx docs
* Removed redundant Sphinx Makefile support

Misc
* Enabled test results reporting in AppVeyor CI
* Replace Python 3.9.0 beta with 3.9.0 final on GitHub Actions.
* Python 3.9 Trove classifier got added to the dist metadata

v50.3.1

Documentation changes
* Finalized doc revamp.
* doc: simplify index and group deprecated files
* doc overhaul step 2: break main doc into multiple sections
* doc overhaul step 3: update userguide
* Added a :user: role to Sphinx config
* Added an illustrative explanation about the change notes to fragments dir

Misc
* Travis CI test suite now tests against PPC64.
* Suppress EOF errors (and other exceptions) when importing lib2to3.

Revision 1.159 / (download) - annotate - [select for diffs], Wed Sep 9 07:25:46 2020 UTC (3 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.158: +5 -5 lines
Diff to previous 1.158 (colored)

py-setuptools: updated to 50.3.0

v50.3.0
In distutils, restore support for monkeypatched CCompiler.spawn per pypa/distutils#15.

Revision 1.158 / (download) - annotate - [select for diffs], Sat Sep 5 10:14:31 2020 UTC (3 years ago) by ryoon
Branch: MAIN
Changes since 1.157: +5 -5 lines
Diff to previous 1.157 (colored)

py-setuptools: Update to 50.2.0

* It seems that this fixes PLIST divergence of some packages,
  including py-libxml2 and py-cElementTree.

Changelog:
v50.2.0

    #2355: When pip is imported as part of a build, leave distutils patched.
    #2380: There are some setuptools specific changes in the setuptools.command.bdist_rpm module that are no longer needed, because they are part of the bdist_rpm module in distutils in Python 3.5.0. Therefore, code was removed from setuptools.command.bdist_rpm.

v50.1.0

    #2350: Setuptools reverts using the included distutils by default. Platform maintainers and system integrators and others are strongly encouraged to set SETUPTOOLS_USE_DISTUTILS=local to help identify and work through the reported issues with distutils adoption, mainly to file issues and pull requests with pypa/distutils such that distutils performs as needed across every supported environment.

v50.0.3

    #2363: Restore link_libpython support on Python 3.7 and earlier (see pypa/distutils#9).

v50.0.2

    #2352: In distutils hack, use absolute import rather than relative to avoid bpo-30876.

Revision 1.157 / (download) - annotate - [select for diffs], Wed Sep 2 21:42:18 2020 UTC (3 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.156: +7 -5 lines
Diff to previous 1.156 (colored)

py-setuptools: update to 50.0.1.

Please note the change in 50.0.0:

"Setuptools overrides the stdlib distutils on import"

and the workaround:

"If the environment variable ``SETUPTOOLS_USE_DISTUTILS`` is set to
``stdlib``, Setuptools will fall back to the legacy behavior."

v50.0.1
-------

* #2357: Restored Python 3.5 support in distutils.util for missing `subprocess._optim_args_from_interpreter_flags`.
* #2358: Restored AIX support on Python 3.8 and earlier.
* #2361: Add Python 3.10 support to _distutils_hack. Get the 'Loader' abstract class
  from importlib.abc rather than importlib.util.abc (alias removed in Python
  3.10).


v50.0.0
-------

* #2232: Once again, Setuptools overrides the stdlib distutils on import. For environments or invocations where this behavior is undesirable, users are provided with a temporary escape hatch. If the environment variable ``SETUPTOOLS_USE_DISTUTILS`` is set to ``stdlib``, Setuptools will fall back to the legacy behavior. Use of this escape hatch is discouraged, but it is provided to ease the transition while proper fixes for edge cases can be addressed.
* #2334: In MSVC module, refine text in error message.


v49.6.0
-------

* #2129: In pkg_resources, no longer detect any pathname ending in .egg as a Python egg. Now the path must be an unpacked egg or a zip file.


v49.5.0
-------

* #2306: When running as a PEP 517 backend, setuptools does not try to install
  ``setup_requires`` itself. They are reported as build requirements for the
  frontend to install.


v49.4.0
-------

* #2310: Updated vendored packaging version to 20.4.


v49.3.2
-------

* #2300: Improve the ``safe_version`` function documentation
* #2297: Once again, in stubs prefer exec_module to the deprecated load_module.


v49.3.1
-------

* #2316: Removed warning when ``distutils`` is imported before ``setuptools`` when ``distutils`` replacement is not enabled.


v49.3.0
-------

* #2259: Setuptools now provides a .pth file (except for editable installs of setuptools) to the target environment to ensure that when enabled, the setuptools-provided distutils is preferred before setuptools has been imported (and even if setuptools is never imported). Honors the SETUPTOOLS_USE_DISTUTILS environment variable.


v49.2.1
-------

* #2257: Fixed two flaws in distutils._msvccompiler.MSVCCompiler.spawn.


v49.2.0
-------

* #2230: Now warn the user when setuptools is imported after distutils modules have been loaded (exempting PyPy for 3.6), directing the users of packages to import setuptools first.


v49.1.3
-------

* #2212: (Distutils) Allow spawn to accept environment. Avoid monkey-patching global state.
* #2249: Fix extension loading technique in stubs.


v49.1.2
-------

* #2232: In preparation for re-enabling a local copy of distutils, Setuptools now honors an environment variable, SETUPTOOLS_USE_DISTUTILS. If set to 'stdlib' (current default), distutils will be used from the standard library. If set to 'local' (default in a imminent backward-incompatible release), the local copy of distutils will be used.


v49.1.1
-------

* #2094: Removed pkg_resources.py2_warn module, which is no longer reachable.


v49.0.1
-------

* #2228: Applied fix for pypa/distutils#3, restoring expectation that spawn will raise a DistutilsExecError when attempting to execute a missing file.


v49.1.0
-------

* #2228: Disabled distutils adoption for now while emergent issues are addressed.


v49.0.0
-------

* #2165: Setuptools no longer installs a site.py file during easy_install or develop installs. As a result, .eggs on PYTHONPATH will no longer take precedence over other packages on sys.path. If this issue affects your production environment, please reach out to the maintainers at #2165.
* #2137: Removed (private) pkg_resources.RequirementParseError, now replaced by packaging.requirements.InvalidRequirement. Kept the name for compatibility, but users should catch InvalidRequirement instead.
* #2180: Update vendored packaging in pkg_resources to 19.2.
* #2199: Fix exception causes all over the codebase by using ``raise new_exception from old_exception``

Revision 1.156 / (download) - annotate - [select for diffs], Mon Aug 31 23:06:02 2020 UTC (3 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.155: +5 -5 lines
Diff to previous 1.155 (colored)

py-setuptools: update to 47.3.2.

v47.3.2
-------

* #2071: Replaced references to the deprecated imp package with references to importlib


v47.3.1
-------

* #1973: Removed ``pkg_resources.py31compat.makedirs`` in favor of the stdlib. Use ``os.makedirs()`` instead.
* #2198: Restore ``__requires__`` directive in easy-install wrapper scripts.


v47.3.0
-------

* #2197: Console script wrapper for editable installs now has a unified template and honors importlib_metadata if present for faster script execution on older Pythons.
* #2195: Fix broken entry points generated by easy-install (pip editable installs).


v47.2.0
-------

* #2194: Editable-installed entry points now load significantly faster on Python versions 3.8+.


v47.1.1
-------

* #2156: Update mailing list pointer in developer docs

Incorporate changes from v44.1.1:

* #2158: Avoid loading working set during ``Distribution.finalize_options`` prior to invoking ``_install_setup_requires``, broken since v42.0.0.


v44.1.1
-------

* #2158: Avoid loading working set during ``Distribution.finalize_options`` prior to invoking ``_install_setup_requires``, broken since v42.0.0.


v47.1.0
-------

* #2070: In wheel-to-egg conversion, use simple pkg_resources-style namespace declaration for packages that declare namespace_packages.


v47.0.0
-------

* #2094: Setuptools now actively crashes under Python 2. Python 3.5 or later is required. Users of Python 2 should use ``setuptools<45``.
* #1700: Document all supported keywords by migrating the ones from distutils.


v46.4.0
-------

* #1753: ``attr:`` now extracts variables through rudimentary examination of the AST,
  thereby supporting modules with third-party imports. If examining the AST
  fails to find the variable, ``attr:`` falls back to the old behavior of
  importing the module. Works on Python 3 only.


v46.3.1
-------

No significant changes.


v46.3.0
-------

* #2089: Package index functionality no longer attempts to remove an md5 fragment from the index URL. This functionality, added for distribute #163 is no longer relevant.
* #2041: Preserve file modes during pkg files copying, but clear read only flag for target afterwards.
* #2105: Filter ``2to3`` deprecation warnings from ``TestDevelop.test_2to3_user_mode``.


v46.2.0
-------

* #2040: Deprecated the ``bdist_wininst`` command. Binary packages should be built as wheels instead.
* #2062: Change 'Mac OS X' to 'macOS' in code.
* #2075: Stop recognizing files ending with ``.dist-info`` as distribution metadata.
* #2086: Deprecate 'use_2to3' functionality. Packagers are encouraged to use single-source solutions or build tool chains to manage conversions outside of setuptools.
* #1698: Added documentation for ``build_meta`` (a bare minimum, not completed).
* #2082: Filter ``lib2to3`` ``PendingDeprecationWarning`` and ``DeprecationWarning`` in tests,
  because ``lib2to3`` is `deprecated in Python 3.9 <https://bugs.python.org/issue40360>`_.


v46.1.3
-------

No significant changes.


v46.1.2
-------

* #1458: Added template for reporting Python 2 incompatibilities.


v46.1.1
-------

No significant changes.


v46.1.0
-------

* #308: Allow version number normalization to be bypassed by wrapping in a 'setuptools.sic()' call.
* #1424: Prevent keeping files mode for package_data build. It may break a build if user's package data has read only flag.
* #1431: In ``easy_install.check_site_dir``, ensure the installation directory exists.
* #1563: In ``pkg_resources`` prefer ``find_spec`` (PEP 451) to ``find_module``.

Incorporate changes from v44.1.0:

* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2
* #1994: Fixed a bug in the "setuptools.finalize_distribution_options" hook that lead to ignoring the order attribute of entry points managed by this hook.


v44.1.0
-------

* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2
* #1994: Fixed a bug in the "setuptools.finalize_distribution_options" hook that lead to ignoring the order attribute of entry points managed by this hook.


v46.0.0
-------

* #65: Once again as in 3.0, removed the Features feature.
* #1890: Fix vendored dependencies so importing ``setuptools.extern.some_module`` gives the same object as ``setuptools._vendor.some_module``. This makes Metadata picklable again.
* #1899: Test suite now fails on warnings.
* #2011: Fix broken link to distutils docs on package_data
* #1991: Include pkg_resources test data in sdist, so tests can be executed from it.


v45.3.0
-------

* #1557: Deprecated eggsecutable scripts and updated docs.
* #1904: Update msvc.py to use CPython 3.8.0 mechanism to find msvc 14+


v45.2.0
-------

* #1905: Fixed defect in _imp, introduced in 41.6.0 when the 'tests' directory is not present.
* #1941: Improve editable installs with PEP 518 build isolation:

  * The ``--user`` option is now always available. A warning is issued if the user site directory is not available.
  * The error shown when the install directory is not in ``PYTHONPATH`` has been turned into a warning.
* #1981: Setuptools now declares its ``tests`` and ``docs`` dependencies in metadata (extras).
* #1985: Add support for installing scripts in environments where bdist_wininst is missing (i.e. Python 3.9).
* #1968: Add flake8-2020 to check for misuse of sys.version or sys.version_info.


v45.1.0
-------

* #1458: Add minimum sunset date and preamble to Python 2 warning.
* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1974: Add Python 3 Only Trove Classifier and remove universal wheel declaration for more complete transition from Python 2.


v45.0.0
-------

* #1458: Drop support for Python 2. Setuptools now requires Python 3.5 or later. Install setuptools using pip >=9 or pin to Setuptools <45 to maintain 2.7 support.
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2

Revision 1.155 / (download) - annotate - [select for diffs], Mon Jun 1 20:31:03 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.154: +5 -5 lines
Diff to previous 1.154 (colored)

py-setuptools: updated to 44.1.1

v44.1.1
Avoid loading working set during Distribution.finalize_options prior to invoking _install_setup_requires, broken since v42.0.0.

Revision 1.154 / (download) - annotate - [select for diffs], Fri May 15 08:27:54 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.153: +5 -5 lines
Diff to previous 1.153 (colored)

py-setuptools: updated to 44.1.0

v44.1.0
* Set sys.argv[0] in setup script run by build_meta.__legacy__
* Fix for Python 4: replace unsafe six.PY3 with six.PY2
* Fixed a bug in the "setuptools.finalize_distribution_options" hook that lead to ignoring the order attribute of entry points managed by this hook.

Revision 1.153 / (download) - annotate - [select for diffs], Wed Jan 8 17:32:25 2020 UTC (3 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.152: +5 -5 lines
Diff to previous 1.152 (colored)

py-setuptools: update to 44.0.0.

v44.0.0
-------

* #1908: Drop support for Python 3.4.


v43.0.0
-------

* #1634: Include ``pyproject.toml`` in source distribution by
default. Projects relying on the previous behavior where
``pyproject.toml`` was excluded by default should stop relying on
that behavior or add ``exclude pyproject.toml`` to their MANIFEST.in
file.
* #1927: Setuptools once again declares 'setuptools' in the
``build-system.requires`` and adds PEP 517 build support by declaring
itself as the ``build-backend``. It additionally specifies
``build-system.backend-path`` to rely on itself for those builders
that support it.

Revision 1.152 / (download) - annotate - [select for diffs], Wed Dec 11 14:19:35 2019 UTC (3 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.151: +5 -5 lines
Diff to previous 1.151 (colored)

py-setuptools: updated to 42.0.2

v42.0.2
Fix support for easy_install's find-links option in setup.cfg.
Build dependencies (setup_requires and tests_require) now install transitive dependencies indicated by extras.

Revision 1.151 / (download) - annotate - [select for diffs], Tue Nov 26 12:41:36 2019 UTC (3 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.150: +5 -5 lines
Diff to previous 1.150 (colored)

py-setuptools: update to 42.0.1.

v42.0.1
-------

* #1918: Fix regression in handling wheels compatibility tags.


v42.0.0
-------

* #1830, #1909: Mark the easy_install script and setuptools command as deprecated, and use `pip <https://pip.pypa.io/en/stable/>`_ when available to fetch/build wheels for missing ``setup_requires``/``tests_require`` requirements, with the following differences in behavior:
   * support for ``python_requires``
   * better support for wheels (proper handling of priority with respect to PEP 425 tags)
   * PEP 517/518 support
   * eggs are not supported
   * no support for the ``allow_hosts`` easy_install option (``index_url``/``find_links`` are still honored)
   * pip environment variables are honored (and take precedence over easy_install options)
* #1898: Removed the "upload" and "register" commands in favor of `twine <https://pypi.org/p/twine>`_.
* #1767: Add support for the ``license_files`` option in ``setup.cfg`` to automatically
  include multiple license files in a source distribution.
* #1829: Update handling of wheels compatibility tags:
  * add support for manylinux2010
  * fix use of removed 'm' ABI flag in Python 3.8 on Windows
* #1861: Fix empty namespace package installation from wheel.
* #1877: Setuptools now exposes a new entry point hook "setuptools.finalize_distribution_options", enabling plugins like `setuptools_scm <https://pypi.org/project/setuptools_scm>`_ to configure options on the distribution at finalization time.

Revision 1.150 / (download) - annotate - [select for diffs], Tue Oct 29 15:15:40 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.149: +5 -5 lines
Diff to previous 1.149 (colored)

py-setuptools: updated to 41.6.0

v41.6.0
* Replace usage of deprecated imp module with local re-implementation in setuptools._imp.

v41.5.1
* Fix code for detecting Visual Studio's version on Windows under Python 2.

v41.5.0
* Improve Visual C++ 14.X support, mainly for Visual Studio 2017 and 2019.
* Fix pkg_resources.Requirement hash/equality implementation: take PEP 508 direct URL into account.
* Fix tests when running under python3.10.
* Formally deprecated the test command, with the recommendation that users migrate to tox.
* Update documentation to mention the egg format is not supported by pip and dependency links support was dropped starting with pip 19.0.
* Drop ez_setup documentation: deprecated for some time (last updated in 2016), and still relying on easy_install (deprecated too).
* Drop most documentation references to (deprecated) EasyInstall.
* Added a trove classifier to document support for Python 3.8.
* Added Python 3.8 release to the Travis test matrix.

Revision 1.149 / (download) - annotate - [select for diffs], Wed Oct 16 07:21:46 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.148: +5 -5 lines
Diff to previous 1.148 (colored)

py-setuptools: updated to 41.4.0

v41.4.0
In declarative config, now traps errors when invalid python_requires values are supplied.

v41.3.0
When storing extras, rely on OrderedSet to retain order of extras as indicated by the packager, which will also be deterministic on Python 2.7 (with PYTHONHASHSEED unset) and Python 3.6+.
Fixed failing integration test triggered by 'long_description_content_type' in packaging.

Revision 1.148 / (download) - annotate - [select for diffs], Wed Sep 4 07:55:43 2019 UTC (4 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.147: +5 -5 lines
Diff to previous 1.147 (colored)

py-setuptools: updated to 41.2.0

v41.2.0
Remove some usage of the deprecated imp module.
Changed html_sidebars from string to list of string as per https://www.sphinx-doc.org/en/master/changes.html#id58

Revision 1.147 / (download) - annotate - [select for diffs], Sat Aug 17 10:22:39 2019 UTC (4 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.146: +5 -5 lines
Diff to previous 1.146 (colored)

py-setuptools: updated to 41.1.0

v41.1.0
* Moved most of the constants from setup.py to setup.cfg
* Fixed issue with the PEP 517 backend where building a source distribution would fail if any tarball existed in the destination directory.
* Fixed an issue with PEP 517 backend where wheel builds would fail if the destination directory did not already exist.
* Forse metadata-version >= 1.2. when project urls are present.
* Improve package_data check: ensure the dictionary values are lists/tuples of strings.
* Changed compatibility fallback logic for html.unescape to avoid accessing HTMLParser.unescape when not necessary. HTMLParser.unescape is deprecated and will be removed in Python 3.9.
* Added the file path to the error message when a UnicodeDecodeError occurs while reading a metadata file.
* Use license classifiers rather than the license field.

Revision 1.146 / (download) - annotate - [select for diffs], Tue Apr 23 09:39:13 2019 UTC (4 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.145: +5 -5 lines
Diff to previous 1.145 (colored)

py-setuptools: updated to 41.0.1

v41.0.1
* Fixed issue with the PEP 517 backend that prevented building a wheel when the dist/ directory contained existing .whl files.
* In test.paths_on_python_path, avoid adding unnecessary duplicates to the PYTHONPATH.
* In package_index, now honor "current directory" during a checkout of git and hg repositories under Windows

Revision 1.145 / (download) - annotate - [select for diffs], Fri Apr 12 13:13:44 2019 UTC (4 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.144: +5 -5 lines
Diff to previous 1.144 (colored)

py-setuptools: update to 41.0.0.

v41.0.0
-------

* #1735: When parsing setup.cfg files, setuptools now requires the files to be encoded as UTF-8. Any other encoding will lead to a UnicodeDecodeError. This change removes support for specifying an encoding using a 'coding: ' directive in the header of the file, a feature that was introduces in 40.7. Given the recent release of the aforementioned feature, it is assumed that few if any projects are utilizing the feature to specify an encoding other than UTF-8.

Revision 1.144 / (download) - annotate - [select for diffs], Thu Apr 4 07:19:26 2019 UTC (4 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.143: +5 -5 lines
Diff to previous 1.143 (colored)

py-setuptools: updated to 40.9.0

v40.9.0
* Added support for setup.cfg-only projects when using the setuptools.build_meta backend. Projects that have enabled PEP 517 no longer need to have a setup.py and can use the purely declarative setup.cfg configuration file instead.
* Added support for pkg_resources.parse_requirements-style requirements in setup_requires when setup.py is invoked from the setuptools.build_meta build backend.
* Added the path to the PKG-INFO or METADATA file in the exception text when the Version: header can't be found.
* Removed some placeholder documentation sections referring to deprecated features.

Revision 1.143 / (download) - annotate - [select for diffs], Sat Feb 9 17:11:49 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.142: +5 -5 lines
Diff to previous 1.142 (colored)

py-setuptools: updated to 40.8.0

v40.8.0
* Added the build_meta:__legacy__ backend, a "compatibility mode" PEP 517 backend that can be used as the default when build-backend is left unspecified in pyproject.toml.
* Resource paths are passed to pkg_resources.resource_string and similar no longer accept paths that traverse parents, that begin with a leading /. Violations of this expectation raise DeprecationWarnings and will become errors. Additionally, any paths that are absolute on Windows are strictly disallowed and will raise ValueErrors.
* setuptools will now automatically include licenses if setup.cfg contains a license_file attribute, unless this file is manually excluded inside MANIFEST.in.

v40.7.3
* In package_index, revert to using a copy of splituser from Python 3.8.

Revision 1.142 / (download) - annotate - [select for diffs], Fri Feb 1 09:17:46 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.141: +5 -5 lines
Diff to previous 1.141 (colored)

py-setuptools: updated to 40.7.2

v40.7.2:
Restore port in URL handling in package_index.

Revision 1.141 / (download) - annotate - [select for diffs], Tue Jan 29 06:42:33 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.140: +5 -5 lines
Diff to previous 1.140 (colored)

py-setuptools: updated to 40.7.1

v40.7.1
On Python 2, when reading config files, downcast options from text to bytes to satisfy distutils expectations.

Revision 1.140 / (download) - annotate - [select for diffs], Mon Jan 28 08:38:09 2019 UTC (4 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.139: +5 -5 lines
Diff to previous 1.139 (colored)

py-setuptools: updated to 40.7.0

v40.7.0
* File inputs for the license field in setup.cfg files now explicitly raise an error.
* Add support for non-ASCII in setup.cfg. Add support for native strings on some parameters.
* setuptools.package_index no longer relies on the deprecated urllib.parse.splituser per Python.
* Added tests for PackageIndex.download (for git URLs).
* In PEP 517 build_meta builder, ensure that sdists are built as gztar per the spec.

Revision 1.139 / (download) - annotate - [select for diffs], Thu Dec 13 07:05:46 2018 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.138: +5 -5 lines
Diff to previous 1.138 (colored)

py-setuptools: updated to 40.6.3

v40.6.3
* PEP 517 backend no longer declares setuptools as a dependency as it can be assumed.

Revision 1.138 / (download) - annotate - [select for diffs], Tue Nov 13 16:03:58 2018 UTC (4 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.137: +5 -5 lines
Diff to previous 1.137 (colored)

py-setuptools: updated to 40.6.2

v40.6.2:
* Fix invalid dependency on external six module (instead of vendored version).

Revision 1.137 / (download) - annotate - [select for diffs], Tue Nov 13 09:04:37 2018 UTC (4 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.136: +5 -5 lines
Diff to previous 1.136 (colored)

py-setuptools: updated to 40.6.1

v40.6.1
* Fixed regression where packages without author or author_email fields generated malformed package metadata.

v40.6.0
* Officially deprecated the requires parameter in setup().
* In pkg_resources.normalize_path, additional path normalization is now performed to ensure path values to a directory is always the same, preventing false positives when checking scripts have a consistent prefix to set up on Windows.
* Changed the warning class of all deprecation warnings; deprecation warning classes are no longer derived from DeprecationWarning and are thus visible by default.
* build_meta.build_sdist now includes setup.py in source distributions by default.
* Started monkey-patching get_metadata_version and read_pkg_file onto distutils.DistributionMetadata to retain the correct version on the PKG-INFO file in the (deprecated) upload command.
* Restricted the recursive-include setuptools/_vendor to contain only .py and .txt files.
* Changed Pyrex references to Cython in the documentation.
* Documented that the rpmbuild packages is required for the bdist_rpm command.
* Documented how to use setup.cfg for src/ layouts
* Added minimum version column in setup.cfg metadata table.
* Fixed a minor typo in the python 2/3 compatibility documentation.
* Updated installation instructions to point to pip install instead of ez_setup.py.
* Updated setuptools distribution documentation to remove some outdated information.
* Documented setup.cfg minimum version for version and project_urls.
* Added the concurrent.futures backport futures to the Python 2.7 test suite requirements.

Revision 1.136 / (download) - annotate - [select for diffs], Mon Oct 29 17:56:44 2018 UTC (4 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.135: +5 -5 lines
Diff to previous 1.135 (colored)

py-setuptools: updated to 40.5.0

v40.5.0
* In pkg_resources.normalize_path, fix issue on Cygwin when cwd contains symlinks.
* Deprecated support for downloads from Subversion in package_index/easy_install.
* Dropped use of six.u in favor of u"" literals.
* Added support for data_files in setup.cfg.
* Fixed rendering of the deprecation warning in easy_install doc.

Revision 1.135 / (download) - annotate - [select for diffs], Mon Sep 24 08:05:23 2018 UTC (5 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.134: +5 -5 lines
Diff to previous 1.134 (colored)

py-setuptools: updated to 40.4.3

v40.4.3
Bump vendored pyparsing in pkg_resources to 2.2.1.

v40.4.2
Updated gitignore in repo.

Revision 1.134 / (download) - annotate - [select for diffs], Wed Sep 19 11:33:34 2018 UTC (5 years ago) by adam
Branch: MAIN
Changes since 1.133: +5 -5 lines
Diff to previous 1.133 (colored)

py-setuptools: updated to 40.4.1

v40.4.1:
* Bump vendored pyparsing to 2.2.1.

v40.4.0:
* Join the sdist --dist-dir and the build_meta sdist directory argument to point to the same target (meaning the build frontend no longer needs to clean manually the dist dir to avoid multiple sdist presence, and setuptools no longer needs to handle conflicts between the two).

v40.3.0:
* Fixed a bug with namespace packages under Python 3.6 when one package in current directory hides another which is installed.
* Set timestamp of .egg-info directory whenever egg_info command is run.
* build_meta.get_requires_for_build_sdist now does not include the wheel package anymore.
* Suppress warnings in pkg_resources.handle_ns.
* Remove internal use of six.binary_type.

Revision 1.133 / (download) - annotate - [select for diffs], Sat Aug 25 17:22:41 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.132: +5 -5 lines
Diff to previous 1.132 (colored)

py-setuptools: updated to 40.2.0

v40.2.0
Fix handling of Unicode arguments in PEP 517 backend

vv40.1.1
Fix regression with egg_info command when tagging is used.

Revision 1.132 / (download) - annotate - [select for diffs], Sun Aug 19 08:06:54 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.131: +5 -5 lines
Diff to previous 1.131 (colored)

py-setuptools: updated to 40.1.0

v40.1.0
* Deprecated upload and register commands.
* Introduced find_namespace_packages() to find PEP 420 namespace packages.
* Added find_namespace: directive to config parser.
* Solved race in when creating egg cache directories.
* Upgraded vendored PyParsing from 2.1.10 to 2.2.0.
* Upgraded vendored appdirs from 1.4.0 to 1.4.3.
* Fixed "Microsoft Visual C++ Build Tools" link in exception when Visual C++ not found.
* Added support for scripts which have unicode content.
* Moved several Python version checks over to using six.PY2 and six.PY3.
* Removed spurious executable permissions from files that don't need them.

Revision 1.131 / (download) - annotate - [select for diffs], Tue Aug 7 09:55:29 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.130: +5 -5 lines
Diff to previous 1.130 (colored)

py-setuptools: updated to 40.0.0

v40.0.0
Drop support for Python 3.3.
In package_index, fixed handling of encoded entities in URLs.
In pkg_resources VendorImporter, avoid removing packages imported from the root.
Minor doc fixes after actually using the new release process.
Removed section on non-package data files.
Fix developer's guide.
Fix PEP 518 configuration: set build requirements in pyproject.toml to ["wheel"].

Revision 1.130 / (download) - annotate - [select for diffs], Sun May 27 12:27:05 2018 UTC (5 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2
Changes since 1.129: +5 -5 lines
Diff to previous 1.129 (colored)

py-setuptools: update to 39.2.0.

v39.2.0
-------

* #1359: Support using "file:" to load a PEP 440-compliant package version from
  a text file.
* #1360: Fixed issue with a mismatch between the name of the package and the
  name of the .dist-info file in wheel files
* #1365: Take the package_dir option into account when loading the version from
  a module attribute.
* #1353: Added coverage badge to README.
* #1356: Made small fixes to the developer guide documentation.
* #1357: Fixed warnings in documentation builds and started enforcing that the
  docs build without warnings in tox.
* #1376: Updated release process docs.
* #1343: The ``setuptools`` specific ``long_description_content_type``,
  ``project_urls`` and ``provides_extras`` fields are now set consistently
  after any ``distutils`` ``setup_keywords`` calls, allowing them to override
  values.
* #1352: Added ``tox`` environment for documentation builds.
* #1354: Added ``towncrier`` for changelog managment.
* #1355: Add PR template.
* #1368: Fixed tests which failed without network connectivity.
* #1369: Added unit tests for PEP 425 compatibility tags support.
* #1372: Stop testing Python 3.3 in Travis CI, now that the latest version of
  ``wheel`` no longer installs on it.

Revision 1.129 / (download) - annotate - [select for diffs], Sun Apr 29 10:09:22 2018 UTC (5 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.128: +5 -5 lines
Diff to previous 1.128 (colored)

py-setuptools: update to 39.1.0.

v39.1.0
-------

* #1340: Update all PyPI URLs to reflect the switch to the
  new Warehouse codebase.
* #1337: In ``pkg_resources``, now support loading resources
  for modules loaded by the ``SourcelessFileLoader``.
* #1332: Silence spurious wheel related warnings on Windows.

Revision 1.128 / (download) - annotate - [select for diffs], Sat Mar 24 07:49:33 2018 UTC (5 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.127: +5 -5 lines
Diff to previous 1.127 (colored)

py-setuptools: updated to 39.0.1

v39.0.1
Restore Unicode handling for Maintainer fields in metadata.

v39.0.0:
Setuptools now vendors its own direct dependencies, no longer relying on the dependencies as vendored by pkg_resources.
Removed long-deprecated support for iteration on Version objects as returned by pkg_resources.parse_version. Removed the SetuptoolsVersion and SetuptoolsLegacyVersion names as well. They should not have been used, but if they were, replace with Version and LegacyVersion from packaging.version.

v38.7.0:
Add support for maintainer in PKG-INFO.

Revision 1.127 / (download) - annotate - [select for diffs], Sat Mar 17 06:51:00 2018 UTC (5 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.126: +5 -5 lines
Diff to previous 1.126 (colored)

py-setuptools: updated to 38.6.0

38.6.0:
Add support for Metadata 2.1 (PEP 566).

Revision 1.126 / (download) - annotate - [select for diffs], Sun Mar 11 19:42:33 2018 UTC (5 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.125: +5 -5 lines
Diff to previous 1.125 (colored)

py-setuptools: update to 38.5.2.

v38.5.2
-------

* #1285: Fixed RuntimeError in pkg_resources.parse_requirements
  on Python 3.7 (stemming from PEP 479).

Revision 1.125 / (download) - annotate - [select for diffs], Sun Feb 11 18:47:58 2018 UTC (5 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.124: +5 -5 lines
Diff to previous 1.124 (colored)

py-setuptools: update to 38.5.1.

v38.5.1
-------

* #1271: Revert to Cython legacy ``build_ext`` behavior for
  compatibility.

v38.5.0
-------

* #1229: Expand imports in ``build_ext`` to refine detection of
  Cython availability.

* #1270: When Cython is available, ``build_ext`` now uses the
  new_build_ext.

Revision 1.124 / (download) - annotate - [select for diffs], Wed Jan 10 23:09:57 2018 UTC (5 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.123: +5 -5 lines
Diff to previous 1.123 (colored)

py-setuptools: update to 38.4.0.

v38.4.0
-------

* #1231: Removed warning when PYTHONDONTWRITEBYTECODE is enabled.

v38.3.0
-------

* #1210: Add support for PEP 345 Project-URL metadata.
* #1207: Add support for ``long_description_type`` to setup.cfg
  declarative config as intended and documented.

Revision 1.123 / (download) - annotate - [select for diffs], Sat Dec 30 09:48:54 2017 UTC (5 years, 9 months ago) by adam
Branch: MAIN
Changes since 1.122: +5 -5 lines
Diff to previous 1.122 (colored)

py-setuptools: updated to 38.2.5

v38.2.5
Fix trailing slash handling in pkg_resources.ZipProvider.

Revision 1.122 / (download) - annotate - [select for diffs], Sun Dec 10 14:04:44 2017 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.121: +5 -5 lines
Diff to previous 1.121 (colored)

py-setuptools: updated to 38.2.4

v38.2.4:
Fix data_files handling when installing from wheel.

Revision 1.121 / (download) - annotate - [select for diffs], Thu Nov 30 07:52:55 2017 UTC (5 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.120: +5 -5 lines
Diff to previous 1.120 (colored)

py-setuptools: updated to 38.2.3

v38.2.2
fix handling of namespace packages when installing from a wheel.

v38.2.1
fix encoding handling of metadata when installing from a wheel.

v38.2.0
easy_install now support installing from wheels: they will be installed as standalone unzipped eggs.

Revision 1.120 / (download) - annotate - [select for diffs], Tue Nov 28 14:09:09 2017 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.119: +5 -5 lines
Diff to previous 1.119 (colored)

py-setuptools: update to 38.1.0.

v38.1.0
-------

* #1208: Improve error message when failing to locate scripts
  in egg-info metadata.

v38.0.0
-------

* #458: In order to support deterministic builds, Setuptools no
  longer allows packages to declare ``install_requires`` as
  unordered sequences (sets or dicts).

v37.0.0
-------

* #878: Drop support for Python 2.6. Python 2.6 users should
  rely on 'setuptools < 37dev'.

v36.8.0
-------

* #1190: In SSL support for package index operations, use SNI
  where available.

v36.7.3
-------

* #1175: Bug fixes to ``build_meta`` module.

Revision 1.119 / (download) - annotate - [select for diffs], Thu Nov 23 22:41:55 2017 UTC (5 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.118: +5 -5 lines
Diff to previous 1.118 (colored)

py-setuptools: update to 36.7.2.

v36.7.2
-------

* #701: Fixed duplicate test discovery on Python 3.

v36.7.1
-------

* #1193: Avoid test failures in bdist_egg when
  PYTHONDONTWRITEBYTECODE is set.

v36.7.0
-------

* #1054: Support ``setup_requires`` in ``setup.cfg`` files.

v36.6.1
-------

* #1132: Removed redundant and costly serialization/parsing step
  in ``EntryPoint.__init__``.

* #844: ``bdist_egg --exclude-source-files`` now tested and works
  on Python 3.

Revision 1.118 / (download) - annotate - [select for diffs], Mon Oct 16 17:20:38 2017 UTC (5 years, 11 months ago) by adam
Branch: MAIN
Changes since 1.117: +5 -5 lines
Diff to previous 1.117 (colored)

py-setuptools: update to 36.6.0

v36.6.0:
* Added setuptools.build_meta module, an implementation of PEP-517 for Setuptools-defined packages.
* Added dist_info command for producing dist_info metadata.

Revision 1.117 / (download) - annotate - [select for diffs], Sun Sep 17 09:55:59 2017 UTC (6 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.116: +5 -5 lines
Diff to previous 1.116 (colored)

devel/py-setuptools: update to 36.5.0

v36.5.0
* 170: When working with Mercurial checkouts, use Windows-friendly syntax for suppressing output.
* Inspired by 1134, performed substantial refactoring of pkg_resources.find_on_path to facilitate an optimization for paths with many non-version entries.

Revision 1.116 / (download) - annotate - [select for diffs], Mon Sep 4 17:27:13 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
Changes since 1.115: +5 -5 lines
Diff to previous 1.115 (colored)

v36.4.0

* 1075: Add new ``Description-Content-Type`` metadata field. `See here for
  documentation on how to use this field.

* 1068: Sort files and directories when building eggs for
  deterministic order.

* 196: Remove caching of easy_install command in fetch_build_egg.
  Fixes issue where ``pytest-runner-N.N`` would satisfy the installation
  of ``pytest``.

* 1129: Fix working set dependencies handling when replacing conflicting
  distributions (e.g. when using ``setup_requires`` with a conflicting
  transitive dependency, fix 1124).

* 1133: Improved handling of README files extensions and added
  Markdown to the list of searched READMES.

* 1135: Improve performance of pkg_resources import by not invoking
  ``access`` or ``stat`` and using ``os.listdir`` instead.

Revision 1.115 / (download) - annotate - [select for diffs], Mon Sep 4 14:46:23 2017 UTC (6 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.114: +5 -5 lines
Diff to previous 1.114 (colored)

Updated py-setuptools to 36.3.0.

v36.3.0
-------

* #1131: Make possible using several files within ``file:`` directive
  in metadata.long_description in ``setup.cfg``.

Revision 1.114 / (download) - annotate - [select for diffs], Thu Aug 3 07:19:56 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.113: +5 -5 lines
Diff to previous 1.113 (colored)

v36.2.7
Fix handling of requirements with environment markers when declared in setup.cfg.

v36.2.6
Don't assume a directory is an egg by the .egg extension alone.

v36.2.5
Fix test command handler with extras_require.
Now using Trusty containers in Travis for CI and CD.

Revision 1.113 / (download) - annotate - [select for diffs], Sun Jul 30 05:27:30 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.112: +5 -5 lines
Diff to previous 1.112 (colored)

v36.2.4
* ``pkg_resources`` now uses ``inspect.getmro`` to
  resolve classes in method resolution order

Revision 1.112 / (download) - annotate - [select for diffs], Wed Jul 26 16:34:40 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.111: +5 -5 lines
Diff to previous 1.111 (colored)

v36.2.3
Restore behavior for empty extras.

Revision 1.111 / (download) - annotate - [select for diffs], Tue Jul 25 08:11:17 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.110: +5 -5 lines
Diff to previous 1.110 (colored)

v36.2.2
* Revert commit a3ec721, restoring intended purpose of extras as part of a requirement declaration.

v36.2.1
* fix 1086
* fix 1087
* support extras specifiers in install_requires requirements

Revision 1.110 / (download) - annotate - [select for diffs], Tue Jul 18 13:44:36 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.109: +5 -5 lines
Diff to previous 1.109 (colored)

v36.2.0

* 1081: Environment markers indicated in ``install_requires``
  are now processed and treated as nameless ``extras_require``
  with markers, allowing their metadata in requires.txt to be
  correctly generated.

* 1053: Tagged commits are now released using Travis-CI
  build stages, meaning releases depend on passing tests on
  all supported Python versions (Linux) and not just the latest
  Python version.

Revision 1.109 / (download) - annotate - [select for diffs], Thu Jun 1 13:30:03 2017 UTC (6 years, 4 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.108: +5 -5 lines
Diff to previous 1.108 (colored)

Updated py-setuptools to 36.0.1.

v36.0.1
-------

* #1042: Fix import in py27compat module that still
  referenced six directly, rather than through the externs
  module (vendored packages hook).

v36.0.0
-------

* #980 and others: Once again, Setuptools vendors all
  of its dependencies. It seems to be the case that in
  the Python ecosystem, all build tools must run without
  any dependencies (build, runtime, or otherwise). At
  such a point that a mechanism exists that allows
  build tools to have dependencies, Setuptools will adopt
  it.

Revision 1.108 / (download) - annotate - [select for diffs], Tue May 2 10:57:16 2017 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.107: +5 -5 lines
Diff to previous 1.107 (colored)

Updated py-setuptools to 35.0.2.

v35.0.2
-------

* #1015: Fix test failures on Python 3.7.

* #1024: Add workaround for Jython #2581 in monkey module.

Revision 1.107 / (download) - annotate - [select for diffs], Sat Apr 22 23:43:20 2017 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.106: +5 -5 lines
Diff to previous 1.106 (colored)

Updated py-setuptools to 35.0.1.

v35.0.1

    #992: Revert change introduced in v34.4.1, now considered invalid.
    #1016: Revert change introduced in v35.0.0 per #1014, referencing #436. The approach had unintended consequences, causing sdist installs to be missing files.

Revision 1.106 / (download) - annotate - [select for diffs], Wed Apr 19 17:29:28 2017 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.105: +5 -5 lines
Diff to previous 1.105 (colored)

Updated py-setuptools to 35.0.0.

v35.0.0
-------

* #436: In egg_info.manifest_maker, no longer read
  the file list from the manifest file, and instead
  re-build it on each build. In this way, files removed
  from the specification will not linger in the manifest.
  As a result, any files manually added to the manifest
  will be removed on subsequent egg_info invocations.
  No projects should be manually adding files to the
  manifest and should instead use MANIFEST.in or SCM
  file finders to force inclusion of files in the manifest.

v34.4.1
-------

* #1008: In MSVC support, use always the last version available for Windows SDK and UCRT SDK.

* #1008: In MSVC support, fix "vcruntime140.dll" returned path with Visual Studio 2017.

* #992: In msvc.msvc9_query_vcvarsall, ensure the
  returned dicts have str values and not Unicode for
  compatibilty with os.environ.

v34.4.0
-------

* #995: In MSVC support, add support for "Microsoft Visual Studio 2017" and "Microsoft Visual Studio Build Tools 2017".

* #999 via #1007: Extend support for declarative package
  config in a setup.cfg file to include the options
  ``python_requires`` and ``py_modules``.

Revision 1.105 / (download) - annotate - [select for diffs], Wed Apr 5 15:56:30 2017 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.104: +5 -5 lines
Diff to previous 1.104 (colored)

Updated py-setuptools to 34.3.3.

v34.3.3
-------

* #967 (and #997): Explicitly import submodules of
  packaging to account for environments where the imports
  of those submodules is not implied by other behavior.

Revision 1.104 / (download) - annotate - [select for diffs], Mon Mar 13 10:18:37 2017 UTC (6 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.103: +5 -5 lines
Diff to previous 1.103 (colored)

Updated py-setuptools to 34.3.2.

v34.3.2
-------

* #993: Fix documentation upload by correcting
  rendering of content-type in _build_multipart
  on Python 3.

Revision 1.103 / (download) - annotate - [select for diffs], Sun Mar 5 14:29:27 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.102: +5 -5 lines
Diff to previous 1.102 (colored)

Updated py-setuptools to 34.3.1.

v34.3.1
-------

* #988: Trap ``os.unlink`` same as ``os.remove`` in
  ``auto_chmod`` error handler.

* #983: Fixes to invalid escape sequence deprecations on
  Python 3.6.

Revision 1.102 / (download) - annotate - [select for diffs], Mon Feb 27 10:42:34 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.101: +5 -5 lines
Diff to previous 1.101 (colored)

Updated py-setuptools to 34.3.0.

Fix test target.
4 tests failing, three due to pip not existing (we have pip3.6 et al.),
one because of ASCII locale.

v34.3.0
-------

* #941: In the upload command, if the username is blank,
  default to ``getpass.getuser()``.

* #971: Correct distutils findall monkeypatch to match
  appropriate versions (namely Python 3.4.6).

Revision 1.101 / (download) - annotate - [select for diffs], Mon Feb 20 10:04:09 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.100: +5 -5 lines
Diff to previous 1.100 (colored)

Updated py-setuptools to 34.2.0.

v34.2.0
-------

* #966: Add support for reading dist-info metadata and
  thus locating Distributions from zip files.

* #968: Allow '+' and '!' in egg fragments
  so that it can take package names that contain
  PEP 440 conforming version specifiers.

Revision 1.100 / (download) - annotate - [select for diffs], Wed Feb 8 12:11:22 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.99: +5 -5 lines
Diff to previous 1.99 (colored)

Updated py-setuptools to 34.1.1.

v34.1.1
-------

* #953: More aggressively employ the compatibility issue
  originally added in #706.

v34.1.0
-------

* #930: ``build_info`` now accepts two new parameters
  to optimize and customize the building of C libraries.

v34.0.3
-------

* #947: Loosen restriction on the version of six required,
  restoring compatibility with environments relying on
  six 1.6.0 and later.

v34.0.2
-------

* #882: Ensure extras are honored when building the
  working set.
* #913: Fix issue in develop if package directory has
  a trailing slash.

v34.0.1
-------

* #935: Fix glob syntax in graft.

v34.0.0
-------

* #581: Instead of vendoring the growing list of
  dependencies that Setuptools requires to function,
  Setuptools now requires these dependencies just like
  any other project. Unlike other projects, however,
  Setuptools cannot rely on ``setup_requires`` to
  demand the dependencies it needs to install because
  its own machinery would be necessary to pull those
  dependencies if not present (a bootstrapping problem).
  As a result, Setuptools no longer supports self upgrade or
  installation in the general case. Instead, users are
  directed to use pip to install and upgrade using the
  ``wheel`` distributions of setuptools.

  Users are welcome to contrive other means to install
  or upgrade Setuptools using other means, such as
  pre-installing the Setuptools dependencies with pip
  or a bespoke bootstrap tool, but such usage is not
  recommended and is not supported.

  As discovered in #940, not all versions of pip will
  successfully install Setuptools from its pre-built
  wheel. If you encounter issues with "No module named
  six" or "No module named packaging", especially
  following a line "Running setup.py egg_info for package
  setuptools", then your pip is not new enough.

  There's an additional issue in pip where setuptools
  is upgraded concurrently with other source packages,
  described in pip #4253. The proposed workaround is to
  always upgrade Setuptools first prior to upgrading
  other packages that would upgrade Setuptools.

Revision 1.99 / (download) - annotate - [select for diffs], Thu Jan 26 18:09:19 2017 UTC (6 years, 8 months ago) by adam
Branch: MAIN
Changes since 1.98: +6 -6 lines
Diff to previous 1.98 (colored)

v33.1.1
-------
* 921: Correct issue where certifi fallback not being
  reached on Windows.

v33.1.0
-------
Installation via pip, as indicated in the `Python Packaging
User's Guide <https://packaging.python.org/installing/>`_,
is the officially-supported mechanism for installing
Setuptools, and this recommendation is now explicit in the
much more concise README.

Other edits and tweaks were made to the documentation. The
codebase is unchanged.

v33.0.0
-------
* 619: Removed support for the ``tag_svn_revision``
  distribution option. If Subversion tagging support is
  still desired, consider adding the functionality to
  setuptools_svn in setuptools_svn 2.

Revision 1.98 / (download) - annotate - [select for diffs], Mon Dec 19 09:02:59 2016 UTC (6 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.97: +5 -5 lines
Diff to previous 1.97 (colored)

Updated py-setuptools to 32.1.0.

v32.1.0
-------

* #891: In 'test' command on test failure, raise DistutilsError,
  suppression invocation of subsequent commands.

v32.0.0
-------

* #890: Revert #849. ``global-exclude .foo`` will not match all
  ``*.foo`` files any more. Package authors must add an explicit
  wildcard, such as ``global-exclude *.foo``, to match all
  ``.foo`` files. See #886, #849.

v31.0.1
-------

* #885: Fix regression where 'pkg_resources._rebuild_mod_path'
  would fail when a namespace package's '__path__' was not
  a list with a sort attribute.

v31.0.0
-------

* #250: Install '-nspkg.pth' files for packages installed
  with 'setup.py develop'. These .pth files allow
  namespace packages installed by pip or develop to
  co-mingle. This change required the removal of the
  change for #805 and pip #1924, introduced in 28.3.0 and implicated
  in #870, but means that namespace packages not in a
  site packages directory will no longer work on Python
  earlier than 3.5, whereas before they would work on
  Python not earlier than 3.3.

Revision 1.97 / (download) - annotate - [select for diffs], Mon Dec 12 14:58:18 2016 UTC (6 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.96: +5 -5 lines
Diff to previous 1.96 (colored)

Updated py-setuptools to 30.4.0.

v30.4.0
-------

* #879: For declarative config:
  - read_configuration() now accepts ignore_option_errors argument. This allows scraping tools to read metadata without a need to download entire packages. E.g. we can gather some stats right from GitHub repos just by downloading setup.cfg.
  - packages find: directive now supports fine tuning from a subsection. The same arguments as for find() are accepted.

v30.3.0
-------

* #394 via #862: Added support for `declarative package
  config in a setup.cfg file
  <http://setuptools.readthedocs.io/en/latest/setuptools.html#configuring-setup-using-setup-cfg-files>`_.

v30.2.1
-------

* #850: In test command, invoke unittest.main with
  indication not to exit the process.

v30.2.0
-------

* #854: Bump to vendored Packaging 16.8.

v30.1.0
-------

* #846: Also trap 'socket.error' when opening URLs in
  package_index.

* #849: Manifest processing now matches the filename
  pattern anywhere in the filename and not just at the
  start. Restores behavior found prior to 28.5.0.

v30.0.0
-------

* #864: Drop support for Python 3.2. Systems requiring
  Python 3.2 support must use 'setuptools < 30'.

* #825: Suppress warnings for single files.

* #830 via #843: Once again restored inclusion of data
  files to sdists, but now trap TypeError caused by
  techniques employed rjsmin and similar.

Revision 1.96 / (download) - annotate - [select for diffs], Mon Nov 28 13:57:16 2016 UTC (6 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.95: +5 -5 lines
Diff to previous 1.95 (colored)

Updated py-setuptools to 29.0.1.

v29.0.1
-------

* #861: Re-release of v29.0.1 with the executable script
  launchers bundled. Now, launchers are included by default
  and users that want to disable this behavior must set the
  environment variable
  'SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES' to
  a false value like "false" or "0".

v29.0.0
-------

* #841: Drop special exception for packages invoking
  win32com during the build/install process. See
  Distribute #118 for history.

Revision 1.95 / (download) - annotate - [select for diffs], Mon Nov 7 11:24:31 2016 UTC (6 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.94: +5 -5 lines
Diff to previous 1.94 (colored)

Updated py-setuptools to 28.8.0.

v28.8.0
-------

* #629: Per the discussion, refine the sorting to use version
  value order for more accurate detection of the latest
  available version when scanning for packages. See also
  #829.

* #837: Rely on the config var "SO" for Python 3.3.0 only
  when determining the ext filename.

Revision 1.94 / (download) - annotate - [select for diffs], Mon Oct 31 16:30:50 2016 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.93: +5 -5 lines
Diff to previous 1.93 (colored)

Updated py-setuptools to 28.7.1.

v28.7.1
-------

* #827: Update PyPI root for dependency links.

* #833: Backed out changes from #830 as the implementation
  seems to have problems in some cases.

Revision 1.93 / (download) - annotate - [select for diffs], Fri Oct 28 23:26:56 2016 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.92: +5 -5 lines
Diff to previous 1.92 (colored)

Updated py-setuptools to 28.7.0.

v28.7.0
-------

* #832: Moved much of the namespace package handling
  functionality into a separate module for re-use in something
  like #789.
* #830: ``sdist`` command no longer suppresses the inclusion
  of data files, re-aligning with the expectation of distutils
  and addressing #274 and #521.

v28.6.1
-------

* #816: Fix manifest file list order in tests.

Revision 1.92 / (download) - annotate - [select for diffs], Wed Oct 19 13:00:34 2016 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.91: +5 -5 lines
Diff to previous 1.91 (colored)

Updated py-setuptools to 28.6.0.

v28.6.0
-------

* #629: When scanning for packages, ``pkg_resources`` now
  ignores empty egg-info directories and gives precedence to
  packages whose versions are lexicographically greatest,
  a rough approximation for preferring the latest available
  version.

Revision 1.91 / (download) - annotate - [select for diffs], Tue Oct 18 08:33:28 2016 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.90: +5 -5 lines
Diff to previous 1.90 (colored)

Updated py-setuptools to 28.5.0.

v28.5.0
-------

* #810: Tests are now invoked with tox and not setup.py test.
* #249 and #450 via #764: Avoid scanning the whole tree
  when building the manifest.

v28.4.0
-------

* #732: Now extras with a hyphen are honored per PEP 426.
* #811: Update to pyparsing 2.1.10.
* Updated ``setuptools.command.sdist`` to re-use most of
  the functionality directly from ``distutils.command.sdist``
  for the ``add_defaults`` method with strategic overrides.
  See #750 for rationale.
* #760 via #762: Look for certificate bundle where SUSE
  Linux typically presents it. Use ``certifi.where()`` to locate
  the bundle.

Revision 1.90 / (download) - annotate - [select for diffs], Sun Oct 9 21:24:32 2016 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.89: +5 -5 lines
Diff to previous 1.89 (colored)

Updated py-setuptools to 28.3.0.

v28.3.0

    #809: In find_packages(), restore support for excluding a parent
    package without excluding a child package.
    #805: Disable -nspkg.pth behavior on Python 3.3+ where PEP-420
    functionality is adequate. Fixes pip #1924.

Revision 1.89 / (download) - annotate - [select for diffs], Mon Oct 3 12:19:31 2016 UTC (7 years ago) by wiz
Branch: MAIN
Changes since 1.88: +5 -5 lines
Diff to previous 1.88 (colored)

Updated py-setuptools to 28.1.0.

v28.1.0
-------

* #803: Bump certifi to 2016.9.26.

v28.0.0
-------

* #733: Do not search excluded directories for packages.
  This introduced a backwards incompatible change in ``find_packages()``
  so that ``find_packages(exclude=['foo']) == []``, excluding subpackages of ``foo``.
  Previously, ``find_packages(exclude=['foo']) == ['foo.bar']``,
  even though the parent ``foo`` package was excluded.

* #795: Bump certifi.

* #719: Suppress decoding errors and instead log a warning
  when metadata cannot be decoded.

v27.3.1
-------

* #790: In MSVC monkeypatching, explicitly patch each
  function by name in the target module instead of inferring
  the module from the function's ``__module__``. Improves
  compatibility with other packages that might have previously
  patched distutils functions (i.e. NumPy).

v27.3.0
-------

* #794: In test command, add installed eggs to PYTHONPATH
  when invoking tests so that subprocesses will also have the
  dependencies available. Fixes `tox 330
  <https://github.com/tox-dev/tox/issues/330>`_.

* #795: Update vendored pyparsing 2.1.9.

Revision 1.88 / (download) - annotate - [select for diffs], Sun Sep 18 22:10:44 2016 UTC (7 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.87: +5 -5 lines
Diff to previous 1.87 (colored)

Updated py-setuptools to 27.2.0.

v27.2.0
-------

* #520 and #513: Suppress ValueErrors in fixup_namespace_packages
  when lookup fails.

* Nicer, more consistent interfaces for msvc monkeypatching.

Revision 1.87 / (download) - annotate - [select for diffs], Mon Sep 12 08:07:09 2016 UTC (7 years ago) by wiz
Branch: MAIN
Changes since 1.86: +5 -5 lines
Diff to previous 1.86 (colored)

Updated py-setuptools to 27.1.2.

v27.1.2
-------

* #779 via #781: Fix circular import.

v27.1.1
-------

* #778: Fix MSVC monkeypatching.

v27.1.0
-------

* Introduce the (private) ``monkey`` module to encapsulate
  the distutils monkeypatching behavior.

v27.0.0
-------

* Now use Warehouse by default for
  ``upload``, patching ``distutils.config.PyPIRCCommand`` to
  affect default behavior.

  Any config in .pypirc should be updated to replace

    https://pypi.python.org/pypi/

  with

    https://upload.pypi.org/legacy/

  Similarly, any passwords stored in the keyring should be
  updated to use this new value for "system".

  The ``upload_docs`` command will continue to use the python.org
  site, but the command is now deprecated. Users are urged to use
  Read The Docs instead.

* #776: Use EXT_SUFFIX for py_limited_api renaming.

* #774 and #775: Use LegacyVersion from packaging when
  detecting numpy versions.

Revision 1.86 / (download) - annotate - [select for diffs], Thu Sep 1 16:59:21 2016 UTC (7 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.85: +5 -5 lines
Diff to previous 1.85 (colored)

Updated py-setuptools to 26.1.1.

v26.1.1
-------

* Re-release of 26.1.0 with pytest pinned to allow for automated
  deployement and thus proper packaging environment variables,
  fixing issues with missing executable launchers.

v26.1.0
-------

* #763: ``pkg_resources.get_default_cache`` now defers to the
  `appdirs project <https://pypi.org/project/appdirs>`_ to
  resolve the cache directory. Adds a vendored dependency on
  appdirs to pkg_resources.

Revision 1.85 / (download) - annotate - [select for diffs], Mon Aug 22 14:12:15 2016 UTC (7 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.84: +5 -5 lines
Diff to previous 1.84 (colored)

Updated py-setuptools to 26.0.0.

v26.0.0
-------

* #748: By default, sdists are now produced in gzipped tarfile
  format by default on all platforms, adding forward compatibility
  for the same behavior in Python 3.6 (See Python #27819).

* #459 via #736: On Windows with script launchers,
  sys.argv[0] now reflects
  the name of the entry point, consistent with the behavior in
  distlib and pip wrappers.

* #752 via #753: When indicating ``py_limited_api`` to Extension,
  it must be passed as a keyword argument.

v25.4.0
-------

* Add Extension(py_limited_api=True). When set to a truthy value,
  that extension gets a filename apropriate for code using Py_LIMITED_API.
  When used correctly this allows a single compiled extension to work on
  all future versions of CPython 3.
  The py_limited_api argument only controls the filename. To be
  compatible with multiple versions of Python 3, the C extension
  will also need to set -DPy_LIMITED_API=... and be modified to use
  only the functions in the limited API.

Revision 1.84 / (download) - annotate - [select for diffs], Fri Aug 19 15:33:49 2016 UTC (7 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.83: +5 -5 lines
Diff to previous 1.83 (colored)

Updated py-setuptools to 25.2.0.

v25.2.0
-------

* #612 via #730: Add a LICENSE file which needs to be provided by the terms of
  the MIT license.

v25.1.6
-------

* #725

v25.1.5
-------

* #720
* #723

v25.1.4
-------

* #717
* #713
* #707 via #715

v25.1.3
-------

* #714 and #704: Revert fix as it breaks other components
  downstream that can't handle unicode. See #709, #710,
  and #712.

v25.1.2
-------

* #704: Fix errors when installing a zip sdist that contained
  files named with non-ascii characters on Windows would
  crash the install when it attempted to clean up the build.
* #646: MSVC compatibility - catch errors properly in
  RegistryInfo.lookup.
* #702: Prevent UnboundLocalError when initial working_set
  is empty.

Revision 1.83 / (download) - annotate - [select for diffs], Mon Aug 1 10:15:02 2016 UTC (7 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.82: +5 -5 lines
Diff to previous 1.82 (colored)

Updated py-setuptools to 25.1.1.

v25.1.1
-------

* #686: Fix issue in sys.path ordering by pkg_resources when
  rewrite technique is "raw".
* #699: Fix typo in msvc support.

v25.1.0
-------

* #609: Setuptools will now try to download a distribution from
  the next possible download location if the first download fails.
  This means you can now specify multiple links as ``dependency_links``
  and all links will be tried until a working download link is encountered.

v25.0.2
-------

* #688: Fix AttributeError in setup.py when invoked not from
  the current directory.

v25.0.1
-------

* Cleanup of setup.py script.

* Fixed documentation builders by allowing setup.py
  to be imported without having bootstrapped the
  metadata.

* More style cleanup. See #677, #678, #679, #681, #685.

Revision 1.82 / (download) - annotate - [select for diffs], Sun Jul 24 19:30:34 2016 UTC (7 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.81: +5 -5 lines
Diff to previous 1.81 (colored)

Updated py-setuptools to 25.0.0.

v25.0.0
-------

* #674: Default ``sys.path`` manipulation by easy-install.pth
  is now "raw", meaning that when writing easy-install.pth
  during any install operation, the ``sys.path`` will not be
  rewritten, giving preference to easy_installed packages.

  To retain the old behavior when using any easy_install
  operation (including ``setup.py install`` when setuptools is
  present), set the environment variable:

    SETUPTOOLS_SYS_PATH_TECHNIQUE=rewrite

  This project hopes that that few if any environments find it
  necessary to retain the old behavior, and intends to drop
  support for it altogether in a future release. Please report
  any relevant concerns in the ticket for this change.

v24.3.1
-------

* #398: Fix shebang handling on Windows in script
  headers where spaces in ``sys.executable`` would
  produce an improperly-formatted shebang header,
  introduced in 12.0 with the fix for #188.

* #663, #670: More style updates.

v24.3.0
-------

* #516: Disable ``os.link`` to avoid hard linking
  in ``sdist.make_distribution``, avoiding errors on
  systems that support hard links but not on the
  file system in which the build is occurring.

v24.2.1
-------

* #667: Update Metadata-Version to 1.2 when
  ``python_requires`` is supplied.

v24.2.0
-------

* #631: Add support for ``python_requires`` keyword.

v24.1.1
-------

* More style updates. See #660, #661, #641.

v24.1.0
-------

* #659: ``setup.py`` now will fail fast and with a helpful
  error message when the necessary metadata is missing.
* More style updates. See #656, #635, #640,
  #644, #650, #652, and #655.

Revision 1.81 / (download) - annotate - [select for diffs], Thu Jul 21 12:54:49 2016 UTC (7 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.80: +6 -6 lines
Diff to previous 1.80 (colored)

Updated py-setuptools to 24.0.3.

v24.0.3
-------

* Updated style in much of the codebase to match
  community expectations. See #632, #633, #634,
  #637, #639, #638, #642, #648.

v24.0.2
-------

* If MSVC++14 is needed ``setuptools.msvc`` now redirect
  user to Visual C++ Build Tools web page.

v24.0.1
-------

* #625 and #626: Fixes on ``setuptools.msvc`` mainly
  for Python 2 and Linux.

Revision 1.80 / (download) - annotate - [select for diffs], Sun Jul 3 11:23:09 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.79: +5 -5 lines
Diff to previous 1.79 (colored)

Updated py-setuptools to 24.0.0.

v24.0.0
-------

* Pull Request #174: Add more aggressive support for
  Windows SDK in msvc9compiler patch.
* Renamed ``setuptools.msvc9_support`` to
  ``setuptools.msvc``.

v23.2.1
-------

Re-release of v23.2.0, which was missing the intended
commits.

* #623: Remove used of deprecated 'U' flag when reading
  manifests.

Revision 1.79 / (download) - annotate - [select for diffs], Thu Jun 30 17:40:33 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.78: +5 -5 lines
Diff to previous 1.78 (colored)

Updated py-setuptools to 23.1.0.

v23.1.0
-------

* #619: Deprecated ``tag_svn_revision`` distribution
  option.

Revision 1.78 / (download) - annotate - [select for diffs], Sun Jun 12 14:32:27 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.77: +5 -5 lines
Diff to previous 1.77 (colored)

Updated py-setuptools to 23.0.0.

v23.0.0
-------

* #611: Removed ARM executables for CLI and GUI script
  launchers on Windows. If this was a feature you cared
  about, please comment in the ticket.
* #604: Removed docs building support. The project
  now relies on documentation hosted at
  https://setuptools.readthedocs.io/.

Revision 1.77 / (download) - annotate - [select for diffs], Mon Jun 6 12:09:17 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.76: +5 -5 lines
Diff to previous 1.76 (colored)

Updated py-setuptools to 22.0.5.

v22.0.5
-------

* #604: Restore repository for upload_docs command
  to restore publishing of docs during release.

v22.0.4
-------

* #589: Upload releases to pypi.io using the upload
  hostname and legacy path.

v22.0.3
-------

* #589: Releases are now uploaded to pypi.io (Warehouse)
  even when releases are made on Twine via Travis.

v22.0.2
-------

* #589: Releases are now uploaded to pypi.io (Warehouse).

v22.0.1
-------

* #190: On Python 2, if unicode is passed for packages to
  ``build_py`` command, it will be handled just as with
  text on Python 3.

v22.0.0
-------

Intended to be v21.3.0, but jaraco accidentally released as
a major bump.

* #598: Setuptools now lists itself first in the User-Agent
  for web requests, better following the guidelines in
  `RFC 7231
  <https://tools.ietf.org/html/rfc7231#section-5.5.3>`_.

Revision 1.76 / (download) - annotate - [select for diffs], Sun May 29 21:27:05 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.75: +5 -5 lines
Diff to previous 1.75 (colored)

Updated py-setuptools to 21.2.2.

v21.2.2
-------

* Minor fixes to changelog and docs.

v21.2.1
-------

* #261: Exclude directories when resolving globs in
  package_data.

v21.2.0
-------

* #539: In the easy_install get_site_dirs, honor all
  paths found in ``site.getsitepackages``.

v21.1.0
-------

* #572: In build_ext, now always import ``_CONFIG_VARS``
  from ``distutils`` rather than from ``sysconfig``
  to allow ``distutils.sysconfig.customize_compiler``
  configure the OS X compiler for ``-dynamiclib``.

Revision 1.75 / (download) - annotate - [select for diffs], Thu May 5 11:52:09 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.74: +5 -5 lines
Diff to previous 1.74 (colored)

Updated py-setuptools to 21.0.0.

v21.0.0

02 May 2016

    Removed ez_setup.py from Setuptools sdist. The bootstrap script
    will be maintained in its own branch and should be generally
    be retrieved from its canonical location at
    https://bootstrap.pypa.io/ez_setup.py.

v20.10.0

25 Apr 2016

    #553: egg_info section is now generated in a deterministic
    order, matching the order generated by earlier versions of
    Python. Except on Python 2.6, order is preserved when existing
    settings are present.
    #556: Update to Packaging 16.7, restoring support for deprecated
    python_implmentation marker.
    #555: Upload command now prompts for a password when uploading
    to PyPI (or other repository) if no password is present in
    .pypirc or in the keyring.

Revision 1.74 / (download) - annotate - [select for diffs], Sun Apr 17 09:51:07 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.73: +5 -5 lines
Diff to previous 1.73 (colored)

Update py-setuptools to 20.9.0.

v20.9.0
-------

* #548: Update certify version to 2016.2.28
* #545: Safely handle deletion of non-zip eggs in rotate
  command.

v20.8.1
-------

* Issue #544: Fix issue with extra environment marker
  processing in WorkingSet due to refactor in v20.7.0.

v20.8.0
-------

* Issue #543: Re-release so that latest release doesn't
  cause déjà vu with distribute and setuptools 0.7 in
  older environments.

v20.7.0
-------

* Refactored extra enviroment marker processing
  in WorkingSet.
* Issue #533: Fixed intermittent test failures.
* Issue #536: In msvc9_support, trap additional exceptions
  that might occur when importing
  ``distutils.msvc9compiler`` in mingw environments.
* Issue #537: Provide better context when package
  metadata fails to decode in UTF-8.

v20.6.8
-------

* Issue #523: Restored support for environment markers,
  now honoring 'extra' environment markers.

Revision 1.73 / (download) - annotate - [select for diffs], Wed Apr 13 18:21:19 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.72: +5 -5 lines
Diff to previous 1.72 (colored)

Update py-setuptools to 20.6.7.

v20.6.7
-------

* Issue #523: Disabled support for environment markers
  introduced in v20.5.

v20.6.6
-------

* Issue #503: Restore support for PEP 345 environment
  markers by updating to Packaging 16.6.

v20.6.0
-------

* New release process that relies on
  `bumpversion <https://github.com/peritus/bumpversion>`_
  and Travis CI for continuous deployment.
* Project versioning semantics now follow
  `semver <https://semver.org>`_ precisely.
  The 'v' prefix on version numbers now also allows
  version numbers to be referenced in the changelog,
  e.g. https://pythonhosted.org/setuptools/history.html#v20-6-0.

20.5
----

* BB Pull Request #185: Add support for environment markers
  in requirements in install_requires, setup_requires,
  tests_require as well as adding a test for the existing
  extra_requires machinery.

20.4
----

* Issue #422: Moved hosting to
  `Github <https://github.com/pypa/setuptools>`_
  from `Bitbucket <https://bitbucket.org/pypa/setuptools>`_.
  Issues have been migrated, though all issues and comments
  are attributed to bb-migration. So if you have a particular
  issue or issues to which you've been subscribed, you will
  want to "watch" the equivalent issue in Github.
  The Bitbucket project will be retained for the indefinite
  future, but Github now hosts the canonical project repository.

20.3.1
------

* Issue #519: Remove import hook when reloading the
  ``pkg_resources`` module.
* BB Pull Request #184: Update documentation in ``pkg_resources``
  around new ``Requirement`` implementation.

20.3
----

* BB Pull Request #179: ``pkg_resources.Requirement`` objects are
  now a subclass of ``packaging.requirements.Requirement``,
  allowing any environment markers and url (if any) to be
  affiliated with the requirement
* BB Pull Request #179: Restore use of RequirementParseError
  exception unintentionally dropped in 20.2.

Revision 1.72 / (download) - annotate - [select for diffs], Thu Mar 3 13:01:11 2016 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.71: +5 -5 lines
Diff to previous 1.71 (colored)

Update py-setuptools to 20.2.2.

20.2.2
------

* Issue #502: Correct regression in parsing of multiple
  version specifiers separated by commas and spaces.

20.2.1
------

* Issue #499: Restore compatiblity for legacy versions
  by bumping to packaging 16.4.

20.2
----

* Changelog now includes release dates and links to PEPs.
* Pull Request #173: Replace dual PEP 345 _markerlib implementation
  and PEP 426 implementation of environment marker support from
  packaging 16.1 and PEP 508. Fixes Issue #122.
  See also Pull Request #175, Pull Request #168, and
  Pull Request #164. Additionally:
   - ``Requirement.parse`` no longer retains the order of extras.
   - ``parse_requirements`` now requires that all versions be
     PEP-440 compliant, as revealed in #499. Packages released
     with invalid local versions should be re-released using
     the proper local version syntax, e.g. ``mypkg-1.0+myorg.1``.

Revision 1.71 / (download) - annotate - [select for diffs], Sun Feb 14 10:53:17 2016 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.70: +5 -5 lines
Diff to previous 1.70 (colored)

Update py-setuptools to 20.1.1.

20.1.1
------

* Update ``upload_docs`` command to also honor keyring
  for password resolution.

20.1
----

* Added support for using passwords from keyring in the upload
command. See `the upload docs
<http://pythonhosted.org/setuptools/setuptools.html#upload-upload-source-and-or-egg-distributions-to-pypi>`_
for details.

20.0
----

* Issue #118: Once again omit the package metadata (egg-info)
  from the list of outputs in ``--record``. This version of setuptools
  can no longer be used to upgrade pip earlier than 6.0.

Revision 1.70 / (download) - annotate - [select for diffs], Sun Feb 7 14:12:55 2016 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.69: +5 -5 lines
Diff to previous 1.69 (colored)

Update py-setuptools to 19.7:

19.7
----

* `Off-project PR <https://github.com/jaraco/setuptools/pull/32>`_:
  For FreeBSD, also honor root certificates from ca_root_nss.

19.6.2
------

* Issue #491: Correct regression incurred in 19.4 where
  a double-namespace package installed using pip would
  cause a TypeError.

Revision 1.69 / (download) - annotate - [select for diffs], Mon Feb 1 13:08:13 2016 UTC (7 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.68: +5 -5 lines
Diff to previous 1.68 (colored)

Update py-setuptools to 19.6.1. All self-tests pass.

19.6.1
------

* Restore compatibility for PyPy 3 compatibility lost in
  19.4.1 addressing Issue #487.
* ``setuptools.launch`` shim now loads scripts in a new
  namespace, avoiding getting relative imports from
  the setuptools package on Python 2.

19.6
----

* Added a new entry script ``setuptools.launch``,
  implementing the shim found in
  ``pip.util.setuptools_build``. Use this command to launch
  distutils-only packages under setuptools in the same way that
  pip does, causing the setuptools monkeypatching of distutils
  to be invoked prior to invoking a script. Useful for debugging
  or otherwise installing a distutils-only package under
  setuptools when pip isn't available or otherwise does not
  expose the desired functionality. For example::

    $ python -m setuptools.launch setup.py develop

* Issue #488: Fix dual manifestation of Extension class in
  extension packages installed as dependencies when Cython
  is present.

19.5
----

* Issue #486: Correct TypeError when getfilesystemencoding
  returns None.
* Issue #139: Clarified the license as MIT.
* Pull Request #169: Removed special handling of command
  spec in scripts for Jython.

19.4.1
------

* Issue #487: Use direct invocation of ``importlib.machinery``
  in ``pkg_resources`` to avoid missing detection on relevant
  platforms.

Revision 1.68 / (download) - annotate - [select for diffs], Mon Jan 18 23:04:14 2016 UTC (7 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.67: +5 -5 lines
Diff to previous 1.67 (colored)

Update py-setuptools to 19.4:

19.4
----

* Issue #341: Correct error in path handling of package data
  files in ``build_py`` command when package is empty.
* Distribute #323, Issue #141, Issue #207, and
  Pull Request #167: Another implementation of
  ``pkg_resources.WorkingSet`` and ``pkg_resources.Distribution``
  that supports replacing an extant package with a new one,
  allowing for setup_requires dependencies to supersede installed
  packages for the session.

----
19.3
----

* Issue #229: Implement new technique for readily incorporating
  dependencies conditionally from vendored copies or primary
  locations. Adds a new dependency on six.

Revision 1.67 / (download) - annotate - [select for diffs], Sun Dec 27 22:58:18 2015 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.66: +5 -5 lines
Diff to previous 1.66 (colored)

Update py-setuptools to 19.2:

----
19.2
----

* Pull Request #163: Add get_command_list method to Distribution.
* Pull Request #162: Add missing whitespace to multiline string
  literals.

------
19.1.1
------

* Issue #476: Cast version to string (using default encoding)
  to avoid creating Unicode types on Python 2 clients.
* Issue #477: In Powershell downloader, use explicit rendering
  of strings, rather than rely on ``repr``, which can be
  incorrect (especially on Python 2).

----
19.1
----

* Issue #215: The bootstrap script ``ez_setup.py`` now
  automatically detects
  the latest version of setuptools (using PyPI JSON API) rather
  than hard-coding a particular value.
* Issue #475: Fix incorrect usage in _translate_metadata2.

----
19.0
----

* Issue #442: Use RawConfigParser for parsing .pypirc file.
  Interpolated values are no longer honored in .pypirc files.

------
18.8.1
------

* Issue #440: Prevent infinite recursion when a SandboxViolation
  or other UnpickleableException occurs in a sandbox context
  with setuptools hidden. Fixes regression introduced in Setuptools
  12.0.

Revision 1.66 / (download) - annotate - [select for diffs], Sun Dec 13 21:08:50 2015 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.65: +5 -5 lines
Diff to previous 1.65 (colored)

Update py-setuptools to 18.8.

----
18.8
----

* Deprecated ``egg_info.get_pkg_info_revision``.
* Issue #471: Don't rely on repr for an HTML attribute value in
  package_index.
* Issue #419: Avoid errors in FileMetadata when the metadata directory
  is broken.
* Issue #472: Remove deprecated use of 'U' in mode parameter
  when opening files.

Revision 1.65 / (download) - annotate - [select for diffs], Sun Dec 6 11:47:23 2015 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.64: +5 -5 lines
Diff to previous 1.64 (colored)

Update py-setuptools to 18.7.1.

All tests pass.

------
18.7.1
------

* Issue #469: Refactored logic for Issue #419 fix to re-use metadata
  loading from Provider.

Revision 1.64 / (download) - annotate - [select for diffs], Fri Dec 4 21:52:58 2015 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.63: +5 -5 lines
Diff to previous 1.63 (colored)

Update py-setuptools to 18.7:

----
18.7
----

* Update dependency on certify.
* Pull Request #160: Improve detection of gui script in
  ``easy_install._adjust_header``.
* Made ``test.test_args`` a non-data property; alternate fix
  for the issue reported in Pull Request #155.
* Issue #453: In ``ez_setup`` bootstrap module, unload all
  ``pkg_resources`` modules following download.
* Pull Request #158: Honor `PEP-488
  <https://www.python.org/dev/peps/pep-0488/>`_ when excluding
  files for namespace packages.
* Issue #419 and Pull Request #144: Add experimental support for
  reading the version info from distutils-installed metadata rather
  than using the version in the filename.

------
18.6.1
------

* Issue #464: Correct regression in invocation of superclass on old-style
  class on Python 2.

----
18.6
----

* Issue #439: When installing entry_point scripts under development,
  omit the version number of the package, allowing any version of the
  package to be used.

Revision 1.63 / (download) - annotate - [select for diffs], Thu Nov 12 16:34:42 2015 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.62: +5 -5 lines
Diff to previous 1.62 (colored)

Update py-setuptools to 18.5:

----
18.5
----

* In preparation for dropping support for Python 3.2, a warning is
  now logged when pkg_resources is imported on Python 3.2 or earlier
  Python 3 versions.
* `Add support for python_platform_implementation environment marker
  <https://github.com/jaraco/setuptools/pull/28>`_.
* `Fix dictionary mutation during iteration
  <https://github.com/jaraco/setuptools/pull/29>`_.

Revision 1.62 / (download) - annotate - [select for diffs], Wed Nov 4 17:41:17 2015 UTC (7 years, 11 months ago) by agc
Branch: MAIN
Changes since 1.61: +1 -2 lines
Diff to previous 1.61 (colored)

Remove duplicate SHA512 digests that crept in.

Revision 1.61 / (download) - annotate - [select for diffs], Tue Nov 3 03:29:16 2015 UTC (7 years, 11 months ago) by agc
Branch: MAIN
Changes since 1.60: +2 -1 lines
Diff to previous 1.60 (colored)

Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.

Revision 1.60 / (download) - annotate - [select for diffs], Thu Oct 15 10:56:12 2015 UTC (7 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.59: +5 -4 lines
Diff to previous 1.59 (colored)

Update py-setuptools to 18.4:

----
18.4
----

* Issue #446: Test command now always invokes unittest, even
  if no test suite is supplied.

Revision 1.59 / (download) - annotate - [select for diffs], Wed Sep 30 20:28:21 2015 UTC (8 years ago) by wiz
Branch: MAIN
Changes since 1.58: +4 -4 lines
Diff to previous 1.58 (colored)

Update to 18.3.2:

------
18.3.2
------

* Correct another regression in setuptools.findall
  where the fix for Python #12885 was lost.

Revision 1.58 / (download) - annotate - [select for diffs], Sun Sep 13 09:28:16 2015 UTC (8 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.57: +4 -4 lines
Diff to previous 1.57 (colored)

Update to 18.3.1:

------
18.3.1
------

* Issue #425: Correct regression in setuptools.findall.

----
18.3
----

* Setuptools now allows disabling of the manipulation of the sys.path
  during the processing of the easy-install.pth file. To do so, set
  the environment variable ``SETUPTOOLS_SYS_PATH_TECHNIQUE`` to
  anything but "rewrite" (consider "raw"). During any install operation
  with manipulation disabled, setuptools packages will be appended to
  sys.path naturally.

  Future versions may change the default behavior to disable
  manipulation. If so, the default behavior can be retained by setting
  the variable to "rewrite".

* Issue #257: ``easy_install --version`` now shows more detail
  about the installation location and Python version.

Revision 1.57 / (download) - annotate - [select for diffs], Sun Aug 30 14:44:13 2015 UTC (8 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.56: +4 -4 lines
Diff to previous 1.56 (colored)

Update to 18.2:

18.2
----

* Issue #412: More efficient directory search in ``find_packages``.

Revision 1.56 / (download) - annotate - [select for diffs], Fri Aug 14 18:02:50 2015 UTC (8 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.55: +4 -4 lines
Diff to previous 1.55 (colored)

Update to 18.1:

----
18.1
----

* Upgrade to vendored packaging 15.3.

Revision 1.55 / (download) - annotate - [select for diffs], Wed Jul 1 09:29:21 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.54: +4 -4 lines
Diff to previous 1.54 (colored)

Update to 18.0.1:

------
18.0.1
------

* Issue #401: Fix failure in test suite.

----
18.0
----

* Dropped support for builds with Pyrex. Only Cython is supported.
* Issue #288: Detect Cython later in the build process, after
  ``setup_requires`` dependencies are resolved.
  Projects backed by Cython can now be readily built
  with a ``setup_requires`` dependency. For example::

    ext = setuptools.Extension('mylib', ['src/CythonStuff.pyx', 'src/CStuff.c'])
    setuptools.setup(
        ...
        ext_modules=[ext],
        setup_requires=['cython'],
    )

  For compatibility with older versions of setuptools, packagers should
  still include ``src/CythonMod.c`` in the source distributions or
  require that Cython be present before building source distributions.
  However, for systems with this build of setuptools, Cython will be
  downloaded on demand.
* Issue #396: Fixed test failure on OS X.
* Pull Request #136: Remove excessive quoting from shebang headers
  for Jython.

Revision 1.54 / (download) - annotate - [select for diffs], Sun Jun 14 16:29:06 2015 UTC (8 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2
Changes since 1.53: +4 -4 lines
Diff to previous 1.53 (colored)

Update to 17.1.1:

------
17.1.1
------

* Backed out unintended changes to pkg_resources, restoring removal of
  deprecated imp module (`ref
  <https://bitbucket.org/pypa/setuptools/commits/f572ec9563d647fa8d4ffc534f2af8070ea07a8b#comment-1881283>`_).

----
17.1
----

* Issue #380: Add support for range operators on environment
  marker evaluation.

Revision 1.53 / (download) - annotate - [select for diffs], Sun May 31 13:10:53 2015 UTC (8 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.52: +4 -4 lines
Diff to previous 1.52 (colored)

Update to 17.0:

17.0
----

* Issue #378: Do not use internal importlib._bootstrap module.
* Issue #390: Disallow console scripts with path separators in
  the name. Removes unintended functionality and brings behavior
  into parity with pip.

Revision 1.52 / (download) - annotate - [select for diffs], Thu May 28 07:12:22 2015 UTC (8 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.51: +4 -4 lines
Diff to previous 1.51 (colored)

Update to 16.0:

----
16.0
----

* Pull Request #130: Better error messages for errors in
  parsed requirements.
* Pull Request #133: Removed ``setuptools.tests`` from the
  installed packages.

Revision 1.51 / (download) - annotate - [select for diffs], Sun May 3 10:12:32 2015 UTC (8 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.50: +4 -4 lines
Diff to previous 1.50 (colored)

Update to 15.2:

15.2
----

* Issue #373: Provisionally expose
  ``pkg_resources._initialize_master_working_set``, allowing for
  imperative re-initialization of the master working set.

Revision 1.50 / (download) - annotate - [select for diffs], Sun Apr 19 18:24:58 2015 UTC (8 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.49: +4 -4 lines
Diff to previous 1.49 (colored)

Update to 15.1:

15.1
----

* Updated Packaging to 15.1 to address Packaging #28.
* Fix ``setuptools.sandbox._execfile()`` with Python 3.1.

Revision 1.49 / (download) - annotate - [select for diffs], Sun Apr 5 14:17:42 2015 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.48: +4 -4 lines
Diff to previous 1.48 (colored)

Update to 15.0:

----
15.0
----

* Pull Request #126: DistributionNotFound message now lists the package or
  packages that required it. E.g.::

      pkg_resources.DistributionNotFound: The 'colorama>=0.3.1' distribution was not found and is required by smlib.log.

  Note that zc.buildout once dependended on the string rendering of this
  message to determine the package that was not found. This expectation
  has since been changed, but older versions of buildout may experience
  problems. See Buildout #242 for details.

Revision 1.48 / (download) - annotate - [select for diffs], Thu Apr 2 22:39:02 2015 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.47: +4 -4 lines
Diff to previous 1.47 (colored)

Update to 14.3.1:

------
14.3.1
------

* Issue #307: Removed PEP-440 warning during parsing of versions
  in ``pkg_resources.Distribution``.
* Issue #364: Replace deprecated usage with recommended usage of
  ``EntryPoint.load``.

----
14.3
----

* Issue #254: When creating temporary egg cache on Unix, use mode 755
  for creating the directory to avoid the subsequent warning if
  the directory is group writable.

Revision 1.47 / (download) - annotate - [select for diffs], Sun Mar 15 21:06:29 2015 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.46: +4 -4 lines
Diff to previous 1.46 (colored)

Update to 14.2:

14.2
----

* Issue #137: Update ``Distribution.hashcmp`` so that Distributions with
  None for pyversion or platform can be compared against Distributions
  defining those attributes.

------
14.1.1
------

* Issue #360: Removed undesirable behavior from test runs, preventing
  write tests and installation to system site packages.

----
14.1
----

* Pull Request #125: Add ``__ne__`` to Requirement class.
* Various refactoring of easy_install.

Revision 1.46 / (download) - annotate - [select for diffs], Mon Mar 9 08:13:07 2015 UTC (8 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.45: +4 -4 lines
Diff to previous 1.45 (colored)

Update to 14.0:

----
14.0
----

* Bootstrap script now accepts ``--to-dir`` to customize save directory or
  allow for re-use of existing repository of setuptools versions. See
  Pull Request #112 for background.
* Issue #285: ``easy_install`` no longer will default to installing
  packages to the "user site packages" directory if it is itself installed
  there. Instead, the user must pass ``--user`` in all cases to install
  packages to the user site packages.
  This behavior now matches that of "pip install". To configure
  an environment to always install to the user site packages, consider
  using the "install-dir" and "scripts-dir" parameters to easy_install
  through an appropriate distutils config file.

------
13.0.2
------

* Issue #359: Include pytest.ini in the sdist so invocation of py.test on the
  sdist honors the pytest configuration.

------
13.0.1
------

Re-release of 13.0. Intermittent connectivity issues caused the release
process to fail and PyPI uploads no longer accept files for 13.0.

----
13.0
----

* Issue #356: Back out Pull Request #119 as it requires Setuptools 10 or later
  as the source during an upgrade.
* Removed build_py class from setup.py. According to 892f439d216e, this
  functionality was added to support upgrades from old Distribute versions,
  0.6.5 and 0.6.6.

----
12.4
----

* Pull Request #119: Restore writing of ``setup_requires`` to metadata
  (previously added in 8.4 and removed in 9.0).

Revision 1.45 / (download) - annotate - [select for diffs], Sun Mar 1 15:03:37 2015 UTC (8 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.44: +4 -4 lines
Diff to previous 1.44 (colored)

Update to 12.3:

12.3
----

* Documentation is now linked using the rst.linker package.
* Fix ``setuptools.command.easy_install.extract_wininst_cfg()``
  with Python 2.6 and 2.7.
* Issue #354. Added documentation on building setuptools
  documentation.

Revision 1.44 / (download) - annotate - [select for diffs], Sun Feb 22 22:48:16 2015 UTC (8 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.43: +4 -4 lines
Diff to previous 1.43 (colored)

Update to 12.2:

----
12.2
----

* Issue #345: Unload all modules under pkg_resources during
  ``ez_setup.use_setuptools()``.
* Issue #336: Removed deprecation from ``ez_setup.use_setuptools``,
  as it is clearly still used by buildout's bootstrap. ``ez_setup``
  remains deprecated for use by individual packages.
* Simplified implementation of ``ez_setup.use_setuptools``.

Revision 1.43 / (download) - annotate - [select for diffs], Tue Feb 17 13:56:05 2015 UTC (8 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.42: +4 -4 lines
Diff to previous 1.42 (colored)

Update to 12.1:

12.1

* Pull Request #118: Soften warning for non-normalized versions in
  Distribution.

Revision 1.42 / (download) - annotate - [select for diffs], Sun Feb 1 19:44:23 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.41: +4 -4 lines
Diff to previous 1.41 (colored)

Update to 12.0.5:

------
12.0.5
------

* Issue #339: Correct Attribute reference in ``cant_write_to_target``.

Revision 1.41 / (download) - annotate - [select for diffs], Sun Jan 25 18:51:31 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.40: +4 -5 lines
Diff to previous 1.40 (colored)

Update to 12.0.4:

------
12.0.4
------

* Issue #335: Fix script header generation on Windows.

------
12.0.3
------

* Fixed incorrect class attribute in ``install_scripts``. Tests would be nice.

------
12.0.2
------

* Issue #331: Fixed ``install_scripts`` command on Windows systems corrupting
  the header.

Revision 1.40 / (download) - annotate - [select for diffs], Sun Jan 18 17:32:51 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.39: +2 -2 lines
Diff to previous 1.39 (colored)

Add upstream bug report URL.

Revision 1.39 / (download) - annotate - [select for diffs], Sun Jan 18 17:29:01 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.38: +5 -4 lines
Diff to previous 1.38 (colored)

Update to 12.0.1:

------
12.0.1
------

* Restore ``setuptools.command.easy_install.sys_executable`` for pbr
  compatibility. For the future, tools should construct a CommandSpec
  explicitly.

----
12.0
----

* Issue #188: Setuptools now support multiple entities in the value for
  ``build.executable``, such that an executable of "/usr/bin/env my-python" may
  be specified. This means that systems with a specified executable whose name
  has spaces in the path must be updated to escape or quote that value.
* Deprecated ``easy_install.ScriptWriter.get_writer``, replaced by ``.best()``
  with slightly different semantics (no force_windows flag).

Revision 1.38 / (download) - annotate - [select for diffs], Thu Jan 8 16:36:58 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.37: +4 -4 lines
Diff to previous 1.37 (colored)

Update to 11.3.1:

------
11.3.1
------

* Issue #327: Formalize and restore support for any printable character in an
  entry point name.

----
11.3
----

* Expose ``EntryPoint.resolve`` in place of EntryPoint._load, implementing the
  simple, non-requiring load. Deprecated all uses of ``EntryPoint._load``
  except for calling with no parameters, which is just a shortcut for
  ``ep.require(); ep.resolve();``.

  Apps currently invoking ``ep.load(require=False)`` should instead do the
  following if wanting to avoid the deprecating warning::

    getattr(ep, "resolve", lambda: ep.load(require=False))()

----
11.2
----

* Pip #2326: Report deprecation warning at stacklevel 2 for easier diagnosis.

----
11.1
----

* Issue #281: Since Setuptools 6.1 (Issue #268), a ValueError would be raised
  in certain cases where VersionConflict was raised with two arguments, which
  occurred in ``pkg_resources.WorkingSet.find``. This release adds support
  for indicating the dependent packages while maintaining support for
  a VersionConflict when no dependent package context is known. New unit tests
  now capture the expected interface.

Revision 1.37 / (download) - annotate - [select for diffs], Sun Jan 4 23:42:47 2015 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.36: +4 -4 lines
Diff to previous 1.36 (colored)

Update to 11.0:

----
11.0
----

* Interop #3: Upgrade to Packaging 15.0; updates to PEP 440 so that >1.7 does
  not exclude 1.7.1 but does exclude 1.7.0 and 1.7.0.post1.

------
10.2.1
------

* Issue #323: Fix regression in entry point name parsing.

----
10.2
----

* Deprecated use of EntryPoint.load(require=False).
* Substantial refactoring of all unit tests. Tests are now much leaner and
  re-use a lot of fixtures and contexts for better clarity of purpose.

----
10.1
----

* Issue #320: Added a compatibility implementation of
  ``sdist._default_revctrl``
  so that systems relying on that interface do not fail (namely, Ubuntu 12.04
  and similar Debian releases).

------
10.0.1
------

* Issue #319: Fixed issue installing pure distutils packages.

----
10.0
----

* Issue #313: Removed built-in support for subversion. Projects wishing to
  retain support for subversion will need to use a third party library. The
  extant implementation is being ported to `setuptools_svn
  <https://pypi.python.org/pypi/setuptools_svn>`_.
* Issue #315: Updated setuptools to hide its own loaded modules during
  installation of another package. This change will enable setuptools to
  upgrade (or downgrade) itself even when its own metadata and implementation
  change.

---
9.1
---

* Prefer vendored packaging library `as recommended
  <https://github.com/jaraco/setuptools/commit/170657b68f4b92e7e1bf82f5e19a831f5744af67#commitcomment-9109448>`_.

-----
9.0.1
-----

* Issue #312: Restored presence of pkg_resources API tests (doctest) to sdist.

---
9.0
---

* Issue #314: Disabled support for ``setup_requires`` metadata to avoid issue
  where Setuptools was unable to upgrade over earlier versions.

---
8.4
---

* Pull Request #106: Now write ``setup_requires`` metadata.

Revision 1.36 / (download) - annotate - [select for diffs], Tue Dec 30 14:10:36 2014 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.35: +4 -4 lines
Diff to previous 1.35 (colored)

Update to 8.3:

---
8.3
---

* Issue #311: Decoupled pkg_resources from setuptools once again.
  ``pkg_resources`` is now a package instead of a module.

-----
8.2.1
-----

* Issue #306: Suppress warnings about Version format except in select scenarios
  (such as installation).

---
8.2
---

* Pull Request #85: Search egg-base when adding egg-info to manifest.

---
8.1
---

* Upgrade ``packaging`` to 14.5, giving preference to "rc" as designator for
  release candidates over "c".
* PEP-440 warnings are now raised as their own class,
  ``pkg_resources.PEP440Warning``, instead of RuntimeWarning.
* Disabled warnings on empty versions.

-----
8.0.4
-----

* Upgrade ``packaging`` to 14.4, fixing an error where there is a
  different result for if 2.0.5 is contained within >2.0dev and >2.0.dev even
  though normalization rules should have made them equal.
* Issue #296: Add warning when a version is parsed as legacy. This warning will
  make it easier for developers to recognize deprecated version numbers.

-----
8.0.3
-----

* Issue #296: Restored support for ``__hash__`` on parse_version results.

-----
8.0.2
-----

* Issue #296: Restored support for ``__getitem__`` and sort operations on
  parse_version result.

Revision 1.35 / (download) - annotate - [select for diffs], Sun Dec 14 15:52:42 2014 UTC (8 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.34: +4 -4 lines
Diff to previous 1.34 (colored)

Update to 8.0.1:

-----
8.0.1
-----

* Issue #296: Restore support for iteration over parse_version result, but
  deprecated that usage with a warning. Fixes failure with buildout.

---
8.0
---

* Implement `PEP 440 <http://legacy.python.org/dev/peps/pep-0440/>`_ within
  pkg_resources and setuptools. This change
  deprecates some version numbers such that they will no longer be installable
  without using the ``===`` escape hatch. See `the changes to test_resources
  <https://bitbucket.org/pypa/setuptools/commits/dcd552da643c4448056de84c73d56da6d70769d5#chg-setuptools/tests/test_resources.py>`_
  for specific examples of version numbers and specifiers that are no longer
  supported. Setuptools now "vendors" the `packaging
  <https://github.com/pypa/packaging>`_ library.

Revision 1.34 / (download) - annotate - [select for diffs], Mon Oct 27 08:40:59 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.33: +4 -4 lines
Diff to previous 1.33 (colored)

Update to 7.0:

7.0
---

* Issue #80, Issue #209: Eggs that are downloaded for ``setup_requires``,
  ``test_requires``, etc. are now placed in a ``./.eggs`` directory instead of
  directly in the current directory. This choice of location means the files
  can be readily managed (removed, ignored). Additionally,
  later phases or invocations of setuptools will not detect the package as
  already installed and ignore it for permanent install (See #209).

  This change is indicated as backward-incompatible as installations that
  depend on the installation in the current directory will need to account for
  the new location. Systems that ignore ``*.egg`` will probably need to be
  adapted to ignore ``.eggs``. The files will need to be manually moved or
  will be retrieved again. Most use cases will require no attention.

Revision 1.33 / (download) - annotate - [select for diffs], Sun Oct 12 14:59:55 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.32: +4 -4 lines
Diff to previous 1.32 (colored)

Update to 6.1:

6.1
---

* Issue #268: When resolving package versions, a VersionConflict now reports
  which package previously required the conflicting version.

Revision 1.32 / (download) - annotate - [select for diffs], Wed Oct 1 12:25:44 2014 UTC (9 years ago) by wiz
Branch: MAIN
Changes since 1.31: +4 -4 lines
Diff to previous 1.31 (colored)

Update to 6.0.2:

-----
6.0.2
-----

* Issue #262: Fixed regression in pip install due to egg-info directories
  being omitted. Re-opens Issue #118.

-----
6.0.1
-----

* Issue #259: Fixed regression with namespace package handling on ``single
  version, externally managed`` installs.

---
6.0
---

* Issue #100: When building a distribution, Setuptools will no longer match
  default files using platform-dependent case sensitivity, but rather will
  only match the files if their case matches exactly. As a result, on Windows
  and other case-insensitive file systems, files with names such as
  'readme.txt' or 'README.TXT' will be omitted from the distribution and a
  warning will be issued indicating that 'README.txt' was not found. Other
  filenames affected are:

    - README.rst
    - README
    - setup.cfg
    - setup.py (or the script name)
    - test/test*.py

  Any users producing distributions with filenames that match those above
  case-insensitively, but not case-sensitively, should rename those files in
  their repository for better portability.
* Pull Request #72: When using ``single_version_externally_managed``, the
  exclusion list now includes Python 3.2 ``__pycache__`` entries.
* Pull Request #76 and Pull Request #78: lines in top_level.txt are now
  ordered deterministically.
* Issue #118: The egg-info directory is now no longer included in the list
  of outputs.
* Issue #258: Setuptools now patches distutils msvc9compiler to
  recognize the specially-packaged compiler package for easy extension module
  support on Python 2.6, 2.7, and 3.2.

---
5.8
---

* Issue #237: ``pkg_resources`` now uses explicit detection of Python 2 vs.
  Python 3, supporting environments where builtins have been patched to make
  Python 3 look more like Python 2.

Revision 1.31 / (download) - annotate - [select for diffs], Sun Aug 17 16:32:36 2014 UTC (9 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.30: +4 -4 lines
Diff to previous 1.30 (colored)

Update to 5.7:

---
5.7
---

* Issue #240: Based on real-world performance measures against 5.4, zip
  manifests are now cached in all circumstances. The
  ``PKG_RESOURCES_CACHE_ZIP_MANIFESTS`` environment variable is no longer
  relevant. The observed "memory increase" referenced in the 5.4 release
  notes and detailed in Issue #154 was likely not an increase over the status
  quo, but rather only an increase over not storing the zip info at all.

---
5.6
---

* Issue #242: Use absolute imports in svn_utils to avoid issues if the
  installing package adds an xml module to the path.

-----
5.5.1
-----

* Issue #239: Fix typo in 5.5 such that fix did not take.

---
5.5
---

* Issue #239: Setuptools now includes the setup_requires directive on
  Distribution objects and validates the syntax just like install_requires
  and tests_require directives.

Revision 1.30 / (download) - annotate - [select for diffs], Tue Aug 5 18:38:50 2014 UTC (9 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.29: +4 -4 lines
Diff to previous 1.29 (colored)

Update to 5.4.2:

-----
5.4.2
-----

* Issue #236: Corrected regression in execfile implementation for Python 2.6.

Revision 1.29 / (download) - annotate - [select for diffs], Tue Jul 22 10:00:06 2014 UTC (9 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.28: +4 -4 lines
Diff to previous 1.28 (colored)

Update to 5.4.1:

-----
5.4.1
-----

* Python #7776: (ssl_support) Correct usage of host for validation when
  tunneling for HTTPS.

---
5.4
---

* Issue #154: ``pkg_resources`` will now cache the zip manifests rather than
  re-processing the same file from disk multiple times, but only if the
  environment variable ``PKG_RESOURCES_CACHE_ZIP_MANIFESTS`` is set. Clients
  that package many modules in the same zip file will see some improvement
  in startup time by enabling this feature. This feature is not enabled by
  default because it causes a substantial increase in memory usage.

---
5.3
---

* Issue #185: Make svn tagging work on the new style SVN metadata.
  Thanks cazabon!
* Prune revision control directories (e.g .svn) from base path
  as well as sub-directories.

---
5.2
---

* Added a `Developer Guide
  <https://pythonhosted.org/setuptools/developer-guide.html>`_ to the official
  documentation.
* Some code refactoring and cleanup was done with no intended behavioral
  changes.
* During install_egg_info, the generated lines for namespace package .pth
  files are now processed even during a dry run.

---
5.1
---

* Issue #202: Implemented more robust cache invalidation for the ZipImporter,
  building on the work in Issue #168. Special thanks to Jurko Gospodnetic and
  PJE.

-----
5.0.2
-----

* Issue #220: Restored script templates.

Revision 1.28 / (download) - annotate - [select for diffs], Sun Jun 15 14:17:08 2014 UTC (9 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.27: +4 -4 lines
Diff to previous 1.27 (colored)

Update to 5.0.1:

-----
5.0.1
-----

* Renamed script templates to end with .tmpl now that they no longer need
  to be processed by 2to3. Fixes spurious syntax errors during build/install.

---
5.0
---

* Issue #218: Re-release of 3.8.1 to signal that it supersedes 4.x.

Revision 1.27 / (download) - annotate - [select for diffs], Mon Jun 9 12:35:19 2014 UTC (9 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.26: +4 -4 lines
Diff to previous 1.26 (colored)

Update to 4.0.1:

---------------
3.7.1 and 4.0.1
---------------

* Issue #213: Use legacy StringIO behavior for compatibility under pbr.

---
4.0
---

* Issue #210: ``setup.py develop`` now copies scripts in binary mode rather
  than text mode, matching the behavior of the ``install`` command.

---
3.8
---

* Extend Issue #197 workaround to include all Python 3 versions prior to
  3.2.2.

---
3.7
---

* Issue #193: Improved handling of Unicode filenames when building manifests.

Revision 1.26 / (download) - annotate - [select for diffs], Wed May 14 08:53:31 2014 UTC (9 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.25: +4 -4 lines
Diff to previous 1.25 (colored)

Update to 3.6:

---
3.6
---

* Issue #203: Honor proxy settings for Powershell downloader in the bootstrap
  routine.

Revision 1.25 / (download) - annotate - [select for diffs], Sun May 4 17:14:12 2014 UTC (9 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.24: +4 -4 lines
Diff to previous 1.24 (colored)

Update to 3.5:

---
3.5
---

* Issue #195: Follow symbolic links in find_packages (restoring behavior
  broken in 3.4).
* Issue #197: On Python 3.1, PKG-INFO is now saved in a UTF-8 encoding instead
  of ``sys.getpreferredencoding`` to match the behavior on Python 2.6-3.4.
* Issue #192: Preferred bootstrap location is now
  https://bootstrap.pypa.io/ez_setup.py (mirrored from former location).

Revision 1.24 / (download) - annotate - [select for diffs], Fri Apr 11 18:06:19 2014 UTC (9 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.23: +4 -4 lines
Diff to previous 1.23 (colored)

Update to 3.4.4:

-----
3.4.4
-----

* Issue #184: Correct failure where find_package over-matched packages
  when directory traversal isn't short-circuited.

-----
3.4.3
-----

* Issue #183: Really fix test command with Python 3.1.

-----
3.4.2
-----

* Issue #183: Fix additional regression in test command on Python 3.1.

-----
3.4.1
-----

* Issue #180: Fix regression in test command not caught by py.test-run tests.

---
3.4
---

* Issue #176: Add parameter to the test command to support a custom test
  runner: --test-runner or -r.
* Issue #177: Now assume most common invocation to install command on
  platforms/environments without stack support (issuing a warning). Setuptools
  now installs naturally on IronPython. Behavior on CPython should be
  unchanged.

Revision 1.23 / (download) - annotate - [select for diffs], Mon Mar 31 08:32:27 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
Changes since 1.22: +4 -4 lines
Diff to previous 1.22 (colored)

Update to 3.3:

---
3.3
---

* Add ``include`` parameter to ``setuptools.find_packages()``.

---
3.2
---

* Pull Request #39: Add support for C++ targets from Cython ``.pyx`` files.
* Issue #162: Update dependency on certifi to 1.0.1.
* Issue #164: Update dependency on wincertstore to 0.2.

Revision 1.22 / (download) - annotate - [select for diffs], Wed Mar 12 10:14:19 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.21: +4 -4 lines
Diff to previous 1.21 (colored)

Update to 3.1:

---
3.1
---

* Issue #161: Restore Features functionality to allow backward compatibility
  (for Features) until the uses of that functionality is sufficiently removed.

-----
3.0.2
-----

* Correct typo in previous bugfix.

-----
3.0.1
-----

* Issue #157: Restore support for Python 2.6 in bootstrap script where
  ``zipfile.ZipFile`` does not yet have support for context managers.

---
3.0
---

* Issue #125: Prevent Subversion support from creating a ~/.subversion
  directory just for checking the presence of a Subversion repository.
* Issue #12: Namespace packages are now imported lazily.  That is, the mere
  declaration of a namespace package in an egg on ``sys.path`` no longer
  causes it to be imported when ``pkg_resources`` is imported.  Note that this
  change means that all of a namespace package's ``__init__.py`` files must
  include a ``declare_namespace()`` call in order to ensure that they will be
  handled properly at runtime.  In 2.x it was possible to get away without
  including the declaration, but only at the cost of forcing namespace
  packages to be imported early, which 3.0 no longer does.
* Issue #148: When building (bdist_egg), setuptools no longer adds
  ``__init__.py`` files to namespace packages. Any packages that rely on this
  behavior will need to create ``__init__.py`` files and include the
  ``declare_namespace()``.
* Issue #7: Setuptools itself is now distributed as a zip archive in addition to
  tar archive. ez_setup.py now uses zip archive. This approach avoids the potential
  security vulnerabilities presented by use of tar archives in ez_setup.py.
  It also leverages the security features added to ZipFile.extract in Python 2.7.4.
* Issue #65: Removed deprecated Features functionality.
* Pull Request #28: Remove backport of ``_bytecode_filenames`` which is
  available in Python 2.6 and later, but also has better compatibility with
  Python 3 environments.
* Issue #156: Fix spelling of __PYVENV_LAUNCHER__ variable.

Revision 1.21 / (download) - annotate - [select for diffs], Wed Feb 12 15:18:48 2014 UTC (9 years, 7 months ago) by wiz
Branch: MAIN
Changes since 1.20: +4 -4 lines
Diff to previous 1.20 (colored)

Update to 2.2:

---
2.2
---

* Issue #141: Restored fix for allowing setup_requires dependencies to
  override installed dependencies during setup.
* Issue #128: Fixed issue where only the first dependency link was honored
  in a distribution where multiple dependency links were supplied.

Revision 1.20 / (download) - annotate - [select for diffs], Mon Jan 27 19:10:06 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.19: +4 -4 lines
Diff to previous 1.19 (colored)

Update to 2.1:

---
2.1
---

* Issue #129: Suppress inspection of '*.whl' files when searching for files
  in a zip-imported file.
* Issue #131: Fix RuntimeError when constructing an egg fetcher.

Revision 1.19 / (download) - annotate - [select for diffs], Mon Jan 6 14:42:34 2014 UTC (9 years, 8 months ago) by wiz
Branch: MAIN
Changes since 1.18: +5 -5 lines
Diff to previous 1.18 (colored)

Update to 2.0.2:

-----
2.0.2
-----

* Fix NameError during installation with Python implementations (e.g. Jython)
  not containing parser module.
* Fix NameError in ``sdist:re_finder``.

-----
2.0.1
-----

* Issue #124: Fixed error in list detection in upload_docs.

---
2.0
---

* Issue #121: Exempt lib2to3 pickled grammars from DirectorySandbox.
* Issue #41: Dropped support for Python 2.4 and Python 2.5. Clients requiring
  setuptools for those versions of Python should use setuptools 1.x.
* Removed ``setuptools.command.easy_install.HAS_USER_SITE``. Clients
  expecting this boolean variable should use ``site.ENABLE_USER_SITE``
  instead.
* Removed ``pkg_resources.ImpWrapper``. Clients that expected this class
  should use ``pkgutil.ImpImporter`` instead.

-----
1.4.2
-----

* Issue #116: Correct TypeError when reading a local package index on Python
  3.

-----
1.4.1
-----

* Issue #114: Use ``sys.getfilesystemencoding`` for decoding config in
  ``bdist_wininst`` distributions.

* Issue #105 and Issue #113: Establish a more robust technique for
  determining the terminal encoding::

    1. Try ``getpreferredencoding``
    2. If that returns US_ASCII or None, try the encoding from
       ``getdefaultlocale``. If that encoding was a "fallback" because Python
       could not figure it out from the environment or OS, encoding remains
       unresolved.
    3. If the encoding is resolved, then make sure Python actually implements
       the encoding.
    4. On the event of an error or unknown codec, revert to fallbacks
       (UTF-8 on Darwin, ASCII on everything else).
    5. On the encoding is 'mac-roman' on Darwin, use UTF-8 as 'mac-roman' was
       a bug on older Python releases.

    On a side note, it would seem that the encoding only matters for when SVN
    does not yet support ``--xml`` and when getting repository and svn version
    numbers. The ``--xml`` technique should yield UTF-8 according to some
    messages on the SVN mailing lists. So if the version numbers are always
    7-bit ASCII clean, it may be best to only support the file parsing methods
    for legacy SVN releases and support for SVN without the subprocess command
    would simple go away as support for the older SVNs does.

---
1.4
---

* Issue #27: ``easy_install`` will now use credentials from .pypirc if
  present for connecting to the package index.
* Pull Request #21: Omit unwanted newlines in ``package_index._encode_auth``
  when the username/password pair length indicates wrapping.

-----
1.3.2
-----

* Issue #99: Fix filename encoding issues in SVN support.

-----
1.3.1
-----

* Remove exuberant warning in SVN support when SVN is not used.

Revision 1.18 / (download) - annotate - [select for diffs], Mon Nov 4 21:33:08 2013 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.17: +4 -4 lines
Diff to previous 1.17 (colored)

Update to 1.3:

---
1.3
---

* Address security vulnerability in SSL match_hostname check as reported in
  Python #17997.
* Prefer `backports.ssl_match_hostname
  <https://pypi.python.org/pypi/backports.ssl_match_hostname>`_ for backport
  implementation if present.
* Correct NameError in ``ssl_support`` module (``socket.error``).

Revision 1.17 / (download) - annotate - [select for diffs], Sun Nov 3 15:59:41 2013 UTC (9 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.16: +4 -4 lines
Diff to previous 1.16 (colored)

Update to 1.2:

---
1.2
---

* Issue #26: Add support for SVN 1.7. Special thanks to Philip Thiem for the
  contribution.
* Issue #94: Wheels are now distributed with every release.
* Setuptools "natural" launcher support, introduced in 1.0, is now officially
  supported.

-----
1.1.7
-----

* Fixed behavior of NameError handling in 'script template (dev).py' (script
  launcher for 'develop' installs).
* ``ez_setup.py`` now ensures partial downloads are cleaned up following
  a failed download.
* Distribute #363 and Issue #55: Skip an sdist test that fails on locales
  other than UTF-8.

Revision 1.16 / (download) - annotate - [select for diffs], Mon Sep 30 18:21:50 2013 UTC (10 years ago) by wiz
Branch: MAIN
Changes since 1.15: +4 -4 lines
Diff to previous 1.15 (colored)

Update to 1.1.6:

-----
1.1.6
-----

* Distribute #349: ``sandbox.execfile`` now opens the target file in binary
  mode, thus honoring a BOM in the file when compiled.

Revision 1.15 / (download) - annotate - [select for diffs], Sun Sep 15 17:30:50 2013 UTC (10 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.14: +4 -4 lines
Diff to previous 1.14 (colored)

Update to 1.1.5, and comment post-install rule.

-----
1.1.5
-----

* Issue #69: Second attempt at fix (logic was reversed).

Revision 1.14 / (download) - annotate - [select for diffs], Mon Sep 9 20:37:42 2013 UTC (10 years ago) by wiz
Branch: MAIN
Changes since 1.13: +4 -4 lines
Diff to previous 1.13 (colored)

Update to 1.1.4:

-----
1.1.4
-----

* Issue #77: Fix error in upload command (Python 2.4).

-----
1.1.3
-----

* Fix NameError in previous patch.

-----
1.1.2
-----

* Issue #69: Correct issue where 404 errors are returned for URLs with
  fragments in them (such as #egg=).

-----
1.1.1
-----

* Issue #75: Add ``--insecure`` option to ez_setup.py to accommodate
  environments where a trusted SSL connection cannot be validated.
* Issue #76: Fix AttributeError in upload command with Python 2.4.

Revision 1.13 / (download) - annotate - [select for diffs], Mon Sep 2 16:12:49 2013 UTC (10 years, 1 month ago) by wiz
Branch: MAIN
Changes since 1.12: +4 -4 lines
Diff to previous 1.12 (colored)

Update to 1.1:

---
1.1
---

* Issue #71 (Distribute Issue #333): EasyInstall now puts less emphasis on the
  condition when a host is blocked via ``--allow-hosts``.
* Issue #72: Restored Python 2.4 compatibility in ``ez_setup.py``.

---
1.0
---

* Issue #60: On Windows, Setuptools supports deferring to another launcher,
  such as Vinay Sajip's `pylauncher <https://bitbucket.org/pypa/pylauncher>`_
  (included with Python 3.3) to launch console and GUI scripts and not install
  its own launcher executables. This experimental functionality is currently
  only enabled if  the ``SETUPTOOLS_LAUNCHER`` environment variable is set to
  "natural". In the future, this behavior may become default, but only after
  it has matured and seen substantial adoption. The ``SETUPTOOLS_LAUNCHER``
  also accepts "executable" to force the default behavior of creating launcher
  executables.
* Issue #63: Bootstrap script (ez_setup.py) now prefers Powershell, curl, or
  wget for retrieving the Setuptools tarball for improved security of the
  install. The script will still fall back to a simple ``urlopen`` on
  platforms that do not have these tools.
* Issue #65: Deprecated the ``Features`` functionality.
* Issue #52: In ``VerifyingHTTPSConn``, handle a tunnelled (proxied)
  connection.

Backward-Incompatible Changes
=============================

This release includes a couple of backward-incompatible changes, but most if
not all users will find 1.0 a drop-in replacement for 0.9.

* Issue #50: Normalized API of environment marker support. Specifically,
  removed line number and filename from SyntaxErrors when returned from
  `pkg_resources.invalid_marker`. Any clients depending on the specific
  string representation of exceptions returned by that function may need to
  be updated to account for this change.
* Issue #50: SyntaxErrors generated by `pkg_resources.invalid_marker` are
  normalized for cross-implementation consistency.
* Removed ``--ignore-conflicts-at-my-risk`` and ``--delete-conflicting``
  options to easy_install. These options have been deprecated since 0.6a11.

Revision 1.12 / (download) - annotate - [select for diffs], Sun Jul 28 20:42:35 2013 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.11: +4 -4 lines
Diff to previous 1.11 (colored)

Update to 0.9.8:

-----
0.9.8
-----

* Issue #53: Fix NameErrors in `_vcs_split_rev_from_url`.

-----
0.9.7
-----

* Issue #49: Correct AttributeError on PyPy where a hashlib.HASH object does
  not have a `.name` attribute.
* Issue #34: Documentation now refers to bootstrap script in code repository
  referenced by bookmark.
* Add underscore-separated keys to environment markers (markerlib).

Revision 1.11 / (download) - annotate - [select for diffs], Sun Jul 21 20:31:52 2013 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.10: +4 -4 lines
Diff to previous 1.10 (colored)

Update to 0.9.6:

-----
0.9.6
-----

* Issue #44: Test failure on Python 2.4 when MD5 hash doesn't have a `.name`
  attribute.

-----
0.9.5
-----

* Python #17980: Fix security vulnerability in SSL certificate validation.

-----
0.9.4
-----

* Issue #43: Fix issue (introduced in 0.9.1) with version resolution when
  upgrading over other releases of Setuptools.

-----
0.9.3
-----

* Issue #42: Fix new ``AttributeError`` introduced in last fix.

-----
0.9.2
-----

* Issue #42: Fix regression where blank checksums would trigger an
  ``AttributeError``.

-----
0.9.1
-----

* Distribute #386: Allow other positional and keyword arguments to os.open.
* Corrected dependency on certifi mis-referenced in 0.9.

Revision 1.10 / (download) - annotate - [select for diffs], Sun Jul 14 17:37:02 2013 UTC (10 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.9: +4 -4 lines
Diff to previous 1.9 (colored)

Update to 0.9:

---
0.9
---

* `package_index` now validates hashes other than MD5 in download links.

Revision 1.9 / (download) - annotate - [select for diffs], Sun Jul 7 06:28:05 2013 UTC (10 years, 2 months ago) by richard
Branch: MAIN
Changes since 1.8: +4 -4 lines
Diff to previous 1.8 (colored)

Update to setuptools-0.8 and apply misc PLIST related fixes.

* Code base now runs on Python 2.4 - Python 3.3 without Python 2to3
  conversion.

Revision 1.8 / (download) - annotate - [select for diffs], Thu Jul 4 06:43:12 2013 UTC (10 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.7: +5 -5 lines
Diff to previous 1.7 (colored)

Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.

-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.

Revision 1.7 / (download) - annotate - [select for diffs], Sat Oct 31 02:10:34 2009 UTC (13 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4, pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3, pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4
Changes since 1.6: +4 -4 lines
Diff to previous 1.6 (colored)

Update to 0.6c11:

0.6c11

        * Fix "bdist_wininst upload" trying to upload same file twice

0.6c10

        * Fix for the Python 2.6.3 build_ext API change
        * Ensure C libraries (as opposed to extensions) are also built when doing bdist_egg
        * Support for SVN 1.6

Revision 1.6 / (download) - annotate - [select for diffs], Mon Sep 7 14:22:39 2009 UTC (14 years ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base, pkgsrc-2009Q3
Changes since 1.5: +5 -4 lines
Diff to previous 1.5 (colored)

Switch to the tgz sources and install as single version primitive.
Bump revision.

Revision 1.5 / (download) - annotate - [select for diffs], Sun Jan 18 14:50:20 2009 UTC (14 years, 8 months ago) by roy
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1
Changes since 1.4: +4 -4 lines
Diff to previous 1.4 (colored)

Bump to 0.6c9
Misc fixes including one for working with newer subversions.

ok: joerg

Revision 1.4 / (download) - annotate - [select for diffs], Thu Aug 21 16:26:35 2008 UTC (15 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, cube-native-xorg-base, cube-native-xorg
Changes since 1.3: +4 -4 lines
Diff to previous 1.3 (colored)

Update to py-setuptools-0.6c8:
- minor bugfixes, compatibility for Pyrex 0.9.6 and higher.

Revision 1.3 / (download) - annotate - [select for diffs], Thu Aug 9 13:22:14 2007 UTC (16 years, 1 month ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2008Q2-base, pkgsrc-2008Q2, pkgsrc-2008Q1-base, pkgsrc-2008Q1, pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, cwrapper
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

Update to py-setuptools-0.6c6:
- Add support for "eggsecutable" headers: a #!/bin/sh script that is
prepended to an .egg file to allow it to be run as a script on Unix-ish
platforms.
- Various bug fixes.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Jan 20 13:56:02 2007 UTC (16 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.1: +4 -4 lines
Diff to previous 1.1 (colored)

Update to setuptools-0.6c3.

0.6c3
        * Fixed breakages caused by Subversion 1.4's new "working copy"
          format

0.6c2
        * The ez_setup module displays the conflicting version of
          setuptools (and its installation location) when a script
          requests a version that's not available.
        * Running setup.py develop on a setuptools-using project will
          now install setuptools if needed, instead of only downloading
          the egg.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Nov 14 13:33:29 2006 UTC (16 years, 10 months ago) by joerg
Branch: TNF
CVS Tags: pkgsrc-base, pkgsrc-2006Q4-base, pkgsrc-2006Q4
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Reimport devel/py24-setuptools as devel/py-setuptools. This is in
principle usable on Python 2.3 as well, but not tested yet.

Revision 1.1 / (download) - annotate - [select for diffs], Tue Nov 14 13:33:29 2006 UTC (16 years, 10 months ago) by joerg
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>