The NetBSD Project

CVS log for pkgsrc/devel/py-ruamel-yaml/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-ruamel-yaml

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.31 / (download) - annotate - [select for diffs], Sat Jun 17 12:12:36 2023 UTC (3 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
Changes since 1.30: +4 -4 lines
Diff to previous 1.30 (colored)

py-ruamel-yaml: updated to 0.17.32

0.17.32
- fix issue with scanner getting stuck in infinite loop

Revision 1.30 / (download) - annotate - [select for diffs], Tue Jun 6 10:46:01 2023 UTC (3 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.29: +4 -4 lines
Diff to previous 1.29 (colored)

py-ruamel-yaml: update to 0.17.31.

[0, 17, 31]: 2023-05-31
  - added tag.setter on `ScalarEvent` and on `Node`, that takes either
    a `Tag` instance, or a str
    (reported by `Sorin Sbarnea <https://sourceforge.net/u/ssbarnea/profile/>`__)

[0, 17, 30]: 2023-05-30
  - fix issue 467, caused by Tag instances not being hashable (reported by
    `Douglas Raillard
    <https://bitbucket.org/%7Bcf052d92-a278-4339-9aa8-de41923bb556%7D/>`__)

[0, 17, 29]: 2023-05-30
  - changed the internals of the tag property from a string to a class which allows
    for preservation of the original handle and suffix. This should
    result in better results using documents with %TAG directives, as well
    as preserving URI escapes in tag suffixes.

Revision 1.29 / (download) - annotate - [select for diffs], Tue May 30 07:58:41 2023 UTC (3 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.28: +4 -4 lines
Diff to previous 1.28 (colored)

py-ruamel-yaml: update to 0.17.28.

[0, 17, 28]: 2023-05-26
  - fix for issue 464: documents ending with document end marker without final newline
    fail to load (reported by `Mariusz Rusiniak <https://sourceforge.net/u/r2dan/profile/>`__)

[0, 17, 27]: 2023-05-25
  - fix issue with inline mappings as value for merge keys
    (reported by Sirish on `StackOverflow <https://stackoverflow.com/q/76331049/1307905>`__)
  - fix for 468, error inserting after accessing merge attribute on ``CommentedMap``
    (reported by `Bastien gerard <https://sourceforge.net/u/bagerard/>`__)
  - fix for issue 461 pop + insert on same `CommentedMap` key throwing error
    (reported by `John Thorvald Wodder II <https://sourceforge.net/u/jwodder/profile/>`__)

Revision 1.28 / (download) - annotate - [select for diffs], Wed May 10 05:19:29 2023 UTC (4 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.27: +4 -4 lines
Diff to previous 1.27 (colored)

py-ruamel-yaml: updated to 0.17.26

0.17.26
- Fix for error on edge cage for issue 459

0.17.25
- fix for regression while dumping wrapped strings with too many backslashes removed

Revision 1.27 / (download) - annotate - [select for diffs], Sun May 7 08:40:15 2023 UTC (4 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.26: +4 -4 lines
Diff to previous 1.26 (colored)

py-ruamel-yaml: update to 0.17.24.

[0, 17, 24]: 2023-05-06
  - rewrite of ``CommentedMap.insert()``. If you have a merge key in
    the YAML document for the mapping you insert to, the position value should
    be the one as you look at the YAML input.
    This fixes issue 453 where other
    keys of a merged in mapping would show up after an insert (reported by
    `Alex Miller <https://sourceforge.net/u/millerdevel/profile/>`__). It
    also fixes a call to `.insert()` resulting into the merge key to move
    to be the first key if it wasn't already and it is also now possible
    to insert a key before a merge key (even if the fist key in the mapping).
  - fix (in the pure Python implementation including default) for issue 447.
    (reported by `Jack Cherng <https://sourceforge.net/u/jfcherng/profile/>`__,
    also brought up by brent on
    `StackOverflow <https://stackoverflow.com/q/40072485/1307905>`__)

[0, 17, 23]: 2023-05-05
  - fix 458, error on plain scalars starting with word longer than width.
    (reported by `Kyle Larose <https://sourceforge.net/u/klarose/profile/>`__)
  - fix for ``.update()`` no longer correctly handling keyword arguments
    (reported by John Lin on <StackOverflow
    `<https://stackoverflow.com/q/76089100/1307905>`__)
  - fix issue 454: high Unicode (emojis) in quoted strings always
    escaped (reported by `Michal iha <https://sourceforge.net/u/nijel/profile/>`__
    based on a question on StackOverflow).
  - fix issue with emitter conservatively inserting extra backslashes in wrapped
    quoted strings (reported by thebenman on `StackOverflow
    <https://stackoverflow.com/q/75631454/1307905>`__)

Revision 1.26 / (download) - annotate - [select for diffs], Thu May 4 17:23:59 2023 UTC (4 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.25: +4 -4 lines
Diff to previous 1.25 (colored)

py-ruamel-yaml: updated to 0.17.22

0.17.22
- fix issue 449 where the second exclamation marks got URL encoded (reported
  and fixing PR provided by `John Stark <https://sourceforge.net/u/jods/profile/>`__)
- fix issue with indent != 2 and literal scalars with empty first line
  (reported by wrdis on `StackOverflow <https://stackoverflow.com/q/75584262/1307905>`__)
- updated __repr__ of CommentedMap, now that Python's dict is ordered -> no more
  ordereddict(list-of-tuples)
- merge MR 4, handling OctalInt in YAML 1.1
  (provided by `Jacob Floyd <https://sourceforge.net/u/cognifloyd/profile/>`_)
- fix loading of `!!float 42` (reported by Eric on
  `Stack overflow <https://stackoverflow.com/a/71555107/1307905>`_)
- line numbers are now set on `CommentedKeySeq` and `CommentedKeyMap` (which
  are created if you have a sequence resp. mapping as the key in a mapping)
- plain scalars: put single words longer than width on a line of their own, instead
  of after the previous line (issue 427, reported by `Antoine Cotten
  <https://sourceforge.net/u/antoineco/profile/>`_). Caveat: this currently results in a
  space ending the previous line.
- fix for folded scalar part of 421: comments after ">" on first line of folded
  scalars are now preserved (as were those in the same position on literal scalars).
  Issue reported by Jacob Floyd.
- added stacklevel to warnings
- typing changed from Py2 compatible comments to Py3, removed various Py2-isms

Revision 1.25 / (download) - annotate - [select for diffs], Sat Feb 12 17:55:10 2022 UTC (19 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.24: +4 -4 lines
Diff to previous 1.24 (colored)

py-ruamel-yaml: updated to 0.17.21

0.17.21:
- fix bug in calling `.compose()` method with `pathlib.Path` instance.

Revision 1.24 / (download) - annotate - [select for diffs], Mon Jan 10 22:40:19 2022 UTC (20 months, 1 week ago) by wiz
Branch: MAIN
Changes since 1.23: +2 -1 lines
Diff to previous 1.23 (colored)

py-ruamel-yaml: fix installation

Revision 1.23 / (download) - annotate - [select for diffs], Tue Jan 4 12:35:59 2022 UTC (20 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.22: +4 -4 lines
Diff to previous 1.22 (colored)

py-ruamel-yaml: updated to 0.17.20

0.17.20
- fix error in microseconds while rounding datetime fractions >= 9999995

0.17.19
- fix mypy problems

0.17.18
- copy-paste error in folded scalar comment attachment
- fix 411, indent error comment between key empty seq value

Revision 1.22 / (download) - annotate - [select for diffs], Sun Nov 7 14:51:18 2021 UTC (22 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.21: +4 -4 lines
Diff to previous 1.21 (colored)

py-ruamel-yaml: updated to 0.17.17

0.17.17
- extract timestamp matching/creation to util

Revision 1.21 / (download) - annotate - [select for diffs], Tue Oct 26 10:19:03 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
Changes since 1.20: +2 -2 lines
Diff to previous 1.20 (colored)

archivers: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Could not be committed due to merge conflict:
devel/py-traitlets/distinfo

The following distfiles were unfetchable (note: some may be only fetched
conditionally):

./devel/pvs/distinfo pvs-3.2-solaris.tgz
./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip

Revision 1.20 / (download) - annotate - [select for diffs], Thu Oct 7 13:43:42 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.19: +1 -2 lines
Diff to previous 1.19 (colored)

devel: Remove SHA1 hashes for distfiles

Revision 1.19 / (download) - annotate - [select for diffs], Sat Oct 2 18:30:59 2021 UTC (23 months, 3 weeks ago) by adam
Branch: MAIN
Changes since 1.18: +5 -5 lines
Diff to previous 1.18 (colored)

py-ruamel-yaml: updated to 0.17.16

0.17.16:
- also handle issue 397 when comment is newline

Revision 1.18 / (download) - annotate - [select for diffs], Sun Aug 29 08:42:13 2021 UTC (2 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.17: +5 -5 lines
Diff to previous 1.17 (colored)

py-ruamel-yaml: updated to 0.17.15

0.17.15:
- fix issue 397, insert comment before key when a comment between key and value exists

Revision 1.17 / (download) - annotate - [select for diffs], Thu Aug 26 07:30:05 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.16: +5 -5 lines
Diff to previous 1.16 (colored)

py-ruamel-yaml: updated to 0.17.14

[0, 17, 14]: 2021-08-25
  - fix issue 396, inserting key/val in merged-in dictionary (reported by `Bastien gerard
    <https://sourceforge.net/u/bagerard/>`__)

[0, 17, 13]: 2021-08-21
  - minor fix in attr handling

[0, 17, 12]: 2021-08-21
  - fix issue with anchor on registered class not preserved and those classes using package
    attrs with `@attr.s()` (both reported by `ssph <https://sourceforge.net/u/sph/>`__)

[0, 17, 11]: 2021-08-19
  - fix error baseclass for ``DuplicateKeyErorr`` (reported by `ukasz Rogalski
    <https://sourceforge.net/u/lrogalski/>`__)
  - fix typo in reader error message, causing `KeyError` during reader error
    (reported by `MTU <https://sourceforge.net/u/mtu/>`__)

Revision 1.16 / (download) - annotate - [select for diffs], Fri Jul 9 18:33:40 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.15: +5 -5 lines
Diff to previous 1.15 (colored)

py-ruamel-yaml: updated to 0.17.10

0.17.10 (2021-06-24):
fix issue 388, token with old comment structure != two elements

0.17.9 (2021-06-10):
fix issue with updating CommentedMap

0.17.8 (2021-06-09):
fix for issue 387 where templated anchors on tagged object did get set resulting in potential id reuse.

0.17.7 (2021-05-31):
issue 385 also affected other deprecated loaders

0.17.6 (2021-05-31):
merged type annotations update provided by Jochen Sprickerhof
fix for issue 385: deprecated round_trip_loader function not working
wasted a few hours getting rid of mypy warnings/errors

0.17.5 (2021-05-30):
fix for issue 384 !!set with aliased entry resulting in broken YAML on rt

0.17.4 (2021-04-07):
prevent (empty) comments from throwing assertion error (issue 351 reported by William Kimball) comments (or empty line) will be dropped

0.17.3 (2021-04-07):
fix for issue 382 caused by an error in a format string
allow expansion of aliases by setting yaml.composer.return_alias = lambda s: copy.deepcopy(s)

0.17.2 (2021-03-29):
change -py2.py3-none-any.whl to -py3-none-any.whl, and remove 0.17.1

0.17.1 (2021-03-29):
added ãàϱrogramming Language :: Python :: 3 :: Onlyãà and removing 0.17.0 from PyPI

0.17.0 (2021-03-26):
removed because of incomplete classifiers
this release no longer supports Python 2.7, most if not all Python 2 specific code is removed. The 0.17.x series is the last to support Python 3.5 (this also allowed for removal of the dependency on ruamel.std.pathlib)
remove Python2 specific code branches and adaptations (u-strings)
prepare % code for f-strings using _F
allow PyOxidisation (issue 324 resp. issue 171)
replaced Python 2 compatible enforcement of keyword arguments with ãàãàthe old top level functions load, safe_load, round_trip_load, dump, safe_dump, round_trip_dump, scan, parse, compose, emit, serialize as well as their _all variants for multi-document streams, now issue a PendingDeprecationning (e.g. when run from pytest, but also Python is started with -Wd). Use the methods on YAML(), which have been extended.
fix for issue 376: indentation changes could put literal/folded scalar to start before the # column of a following comment. Effectively making the comment part of the scalar in the output.

Revision 1.15 / (download) - annotate - [select for diffs], Fri Mar 5 13:45:28 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.14: +5 -5 lines
Diff to previous 1.14 (colored)

py-ruamel-yaml: updated to 0.16.13

0.16.13:
- fix for issue 359: could not update() CommentedMap with keyword arguments
- fix for issue 365: unable to dump mutated TimeStamp objects
- fix for issue 371: unable to addd comment without starting space
- fix for issue 373: recursive call to walk_tree not preserving all params
- a None value in a flow-style sequence is now dumped as `null` instead
  of `!!null ''`

Revision 1.14 / (download) - annotate - [select for diffs], Sat Sep 5 07:06:43 2020 UTC (3 years ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.13: +5 -6 lines
Diff to previous 1.13 (colored)

py-ruamel-yaml: update to 0.16.12.

Changes not found, but fixes problem with setuptools 50.0.

Revision 1.13 / (download) - annotate - [select for diffs], Wed Sep 2 21:42:48 2020 UTC (3 years ago) by wiz
Branch: MAIN
Changes since 1.12: +2 -1 lines
Diff to previous 1.12 (colored)

*: fix some packages for py-setuptools 50.0.1

Revision 1.12 / (download) - annotate - [select for diffs], Wed Feb 19 09:41:50 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.11: +5 -5 lines
Diff to previous 1.11 (colored)

py-ruamel-yaml: updated to 0.16.10

[0, 16, 10]:
- (auto) updated image references in README to sourceforge

[0, 16, 9]:
- update CHANGES

[0, 16, 8]:
- update requirements so that ruamel.yaml.clib is installed for 3.8,
  as it has become available (via manylinux builds)

[0, 16, 7]:
- fix typchecking issue on TaggedScalar
- fix error in dumping literal scalar in sequence with comments before element

[0, 16, 6]:
- fix empty string mapping key roundtripping with preservation of quotes as `? ''`
- fix incorrect state setting in class constructor
- adjust deprecation warning test for Hashable, as that no longer warns

Revision 1.11 / (download) - annotate - [select for diffs], Tue Dec 17 10:11:28 2019 UTC (3 years, 9 months ago) by leot
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.10: +5 -5 lines
Diff to previous 1.10 (colored)

py-ruamel-yaml: Update to 0.16.5

pkgsrc changes:
 - Remove dependency to py-typing, no longer needed since version 0.14.9
 - Reset USE_LANGUAGES, C parts were splitted in py-ruamel-yaml-clib and a C
   compiler is no longer needed

Changes:
[0, 16, 5]: 2019-08-18
  - allow for ``YAML(typ=['unsafe', 'pytypes'])``

[0, 16, 4]: 2019-08-16
  - fix output of TAG directives with # (reported by `Thomas Smith
    <https://bitbucket.org/%7Bd4c57a72-f041-4843-8217-b4d48b6ece2f%7D/>`__)

[0, 16, 3]: 2019-08-15
  - move setting of version based on YAML directive to scanner, allowing to
    check for file version during TAG directive scanning

[0, 16, 2]: 2019-08-15
  - preserve YAML and TAG directives on roundtrip, correctly output #
    in URL for YAML 1.2 (both reported by `Thomas Smith
    <https://bitbucket.org/%7Bd4c57a72-f041-4843-8217-b4d48b6ece2f%7D/>`__)

[0, 16, 1]: 2019-08-08
  - Force the use of new version of ruamel.yaml.clib (reported by `Alex Joz
    <https://bitbucket.org/%7B9af55900-2534-4212-976c-61339b6ffe14%7D/>`__)
  - Allow '#' in tag URI as these are allowed in YAML 1.2 (reported by
    `Thomas Smith
    <https://bitbucket.org/%7Bd4c57a72-f041-4843-8217-b4d48b6ece2f%7D/>`__)

[0, 16, 0]: 2019-07-25
  - split of C source that generates .so file to ruamel.yaml.clib
  - duplicate keys are now an error when working with the old API as well

Revision 1.10 / (download) - annotate - [select for diffs], Tue Aug 13 22:50:51 2019 UTC (4 years, 1 month ago) by gdt
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.9: +5 -5 lines
Diff to previous 1.9 (colored)

devel/py-ruamel-yaml: Update to 0.15.100

(While 0.16.1 is current, that update perhaps is more complicated, so
I'm updating to the last release of 0.15 as an intermediate step.)

[0, 15, 100]: 2019-07-17
  - fixing issue with dumping deep-copied data from commented YAML, by
    providing both the memo parameter to __deepcopy__, and by allowing
    startmarks to be compared on their content (reported by `Theofilos
    Petsios
    <https://bitbucket.org/%7Be550bc5d-403d-4fda-820b-bebbe71796d3%7D/>`__)

[0, 15, 99]: 2019-07-12
  - add `py.typed` to distribution, based on a PR submitted by
    `Michael Crusoe
    <https://bitbucket.org/%7Bc9fbde69-e746-48f5-900d-34992b7860c8%7D/>`__
  - merge PR 40 (also by Michael Crusoe) to more accurately specify
    repository in the README (also reported in a misunderstood issue
    some time ago)

[0, 15, 98]: 2019-07-09
  - regenerate ext/_ruamel_yaml.c with Cython version 0.29.12, needed
    for Python 3.8.0b2 (reported by `John Vandenberg
    <https://bitbucket.org/%7B6d4e8487-3c97-4dab-a060-088ec50c682c%7D/>`__)

[0, 15, 97]: 2019-06-06
  - regenerate ext/_ruamel_yaml.c with Cython version 0.29.10, needed for
    Python 3.8.0b1
  - regenerate ext/_ruamel_yaml.c with Cython version 0.29.9, needed for
    Python 3.8.0a4 (reported by `Anthony Sottile
    <https://bitbucket.org/%7B569cc8ea-0d9e-41cb-94a4-19ea517324df%7D/>`__)

[0, 15, 96]: 2019-05-16
  - fix failure to indent comments on round-trip anchored block style
    scalars in block sequence (reported by `William Kimball
    <https://bitbucket.org/%7Bba35ed20-4bb0-46f8-bb5d-c29871e86a22%7D/>`__)

[0, 15, 95]: 2019-05-16
  - fix failure to round-trip anchored scalars in block sequence
    (reported by `William Kimball
    <https://bitbucket.org/%7Bba35ed20-4bb0-46f8-bb5d-c29871e86a22%7D/>`__)
  - wheel files for Python 3.4 no longer provided (`Python 3.4 EOL 2019-03-18
    <https://www.python.org/dev/peps/pep-0429/>`__)

Revision 1.9 / (download) - annotate - [select for diffs], Tue May 7 09:29:38 2019 UTC (4 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.8: +5 -5 lines
Diff to previous 1.8 (colored)

py-ruamel.yaml: updated to 0.15.94

0.15.94:
- fix missing line-break after end-of-file comments not ending in
  line-break

0.15.93:
- fix failure to parse empty implicit flow mapping key
- in YAML 1.1 plains scalars y, 'n', Y, and 'N' are now
  correctly recognised as booleans and such strings dumped quoted

0.15.92:
- fix failure to parse empty implicit block mapping key

0.15.91:
- allowing duplicate keys would not work for merge keys

0.15.90:
- fix issue with updating CommentedMap from list of tuples

0.15.89:
- fix for items with flow-mapping in block sequence output on single line
- fix for safe dumping erroring in creation of representereror when dumping namedtuple

0.15.88:
- fix inclusing of python code from the subpackage data

0.15.87:
- fix problem with empty lists and the code to reinsert merge keys

0.15.86:
- reinsert merge key in its old position
- fix for issue with non-ASCII anchor names
- fix for issue when parsing flow mapping value starting with colon (in pure Python only)

0.15.85:
- the types used by SafeConstructor for mappings and sequences can
  now by set by assigning to XXXConstructor.yaml_base_dict_type
  (and ..._list_type), preventing the need to copy two methods
  with 50+ lines that had var = {} hardcoded.

0.15.84:
- fix for CommentedMap.copy() not returning CommentedMap, let alone copying comments etc.

0.15.83:
- fix for bug in roundtripping aliases used as key

0.15.82:
- anchors and aliases on scalar int, float, string and bool are now preserved. Anchors
  do not need a referring alias for these
- anchors no longer lost on tagged objects when roundtripping

0.15.81:
 - fix issue saving methods of metaclass derived classes

0.15.80:
 - fix issue emitting BEL character when round-tripping invalid folded input

0.15.79:
- fix issue with anchors nested deeper than alias

0.15.78:
- fix setup issue for 3.8

0.15.77:
- setting yaml.sort_base_mapping_type_on_output = False, will prevent
  explicit sorting by keys in the base representer of mappings. Roundtrip
  already did not do this. Usage only makes real sense for Python 3.6+
- implement Python version check in YAML metadata in _test/test_z_data.py

0.15.76:
- fix issue with empty mapping and sequence loaded as flow-style

0.15.75:
- fix issue with single '?' scalar
- fix issue with duplicate merge keys

0.15.74:
- fix dropping of comment on rt before sequence item that is sequence item

0.15.73:
- fix irregular output on pre-comment in sequence within sequence
- allow non-compact (i.e. next line) dumping sequence/mapping within sequence.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Oct 14 16:26:51 2018 UTC (4 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.7: +5 -5 lines
Diff to previous 1.7 (colored)

py-ruamel-yaml: updated to 0.15.72

0.15.72:
- fix regression on explicit 1.1 loading with the C based scanner/parser

0.15.72:
- fix regression on explicit 1.1 loading with the C based scanner/parser

0.15.71:
- fix regression where handcrafted CommentedMaps could not be initiated
- fix regression with non-root literal scalars that needed indent indicator
- tag:yaml.org,2002:python/object/apply now also uses __qualname__ on PY3

0.15.70:
- reverted CommentedMap and CommentedSeq to subclass ordereddict resp. list,
  reimplemented merge maps so that both dict(**commented_map_instance) and JSON
  dumping works. This also allows checking with isinstance() on dict resp. list.

0.15.69:
- fix issue with dump_all gobbling end-of-document comments on parsing

0.15.68:
- fix issue with parsabel, but incorrect output with nested flow-style sequences
- fix issue with loading Python objects that have __setstate__ and recursion in parameters

0.15.67:
- fix issue with extra space inserted with non-root literal strings

0.15.66:
- fix issue with fold indicating characters inserted in safe_load-ed folded strings

0.15.65:
- fix issue 232 revert to throw ParserError for unexcpected ]
  and } instead of IndexError.
- added key and reverse parameter (suggested by Jannik Klemm via email)
- indent root level literal scalars that have directive or document end markers
  at the beginning of a line

0.15.64:
- support round-trip of tagged sequences: !Arg [a, {b: 1}]
- single entry mappings in flow sequences now written by default without quotes
  set yaml.brace_single_entry_mapping_in_flow_sequence=True to force
  getting [a, {b: 1}, {c: {d: 2}}] instead of the default [a, b: 1, c: {d: 2}]
- fix issue when roundtripping floats starting with a dot such as .5

0.15.63:
- small fix only necessary for Windows users that don't use wheels.

0.15.62:
- C based reader/scanner & emitter now allow setting of 1.2 as YAML version.
  ** The loading/dumping is still YAML 1.1 code**, so use the common subset of
  YAML 1.2 and 1.1

0.15.61:
- support for round-tripping folded style scalars
- update of C code
- speed up of scanning (~30% depending on the input)

0.15.60:
- cleanup for mypy
- spurious print in library

0.15.59:
- issue with C based loader and leading zeros

0.15.59:
- issue with C based loader and leading zeros

0.15.58:
- simple mappings can now be used as keys when round-tripping::

    {a: 1, b: 2}: hello world

  although using the obvious operations (del, popitem) on the key will
  fail, you can mutilate it by going through its attributes. If you load the
  above YAML in d, then changing the value is cumbersome:

      d = {CommentedKeyMap([('a', 1), ('b', 2)]): "goodbye"}

  and changing the key even more so:

      d[CommentedKeyMap([('b', 1), ('a', 2)])] = d.pop(
                   CommentedKeyMap([('a', 1), ('b', 2)]))

  (you can use a dict instead of a list of tuples (or ordereddict), but that might result
  in a different order, of the keys of the key, in the output)
- check integers to dump with 1.2 patterns instead of 1.1

0.15.57:
- Fix that CommentedSeq could no longer be used in adding or do a copy

0.15.56:
- fix issue with python -O optimizing away code

0.15.55:
- unmade CommentedSeq a subclass of list. It is now
  indirectly a subclass of the standard
  collections.abc.MutableSequence (without .abc if you are
  still on Python2.7). If you do isinstance(yaml.load('[1, 2]'),
  list)) anywhere in your code replace list with
  MutableSequence.  Directly, CommentedSeq is a subclass of
  the abstract baseclass ruamel.yaml.compat.MutableScliceableSequence,
  with the result that *(extended) slicing is supported on
  CommentedSeq*.
- duplicate keys (or their values) with non-ascii now correctly
  report in Python2, instead of raising a Unicode error.

Revision 1.7 / (download) - annotate - [select for diffs], Tue Aug 14 14:54:26 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.6: +5 -5 lines
Diff to previous 1.6 (colored)

py-ruamel-yaml: updated to 0.15.54

[0, 15, 54]:
  - fix issue where a comment could pop-up twice in the output
  - fix issue where JSON object (mapping) without spaces was not parsed
    properly
  - fix issue where comments after empty flow-style mappings were not emitted

[0, 15, 53]:
  - fix issue with flow style mapping with comments gobbled newline
  - fix issue where single '+' under YAML 1.2 was interpreted as
    integer, erroring out

[0, 15, 52]:
  - added .copy() mapping representation for round-tripping
    (CommentedMap) to fix incomplete copies of merged mappings
  - Also unmade that class a subclass of ordereddict to solve incorrect behaviour
    for {**merged-mapping} and dict(**merged-mapping)

[0, 15, 51]:
  - Fix method name dumps (were not dotted) and loads (reported by Douglas Raillard
  - Fix spurious trailing white-space caused when the comment start
    column was no longer reached and there was no actual EOL comment
    (e.g. following empty line) and doing substitutions, or when
    quotes around scalars got dropped.

[0, 15, 50]:
  - Allow YAML() as a context manager for output, thereby making it much easier
    to generate multi-documents in a stream.
  - Fix issue with incorrect type information for load() and dump()

Revision 1.6 / (download) - annotate - [select for diffs], Fri Jul 13 08:06:39 2018 UTC (5 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.5: +5 -5 lines
Diff to previous 1.5 (colored)

py-ruamel-yaml: updated to 0.15.43

0.15.43:
merge PR33: Python2.7 on Windows is narrow, but has no sysconfig.get_config_var('Py_UNICODE_SIZE').
register_class() now returns class

Revision 1.5 / (download) - annotate - [select for diffs], Tue Jul 3 12:27:03 2018 UTC (5 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.4: +5 -5 lines
Diff to previous 1.4 (colored)

py-ruamel-yaml: updated to 0.15.42

0.15.42:
fix regression showing only on narrow Python 2.7 (py27mu) builds
run pre-commit tox on Python 2.7 wide and narrow, as well as 3.4/3.5/3.6/3.7/pypy

0.15.41:
add detection of C-compile failure, which was removed while no longer dependent on libyaml, C-extensions compilation still needs a compiler though.

0.15.40:
added links to landing places as suggested in issue 190
fixes issue 201: decoding unicode escaped tags on Python2

0.15.39:
merge P.R.27 improving package startup time (and loading when regexp not actually used)

0.15.38:
fix for losing precision when roundtripping floats
fix for hardcoded dir separator not working for Windows

0.15.37:
again trying to create installable files for 187

0.15.36:
fix issue 187, incompatibility of C extension with 3.7

Revision 1.4 / (download) - annotate - [select for diffs], Thu Dec 14 13:21:02 2017 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.3: +5 -5 lines
Diff to previous 1.3 (colored)

py-ruamel-yaml: updated to 0.15.35

[0, 15, 35]:
- allow None as stream when specifying transform parameters to
  YAML.dump().
  This is useful if the transforming function doesn't return a meaningful value

Revision 1.3 / (download) - annotate - [select for diffs], Sat Oct 28 08:51:25 2017 UTC (5 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.2: +5 -5 lines
Diff to previous 1.2 (colored)

py-ruamel-yaml: updated to 0.15.34

0.15.34:
- fix for issue 157: CDumper not dumping floats

Revision 1.2 / (download) - annotate - [select for diffs], Fri Apr 14 13:05:06 2017 UTC (6 years, 5 months ago) by leot
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.1: +5 -5 lines
Diff to previous 1.1 (colored)

Update devel/py-ruamel-yaml to 0.14.6

Changes:
[0, 14, 6]: 2017-04-14
  - binary, octal and hex integers are now preserved by default. This
    was a known deficiency. Working on this was prompted by the issue report (112)
    from devnoname120, as well as the additional experience with `.replace()`
    on `scalarstring` classes.
  - fix issues 114: cannot install on Buildozer (reported by mixmastamyk).
    Setting env. var ``RUAMEL_NO_PIP_INSTALL_CHECK`` will suppress ``pip``-check.

[0, 14, 5]: 2017-04-04
  - fix issue 109: None not dumping correctly at top level (reported by Andrea Censi)
  - fix issue 110: .replace on Preserved/DoubleQuoted/SingleQuoted ScalarString
    would give back "normal" string (reported by sandres23)

[0, 14, 4]: 2017-03-31
  - fix readme

[0, 14, 3]: 2017-03-31
  - fix for 0o52 not being a string in YAML 1.1 (reported on
    `StackOverflow Q&A 43138503><http://stackoverflow.com/a/43138503/1307905>`_ by
    `Frank D <http://stackoverflow.com/users/7796630/frank-d>`_

[0, 14, 2]: 2017-03-23
  - fix for old default pip on Ubuntu 14.04 (reported by Sébastien Maccagnoni-Munch)

0.14.1: 2017-03-22
  - fix Text not available on 3.5.0 and 3.5.1 (reported by Charles Bouchard-Légaré)

0.14.0: 2017-03-21
  - updates for mypy --strict
  - preparation for moving away from inheritance in Loader and Dumper, calls from e.g.
    the Representer to the Serializer.serialize() are now done via the attribute
    .serializer.serialize(). Usage of .serialize() outside of Serializer will be
    deprecated soon
  - some extra tests on main.py functions

0.13.14: 2017-02-12
  - fix for issue 97: clipped block scalar followed by empty lines and comment
    would result in two CommentTokens of which the first was dropped.
    (reported by Colm O'Connor)

0.13.13: 2017-01-28
  - fix for issue 96: prevent insertion of extra empty line if indented mapping entries
    are separated by an empty line (reported by Derrick Sawyer)

0.13.11: 2017-01-23
  - allow ':' in flow style scalars if not followed by space. Also don't
    quote such scalar as this is no longer necessary.
  - add python 3.6 manylinux wheel to PyPI

0.13.10: 2017-01-22
  - fix for issue 93, insert spurious blank line before single line comment
    between indented sequence elements (reported by Alex)

0.13.9: 2017-01-18
  - fix for issue 92, wrong import name reported by the-corinthian

0.13.8: 2017-01-18
  - fix for issue 91, when a compiler is unavailable reported by Maximilian Hils
  - fix for deepcopy issue with TimeStamps not preserving 'T', reported on
    `StackOverflow Q&A <http://stackoverflow.com/a/41577841/1307905>`_ by
    `Quuxplusone <http://stackoverflow.com/users/1424877/quuxplusone>`_

0.13.7: 2016-12-27
  - fix for issue 85, constructor.py importing unicode_literals caused mypy to fail
    on 2.7 (reported by Peter Amstutz)

0.13.6: 2016-12-27
  - fix for issue 83, collections.OrderedDict not representable by SafeRepresenter
    (reported by Frazer McLean)

0.13.5: 2016-12-25
  - fix for issue 84, deepcopy not properly working (reported by Peter Amstutz)

0.13.4: 2016-12-05
  - another fix for issue 82, change to non-global resolver data broke implicit type
    specification

0.13.3: 2016-12-05
  - fix for issue 82, deepcopy not working (reported by code monk)

0.13.2: 2016-11-28
  - fix for comments after empty (null) values  (reported by dsw2127 and cokelaer)

0.13.1: 2016-11-22
  - optimisations on memory usage when loading YAML from large files (py3: -50%, py2: -85%)

0.13.0: 2016-11-20
  - if ``load()`` or ``load_all()`` is called with only a single argument
    (stream or string)
    a UnsafeLoaderWarning will be issued once. If appropriate you can surpress this
    warning by filtering it. Explicitly supplying the ``Loader=ruamel.yaml.Loader``
    argument, will also prevent it from being issued. You should however consider
    using ``safe_load()``, ``safe_load_all()`` if your YAML input does not use tags.
  - allow adding comments before and after keys (based on
    `StackOveflow Q&A <http://stackoverflow.com/a/40705671/1307905>`_  by
    `msinn <http://stackoverflow.com/users/7185467/msinn>`_)

0.12.18: 2016-11-16
  - another fix for numpy (re-reported independently by PaulG & Nathanial Burdic)

0.12.17: 2016-11-15
  - only the RoundTripLoader included the Resolver that supports YAML 1.2
    now all loaders do (reported by mixmastamyk)

0.12.16: 2016-11-13
  - allow dot char (and many others) in anchor name
    Fix issue 72 (reported by Shalon Wood)
  - Slightly smarter behaviour dumping strings when no style is
    specified. Single string scalars that start with single quotes
    or have newlines now are dumped double quoted: "'abc\nklm'" instead of::

      '''abc

        klm'''

0.12.14: 2016-09-21
 - preserve round-trip sequences that are mapping keys
   (prompted by stackoverflow question 39595807 from Nowox)

0.12.13: 2016-09-15
 - Fix for issue #60 representation of CommentedMap with merge
   keys incorrect (reported by Tal Liron)

0.12.11: 2016-09-06
 - Fix issue 58 endless loop in scanning tokens (reported by
   Christopher Lambert)

0.12.10: 2016-09-05
 - Make previous fix depend on unicode char width (32 bit unicode support
   is a problem on MacOS reported by David Tagatac)

0.12.8: 2016-09-05
  - To be ignored Unicode characters were not properly regex matched
    (no specific tests, PR by Haraguroicha Hsu)

0.12.7: 2016-09-03
  - fixing issue 54 empty lines with spaces (reported by Alex Harvey)

0.12.6: 2016-09-03
  - fixing issue 46 empty lines between top-level keys were gobbled (but
    not between sequence elements, nor between keys in netsted mappings
    (reported by Alex Harvey)

0.12.5: 2016-08-20
  - fixing issue 45 preserving datetime formatting (submitted by altuin)
    Several formatting parameters are preserved with some normalisation:
  - preserve 'T', 't' is replaced by 'T', multiple spaces between date
    and time reduced to one.
  - optional space before timezone is removed
  - still using microseconds, but now rounded (.1234567 -> .123457)
  - Z/-5/+01:00 preserved

0.12.4: 2016-08-19
  - Fix for issue 44: missing preserve_quotes keyword argument (reported
    by M. Crusoe)

0.12.3: 2016-08-17
  - correct 'in' operation for merged CommentedMaps in round-trip mode
    (implementation inspired by J.Ngo, but original not working for merges)
  - iteration over round-trip loaded mappings, that contain merges. Also
    keys(), items(), values() (Py3/Py2) and iterkeys(), iteritems(),
    itervalues(), viewkeys(), viewitems(), viewvalues() (Py2)
  - reuse of anchor name now generates warning, not an error. Round-tripping such
    anchors works correctly. This inherited PyYAML issue was brought to attention
    by G. Coddut (and was long standing https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=515634)
    suppressing the warning::

        import warnings
        from ruamel.yaml.error import ReusedAnchorWarning
        warnings.simplefilter("ignore", ReusedAnchorWarning)

0.12.2: 2016-08-16
  - minor improvements based on feedback from M. Crusoe
    https://bitbucket.org/ruamel/yaml/issues/42/

0.12.0: 2016-08-16
  - drop support for Python 2.6
  - include initial Type information (inspired by M. Crusoe)

0.11.15: 2016-08-07
  - Change to prevent FutureWarning in NumPy, as reported by tgehring
    ("comparison to None will result in an elementwise object comparison in the future")

0.11.14: 2016-07-06
  - fix preserve_quotes missing on original Loaders (as reported
    by Leynos, bitbucket issue 38)

0.11.13: 2016-07-06
  - documentation only, automated linux wheels

0.11.12: 2016-07-06
  - added support for roundtrip of single/double quoted scalars using:
    ruamel.yaml.round_trip_load(stream, preserve_quotes=True)

0.11.10: 2016-05-02
  - added .insert(pos, key, value, comment=None) to CommentedMap

0.11.10: 2016-04-19
  - indent=2, block_seq_indent=2 works as expected

0.11.0: 2016-02-18
  - RoundTripLoader loads 1.2 by default (no sexagesimals, 012 octals nor
    yes/no/on/off booleans

Revision 1.1 / (download) - annotate - [select for diffs], Mon May 16 13:52:54 2016 UTC (7 years, 4 months ago) by nils
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2

Initial import of py-ruamel-yaml, version 0.10.23,
into the NetBSD Packages Collection.

ruamel.yaml is a YAML parser/emitter that supports roundtrip preservation
of comments, seq/map flow style, and map key order

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>