The NetBSD Project

CVS log for pkgsrc/devel/py-rope/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-rope

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.38 / (download) - annotate - [select for diffs], Thu Nov 9 19:15:57 2023 UTC (3 weeks ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.37: +5 -5 lines
Diff to previous 1.37 (colored)

py-rope: updated to 1.11.0

1.11.0

- Implement `except*` syntax
- allow building documentation without having rope module installed
- Allows the in-memory db to be shared across threads
- create one sqlite3.Connection per thread using a thread local
- change AutoImport's `get_modules` to be case sensitive

Revision 1.37 / (download) - annotate - [select for diffs], Tue Nov 7 22:38:00 2023 UTC (3 weeks, 2 days ago) by wiz
Branch: MAIN
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

*: latest py-sphinx only support Python 3.9+

Revision 1.36 / (download) - annotate - [select for diffs], Mon Oct 23 06:37:42 2023 UTC (5 weeks, 4 days ago) by wiz
Branch: MAIN
Changes since 1.35: +3 -2 lines
Diff to previous 1.35 (colored)

*: update for Python base package change

Instead of depending on one of the removed packages (that are now included
in the base Python packages), include batteries-included.mk to require
a Python version that supplies them.

Remove now included packages.

Bump PKGREVISION.

Revision 1.35 / (download) - annotate - [select for diffs], Wed Oct 4 20:21:18 2023 UTC (8 weeks, 1 day ago) by adam
Branch: MAIN
Changes since 1.34: +2 -2 lines
Diff to previous 1.34 (colored)

py-rope: updated to 1.10.0

Release 1.10.0

- Add support for Python 3.12

Revision 1.34 / (download) - annotate - [select for diffs], Tue Jul 4 13:15:37 2023 UTC (4 months, 4 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

py-rope: updated to 1.9.0

Release 1.9.0
- Implement `nonlocal` keyword
- Automatically purge autoimport.db when there is schema change

Revision 1.33 / (download) - annotate - [select for diffs], Sun May 7 08:39:16 2023 UTC (6 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.32: +2 -2 lines
Diff to previous 1.32 (colored)

py-rope: update to 1.8.0.

# Release 1.8.0

- #650 Install pre-commit hooks on rope repository (@lieryan)
- #655 Remove unused __init__() methods (@edreamleo, @lieryan)
- #656 Reformat using black 23.1.0 (@edreamleo)
- #674 Fix/supress all mypy complaints (@edreamleo)
- #680 Remove a do-nothing statement in soi._handle_first_parameter (@edreamleo)
- #687, #688 Fix autoimport not scanning packages recursively (@lieryan)

Revision 1.32 / (download) - annotate - [select for diffs], Thu May 4 10:03:52 2023 UTC (6 months, 4 weeks ago) by wiz
Branch: MAIN
Changes since 1.31: +4 -2 lines
Diff to previous 1.31 (colored)

py-rope: update to 1.7.0.

# Release 1.7.0

## Feature

- #548 Implement MoveGlobal using string as destination module names (@lieryan)

## Bug

- #627 Fix parsing of octal literal (@lieryan)
- #643, #435 Fix fstrings with mismatched parens (@apmorton)
- #646 Fix renaming kwargs when refactoring from imports (@apmorton)
- #648 Remove __init__ from import statement when using sqlite autoimport (@bagel897)

## Improvements

- rope.contrib.generate improvements
  - #640 Remove unnecessary eval in generate.py (@edreamleo)
  - #641 Add type annotations for rope.contrib.generate.create_generate() (@edreamleo)

- call_for_nodes() improvements
  - #634 Remove call_for_nodes(recursive) argument (@edreamleo)
  - #642 Add comments & docstrings related to call_for_nodes (@edreamleo, @lieryan)

- Data storage improvements
  - #604 Fix test that sometimes leaves files behind in the current working directory (@lieryan)
  - #606 Deprecate compress_objectdb and compress_history (@lieryan)
  - #607 Remove importing from legacy files with `.pickle` suffix (@lieryan)
  - #611 Implement JSON DataFile serialization (@lieryan)
  - #630 SQLite models improvements (@lieryan)
  - #631 Implement version hash (@lieryan)

## Tech Debt

- #594 Tidy up patchedast (@Alex-CodeLab)
- #595 Global default DEFAULT_TASK_HANDLE (@Alex-CodeLab)
- #609, #610, #612, #613 Fix pyflakes issues (@edreamleo)
- #615 Remove 'unicode' from builtins dict (@edreamleo)
- #616, #621 Remove `file` builtins (@edreamleo)
- #618 Separate pynames and pynamesdef and remove star-import (@edreamleo, @lieryan)
- #620 Remove unused import in occurrences.py (@edreamleo)
- #625 Remove support for deprecated ast nodes (@lieryan)


## Tests/Dev

- #626 Install pre-commit hooks on rope repository (@lieryan)
- #628 Add isort to pre-commit
- #638 Add a function to identify ast Constant nodes more granularly

## Docs

- #636 Update readme to reflect 1.0 has been released.


# Release 1.6.0

## New features & Enhancements

- #559, #560 Improve handling of whitespace in import and from-import statements (@lieryan)
- #566, #567, #597 Fix variables in kwonlyargs and posonlyargs not being correctly passed to extracted methods (@lieryan)

## Unit Test

- #589, #596 Fix issue with `sample_project()` creating directories where it shouldn't when running tests (@lieryan)
- #547 Add config file for linters
- #593 Remove `only_for` decorator for all python versions less than 3.7 (@edreamleo)

## Tech Debt

- Code quality
  - #546 Remove unused vars in test (@lieryan, @edreamleo)
  - #551, #552 Numerous flake8 linter complaints (@edreamleo)
  - #558 Fix typos (@kianmeng)
  - #583, #584 More consistent import style (@edreamleo)
- Python 2-related tech debt
  - #533 Refactoring to Remove usage of unicode type (@lieryan)
  - #549, #553 Remove rope.base.utils.pycompat (@dreamleo)
  - #555 Fix some python2-isms (@lieryan)
- Rope's AST Wrapper
  - #536, #578 walk does not return a value (@edreamleo)
  - #537, #538 Remove special case code from walk (@edreamleo)
  - #581 Remove functions in rope.base.ast that has functionally identical implementation in stdlib's ast (@lieryan, @edreamleo)
  - #582 Refactoring rope.base.ast and remove rope.base.astutils (@lieryan, @edreamleo)
- pynames and pyobjects
  - #569, #572 rename pynames to pynamesdef in pyobjectsdef.ph (@edreamleo)


# Release 1.5.1

- #531 Add alternative way to retrieve version number from pyproject.toml

# Release 1.5.0

Date: 2022-11-23

- #492 Feat: Global configuration support (@bagel897)
- #519 Move pytest to pyproject.toml (@gliptak, @bagel897)
- #509 Fix read/write analysis of the left-hand side of an augmented assignment (@lieryan)
- #522 Implement patchedast parsing of MatchMapping (@lieryan)
- #514 Fix inlining dictionary with inline comment (@lieryan)


# Release 1.4.0

Date: 2022-10-22

## Bug fixes

- #506, #507 Fix issue with parsing function call args list
- #411, #505 Fix extracting generator without parens
- #18, #510 When the function is a builtin function, the call parameter's name was sometimes incorrectly identified as an AssignedName. This led to rename refactoring incorrectly renaming these parameters.


# Release 1.3.0

Date: 2022-07-29

## Bug fixes

- #496, #497 Add MatMul operator to patchedast
- #495 Fix autoimport collection for compiled modules

## Improvement

- #501, #502 Autoimport improvements


# Release 1.2.0

Date: 2022-04-22

## New feature

- #473 Pyproject.toml support (@bageljrkhanofemus)
- #489 Rope now publishes documentations to rope.readthedocs.org (@bageljrkhanofemus)
- #490 Migrate from setup.py to pyproject.toml (@bageljrkhanofemus)

## Improvement

- #479 Add ABC and type hints for TaskHandle and JobSet (@bageljrkhanofemus)
- #486 Drop Python 2 support (@bageljrkhanofemus, @lieryan)
- #487 Improved value inference of __all__ declaration (@lieryan)
- #424 Add some basic __repr__ to make it easier for debugging (@lieryan)

Revision 1.31 / (download) - annotate - [select for diffs], Sun Apr 30 18:24:21 2023 UTC (7 months ago) by wiz
Branch: MAIN
Changes since 1.30: +4 -2 lines
Diff to previous 1.30 (colored)

py-rope: update to 1.1.1.

(1.2 and newer need unpackaged pytoolconfig)

Release 1.1.1

Bug fixes

    #476 Fix rope.contrib.autoimport package missing from release (@bageljrkhanofemus)

Release 1.1.0

Date: 2022-05-25

New feature

    #464 Add new autoimport implementation that uses a sqllite3 database, cache all available modules quickly, search for names and produce import statements, sort import statements. (@bageljrkhanofemus)

Bug fixes

    #419 Fix bug while moving decorated function (@dryobates)
    #439 Fix bug while moving decorated class (@dryobates)
    #461 Fix bug while extracting method with list comprehension in class method (@dryobates)
    #440 Fix bug while inlining function with type hints in signature (@dryobates)

Deprecation

    The pickle-based autoimport implementation is still the default, but will be deprecated sometime in the future.

Revision 1.30 / (download) - annotate - [select for diffs], Sun Apr 30 18:19:34 2023 UTC (7 months ago) by wiz
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

py-rope: update to 1.0.0.

Syntax support

    #400 Drop Python 2.7 support

Bug fixes

    #459 Fix bug while extracting method with augmented assignment to subscript in try block (@dryobates)

Revision 1.29 / (download) - annotate - [select for diffs], Sun Apr 30 18:17:47 2023 UTC (7 months ago) by wiz
Branch: MAIN
Changes since 1.28: +3 -1 lines
Diff to previous 1.28 (colored)

py-rope: not for python 2

Revision 1.28 / (download) - annotate - [select for diffs], Sun Feb 27 08:52:13 2022 UTC (21 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.27: +2 -3 lines
Diff to previous 1.27 (colored)

py-rope: updated to 0.23.0

Release 0.23.0

Syntax support

- Implement structural pattern matching (PEP634)
- Improve the heuristic for joining lines when extracting one line
  expression

Bug fixes

- Preserve newline format when writing files
- Fix extract info collection for list comprehension with multiple targets

Documentation

- Fix typo

Revision 1.27 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:37 2022 UTC (22 months, 3 weeks ago) by wiz
Branch: MAIN
Changes since 1.26: +2 -1 lines
Diff to previous 1.26 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.26 / (download) - annotate - [select for diffs], Tue Nov 23 20:47:04 2021 UTC (2 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Changes since 1.25: +2 -2 lines
Diff to previous 1.25 (colored)

py-rope: updated to 0.22.0

Release 0.22.0

Syntax support

Implement yield from syntax support to patchedast.py

Bug fixes

Improve empty tuple and handling of parentheses around tuple
Fix rename import statement with dots and as keyword

Revision 1.25 / (download) - annotate - [select for diffs], Fri Nov 12 10:21:47 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.24: +2 -2 lines
Diff to previous 1.24 (colored)

py-rope: updated to 0.21.1

0.21.1

Bug fixes
- Start publishing wheel packages to allow offline installs

Revision 1.24 / (download) - annotate - [select for diffs], Tue Nov 2 06:17:16 2021 UTC (2 years ago) by adam
Branch: MAIN
Changes since 1.23: +2 -2 lines
Diff to previous 1.23 (colored)

py-rope: updated to 0.21.0

Release 0.21.0

Syntax support

- Handle `global` keyword when extracting method
- context manager:
  - Implement extract refactoring for code containing `async with`
  - Fix parsing of nested `with` statement/context manager
- list/set/dict/generator comprehension scope issues:
  - Added scopes for comprehension expressions
  - Added support for checking scopes by offset
  - Fix renaming global var affects list comprehension
  - Reuse of variable in comprehensions confuses method extraction
  - Fix error `TypeError: 'PyDefinedObject' object is not subscriptable`
- f-string:
  - Fix inlining into f-string containing quote characters
- inline assignment/walrus operator:
  - Fix `AttributeError: '_ExpressionVisitor' object has no attribute 'defineds'`

Bug fixes

- Fix improper replacement when extracting attribute access expression with `similar=True`
- Fix improper replacement when extracting index access expression with `similar=True`

New feature

- Move read() to FileSystemCommands

Misc

- Setup all-contributors bot
- Blacken source code, rope now follows black code style
- Add Github Actions to enforce black code style
- Remove plain 'unittest' only runner

Revision 1.23 / (download) - annotate - [select for diffs], Sun Sep 19 10:50:42 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3
Changes since 1.22: +2 -2 lines
Diff to previous 1.22 (colored)

py-rope: updated to 0.20.1

Release 0.20.1

Bug fixes
- Fix caller of `_namedexpr_last()` throwing exception due to returning unexpected list
  instead of boolean


Release 0.20.0

New feature
- Added the ability to extract method to @staticmethod/@classmethod (@climbus)
- Changed Organize import to keep variables listed in `__all__`
- Change default .ropeproject/config.py to ignore code in folders named
  .venv and venv (@0x1e02)

Syntax support
- Add extract method refactoring of code containing `exec` (@ceridwen)
- Add extract method refactoring of code containing `async def`, `async for`, and `await`
- Support extract method of expressions containing inline assignment (walrus operator)

Bug fixes
- Fix list of variables that are returned and/or turned into argument when extracting method in a loop

Revision 1.22 / (download) - annotate - [select for diffs], Thu Apr 29 17:08:01 2021 UTC (2 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-rope: updated to 0.19.0

0.19.0
- Fix AttributeError lineno
- Python 3.9 ast changes
- create_generate with goal_resource param
- Fix relative import offset calculation
- Fix missinge lineno attribute for AssignedName ast node
- Added _NamedExpr into `patchedast.py`
- Add support for the walrus operator.
- fix test case name for `test_ann_assign_node_without_target`
- Returned _AnnAssign and checked for support assignment without value
- fixed version restriction in tests for NamedExpr
- Removed AnnAssign, added NeamedExpr, testa are made
- Added _AnnAsign into `patchedast.py`
- Extract augmented assignment
- Fix handling of dict rename in Python 2.x
- Improve handling of generalized dict unpacking during dict rename
- Add expected failure test for comprehension variable scopes
- Implement basic scoping and rename for set and dict comprehension
- Visit subexpressions of comprehensions to collect names for scopes
- Implement rename of inline assignment expression
- Implement basic scoping and renaming of list and generator
  comprehension loop variables
- Implement f-string extract refactoring
- Refactor consume_joined_string and also fix missing
  ast.JoinedStr/FormattedValue in older python
- Fix some f-string corner cases
- Implement PEP-448 generalized dict-unpacking

Revision 1.21 / (download) - annotate - [select for diffs], Thu Oct 8 08:24:20 2020 UTC (3 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Changes since 1.20: +3 -3 lines
Diff to previous 1.20 (colored)

py-rope: updated to 0.18.0

Release 0.18.0:
- Fix `Worder.get_primary_at` for names that start like
  keywords.
- Add guess_def_lineno() to get actual function/class
  definition line number
- Fix SimilarFinder/_ASTMatcher to consider 1/0 and True/False
  to be unequal
- Compatibility with Python 3.8
- Add pytest.ini to collect all tests

Revision 1.20 / (download) - annotate - [select for diffs], Wed May 27 14:20:24 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

py-rope: updated to 0.17.0

New release 0.17.0:
Make tests compatible with Python 3.8
Use context manager for open()
DonãàÑÕ use UserDict (!!!) and collections.MutableMapping.
assertEquals has been deprecated for long time (-> assertEqual)
Remove weird escpaing of 's' character, which is the syntax error these days.
Add testing for Python 3.8 as well
Fix pattern for matching short strings
Work with deprecated types and using aliased ones.
Don't use underscored _ast, but use ast instead
Direct import from collections is getting deprecated.
Use .is_alive method instead of a deprecated .isAlive in threading.Thread
Fix simple typo: sitaution -> situation
Two more assertEquals happened.

Revision 1.19 / (download) - annotate - [select for diffs], Sat Apr 11 07:26:27 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
Changes since 1.18: +2 -2 lines
Diff to previous 1.18 (colored)

py-rope: updated to 0.16.0

0.16.0:
Version bump (no changes, just to fix botched release of 0.15.0)

0.15.0:
New minor relase with bugfixes.

Revision 1.18 / (download) - annotate - [select for diffs], Thu Apr 25 12:54:05 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.17: +3 -3 lines
Diff to previous 1.17 (colored)

py-rope: updated to 0.14.0

Version 0.14.0, relicensed under LGPLv3+

Revision 1.17 / (download) - annotate - [select for diffs], Sun Feb 17 08:43:06 2019 UTC (4 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1
Changes since 1.16: +4 -4 lines
Diff to previous 1.16 (colored)

py-rope: updated to 0.12.0

0.12.0:
Unknown changes

Revision 1.16 / (download) - annotate - [select for diffs], Sun Oct 7 07:35:49 2018 UTC (5 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.15: +3 -3 lines
Diff to previous 1.15 (colored)

py-rope: updated to 0.11.0

0.11.0:
Unknown changes

Revision 1.15 / (download) - annotate - [select for diffs], Fri Aug 25 09:24:48 2017 UTC (6 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.14: +2 -2 lines
Diff to previous 1.14 (colored)

Update to 0.10.7 for installation fix (again)

Revision 1.14 / (download) - annotate - [select for diffs], Sun Aug 6 19:57:49 2017 UTC (6 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.13: +2 -6 lines
Diff to previous 1.13 (colored)

Makefile clean-up

Revision 1.13 / (download) - annotate - [select for diffs], Sun Aug 6 19:55:11 2017 UTC (6 years, 3 months ago) by adam
Branch: MAIN
Changes since 1.12: +4 -5 lines
Diff to previous 1.12 (colored)

0.10.5:
Update to 0.10.4 to fix issue with package in pypi

Revision 1.12 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:35 2017 UTC (6 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Add python-3.6 to incompatible versions.

Revision 1.11 / (download) - annotate - [select for diffs], Sat Aug 27 01:51:56 2016 UTC (7 years, 3 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.10: +4 -4 lines
Diff to previous 1.10 (colored)

py-rope: update to 0.10.2

Revision 1.10 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:43 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:26 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.8: +2 -2 lines
Diff to previous 1.8 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.8 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:39 2015 UTC (7 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.7 / (download) - annotate - [select for diffs], Fri May 9 07:37:02 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:04 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.5: +3 -2 lines
Diff to previous 1.5 (colored)

Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.5 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:34 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2, pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.4: +1 -3 lines
Diff to previous 1.4 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.4 / (download) - annotate - [select for diffs], Sun Apr 8 19:08:54 2012 UTC (11 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.3: +1 -3 lines
Diff to previous 1.3 (colored)

Remove python24 and all traces of it from pkgsrc.
Remove devel/py-ctypes (only needed by and supporting python24).
Remove PYTHON_VERSIONS_ACCEPTED and PYTHON_VERSIONS_INCOMPATIBLE
lines that just mirror defaults now.
Miscellaneous cleanup while editing all these files.

Revision 1.3 / (download) - annotate - [select for diffs], Fri Feb 25 09:47:22 2011 UTC (12 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Let's assume for now that everything that worked with python-2.6 also
works with python-2.7.

Revision 1.2 / (download) - annotate - [select for diffs], Tue Aug 31 10:57:13 2010 UTC (13 years, 3 months ago) by drochner
Branch: MAIN
CVS Tags: pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.1: +3 -1 lines
Diff to previous 1.1 (colored)

uses new "<case1> if <cond> else <case2>" syntax -> Python-2.5+ only
(seen in bulk build)

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Aug 15 10:34:56 2010 UTC (13 years, 3 months ago) by drochner
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

add py-rope-0.9.3, a Python code refactoring library, from
Helge Muehlmeier per pkgsrc-wip

Revision 1.1 / (download) - annotate - [select for diffs], Sun Aug 15 10:34:56 2010 UTC (13 years, 3 months ago) by drochner
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>