Up to [cvs.NetBSD.org] / pkgsrc / devel / py-requests-mock
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.15 / (download) - annotate - [select for diffs], Sat Jul 8 07:33:35 2023 UTC (2 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.14: +4 -4
lines
Diff to previous 1.14 (colored)
py-requests-mock: updated to 1.11.0 1.11.0 ====== New Features ------------ - Exposes some public type aliases (for type hinting only, they can't be instanciated) for the types intended to be used by `requests_mock` users. The following types are now exposed: - `requests_mock.Context` used in callbacks - `requests_mock.Request` used in callbacks, which is a `requests.PreparedRequest` proxy. - `requests_mock.Callback[T]` which is the callbacks type. Bug Fixes --------- - Some typing inconsistencies have been fixed. Especially for `request` object in signatures which is in fact a `requests_mock.Request` object. - Fix incompatibility with urllib3 >2.0.0. In 2.0.0 they default to enforcing content length checking on returned bodies in responses from the previous default of false. However the flag is still available so for compatibility we can just default the other way.
Revision 1.14 / (download) - annotate - [select for diffs], Thu Oct 13 16:13:43 2022 UTC (11 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.13: +4 -4
lines
Diff to previous 1.13 (colored)
py-requests-mock: updated to 1.10.0 1.10.0 ------ * Add a release note for the RLock * Allow passing json\_encoder to mocking * Improvements to Type Hints * Lint fix for long line exception * Shorten line length of comments * Workaround for python2.7 not supporting lock timeout * Comments to explain reentrant behaviour * Change to use RLock and set a timeout to prevent infinite deadlocks * Update homepage/doc URLs of requests library * Add comment for pytest late loading feature * pytest plugin should lazy-load requests\_mock * Add test for threaded race condition * Use threading.Lock() to prevent race conditions around monkeypatching of get\_adapter() * add GitHub URL for PyPi * Add reset methods on the Mocker class type * Avoid using distutils to check pytest version * YAML quoting * Support Python 3.10 * Minor changes to code snippet example * Fix DeprecationWarnings in setup.cfg keys * a few minor fixes and proposed changes to documentation files * Improve response-related param type hints * Explicitly indicate start of keyword-only args * Fix failing pytest
Revision 1.13 / (download) - annotate - [select for diffs], Tue Oct 26 10:19:02 2021 UTC (23 months ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.12: +2 -2
lines
Diff to previous 1.12 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.12 / (download) - annotate - [select for diffs], Thu Oct 7 13:43:41 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.11: +1 -2
lines
Diff to previous 1.11 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.11 / (download) - annotate - [select for diffs], Tue Jun 1 05:22:36 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.10: +5 -5
lines
Diff to previous 1.10 (colored)
py-requests-mock: updated to 1.9.3 1.9.3 * Release note for 1.9.3 type annotations * Additional improvements to response matching type stubs * Improve MockerCore type stubs
Revision 1.10 / (download) - annotate - [select for diffs], Wed May 5 04:51:30 2021 UTC (2 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.9: +5 -5
lines
Diff to previous 1.9 (colored)
py-requests-mock: updated to 1.9.2 1.9.2 * Add release note for urlquote fix * Simple tests to ensure character encoding works * Use requests to quote URLs * Remove circleci badge from README
Revision 1.9 / (download) - annotate - [select for diffs], Thu Apr 29 07:44:58 2021 UTC (2 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.8: +5 -5
lines
Diff to previous 1.8 (colored)
py-requests-mock: updated to 1.9.1 1.9.1 * Restore py.typed file to enable types
Revision 1.8 / (download) - annotate - [select for diffs], Wed Apr 28 10:27:09 2021 UTC (2 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.7: +5 -5
lines
Diff to previous 1.7 (colored)
py-requests-mock: updated to 1.9.0 1.9.0 ===== New Features ------------ - Add python type hints for python 3. Bug Fixes --------- - Issue 144 - When performing a read we handled an empty byte return as an indication to close the file pointer. This is not true when you actually ask for a zero byte read so we should allow it. - Fix: When you have a non url-safe character in your URL it is quoted by requests however requests-mock just treated it as a normal string.
Revision 1.7 / (download) - annotate - [select for diffs], Wed May 13 14:37:43 2020 UTC (3 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.6: +5 -5
lines
Diff to previous 1.6 (colored)
py-requests-mock: updated to 1.8.0 1.8.0 * Remove requests 2.3 compatibility code * Add release notes for reset function * Add release note for session scoped mock * Allow passing session as postiional argument * Create bound method instead of a wrapper * Added reset\_mock to \_RequestHistoryTracker and Adapter * doc on session Mockers * doc on nesting Mockers * fix README.rst typo * suggest Mocker for users unfamiliar with adapters * update examples to mount adapter on 'mock://' * fix global/session mock interactions and real\_http * Added installation instructions * Add release note for nested mocking * fix redirects and mock nesting * Mark IOReader object closed when using a stream * Add the default response reason if not set * Don't check that proxies are set in test * Add StackOverflow tag to README * Mention pytest fixture on the README * Add background information to pytest doc * docs: update examples to match Read the Docs * Expose real\_http as a public property * fix py27 error * easier session scoped mock
Revision 1.6 / (download) - annotate - [select for diffs], Mon Sep 2 07:34:54 2019 UTC (4 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
py-requests-mock: updated to 1.7.0 1.7.0 * Keep blank values query string values on request history * Add release notes for requests version pin * Keep blank values * Pin requests version to <3 * Add known issue for cookies in Sessions * logger added to adapter.py
Revision 1.5 / (download) - annotate - [select for diffs], Tue Apr 30 09:34:25 2019 UTC (4 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2
Changes since 1.4: +5 -5
lines
Diff to previous 1.4 (colored)
py-requests-mock: updated to 1.6.0 1.6.0 * Fix PEP8 failure in test\_adapter * Respect user provided content encoding type * Update minimum requests version to 2.3 * Added support for purl * Add testing for Python 3.7 & PyPy3 * Drop \_matcher from request pickled state * Clarify the pytest configuration documentation * Update mocker.rst
Revision 1.4 / (download) - annotate - [select for diffs], Tue Jul 24 10:09:22 2018 UTC (5 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Changes since 1.3: +5 -5
lines
Diff to previous 1.3 (colored)
py-requests-mock: updated to 1.5.2 1.5.2: Prelude Fix py.test plugin with py.test < 3.0 Bug Fixes Fixed a bug relating to how the pytest version was being discovered that meant new versions of pytest were being treated as old versions and would receive bad configuration. The py.test plugin was broken when using py.test < 3.0. The version of py.test that ships in EPEL is only 2.7 so we need to make sure we support at least that version. 1.5.1: New Features The stream parameter is recorded when the request is sent and available in request history in the same was as parameters like verify or timeout.
Revision 1.3 / (download) - annotate - [select for diffs], Thu May 17 10:30:04 2018 UTC (5 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.2: +5 -5
lines
Diff to previous 1.2 (colored)
py-requests-mock: updated to 1.5.0 1.5.0 * Add release note describe repository migration * Add pytest plugin * Include release-notes in documentation * Another attempt at circleci tags * Only try and push to pypi on a tag * Update all pypi.python.org URLs to pypi.org * Add pypi upload configuration to circleci * Move tests outside of package to top level directory * Remove zuul.yaml as we're not using zuul anymore * Add CircleCI badge to README * Remove links to launchpad bug reporting * Remove .gitreview * Unpin sphinx dependency * Add circleci testing configuration * Use set literals throughout project * Prefer https:// links over http:// in docs and comments * Fix last\_request examples * Fix spelling mistakes * Move Zuul jobs in-tree
Revision 1.2 / (download) - annotate - [select for diffs], Sun Dec 10 08:45:40 2017 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4
Changes since 1.1: +5 -5
lines
Diff to previous 1.1 (colored)
py-requests-mock: updated to 1.4.0 1.4.0 ----- * allow an adapter to be passed to a Mocker object * Rename [wheel] section to [bdist\_wheel] as the former is legacy * Include license file in the generated wheel package * Add testing for newer Python versions 3.5 and 3.6 * Return a separate copy for each call to decorator * Add string representation to \_RequestObjectProxy
Revision 1.1 / (download) - annotate - [select for diffs], Wed May 10 17:54:10 2017 UTC (6 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2
requests-mock provides a building block to stub out the HTTP requests portions of your testing code. You should checkout the docs for more information.