[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-pyobjc-framework-SearchKit

File: [cvs.NetBSD.org] / pkgsrc / devel / py-pyobjc-framework-SearchKit / Makefile (download)

Revision 1.3, Thu Feb 8 19:54:25 2018 UTC (6 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.2: +3 -5 lines

py-pyobjc: updated to 4.1

Version 4.1:
Protection agains buffer overflow and negative indexes in __getitem__ and __setitem__ for objc.varlist instances.

Fix incorrect metadata for +[NSEvent addLocalMonitorForEventsMatchingMask:handler:]

Fix incorrect and misleading error message in the exception that is raised when return a value from a block that should not return a value.

Issue 223: Fix hard crash when executing help(Cocoa)
Fetching the help for PyObjC framework wrappers isnãàÑÕ very useful due to the sheer size of the output (4.5 million lines of output for help(Cocoa) at the moment), but shouldnãàÑÕ cause a hard crash of the interpreter.

Issue 218: Explictly cause an ImportError when reloading `objc._objc`
Reloading the PyObjC core extension now raises an ImportError because this cannot work and used to raise a rather vague error.

Updated metadata for Xcode 9.2

Added missing `MAC_OS_X_VERSION_*` constants

Fix memory error in struct wrappers which resulted in a use-after-free error in the initializer for structs.

Add bindings for frameworks Security, SecurityFoundation and and SecurityInterface.
The bindings for the Security framework donãàÑÕ expose a number of older APIs that were deprecated in macOS 10.7.

Add bindings to libdispatch.
These bindings require macOS 10.8 or later, libdispatch was available earlier but macOS 10.8 changed the API in such a way that wrapping became a lot easier.

# $NetBSD: Makefile,v 1.3 2018/02/08 19:54:25 adam Exp $

.include "../../devel/py-pyobjc/Makefile.common"

DISTNAME=	pyobjc-framework-SearchKit-${PYOBJC_VERS}
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=p/pyobjc-framework-SearchKit/}

COMMENT=	Bridge between Python and Objective-C (SearchKit framework)

USE_LANGUAGES=	c objc

DEPENDS+=	${PYPKGPREFIX}-pyobjc-core>=${PYOBJC_VERS}:../../devel/py-pyobjc-core
DEPENDS+=	${PYPKGPREFIX}-pyobjc-framework-Cocoa>=${PYOBJC_VERS}:../../devel/py-pyobjc-framework-Cocoa

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"