The NetBSD Project

CVS log for pkgsrc/devel/py-py2app/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-py2app

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2015Q2


Revision 1.4 / (download) - annotate - [select for diffs], Thu Aug 7 01:58:35 2014 UTC (9 years, 8 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

py2app 0.9
----------

- issue #146, #147: The "python" binary in MyApp.app/Contents/MacOS was
  the small stub exetable from framework builds, instead of the actual
  command-line interpreter. The result is that you couldn't use
  ``sys.executable`` to start a new interpreter, which (amongst others)
  breaks multiprocessing.

- pull request #7: Add support for PyQt5 to the sip recipe. Patch by
  Mark Montague.

- pull request #4: Copying PySide plugins was broken due to bad
  indentation.

- pull request #5: py2app was broken for python versions that
  don't use _sysconfigdata.

- issue #135: Don't sleep for a second after compiling a XIB file

- issue #134: Remove target location before copying files into
  the bundle.

- issue #133: Ensure that the application's "Framework" folder
  is on the search path for ``ctypes.util.find_library``.

- issue #132: Depend on modulegraph 0.12 to avoid build errors
  when the python code contains references to compatibility modules
  that contain SyntaxErrors for the current python version.

- Explicitly report modules that cannot be found at the end of
  the run (for non-alias builds)

  Note: This is just a warning, missing modules are not necessarily
  a problem because modulegraph can detect imports for modules that
  aren't used on OSX (for example)

- Report modules that contain syntax errors at the end of
  the run (for non-alias builds)

  Note: This is just a warning, syntax errors be valid when the
  dependency tree contains modules for the other major release
  of python (e.g a compat_py2 module that contains compatibility
  code for Python 2 and contains code that isn't valid Python 3)

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>