The NetBSD Project

CVS log for pkgsrc/devel/py-py2app/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-py2app

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.17: download - view: text, markup, annotated - select for diffs
Tue Jun 11 06:36:41 2024 UTC (4 months, 3 weeks ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, HEAD
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +3 -3 lines
py-py2app: updated to 0.28.8

py2app 0.28.8

* Fix breakage with setuptools 70.
* Add support for python 3.13

Revision 1.16: download - view: text, markup, annotated - select for diffs
Wed Jan 31 17:35:13 2024 UTC (9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +3 -3 lines
py-py2app: updated to 0.28.7

py2app 0.28.7
* Introduce support for Python 3.12

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed Jan 17 18:56:43 2024 UTC (9 months, 2 weeks ago) by adam
Branches: MAIN
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +11 -11 lines
py-py2app: updated to 0.28.6

v0.28.5
Update the recipe for 'black' to work with recent releases of that package.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Mon Oct 31 08:26:13 2022 UTC (2 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +11 -15 lines
py-py2app: updated to 0.28.4

py2app 0.28.3
-------------

* Fix crash in py2applet when specifying a directory to
  include in the application bundle.

py2app 0.28.2
-------------

* Fix incompatibility with recent setuptools

py2app 0.28.1
-------------

* Fix typo in qt6 recipe

* Fix issue where the standard output and standard error streams
  are set to non-blocking when using py2app.

  For some reason the "ibtool" command (part of Xcode) sets these streams
  to non-blocking when compiling NIB files. I've added a context manager that
  resets the non-blocking status of these streams.

* Fix Qt5 recipe for newer versions of PyQt5

* Fix error when using ``py2applet --help``


py2app 0.28
-----------

   This is the last version of py2app with compatibility with
   Python 2.7. Future versions will require Python 3.6 or later.

* Fix typo in NamedTemporyFile call

* Workaround for autodiscovery in setuptools 61.0

  Setuptools 61.0 introduces autodiscovery of distribution
  attributes, and that broke py2app. This version introduces
  a ``setuptools.finalize_distribution_options`` entrypoint
  in py2app that will set the distributions's *name* and
  *py_modules* attributes in a way that is compatible with
  the main code of py2app when they are not yet set (before
  autodiscovery kicks in).

  In older versions of py2app buildin an app can fail in two
  ways with setuptools 61.0 or later:

  - The name of the generated application is not based on
    the script name, but some other value.

  - Calling ``python setup.py py2app`` results in an error
    mentioning ``Multiple top-level modules discovered``.


* Add recipe for black

* Also include package dist-info for editable installs

* The qt5 and qt6 recipes used dodge logic to detect
  if the Qt library itself is inside the python package,
  resulting in duplicate copies of Qt.

* Fix incompatibility with python 2.7

  py2app 0.24 accidently broke compatibility with Python 2.7, and
  this release fixes this.

  This is the last release with Python 2.7 support, the next
  release will contain package metadata that ensures it can
  only be installed on Python 3.

* Find dist-info in included pythonXX.zip

  By default the ``working_set`` of pkg_resources does not contain
  distribution information from packages included in zip files, such
  as the zipped-up stdlib + site-pakckages in py2app bundles.

  Add some monkey patching to apps using ``pkg_resources`` to fix this.

* Fix hard crash in "rtree" recipe when the package contents doesn't
  match the recipe expectations.

* Add definition of ``site.PREFIXES``

* Fix incompatibility with setuptools 60.8.1

  The setuptools recipe did not recoginize all vendored dependencies
  in ``pkg_resources`` and that breaks app bundles that use ``pkg_resoures``.

* Add builtin definitions for 'quit' and 'exit' in site.py

* Set "ENABLE_USER_SITE=False" in site.py

* Update pygame recipe to remove missing icon


py2app 0.27
-----------

* The qt5 and qt6 recipes caused a py2app crash when
  the PyQt5 or PyQt6 is not installed.

* Fix incompatibility with setuptools 60.7 and later

* Drop usage of tempfile.mktemp

* Add ``site.ENABLE_USER_SITE`` in the site.py file
  for applications (value is always ``False``).

Revision 1.13: download - view: text, markup, annotated - select for diffs
Wed Jan 5 20:47:35 2022 UTC (2 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -2 lines
*: set USE_PKG_RESOURCES for more packages

Revision 1.12: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:22 2022 UTC (2 years, 9 months ago) by wiz
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.11: download - view: text, markup, annotated - select for diffs
Sun Apr 26 10:00:41 2020 UTC (4 years, 6 months ago) by rillig
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +7 -1 lines
devel/py-py2app: disable tests for py27

Revision 1.10: download - view: text, markup, annotated - select for diffs
Sat Apr 14 08:38:53 2018 UTC (6 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +8 -8 lines
py-py2app: updated to 0.14

0.14:
Features:
Started using flake8 to improve coding style

Bug fixes:
The fix for issue #179 broke the argv emulator
Py2app could fail while reporting on possibly missing modules
The python executable included in the app bundle as sys.exectuable was not executable

Revision 1.9: download - view: text, markup, annotated - select for diffs
Sat Sep 16 19:26:48 2017 UTC (7 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Reset maintainer

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Sep 4 18:08:21 2017 UTC (7 years, 1 month ago) by wiz
Branches: MAIN
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
Follow some redirects.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jan 3 13:23:02 2017 UTC (7 years, 10 months ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Use "${MV} || ${TRUE}" and "${RM} -f" consistently in post-install targets.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Aug 28 15:45:36 2016 UTC (8 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +1 -3 lines
Remove unnecessary PLIST_SUBST, now provided by infrastructure.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Jun 8 17:43:27 2016 UTC (8 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Switch to MASTER_SITES_PYPI.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Thu Aug 7 01:58:35 2014 UTC (10 years, 2 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
py2app 0.9
----------

- issue #146, #147: The "python" binary in MyApp.app/Contents/MacOS was
  the small stub exetable from framework builds, instead of the actual
  command-line interpreter. The result is that you couldn't use
  ``sys.executable`` to start a new interpreter, which (amongst others)
  breaks multiprocessing.

- pull request #7: Add support for PyQt5 to the sip recipe. Patch by
  Mark Montague.

- pull request #4: Copying PySide plugins was broken due to bad
  indentation.

- pull request #5: py2app was broken for python versions that
  don't use _sysconfigdata.

- issue #135: Don't sleep for a second after compiling a XIB file

- issue #134: Remove target location before copying files into
  the bundle.

- issue #133: Ensure that the application's "Framework" folder
  is on the search path for ``ctypes.util.find_library``.

- issue #132: Depend on modulegraph 0.12 to avoid build errors
  when the python code contains references to compatibility modules
  that contain SyntaxErrors for the current python version.

- Explicitly report modules that cannot be found at the end of
  the run (for non-alias builds)

  Note: This is just a warning, missing modules are not necessarily
  a problem because modulegraph can detect imports for modules that
  aren't used on OSX (for example)

- Report modules that contain syntax errors at the end of
  the run (for non-alias builds)

  Note: This is just a warning, syntax errors be valid when the
  dependency tree contains modules for the other major release
  of python (e.g a compat_py2 module that contains compatibility
  code for Python 2 and contains code that isn't valid Python 3)

Revision 1.3: download - view: text, markup, annotated - select for diffs
Sun Jun 1 01:08:48 2014 UTC (10 years, 5 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2014Q2-base, pkgsrc-2014Q2
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -3 lines
py2app 0.8.1
------------
- Loading scripts didn't work when --no-chdir was used

Revision 1.2: download - view: text, markup, annotated - select for diffs
Mon Feb 10 00:20:27 2014 UTC (10 years, 8 months ago) by rodent
Branches: MAIN
CVS tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +8 -1 lines
Move bin/* to bin/*${PYVERSSUFFIX} in post-install, to allow parallel
installation of this package for different python versions. Bump
PKGREVISION.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun Feb 9 15:25:46 2014 UTC (10 years, 8 months ago) by rodent
Branches: MAIN
Import py27-py2app-0.8 as devel/py-py2app.

py2app is a Python setuptools command which will allow you to make standalone
Mac OS X application bundles and plugins from Python scripts.

py2app is similar in purpose and design to py2exe for Windows.

NOTE: py2app must be used on OSX to build applications, it cannot create Mac
applications on other platforms.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>