The NetBSD Project

CVS log for pkgsrc/devel/py-polib/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-polib

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:21 2022 UTC (2 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, HEAD
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sun Nov 7 11:49:06 2021 UTC (3 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +8 -5 lines
py-polib: updated to 1.1.1

Version 1.1.1 (2021/03/26)
--------------------------
- Strip UTF-16 BOM (U+FEFF) from start of file
- Message context (msgctxt) support for MO files
- Dropped Python < 2.7 support
- Updated docs and README after switch from Bitbucket to Github

Revision 1.5: download - view: text, markup, annotated - select for diffs
Sun Jan 28 16:39:54 2018 UTC (6 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-polib: update to 1.1.0.

Version 1.1.0 (2017/11/27)
--------------------------
 - Fixed entries sorting when generating mo file (Fixes #78)
 - Fixed find method (Fixes #84)
 - Refactored POEntry.__cmp__ method (this should fix issues #60, #65 and #79)
 - Fixed duplicated entries when merging po file with pot file (fixes #68)
 - Fixed "None" string being outputted when polib deals with syntax error in string (Fixes issue #66)
 - Added a fuzzy property to entries (Fixes #76)
 - Take into account the message context when comparing entries
 - Leave occurence untouched if line number is not a number (fixes #80 and #90)
 - Fixed test for mo files that was failing because since gettext version 0.19.8.1, msgfmt skips the "POT-Creation-Date" metadata entry (Fixes #86)
 - Fixed major revision number comparison
 - Dropped python 2.4 support

Revision 1.4: download - view: text, markup, annotated - select for diffs
Tue Sep 26 10:12:25 2017 UTC (7 years, 1 month ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +6 -6 lines
py-polib: update to 1.0.8.

Version 1.0.8 (2016/11/21)
--------------------------
 - Fixed issue #70 (occurrences parsing for windows pathes)
 - Fixed issue #71 (tcomment and flags not saved for obsolete entries)
 - Fixed issue #72 (wrong metadata ordering)
 - Fixed issue #73 (can't always unpickle POFile)
 - Use natural sorting for additional headers (metadata)
 - Fixed typos in various documents

Version 1.0.7 (2015/07/08)
--------------------------
 - Fixed bad parsing of indented msgstr_plural
 - Fixed ordering of "Language" metadata entry
 - Removed space after "#" in header if comment line is empty (like gettext tools)
 - Fixed typos / grammar errors (thanks Jakub Wilk)
 - Take into account msgid_plural if needed when comparing entries (thanks Leonardo Constantino Oliveira)
 - Fixed issue #63 (str() on a bytes instance when using python3) (thanks Jakub Wilk)

Version 1.0.6 (2015/01/04)
--------------------------
 - Wheel support
 - Add missing 'Language' and 'Plural-Forms' to metadata ordering
 - More accurate float operation for POFile.percent_translated()

Version 1.0.5 (2014/08/22)
--------------------------
 - Fixed issue #59: tokens variable referenced before assignment
 - Implemented feature request #56: line number information in PO entries
 - Fixed issue #61: polib does not handle previous msgid on multilines properly

Version 1.0.4 (2014/02/19)
--------------------------
 - Fixed issue #43: improved check that determine if polib is dealing with a filepath or unicode content
 - Fixed issue #44: polib now checks MO files revision number and throws an error if the number is unexpected
 - Fixed issue #45: parse properly mo files with no header entry
 - Fixed issue #47: added flags attribute for MOEntry to be consistent with POEntry
 - Fixed issue #49: use integers rather than strings for msgstr_plural keys
 - Fixed issue #51: if a PO file ends with a comment, polib adds a spurious empty entry at the end
 - Fixed issue #52: bad magic number written on big endian platforms
 - Fixed issue #53: added a __hash__() method to POEntry and MOEntry classes
 - Fixed issue #54: use lowercase for state identifiers. This fixes issues with certain locales and string.lower()
 - Fixed issue #58: use io.open() instead of codecs.open() because the latter doesn't handle very well universal line endings
 - Make sure the mo file is closed at garbage collection, this prevents warnings on unclosed file when running tests with python >= 3.2
 - Better way to test endianness
 - polib download URL is now on Pypi

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Sep 4 18:08:21 2017 UTC (7 years, 2 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Follow some redirects.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Jan 25 10:30:04 2014 UTC (10 years, 9 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +1 -3 lines
Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Wed Apr 24 13:34:28 2013 UTC (11 years, 6 months ago) by obache
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Import py27-polib-1.0.3 as devel/py-polib.
Based on PR pkg/47459 by Richard PALO.

polib is a library to manipulate, create, modify gettext files (pot, po and mo
files). You can load existing files, iterate through its entries, add, modify
entries, comments or metadata, etc. or create new po files from scratch.

polib supports out of the box any version of python ranging from 2.4 to latest
3.X version.

polib is pretty stable now and is used by many opensource projects.

polib is completely free and opensource, the license used is the MIT license.
It was developed back in 2006 by David Jean Louis and it is still actively
maintained.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>