The NetBSD Project

CVS log for pkgsrc/devel/py-pip/distinfo

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-pip

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2018Q3


Revision 1.19 / (download) - annotate - [select for diffs], Tue Aug 7 09:56:53 2018 UTC (14 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.18: +5 -5 lines
Diff to previous 1.18 (colored)

py-pip: updated to 18.0

18.0:

Process
- Switch to a Calendar based versioning scheme.
- Formally document our deprecation process as a minimum of 6 months of deprecation
  warnings.
- Adopt and document NEWS fragment writing style.
- Switch to releasing a new, non bug fix version of pip every 3 months.

Deprecations and Removals
- Remove the legacy format from pip list.
- Dropped support for Python 3.3.
- Remove support for cleaning up #egg fragment postfixes.
- Remove the shim for the old get-pip.py location.

  For the past 2 years, it's only been redirecting users to use the newer
  https://bootstrap.pypa.io/get-pip.py location.

Features
- Introduce a new --prefer-binary flag, to prefer older wheels over newer source packages.
- Improve autocompletion function on file name completion after options
  which have ``<file>``, ``<dir>`` or ``<path>`` as metavar.
- Add support for installing PEP 518 build dependencies from source.
- Improve status message when upgrade is skipped due to only-if-needed strategy.

Bug Fixes
- Update pip's self-check logic to not use a virtualenv specific file and honor cache-dir.
- Remove compiled pyo files for wheel packages.
- Speed up printing of newly installed package versions.
- Restrict install time dependency warnings to directly-dependant packages.

  Warning about the entire package set has resulted in users getting confused as
  to why pip is printing these warnings.
- Improve handling of PEP 518 build requirements: support environment markers and extras.
- Remove username/password from log message when using index with basic auth.
- Remove trailing os.sep from PATH directories to avoid false negatives.
- Fix "pip wheel pip" being blocked by the "don't use pip to modify itself" check.
- Disable pip's version check (and upgrade message) when installed by a different package manager.

  This works better with Linux distributions where pip's upgrade message may
  result in users running pip in a manner that modifies files that should be
  managed by the OS's package manager.
- Check for file existence and unlink first when clobbering existing files during a wheel install.
- Improve error message to be more specific when no files are found as listed in as listed in PKG-INFO.
- Always read ``pyproject.toml`` as UTF-8. This fixes Unicode handling on Windows and Python 2.
- Fix a crash that occurs when PATH not set, while generating script location warning.
- Disallow packages with ``pyproject.toml`` files that have an empty build-system table.

Vendored Libraries
- Update CacheControl to 0.12.5.
- Update certifi to 2018.4.16.
- Update distro to 1.3.0.
- Update idna to 2.7.
- Update ipaddress to 1.0.22.
- Update pkg_resources to 39.2.0 (via setuptools).
- Update progress to 1.4.
- Update pytoml to 0.1.16.
- Update requests to 2.19.1.
- Update urllib3 to 1.23.

Improved Documentation
- Document how to use pip with a proxy server.
- Document that the output of pip show is in RFC-compliant mail header format.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>