[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-pip-run

File: [cvs.NetBSD.org] / pkgsrc / devel / py-pip-run / Makefile (download)

Revision 1.4, Thu Feb 9 12:51:38 2023 UTC (14 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q1-base, pkgsrc-2023Q1
Changes since 1.3: +18 -13 lines

py-pip-run: updated to 10.0.5

v10.0.5
Fixed handling of inferred Python args.

v10.0.4
Fixed ``FileNotFoundError`` in persistent mode.

v10.0.3
Fixed regression in sitecustomize generation where pathlib
objects were being rendered.

v10.0.2
Tests that require connectivity are now tagged with the
``network`` marker.

v10.0.1
Tests that require connectivity to the Internet now are skipped.

v10.0.0
Removed ``launch.with_path_overlay``, unused in this project.

Removed explicit parsing of ``.pth`` files, redundant to the
use of ``sitecustomize``.

Removed ``commands.parse_script_args`` (use ``separate`` instead).

Removed processing of ``JYTHONPATH`` as Jython is Python 2 only.

Removed ``commands.separate_dash``.

# $NetBSD: Makefile,v 1.4 2023/02/09 12:51:38 adam Exp $

DISTNAME=	pip-run-10.0.5
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=p/pip-run/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/jaraco/pip-run
COMMENT=	Install packages and run Python with them
LICENSE=	mit

TOOL_DEPENDS+=	${PYPKGPREFIX}-setuptools_scm>=3.4.1:../../devel/py-setuptools_scm
TOOL_DEPENDS+=	${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+=	${PYPKGPREFIX}-autocommand-[0-9]*:../../misc/py-autocommand
DEPENDS+=	${PYPKGPREFIX}-jaraco.context-[0-9]*:../../devel/py-jaraco.context
DEPENDS+=	${PYPKGPREFIX}-jaraco.functools-[0-9]*:../../devel/py-jaraco.functools
DEPENDS+=	${PYPKGPREFIX}-jaraco.text-[0-9]*:../../textproc/py-jaraco.text
DEPENDS+=	${PYPKGPREFIX}-more-itertools>=8.3:../../devel/py-more-itertools
DEPENDS+=	${PYPKGPREFIX}-packaging-[0-9]*:../../devel/py-packaging
DEPENDS+=	${PYPKGPREFIX}-path>=15.1:../../devel/py-path
DEPENDS+=	${PYPKGPREFIX}-pip>=19.3:../../devel/py-pip
DEPENDS+=	${PYPKGPREFIX}-platformdirs-[0-9]*:../../misc/py-platformdirs
TEST_DEPENDS+=	${PYPKGPREFIX}-jaraco.path-[0-9]*:../../devel/py-jaraco.path
TEST_DEPENDS+=	${PYPKGPREFIX}-nbformat-[0-9]*:../../www/py-nbformat
TEST_DEPENDS+=	${PYPKGPREFIX}-test>=6:../../devel/py-test
TEST_DEPENDS+=	${PYPKGPREFIX}-test-cov-[0-9]*:../../devel/py-test-cov

USE_LANGUAGES=	# none

PYTHON_VERSIONS_INCOMPATIBLE=	27

post-install:
	cd ${DESTDIR}${PREFIX}/bin && \
	${MV} pip-run pip-run-${PYVERSSUFFIX} || ${TRUE}

do-test:
	cd ${WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYVERSSUFFIX} tests

.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"