[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-pebble

File: [cvs.NetBSD.org] / pkgsrc / devel / py-pebble / Makefile (download)

Revision 1.10, Sun Apr 30 17:37:50 2023 UTC (10 months, 4 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2
Changes since 1.9: +5 -9 lines

py-pebble: update to 5.0.3.

5.0.3

Fixes:
 - issue #111: reinstate `Pool.schedule` function in place of
   `Pool.submit`.

5.0.2

Fixes:
 - issue #108: fix build tag enforcing Python 3.6 as minimum
   compatible version.

5.0.1

Improvements:
 - issue #105: run callbacks after process termination on timeout or
   task cancellation

5.0.0

Backward incompatible changes:
 - issue #93: Python 2 is no longer compatible. Minimum supported
   version is now 3.7.

Deprecations:
 - issue #90: pools `schedule` method is now deprecated, use `submit`
   instead.

Features:
 - issue #90: pools are now compatible with asyncio APIs.
 - issue #94: asynchronous function decorators
 - issue #102: type hints have been added to all functionalities
 - issue #103: support alternative multiprocessing.context
   implementations

Fixes:
 - issue #99: fix deadlock when closing a full pipe on Windows in pool

# $NetBSD: Makefile,v 1.10 2023/04/30 17:37:50 wiz Exp $

DISTNAME=	Pebble-5.0.3
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=P/Pebble/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/noxdafox/pebble
COMMENT=	Threading and multiprocessing eye-candy
LICENSE=	gnu-lgpl-v3

PYTHON_VERSIONS_INCOMPATIBLE=	27

USE_LANGUAGES=	# none

TEST_ENV+=	PYTHONPATH=${WRKSRC}/build/lib
do-test:
	cd ${WRKSRC}/test && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m unittest discover -v

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"