Up to [cvs.NetBSD.org] / pkgsrc / devel / py-more-itertools
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.30 / (download) - annotate - [select for diffs], Sat Oct 28 19:57:03 2023 UTC (6 weeks, 1 day ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.29: +2 -1
lines
Diff to previous 1.29 (colored)
python/wheel.mk: simplify a lot, and switch to 'installer' for installation This follows the recommended bootstrap method (flit_core, build, installer). However, installer installs different files than pip, so update PLISTs for all packages using wheel.mk and bump their PKGREVISIONs.
Revision 1.29 / (download) - annotate - [select for diffs], Thu Aug 24 20:04:05 2023 UTC (3 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base,
pkgsrc-2023Q3
Changes since 1.28: +2 -2
lines
Diff to previous 1.28 (colored)
py-more-itertools: update to 10.1.0. What's Changed Add more tests for zip_broadcast() by @kalekundert in #739 Added takewhile_inclusive by @OlegAlexander in #736 Speed up zip_broadcast() by pre-filling the scalar elements by @kalekundert in #740 Added outer_product. by @OlegAlexander in #743 Simplify zip_broadcast by @pochmann in #742 Simplify _zip_equal by @pochmann in #744 fix consume() type annotation by @obaltian in #746 Version 10.1.0 by @bbayles in #747
Revision 1.28 / (download) - annotate - [select for diffs], Wed Mar 1 10:58:59 2023 UTC (9 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1
Changes since 1.27: +3 -3
lines
Diff to previous 1.27 (colored)
py-more-itertools: updated to 9.1.0 Version 9.1.0 See PR 678 for details.
Revision 1.27 / (download) - annotate - [select for diffs], Thu Nov 17 09:19:20 2022 UTC (12 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q4-base,
pkgsrc-2022Q4
Changes since 1.26: +2 -2
lines
Diff to previous 1.26 (colored)
py-more-itertools: updated to 9.0.0 9.0.0 ------ * Potentially breaking changes * :func:`grouper` no longer accepts an integer as its first argument. Previously this raised a ``DeprecationWarning``. * :func:`collate` has been removed. Use the built-in :func:`heapq.merge` instead. * :func:`windowed` now yields nothing when its iterable is empty. * This library now advertises support for Python 3.7+. * New functions * :func:`constrained_batches` * :func:`batched` (from the Python itertools docs) * :func:`polynomial_from_roots` (from the Python itertools docs) * :func:`sieve` (from the Python itertools docs) * Other changes * Some documentation issues were fixed (thanks to nanouasyn)
Revision 1.26 / (download) - annotate - [select for diffs], Wed Aug 10 11:45:02 2022 UTC (16 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3
Changes since 1.25: +2 -2
lines
Diff to previous 1.25 (colored)
py-more-itertools: updated to 8.14.0 8.14.0 ------ * New functions * :func:`longest_common_prefix` (thanks to nanouasyn) * :func:`iequals` (thanks to nanouasyn) * Changes to existing functions * `concurrent.futures.ThreadPoolExecutor` is now imported lazily in :func:`callback_iter`. * :func:`tail` is now optimized for iterables with a fixed length. * Other changes * Some documentation issues were fixed (thanks to pochmann and timgates42) * This library is now marked for Python 3.10 compatibility in PyPI (thanks to chayim)
Revision 1.25 / (download) - annotate - [select for diffs], Tue May 10 13:05:54 2022 UTC (19 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2022Q2-base,
pkgsrc-2022Q2
Changes since 1.24: +5 -4
lines
Diff to previous 1.24 (colored)
py-more-itertools: updated to 8.13.0 8.13.0 ------ * New functions * The :func:`subslices` recipe from the `itertools` docs was added (thanks to rhettinger) * Changes to existing functions * The :func:`ichunked` function is now more efficient (thanks to hjtran0 and seanmacavaney) * The :func:`difference` function is now more efficient (thanks to Masynchin) * The :func:`grouper` recipe now has more features, mirroring the one in the `itertools` docs (thanks to rhettinger) * Other changes * Some documentation issues were fixed (thanks to medvied and Freed-Wu) * The `more_itertools` package is now built with `flit` (thanks to mgorny)
Revision 1.24 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:18 2022 UTC (23 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base,
pkgsrc-2022Q1
Changes since 1.23: +2 -1
lines
Diff to previous 1.23 (colored)
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Revision 1.23 / (download) - annotate - [select for diffs], Mon Nov 29 10:51:14 2021 UTC (2 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.22: +2 -2
lines
Diff to previous 1.22 (colored)
py-more-itertools: updated to 8.12.0 8.12.0 ------ * Bug fixes * Some documentation issues were fixed * Python 3.5 support was temporarily restored 8.11.0 ------ * New functions * The :func:`before_and_after`, :func:`sliding_window`, and :func:`triplewise` recipes from the Python 3.10 docs were added * :func:`duplicates_everseen` and :func:`duplicates_justseen` * :func:`minmax` * :func:`strictly_n` * :func:`unique_in_window` * Changes to existing functions * :func:`groupby_transform` had its type stub improved * :func:`is_sorted` now accepts a ``strict`` parameter * :func:`zip_broadcast` was updated to fix a bug
Revision 1.22 / (download) - annotate - [select for diffs], Wed Sep 29 09:22:29 2021 UTC (2 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.21: +2 -2
lines
Diff to previous 1.21 (colored)
py-more-itertools: updated to 8.10.0 8.10.0 ------ * Changes to existing functions * The type stub for :func:`iter_except` was improved (thanks to MarcinKonowalczyk) * Other changes: * Type stubs now ship with the source release (thanks to saaketp) * The Sphinx docs were improved (thanks to MarcinKonowalczyk)
Revision 1.21 / (download) - annotate - [select for diffs], Fri Sep 10 15:06:24 2021 UTC (2 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3
Changes since 1.20: +2 -2
lines
Diff to previous 1.20 (colored)
py-more-itertools: updated to 8.9.0 8.9.0 ----- * New functions * :func:`interleave_evenly` (thanks to mbugert) * :func:`repeat_each` (thanks to FinalSh4re) * :func:`chunked_even` (thanks to valtron) * :func:`map_if` (thanks to sassbalint) * :func:`zip_broadcast` (thanks to kalekundert) * Changes to existing functions * The type stub for :func:`chunked` was improved (thanks to PhilMacKay) * The type stubs for :func:`zip_equal` and `zip_offset` were improved (thanks to maffoo) * Building Sphinx docs locally was improved (thanks to MarcinKonowalczyk)
Revision 1.20 / (download) - annotate - [select for diffs], Tue May 25 05:20:12 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q2-base,
pkgsrc-2021Q2
Changes since 1.19: +2 -2
lines
Diff to previous 1.19 (colored)
py-more-itertools: updated to 8.8.0 8.8.0 ----- * New functions * :func:`countable` * Changes to existing functions * :func:`split_before` was updated to handle empy collections * :func:`unique_everseen` got a performance boost * The type hint for :func:`value_chain` was corrected
Revision 1.19 / (download) - annotate - [select for diffs], Mon Feb 8 06:18:39 2021 UTC (2 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base,
pkgsrc-2021Q1
Changes since 1.18: +2 -2
lines
Diff to previous 1.18 (colored)
py-more-itertools: 8.7.0 8.7.0 ----- * New functions * :func:`convolve` (from the Python itertools docs) * :func:`product_index`, :func:`combination_index`, and :func:`permutation_index` (thanks to N8Brooks) * :func:`value_chain` (thanks to jenstroeger) * Changes to existing functions * :func:`distinct_combinations` now uses a non-recursive algorithm (thanks to knutdrand) * :func:`pad_none` is now the preferred name for :func:`padnone`, though the latter remains available. * :func:`pairwise` will now use the Python standard library implementation on Python 3.10+ * :func:`sort_together` now accepts a ``key`` argument (thanks to brianmaissy) * :func:`seekable` now has a ``peek`` method, and can indicate whether the iterator it's wrapping is exhausted (thanks to gsakkis) * :func:`time_limited` can now indicate whether its iterator has expired (thanks to roysmith) * The implementation of :func:`unique_everseen` was improved (thanks to plammens) * Other changes: * Various documentation updates
Revision 1.18 / (download) - annotate - [select for diffs], Sun Nov 22 11:16:54 2020 UTC (3 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base,
pkgsrc-2020Q4
Changes since 1.17: +2 -2
lines
Diff to previous 1.17 (colored)
py-more-itertools: updated to 8.6.0 8.6.0 ----- * New itertools * :func:`all_unique` * :func:`nth_product` and :func:`nth_permutation` * Changes to existing itertools * :func:`chunked` and :func:`sliced` now accept a ``strict`` parameter * Other changes * Python 3.5 has reached its end of life and is no longer supported. * Python 3.9 is officially supported. * Various documentation fixes
Revision 1.17 / (download) - annotate - [select for diffs], Thu Oct 1 06:59:14 2020 UTC (3 years, 2 months ago) by adam
Branch: MAIN
Changes since 1.16: +2 -2
lines
Diff to previous 1.16 (colored)
py-more-itertools: updated to 8.5.0 8.5.0 * New itertools * :func:`windowed_complete` (thanks to MarcinKonowalczyk) * Changes to existing itertools: * The :func:`is_sorted` implementation was improved (thanks to cool-RR) * The :func:`groupby_transform` now accepts a ``reducefunc`` parameter. * The :func:`last` implementation was improved (thanks to brianmaissy) * Other changes * Various documentation fixes (thanks to craigrosie, samuelstjean, PiCT0) * The tests for :func:`distinct_combinations` were improved (thanks to Minabsapi) * Automated tests now run on GitHub Actions. All commits now check: * That unit tests pass * That the examples in docstrings work * That test coverage remains high (using `coverage`) * For linting errors (using `flake8`) * For consistent style (using `black`) * That the type stubs work (using `mypy`) * That the docs build correctly (using `sphinx`) * That packages build correctly (using `twine`)
Revision 1.16 / (download) - annotate - [select for diffs], Wed Jun 17 06:48:17 2020 UTC (3 years, 5 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2
Changes since 1.15: +2 -2
lines
Diff to previous 1.15 (colored)
py-more-itertools: updated to 8.4.0 8.4.0 * New itertools * :func:`mark_ends` * :func:`is_sorted` * Changes to existing itertools: * :func:`islice_extended` can now be used with real slices * The implementations for :func:`filter_except` and :func:`map_except` were improved * Other changes * Automated tests now enforce code style (using `black <https://github.com/psf/black>`__) * The various signatures of :func:`islice_extended` and :func:`numeric_range` now appear in the docs * The test configuration for mypy was updated
Revision 1.15 / (download) - annotate - [select for diffs], Sat May 16 04:54:09 2020 UTC (3 years, 6 months ago) by adam
Branch: MAIN
Changes since 1.14: +2 -2
lines
Diff to previous 1.14 (colored)
py-more-itertools: updated to 8.3.0 8.3.0 * New itertools * :func:`zip_equal` * Changes to existing itertools: * :func:`split_at`, :func:`split_before`, :func:`split_after`, and :func:`split_when` all got a ``maxsplit`` paramter * :func:`split_at` now accepts a ``keep_separator`` parameter * :func:`distinct_permutations` can now generate ``r``-length permutations * The :func:`windowed` implementation was improved * The :func:`spy` implementation was improved * Other changes * Type stubs are now tested with ``stubtest`` * Tests now run with ``python -m unittest`` instead of ``python setup.py test``
Revision 1.14 / (download) - annotate - [select for diffs], Sat Feb 1 20:59:25 2020 UTC (3 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base,
pkgsrc-2020Q1
Changes since 1.13: +4 -4
lines
Diff to previous 1.13 (colored)
py-more-itertools: updated to 8.2.0 8.2.0 * Bug fixes * The .pyi files for typing were updated. * Changes to existing itertools: * :func:`numeric_range` now behaves more like the built-in :func:`range`. * :func:`bucket` now allows for enumerating keys. * :func:`sliced` now should now work for numpy arrays. * :func:`seekable` now has a ``maxlen`` parameter.
Revision 1.13 / (download) - annotate - [select for diffs], Tue Jan 14 22:42:18 2020 UTC (3 years, 10 months ago) by wiz
Branch: MAIN
Changes since 1.12: +2 -2
lines
Diff to previous 1.12 (colored)
py-more-itertools: update to 8.1.0. 8.1.0 ----- * Bug fixes * :func:`partition` works with ``pred=None`` again. (thanks to MSeifert04) * New itertools * :func:`sample` (thanks to tommyod) * :func:`nth_or_last` (thanks to d-ryzhikov) * Changes to existing itertools: * The implementation for :func:`divide` was improved. (thanks to jferard)
Revision 1.12 / (download) - annotate - [select for diffs], Sun Dec 15 11:55:24 2019 UTC (3 years, 11 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base,
pkgsrc-2019Q4
Changes since 1.11: +2 -2
lines
Diff to previous 1.11 (colored)
py-more-itertools: updated to 8.0.2 8.0.2: Bug fixes * The type stub files are now part of the wheel distribution 8.0.1: Bug fixes * The type stub files now work for functions imported from the root package 8.0.0: New itertools and other additions * This library now ships type hints for use with mypy. * :func:`split_when` * :func:`repeat_last` Changes to existing itertools: * The implementation for :func:`set_partitions` was improved. * :func:`partition` was optimized for expensive predicates. * :func:`unique_everseen` and :func:`groupby_transform` were re-factored. * The implementation for :func:`difference` was improved. Other changes * Python 3.4 has reached its end of life and is no longer supported. * Python 3.8 is officially supported. * The collate function has been deprecated. It raises a DeprecationWarning if used, and will be removed in a future release. * :func:`one` and :func:`only` now provide more informative error messages. * Unit tests were moved outside of the main package * Various documentation fixes
Revision 1.11 / (download) - annotate - [select for diffs], Fri Nov 15 14:22:30 2019 UTC (4 years ago) by wiz
Branch: MAIN
Changes since 1.10: +3 -3
lines
Diff to previous 1.10 (colored)
py-more-itertools: update to 7.2.0. 7.2.0 ----- * New itertools * :func:`distinct_combinations` * :func:`set_partitions` (thanks to kbarrett) * :func:`filter_except` * :func:`map_except` 7.1.0 ----- * New itertools * :func:`ichunked` (thanks davebelais and youtux) * :func:`only` (thanks jaraco) * Changes to existing itertools: * :func:`numeric_range` now supports ranges specified by ``datetime.datetime`` and ``datetime.timedelta`` objects (thanks to MSeifert04 for tests). * :func:`difference` now supports an *initial* keyword argument. * Other changes * Various documentation fixes (thanks raimon49, pylang) 7.0.0 ----- * New itertools: * :func:`time_limited` * :func:`partitions` (thanks to rominf and Saluev) * :func:`substrings_indexes` (thanks to rominf) * Changes to existing itertools: * :func:`collapse` now treats ``bytes`` objects the same as ``str`` objects. (thanks to Sweenpet) The major version update is due to the change in the default behavior of :func:`collapse`. It now treats ``bytes`` objects the same as ``str`` objects. This aligns its behavior with :func:`always_iterable`. .. code-block:: python >>> from more_itertools import collapse >>> iterable = [[1, 2], b'345', [6]] >>> print(list(collapse(iterable))) [1, 2, b'345', 6] 6.0.0 ----- * Major changes: * Python 2.7 is no longer supported. The 5.0.0 release will be the last version targeting Python 2.7. * All future releases will target the active versions of Python 3. As of 2019, those are Python 3.4 and above. * The ``six`` library is no longer a dependency. * The :func:`accumulate` function is no longer part of this library. You may import a better version from the standard ``itertools`` module. * Changes to existing itertools: * The order of the parameters in :func:`grouper` have changed to match the latest recipe in the itertools documentation. Use of the old order will be supported in this release, but emit a ``DeprecationWarning``. The legacy behavior will be dropped in a future release. (thanks to jaraco) * :func:`distinct_permutations` was improved (thanks to jferard - see also `permutations with unique values <https://stackoverflow.com/questions/6284396/permutations-with-unique-values>`_ at StackOverflow.) * An unused parameter was removed from :func:`substrings`. (thanks to pylang) * Other changes: * The docs for :func:`unique_everseen` were improved. (thanks to jferard and MSeifert04) * Several Python 2-isms were removed. (thanks to jaraco, MSeifert04, and hugovk)
Revision 1.10 / (download) - annotate - [select for diffs], Tue Jan 22 09:45:22 2019 UTC (4 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
py-more-itertools: updated 5.0.0 5.0.0 * New itertools: * :func:split_into * :func:unzip * :func:substrings * Changes to existing itertools: * :func:ilen was optimized a bit * :func:first_true now returns None by default. This is the reason for the major version bump - see below. * Other changes: * Some code for old Python versions was removed * Some documentation mistakes were corrected * Tests now run properly on 32-bit versions of Python * Newer versions of CPython and PyPy are now tested against
Revision 1.9 / (download) - annotate - [select for diffs], Sun Aug 19 08:16:05 2018 UTC (5 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
Changes since 1.8: +2 -2
lines
Diff to previous 1.8 (colored)
py-more-itertools: updated to 4.3.0 4.3.0: New itertools: - last() - replace() - rlocate() Improvements to existing itertools: - locate() can now search for multiple items Other changes: - The docs now include a nice table of tools
Revision 1.8 / (download) - annotate - [select for diffs], Thu May 24 07:14:37 2018 UTC (5 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.7: +2 -3
lines
Diff to previous 1.7 (colored)
py-more-itertools: updated to 4.2.0 4.2.0: * New itertools: * :func:map_reduce * :func:prepend * Improvements to existing itertools: * :func:bucket now complies with PEP 479 * Other changes: * Python 3.7 is now supported * Python 3.3 is no longer supported * The test suite no longer requires third-party modules to run * The API docs now include links to source code
Revision 1.7 / (download) - annotate - [select for diffs], Sun Jan 28 08:44:04 2018 UTC (5 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1
Changes since 1.6: +2 -2
lines
Diff to previous 1.6 (colored)
py-more-itertools: updated to 4.1.0 4.1.0 New itertools: - split_at - circular_shifts - make_decorator - see the blog post Yo, I heard you like decorators for a tour - always_reversible - nth_combination (from the Python 3.7 docs) Improvements to existing itertools: - seekable now has an elements method to return cached items. - The performance tradeoffs between roundrobin and interleave_longest are now documented
Revision 1.6 / (download) - annotate - [select for diffs], Thu Jan 18 12:38:16 2018 UTC (5 years, 10 months ago) by adam
Branch: MAIN
Changes since 1.5: +2 -2
lines
Diff to previous 1.5 (colored)
py-more-itertools: updated to 4.0.1 4.0.1 No code changes - this release fixes how the docs display on PyPI. 4.0.0 New itertools: * consecutive_groups (Based on the example in the Python 2.4 docs) * seekable (If you're looking for how to "reset" an iterator, you're in luck!) * exactly_n * run_length.encode and :func:run_length.decode * difference Improvements to existing itertools: The number of items between filler elements in * intersperse can now be specified * distinct_permutations and :func:peekable got some minor adjustments * always_iterable now returns an iterator object. It also now allows different types to be considered iterable * bucket can now limit the keys it stores in memory * one now allows for custom exceptions Other changes: A few typos were fixed All tests can now be run with python setup.py test
Revision 1.5 / (download) - annotate - [select for diffs], Fri Oct 13 07:58:57 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base,
pkgsrc-2017Q4
Changes since 1.4: +6 -3
lines
Diff to previous 1.4 (colored)
py-more-itertools: update to 3.2.0 3.2.0 * New itertools: * :func:`lstrip`, :func:`rstrip`, and :func:`strip` * :func:`islice_extended` * Improvements to existing itertools: * Some bugs with slicing :func:`peekable`-wrapped iterables were fixed
Revision 1.4 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:28 2016 UTC (7 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2
Changes since 1.3: +2 -2
lines
Diff to previous 1.3 (colored)
Switch to MASTER_SITES_PYPI.
Revision 1.3 / (download) - annotate - [select for diffs], Wed Dec 31 13:57:27 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base,
pkgsrc-2016Q1,
pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1
Changes since 1.2: +1 -2
lines
Diff to previous 1.2 (colored)
Improve EGG_NAME default to work for packages with '-' in their name. Remove now unnecessary overrides in various packages.
Revision 1.2 / (download) - annotate - [select for diffs], Tue May 13 17:08:44 2014 UTC (9 years, 7 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2
Changes since 1.1: +3 -2
lines
Diff to previous 1.1 (colored)
Correctly build as Python Egg.
Revision 1.1 / (download) - annotate - [select for diffs], Fri May 9 21:22:37 2014 UTC (9 years, 7 months ago) by imil
Branch: MAIN
Initial import of py-more-itertools, version 2.2, into the NetBSD Packages Collection. A collection of several routines not found in itertools, meant to operate on itertables.