The NetBSD Project

CVS log for pkgsrc/devel/py-logilab-common/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-logilab-common

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.23 / (download) - annotate - [select for diffs], Wed Jan 5 15:41:05 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, HEAD
Changes since 1.22: +4 -2 lines
Diff to previous 1.22 (colored)

python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.22 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:16 2022 UTC (22 months, 4 weeks ago) by wiz
Branch: MAIN
Changes since 1.21: +2 -1 lines
Diff to previous 1.21 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.21 / (download) - annotate - [select for diffs], Wed May 12 06:55:06 2021 UTC (2 years, 6 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Changes since 1.20: +8 -7 lines
Diff to previous 1.20 (colored)

py-logilab-common: updated to 1.8.1

2021-01-05 -- 1.8.1

* feature: add tox helpers to make pipy and debian releases
* fix: use TypedDict if python version > 3.8 only, otherwise use a Dict
       (TypedDict were imported from typing_extension 3.7.4, which is not
       available on debian buster)

2020-11-22 -- 1.8.0

* deprecation: add subclass to DeprecationWarning with structured
  information (TargetRenamedDeprecationWarning,
  TargetDeprecatedDeprecationWarning, TargetRemovedDeprecationWarning,
  TargetMovedDeprecationWarning)
* deprecation: add tests to ensure that DeprecationWarning target the
  correct line and the correct file
* deprecation: add types annotations
* declare that logilab.common ships type annotations (py.typed file)
* various bug fixes

2020-09-03 -- 1.7.3

* type: declare that logilab-common ship type annotations
* make the build reproducible
* fix(deprecation): stacked decorators breaks getting the real callable
  __name__ attribute
* fix: in some situation (using several deprecation functions), renaming
  deprecation utils failed to point to the correct new name and used random
  internal names of the module

2020-06-24 -- 1.7.2

* fix(deprecation): rollback to old class_deprecation being a class behavior

2020-06-11 -- 1.7.1

* fix: import error on re.Pattern with python < 3.7

2020-06-10 -- 1.7.0

* logilab-common requires python 3.6 now
* greatly improve our CI and migrate it to heptapod/gitlab-ci
* black the whole code base
* move test suit to pytest
* use check-manifest and fix related bugs in MANIFEST.in
* integrates flake8 and please the flake8 gods
* various fixes
* class_deprecation is not a class anymore
* pytest 5.4.2 breaks tests, pin to 5.4.1 for now

2020-05-25 -- 1.6.4

* fix: rollback to old class_deprecation being a class behavior
* fix: @functools.wraps broke callable_renamed, write a @lazy_wraps and
  use it everywhere in logilab.common.deprecation
* add docstring to LazyObject

2020-05-11 -- 1.6.3

* fix: metaclass conflict in class_deprecated

2020-05-11 -- 1.6.2

* fix: explicitly requires python 3.6 in setup.py

2020-05-01 -- 1.6.1

* bug fix, bad usage of callable_renamed

2020-04-30 -- 1.6.0

* logilab-common requires python >= 3.6 now
* use pyannotates to introduces types in all the modules
* introduce a list of new functions in logilab.common.deprecation: callable_renamed, attribute_renamed, argument_renamed, argument_remove
* renamed "renamed" to "callable_renamed", "deprecated" to
  "callable_deprecated", "moved" to "callable_moved" for coherence
* refactor the whole logilab.common.deprecation to simplify its code
* automatically detect from which modules a deprecated utils is called
* correctly display the line where a deprecated utils is used
* various small fixes, thx mypy

2019-12-04  -- 1.5.2

* documentation is now available at https://logilab-common.readthedocs.io/
* drop python2 support, python >= 3.3 is the new required version
* therefor, drop dependency on six
* drop rpm packaging
* registry: add a Registry.add_select_best_listener method to subscribe to
  the result of a _select_best of a Registry.
* shellutils: deprecate 'input' as argument of RawInput in favor of
  'input_function'

Revision 1.20 / (download) - annotate - [select for diffs], Mon Aug 31 23:07:01 2020 UTC (3 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3
Changes since 1.19: +4 -2 lines
Diff to previous 1.19 (colored)

*: switch to versioned_dependencies.mk for py-setuptools

Revision 1.19 / (download) - annotate - [select for diffs], Sat Jul 6 22:56:03 2019 UTC (4 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.18: +5 -4 lines
Diff to previous 1.18 (colored)

py-logilab-common: updated to 1.4.2

1.4.2:
Bug fixes

Revision 1.18 / (download) - annotate - [select for diffs], Wed Oct 11 07:07:10 2017 UTC (6 years, 1 month ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.17: +6 -5 lines
Diff to previous 1.17 (colored)

py-logilab-common: update to 1.4.1

1.4.1:
Bug fixes.

Revision 1.17 / (download) - annotate - [select for diffs], Mon Sep 4 18:08:20 2017 UTC (6 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.16: +2 -2 lines
Diff to previous 1.16 (colored)

Follow some redirects.

Revision 1.16 / (download) - annotate - [select for diffs], Tue Feb 28 16:46:07 2017 UTC (6 years, 9 months ago) by fhajny
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.15: +5 -5 lines
Diff to previous 1.15 (colored)

Update devel/py-logilab-common to 1.3.0.

- pytest: executable deprecated and renamed as logilab-pytest to prevent
  conflict with pytest provided by http://pytest.org/

Revision 1.15 / (download) - annotate - [select for diffs], Mon Aug 29 15:50:06 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.14: +1 -3 lines
Diff to previous 1.14 (colored)

Remove unnecessary PLIST_SUBST.

Revision 1.14 / (download) - annotate - [select for diffs], Mon Aug 29 15:44:26 2016 UTC (7 years, 3 months ago) by darcy
Branch: MAIN
Changes since 1.13: +3 -4 lines
Diff to previous 1.13 (colored)

Update devel/py-logilab-common to version 1.2.0.
This is mainly to remove dependency on time/py-mxDateTime so that it can
build on Python >= 3.4.
Removed PYTHON_VERSIONS_INCOMPATIBLE line from this and other packages
that had it for this incompatibility.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Aug 28 15:48:30 2016 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.12: +1 -2 lines
Diff to previous 1.12 (colored)

Remove unnecessary PLIST_SUBST and FILES_SUBST that are now provided
by the infrastructure.

Mark a couple more packages as not ready for python-3.x.

Revision 1.12 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:42 2016 UTC (7 years, 4 months ago) by wiz
Branch: MAIN
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.11 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:25 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.10 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:38 2015 UTC (8 years ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.9 / (download) - annotate - [select for diffs], Wed Dec 31 13:57:27 2014 UTC (8 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.8: +1 -2 lines
Diff to previous 1.8 (colored)

Improve EGG_NAME default to work for packages with '-' in their name.
Remove now unnecessary overrides in various packages.

Revision 1.8 / (download) - annotate - [select for diffs], Fri Dec 5 17:07:49 2014 UTC (9 years ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.7: +15 -9 lines
Diff to previous 1.7 (colored)

Update to latest release, 0.63.0. Remove bl3 file, as this package does
not install any shared libraries. Added ALTERNATIVES. Clean up Makefile.
DEPENDS on py-six and py-colorama (for Win32). Changes:

2014-11-05  --  0.63.0
    * drop compatibility with python <= 2.5 (#264017)
    * fix textutils.py doctests for py3k
    * produce a clearer exception when dot is not installed (#253516)
    * make source python3-compatible (3.3+), without using 2to3.  This
     introduces a dependency on six (#265740)
    * fix umessage header decoding on python 3.3 and newer (#149345)
    * WARNING: the compat module no longer exports 'callable', 'izip', 'imap',
     'chain', 'sum', 'enumerate', 'frozenset', 'reversed', 'sorted', 'max',
     'relpath', 'InheritableSet', or any subprocess-related names.

2014-07-30  --  0.62.1
    * shellutils: restore py 2.5 compat by removing usage of class decorator
    * pytest: drop broken --coverage option
    * testlib: support for skipping whole test class and conditional skip, don't
      run setUp for skipped tests
    * configuration: load options in config file order (#185648)

2014-03-07  --  0.62.0
    * modutils: cleanup_sys_modules returns the list of cleaned modules

2014-02-11  --  0.61.0
    * pdf_ext: removed, it had no known users (CVE-2014-1838)
    * shellutils: fix tempfile issue in Execute, and deprecate it
     (CVE-2014-1839)
    * pytest: use 'env' to run the python interpreter
    * graph: ensure output is ordered on node and graph ids (#202314)

2013-16-12  --  0.60.1
    * modutils:
    * don't propagate IOError when package's __init__.py file doesn't
         exist (#174606)
    * ensure file is closed, may cause pb depending on the interpreter, eg
       pypy) (#180876)
    * fix support for `extend_path` based nested namespace packages ;
       Report and patch by John Johnson (#177651)
    * fix some cases of failing python3 install on windows platform / cross
     compilation (#180836)

2013-07-26  --  0.60.0
    * configuration: rename option_name method into option_attrname (#140667)
    * deprecation: new DeprecationManager class (closes #108205)
    * modutils:
        - fix typo causing name error in python3 / bad message in python2
       (#136037)
        - fix python3.3 crash in file_from_modpath due to implementation
        change of imp.find_module wrt builtin modules (#137244)
    * testlib: use assertCountEqual instead of assertSameElements/assertItemsEqual
      (deprecated), fixing crash with python 3.3 (#144526)
    * graph: use codecs.open avoid crash when writing utf-8 data under python3
      (#155138)

2013-04-16  --  0.59.1
    * graph: added pruning of the recursive search tree for detecting cycles in
      graphs (closes #2469)
    * testlib: check for generators in with_tempdir (closes #117533)
    * registry:
        - select_or_none should not silent ObjectNotFound exception
        (closes #119819)
        - remove 2 accidentally introduced tabs breaking python 3 compat
        (closes #117580)
    * fix umessages test w/ python 3 and LC_ALL=C (closes #119967, report and
      patch by Ian Delaney)

2013-01-21  --  0.59.0
    * registry:
        - introduce RegistrableObject base class, mandatory to make
          classes automatically registrable, and cleanup code
          accordingly
        - introduce objid and objname methods on Registry instead of
          classid function and inlined code plus other refactorings to allow
          arbitrary objects to be registered, provided they inherit from new
          RegistrableInstance class (closes #98742)
        - deprecate usage of leading underscore to skip object registration, using
          __abstract__ explicitly is better and notion of registered object 'name'
          is now somewhat fuzzy
        - use register_all when no registration callback defined (closes #111011)

    * logging_ext: on windows, use colorama to display colored logs, if available (closes #107436)
    * packaging: remove references to ftp at logilab
    * deprecations: really check them
    * packaging: steal spec file from fedora (closes #113099)
    * packaging force python2.6 on rhel5 (closes #113099)
    * packaging Update download and project urls (closes #113099)
    * configuration: enhance merge_options function (closes #113458)
    * decorators: fix @monkeypatch decorator contract for dark corner
      cases such as monkeypatching of a callable instance: no more
      turned into an unbound method, which was broken in python 3 and
      probably not used anywhere (actually closes #104047).

2012-11-14  --  0.58.3
    * date: fix ustrftime() impl. for python3 (closes #82161, patch by Arfrever
      Frehtes Taifersar Arahesis) and encoding detection for python2 (closes
      #109740)
    * other python3 code and test fixes (closes #104047)
    * registry: Store.setdefault shouldn't raise RegistryNotFound (closes #111010)
    * table: stop encoding to iso-8859-1, use unicode (closes #105847)
    * setup: properly install additional files during build instead of install (closes #104045)

2012-07-30  --  0.58.2
    * modutils: fixes (closes #100757 and #100935)

2012-07-17  --  0.58.1
    * modutils, testlib: be more python implementation independant (closes #99493 and #99627)

2012-04-12  --  0.58.0
    * new `registry` module containing a backport of CubicWeb selectable objects registry (closes #84654)
    * testlib: DocTestCase fix builtins pollution after doctest execution.
    * shellutil: add argument to ``ProgressBar.update`` to tune cursor progression (closes #88981)
    * deprecated: new DeprecationWrapper class (closes #88942)

2012-03-22  --  0.57.2
    * texutils: apply_units raise ValueError if string isn'nt valid (closes #88808)
    * daemon: don't call putenv directly
    * pytest: do not enable extra warning other than DeprecationWarning.
    * testlib: DocTestCase fix builtins pollution after doctest execution.
    * testlib: replace sys.exit with raise ImportError (closes: #84159)
    * fix license in README
    * add trove classifiers (tell about python 3 support for pypi)

2011-10-28  --  0.57.1
    * daemon: change $HOME after dropping privileges (closes #81297)
    * compat: method_type for py3k use instance of the class to have a
      real instance method (closes: #79268)

2011-10-12  --  0.57.0
    * only install unittest2 when python version < 2.7 (closes: #76068)
    * daemon: make pidfile world-readable (closes #75968)
    * daemon: remove unused(?) DaemonMixin class
    * update compat module for callable() and method_type()
    * decorators: fix monkeypatch py3k compat (closes #75290)
    * decorators: provide a @cachedproperty decorator

2011-09-08  --  0.56.2
    * daemon: call initgroups/setgid before setuid (closes #74173)
    * decorators: @monkeypatch should produce a method object (closes #73920)
    * modutils: allow overriding of _getobj by suppressing mangling

2011-08-05  --  0.56.1
    * clcommands: #72450 --rc-file option doesn't work

2011-06-09  --  0.56.0
    * clcommands: make registration possible by class decoration
    * date: new datetime/delta <-> seconds/days conversion function
    * decorators: refactored @cached to allow usages such as
      @cached(cacheattr='_cachename') while keeping bw compat

2011-04-01  --  0.55.2
    * new function for password generation in shellutils
    * pyro_ext: allow to create a server without registering with a pyrons

2011-03-28  --  0.55.1
    * fix date.ustrftime break if year <= 1900
    * fix graph.py incorrectly builds command lines using %s to call dot
    * new functions to get UTC datetime / time

2011-02-18  --  0.55.0
    * new urllib2ext module providing a GSSAPI authentication handler, based on python-kerberos
    * graph: test and fix ordered_nodes() [closes #60288]
    * changelog: refactor ChangeLog class to ease overriding
    * testlib: Fix tag handling for generator.

2011-01-12  --  0.54.0
    * dropped python 2.3 support
    * daemon: we can now specify umask to daemonize function, and it return
     different exit code according to the process
    * pyro_ext: new ns_reregister function to ensure a name is still properly
     registered in the pyro name server
    * hg: new incoming/outgoing functions backward compatible with regards to
     mercurial version (eg hg 1.6 and earlier)
    * testlib/pytest: more deprecation and removed code. Still on the way to
     unittest2

Revision 1.7 / (download) - annotate - [select for diffs], Fri May 9 07:37:01 2014 UTC (9 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.

Revision 1.6 / (download) - annotate - [select for diffs], Sat Jan 25 10:30:04 2014 UTC (9 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Changes since 1.5: +11 -11 lines
Diff to previous 1.5 (colored)

Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.

Revision 1.5 / (download) - annotate - [select for diffs], Tue Jun 4 07:35:14 2013 UTC (10 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.4: +1 -2 lines
Diff to previous 1.4 (colored)

Replace py-readline/buildlink3.mk with DEPENDS.

There are no buildlink3-relevant files here, just a loadable module.

Revision 1.4 / (download) - annotate - [select for diffs], Wed Oct 31 11:19:32 2012 UTC (11 years, 1 month ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.3: +1 -3 lines
Diff to previous 1.3 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.3 / (download) - annotate - [select for diffs], Sun Apr 8 19:08:53 2012 UTC (11 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.2: +1 -3 lines
Diff to previous 1.2 (colored)

Remove python24 and all traces of it from pkgsrc.
Remove devel/py-ctypes (only needed by and supporting python24).
Remove PYTHON_VERSIONS_ACCEPTED and PYTHON_VERSIONS_INCOMPATIBLE
lines that just mirror defaults now.
Miscellaneous cleanup while editing all these files.

Revision 1.2 / (download) - annotate - [select for diffs], Fri Feb 25 09:47:22 2011 UTC (12 years, 9 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4, pkgsrc-2011Q3-base, pkgsrc-2011Q3, pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Let's assume for now that everything that worked with python-2.6 also
works with python-2.7.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Tue Jan 11 20:41:00 2011 UTC (12 years, 10 months ago) by drochner
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

add py-logilab-common-0.53.0, a collection of miscellaneous modules
used by Logilab projects, from Kamel Derouiche and Helge Muehlmeier
per pkgsrc-wip

Revision 1.1 / (download) - annotate - [select for diffs], Tue Jan 11 20:41:00 2011 UTC (12 years, 10 months ago) by drochner
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>