The NetBSD Project

CVS log for pkgsrc/devel/py-limits/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-limits

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.14 / (download) - annotate - [select for diffs], Sun Nov 26 09:55:40 2023 UTC (10 days, 4 hours ago) by adam
Branch: MAIN
CVS Tags: HEAD
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

py-limits: updated to 3.7.0

v3.7.0

* Features

  * Ensure rate limit keys in redis use are prefixed
    with a `LIMITS` prefix. This allows for resetting
    all keys generated by the library without implicit
    knowledge of the key structure.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Oct 29 17:16:51 2023 UTC (5 weeks, 2 days ago) by adam
Branch: MAIN
Changes since 1.12: +5 -3 lines
Diff to previous 1.12 (colored)

py-limits: updated to 3.6.0

v3.6.0

* Bug Fix

  * Remove default socket timeout from mongo storage
  * Ensure _version.py has stable content when generated
    using `git archive` from a tag regardless of when it is
    run.

* Compatibility

  * Remove references to python 3.7
  * Remove unnecessary setuptools dependency

Revision 1.12 / (download) - annotate - [select for diffs], Tue Aug 29 07:38:04 2023 UTC (3 months, 1 week ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.11: +3 -2 lines
Diff to previous 1.11 (colored)

py-limits: updated to 3.5.0

v3.5.0
------
* Bug Fix

  * Handle ``cost`` > 8000 when using redis
  * Remove arbitrary default timeout for redis+sentinel

v3.4.0
------
* Bug Fix

  * Remove use of weakreferences to storages in strategy
    classes as this was not documented or required and
    led to usability issues.

* Chores

  * Update documentation dependencies
  * Remove unused gcra lua script

v3.3.1
------
* Compatibility

  * Block incompatible versions of redis-py

* Chores

  * Force error on warnings in tests

v3.3.0
------
* Compatibility

  * Remove deprecated use of `pkg_resources` and switch
    to `importlib_resource`

* Chores

  * Update documentation dependencies
  * Update github actions versions

v3.2.0
------
* Bug Fix

  * Fix handling of authentication details in storage url of redis cluster

* Chores

  * Add test coverage for redis cluster with auth required

v3.1.6
------
* Bug Fix

  * Disallow acquiring amounts > limit in moving window

* Usability

  * Use a named tuple for the response from `RateLimiter.get_window_stats`

v3.1.5
------
* Performance

  * Reduce rpc calls to etcd for counter increment

* Compatibility

  * Relax version requirements for packaging dependency

* Chores

  * Improve benchmark outputs
  * Improve documentation for etcd

v3.1.4
------
* Chores

  * Fix benchmark result artifact capture

v3.1.3
------
* Chores

  * Fix benchmark result artifact capture

v3.1.2
------
* Chores

  * Collapse benchmark & ci workflows

v3.1.1
------
* Chores

  * Fix compatibility tests for etcd in CI
  * Improve visual identifiers of tests
  * Add benchmark tests in CI

v3.1.0
------
* Compatibility

  * Increase minimum version of pymongo to 4.1

* Chores

  * Refactor storage tests
  * Improve test coverage across python versions in CI

v3.0.0
------
* Features

  * Added etcd storage support for fixed window strategies

* Compatibility

  * Removed deprecated GAE Memcached storage
  * Updated minimum dependencies for mongodb
  * Updated dependency for async memcached on python 3.11

Revision 1.11 / (download) - annotate - [select for diffs], Mon Dec 12 07:53:33 2022 UTC (11 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

py-limits: updated to 2.7.2

v2.7.2
------
* Compatibility Updates
  * Update documentation dependencies
  * Relax version constraint for packaging dependency
  * Bump CI to use python 3.11 final

Revision 1.10 / (download) - annotate - [select for diffs], Fri Oct 21 07:55:18 2022 UTC (13 months, 2 weeks ago) by adam
Branch: MAIN
Changes since 1.9: +7 -4 lines
Diff to previous 1.9 (colored)

py-limits: updated to 2.7.1

v2.7.1
------
Release Date: 2022-10-20

* Compatibility Updates

  * Increase pymemcached dependency range to in include 4.x
  * Add python 3.11 rc2 to CI


v2.7.0
------
Release Date: 2022-07-16

* Compatibility Updates

  * Update :pypi:`coredis` requirements to include 4.x versions
  * Remove CI / support for redis < 6.0
  * Remove python 3.7 from CI
  * Add redis 7.0 in CI

v2.6.3
------
Release Date: 2022-06-05

* Chores

  * Update development dependencies
  * Add CI for python 3.11
  * Increase test coverage for redis sentinel

v2.6.2
------
Release Date: 2022-05-12

* Compatibility Updates

  * Update :pypi:`motor` requirements to include 3.x version
  * Update async redis sentinel implementation to remove use of deprecated methods.
  * Fix compatibility issue with asyncio redis ``reset`` method in cluster mode
    when used with :pypi:`coredis` versions >= 3.5.0

v2.6.1
------
Release Date: 2022-04-25

* Bug Fix

  * Fix typing regression with strategy constructors `Issue 88 <https://github.com/alisaifee/limits/issues/88>`_


v2.6.0
------
Release Date: 2022-04-25

* Deprecation

  * Removed tests for rediscluster using the :pypi:`redis-py-cluster` library

* Bug Fix

  * Fix incorrect ``__slots__`` declaration in :class:`limits.RateLimitItem`
    and it's subclasses

v2.5.4
------
Release Date: 2022-04-25

* Bug Fix

  * Fix typing regression with strategy constructors `Issue 88 <https://github.com/alisaifee/limits/issues/88>`_

v2.5.3
------
Release Date: 2022-04-22

* Chore

  * Automate Github releases

v2.5.2
------
Release Date: 2022-04-17

* Chore

  * Increase strictness of type checking and annotations
  * Ensure installations from source distributions are PEP-561
    compliant

v2.5.1
------
Release Date: 2022-04-15

* Chore

  * Ensure storage reset methods have consistent signature

v2.5.0
------
Release Date: 2022-04-13

* Feature

  * Add support for using redis cluster via the official redis client
  * Update coredis dependency to use 3.x

* Deprecations

  * Deprecate using redis-py-cluster

* Chores

  * Remove beta tags for async support
  * Update code base to remove legacy syntax
  * Tighten up CI test dependencies

v2.4.0
------
Release Date: 2022-03-10

* Feature

  * Allow passing an explicit connection pool to redis storage.
    Addresses `Issue 77 <https://github.com/alisaifee/limits/issues/77>`_

v2.3.3
------
Release Date: 2022-02-03

* Feature

  * Add support for dns seed list when using mongodb

v2.3.2
------
Release Date: 2022-01-30

* Chores

  * Improve authentication tests for redis
  * Update documentation theme
  * Pin pip version for CI

v2.3.1
------
Release Date: 2022-01-21

* Bug fix

  * Fix backward incompatible change that separated sentinel
    and connection args for redis sentinel (introduced in 2.1.0).
    Addresses `Issue 97 <https://github.com/alisaifee/limits/issues/97>`_


v2.3.0
------
Release Date: 2022-01-15

* Feature

  * Add support for custom cost per hit

* Bug fix

  * Fix installation issues with missing setuptools

v2.2.0
------
Release Date: 2022-01-05

* Feature

  * Enable async redis for python 3.10 via coredis

* Chore

  * Fix typing issue with strategy constructors

v2.1.1
------
Release Date: 2022-01-02

* Feature

  * Enable async memcache for python 3.10

* Bug fix

  * Ensure window expiry is reported in local time for mongodb
  * Fix inconsistent expiry for fixed window with memcached

* Chore

  * Improve strategy tests

v2.1.0
------
Release Date: 2021-12-22

* Feature

  * Add beta asyncio support
  * Add beta mongodb support
  * Add option to install with extras for different storages

* Bug fix

  * Fix custom option for cluster client in memcached
  * Fix separation of sentinel & connection args in :class:`limits.storage.RedisSentinelStorage`

* Deprecation

  * Deprecate GAEMemcached support
  * Remove use of unused `no_add` argument in :meth:`limits.storage.MovingWindowSupport.acquire_entry`

* Chore

  * Documentation theme upgrades
  * Code linting
  * Add compatibility CI workflow



v2.0.3
------
Release Date: 2021-11-28

* Chore

  * Ensure package is marked PEP-561 compliant

v2.0.1
------
Release Date: 2021-11-28

* Chore

  * Added type annotations

v2.0.0
------
Release Date: 2021-11-27

* Chore

  * Drop support for python < 3.7

Revision 1.9 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:15 2022 UTC (23 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.8: +2 -1 lines
Diff to previous 1.8 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.8 / (download) - annotate - [select for diffs], Tue Apr 28 13:23:38 2020 UTC (3 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

py-limits: updated to 1.5.1

1.5.1:
* Bug fix
  * Remove duplicate call to ttl in RedisStorage
  * Initialize master/slave connections for RedisSentinel once

1.5:
* Bug fix for handling TTL response from Redis when key doesnãàÑÕ exist
* Support Memcache over unix domain socket
* Support Memcache cluster
* Pass through constructor keyword arguments to underlying storage
  constructor(s)
* CI & test improvements

Revision 1.7 / (download) - annotate - [select for diffs], Thu Jan 16 10:08:57 2020 UTC (3 years, 10 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

py-limits: updated to 1.4.1

1.4.1:
* Bug fix for implementation of clear in MemoryStorage
  not working with MovingWindow

1.4:
* Expose API for clearing individual limits
* Support for redis over unix domain socket
* Support extra arguments to redis storage

Revision 1.6 / (download) - annotate - [select for diffs], Mon Feb 26 09:07:42 2018 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

py-limits: updated to 1.3

1.3:
Remove pinging redis on initialization

Revision 1.5 / (download) - annotate - [select for diffs], Sun Sep 17 13:35:03 2017 UTC (6 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.4: +2 -3 lines
Diff to previous 1.4 (colored)

py-limits: update to 1.2.1

1.2.1:
* Fix regression with csv as multiple limits

1.2.0:
* Support reset for RedisStorage
* Improved rate limit string parsing

Revision 1.4 / (download) - annotate - [select for diffs], Sat Sep 16 19:26:47 2017 UTC (6 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Reset maintainer

Revision 1.3 / (download) - annotate - [select for diffs], Wed Jun 8 17:43:29 2016 UTC (7 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Switch to MASTER_SITES_PYPI.

Revision 1.2 / (download) - annotate - [select for diffs], Tue Jun 30 22:44:17 2015 UTC (8 years, 5 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

1.0.8 2015-06-19
================
* Added check method for all storage classes
* Use lock timeout with redis

1.0.7 2015-06-07
================
* No functional change

1.0.6 2015-05-13
================
* Bug fixes for .test() logic

1.0.5 2015-05-12
================
* Add support for testing a rate limit before hitting it.

Revision 1.1 / (download) - annotate - [select for diffs], Thu Apr 2 23:22:31 2015 UTC (8 years, 8 months ago) by rodent
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2

Import py27-limits-1.0.4 as devel/py-limits.

The python limits package provides utilities to implement rate limiting using
various strategies and storage backends such as redis & memcached.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>