The NetBSD Project

CVS log for pkgsrc/devel/py-lazy-object-proxy/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-lazy-object-proxy

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.19: download - view: text, markup, annotated - select for diffs
Mon Apr 21 07:47:25 2025 UTC (2 days, 19 hours ago) by adam
Branches: MAIN
CVS tags: HEAD
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +3 -4 lines
py-lazy-object-proxy: updated to 1.11.0

1.11.0 (2025-04-16)

* Added Python 3.13 wheels.
* Added support for ``__format__``.
* Dropped support for Python 3.8.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Sat Apr 12 11:33:33 2025 UTC (11 days, 15 hours ago) by adam
Branches: MAIN
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +3 -4 lines
Fix PLIST after py-setuptools update; bump depends and revision

Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Nov 11 07:28:14 2024 UTC (5 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +1 -2 lines
py-*: remove unused tool dependency

py-setuptools includes the py-wheel functionality nowadays

Revision 1.16: download - view: text, markup, annotated - select for diffs
Sat Dec 16 12:05:52 2023 UTC (16 months, 1 week ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +6 -8 lines
py-lazy-object-proxy: updated to 1.10.0

1.10.0 (2023-12-15)
-------------------

* Added Python 3.12 wheels.
* Dropped support for Python 3.7.
* Applied some reformatting and lint fixes using ruff to the codebase (mostly more Python 2 leftover cleanups).

Revision 1.15: download - view: text, markup, annotated - select for diffs
Thu Jan 5 10:35:25 2023 UTC (2 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +7 -6 lines
py-lazy-object-proxy: updated to 1.9.0

1.9.0 (2023-01-04)
------------------
* Added support for matrix multiplication operator (``@``).
* Should have all the wheels now (including the manylinux ones).
* Bumped minimum version requirements for setuptools and setuptools-scm.
* Switched the default pure python fallback implementation to the "simple" one (when you ``from lazy_object_proxy import Proxy``
  and the C extension is not available).
  Previously the "slots" implementation was used but as it turns out it is slower on Python 3.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sun Nov 20 23:24:57 2022 UTC (2 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +5 -5 lines
py-lazy-object-proxy: updated to 1.8.0

1.8.0 (2022-10-26)
------------------
* Cleaned up use of cPickle..
* Cleaned up more dead Python 2 code.
* Added Python 3.11 wheels.
* Dropped support for Python 3.6.

Revision 1.13: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:14 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.12: download - view: text, markup, annotated - select for diffs
Sun Dec 19 13:28:46 2021 UTC (3 years, 4 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +3 -1 lines
py-lazy-object-proxy: mark as not for python 2.7

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Dec 15 20:09:40 2021 UTC (3 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -2 lines
py-lazy-object-proxy: updated to 1.7.1

1.7.1 (2021-12-15)
------------------
* Removed most of the Python 2 support code and fixed ``python_requires`` to require at least Python 3.6.

  Note that 1.7.0 has been yanked because it could not install on Python 2.7.
  Installing lazy-object-proxy on Python 2.7 should automatically fall back to the 1.6.0 release now.

Revision 1.10: download - view: text, markup, annotated - select for diffs
Wed Dec 15 09:37:36 2021 UTC (3 years, 4 months ago) by adam
Branches: MAIN
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
py-lazy-object-proxy: updated to 1.7.0

1.7.0 (2021-12-15)
------------------

* Switched CI to GitHub Actions, this has a couple consequences:

  * Support for Python 2.7 is dropped. You can still install it there but it's not tested anymore and
    Python 2 specific handling will be removed at some point.
  * Linux wheels are now provided in `musllinux` and `manylinux2014` variants.

* Fixed ``__index__`` to fallback to ``int`` if the wrapped object doesn't have an ``__index__`` method.
  This prevents situations where code using a proxy would otherwise likely just call ``int`` had the object
  not have an ``__index__`` method.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon May 10 14:50:44 2021 UTC (3 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +4 -5 lines
py-lazy-object-proxy: updated to 1.6.0

1.6.0 (2021-03-22)
------------------

* Added support for async special methods (``__aiter__``, ``__anext__``,
  ``__await__``, ``__aenter__``, ``__aexit__``).
  These are used in the ``async for``, ``await` and ``async with`` statements.

  Note that ``__await__`` returns a wrapper that tries to emulate the crazy
  stuff going on in the ceval loop, so there will be a small performance overhead.
* Added the ``__resolved__`` property. You can use it to check if the factory has
  been called.

Revision 1.8: download - view: text, markup, annotated - select for diffs
Mon Dec 7 08:59:40 2020 UTC (4 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -2 lines
py-lazy-object-proxy: updated to 1.5.2

1.5.2 (2020-11-26)
------------------
* Added Python 3.9 wheels.
* Removed Python 2.7 Windows wheels
  (not supported on newest image with Python 3.9).

Revision 1.7: download - view: text, markup, annotated - select for diffs
Mon Aug 31 23:07:01 2020 UTC (4 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q3-base, pkgsrc-2020Q3
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +4 -2 lines
*: switch to versioned_dependencies.mk for py-setuptools

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Jul 29 12:07:15 2020 UTC (4 years, 8 months ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +3 -2 lines
py-lazy-object-proxy: updated to 1.5.1

1.5.1:
* Added ARM64 wheels (manylinux2014).

Revision 1.5: download - view: text, markup, annotated - select for diffs
Fri Jun 12 21:04:41 2020 UTC (4 years, 10 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2020Q2-base, pkgsrc-2020Q2
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
py-lazy-object-proxy: update to 1.5.0.

1.5.0 (2020-06-05)
------------------

* Added support for ``__fspath__``.
* Dropped support for Python 3.4.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Sat Oct 26 22:47:08 2019 UTC (5 years, 5 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
py-lazy-object-proxy: updated to 1.4.3

1.4.3:
* Added binary wheels for Python 3.8.
* Fixed license metadata.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Tue Oct 15 07:58:31 2019 UTC (5 years, 6 months ago) by adam
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +6 -3 lines
py-lazy-object-proxy: updated to 1.4.2

1.4.2:
* Included a pyproject.toml to allow users install the sdist with old python/setuptools, as the setuptools-scm dep will be fetched by pip instead of setuptools.

1.4.1:
* Fixed wheels being built with ``-coverage`` cflags. No more issues about bogus ``cext.gcda`` files.
* Removed useless C file from wheels.
* Changed ``setup.py`` to use setuptools-scm.

1.4.0:
* Fixed ``__mod__`` for the slots backend.
* Dropped support for Python 2.6 and 3.3.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sun Jul 16 19:57:11 2017 UTC (7 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +3 -3 lines
1.3.1:
* Fix broken release (``sdist`` had a broken ``MANIFEST.in``).

1.3.0:
* Speed up arithmetic operations involving ``cext.Proxy`` subclasses.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Tue Feb 28 17:11:28 2017 UTC (8 years, 1 month ago) by fhajny
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Import py-lazy-object-proxy 1.2.2 based on wip/py-lazy-object-proxy.

A fast and thorough lazy object proxy.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>