File:  [cvs.NetBSD.org] / pkgsrc / devel / py-iniconfig / Makefile
Revision 1.5: download - view: text, annotated - select for diffs
Sun Apr 30 17:20:36 2023 UTC (22 months, 3 weeks ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, HEAD
py-iniconfig: update to 2.0.0.

2.0.0
======

* add support for Python 3.7-3.11
* drop support for Python 2.6-3.6
* add encoding argument defaulting to utf-8
* inline and clarify type annotations
* move parsing code from inline to extra file
* add typing overloads for helper methods


.. note::

  major release due to the major changes in python versions supported + changes in packaging

  the api is expected to be compatible

# $NetBSD: Makefile,v 1.5 2023/04/30 17:20:36 wiz Exp $

DISTNAME=	iniconfig-2.0.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	devel python
MASTER_SITES=	${MASTER_SITE_PYPI:=i/iniconfig/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://github.com/RonnyPfannschmidt/iniconfig
COMMENT=	Brain-dead simple config-ini parsing
LICENSE=	mit

TOOL_DEPENDS+=	${PYPKGPREFIX}-hatch-vcs-[0-9]*:../../devel/py-hatch-vcs
TOOL_DEPENDS+=	${PYPKGPREFIX}-hatchling-[0-9]*:../../devel/py-hatchling

PYTHON_VERSIONS_INCOMPATIBLE=	27

USE_LANGUAGES=	# none

.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>