The NetBSD Project

CVS log for pkgsrc/devel/py-hg-git/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-hg-git

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.23 / (download) - annotate - [select for diffs], Fri Mar 22 18:43:43 2024 UTC (3 weeks, 6 days ago) by hauke
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, HEAD
Changes since 1.22: +4 -4 lines
Diff to previous 1.22 (colored)

Update devel/py-hg-git to v1.1.1

For changes see
<https://foss.heptapod.net/mercurial/hg-git/-/releases>, upstream's
changelist does not lend itself to easy copying.

Revision 1.22 / (download) - annotate - [select for diffs], Mon Jun 26 11:38:37 2023 UTC (9 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3
Changes since 1.21: +2 -2 lines
Diff to previous 1.21 (colored)

py-hg-git: update to 1.0.2.

This is a minor release, focusing on bugs and compatibility.

Fix --source/-s argument to transplant with Hg-Git
enabled. (#392)
Fix cloning repositories using the old static HTTP support with
Hg-Git enabled.
Handle pushing tags to Git that cannot be stored as references such
as double-quotes on Windows. (#397)
Avoid converting unrelated refs on pull, such as Github PR-related refs. (#386)
Fix tests with GNU Grep 3.8 and later, by avoiding the egrep
alias (#400)
Support reading remote refs even if packed.
Add support for Dulwich 0.21 and later.
Mark Mercurial 6.4 as supported and tested.
Address slowness when pulling large repositories, caused by writing
unchanged references. (#401)

Revision 1.21 / (download) - annotate - [select for diffs], Mon Nov 28 10:20:36 2022 UTC (16 months, 3 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.20: +5 -7 lines
Diff to previous 1.20 (colored)

py-hg-git: update to 1.0.1.

hg-git 1.0.1 (2022-11-04)
=========================

This is a minor release, focusing on bugs and compatibility.

* Ignore any ``GIT_SSH_COMMAND`` environment variable, rather than
  dying with an error. (#369)
* Fix bug with unusual progress lines from Azure Repo (#391)
* Fix incorrect use of localisation APIs (#387)
* Fix pushing with Dulwich 0.2.49 or later.
* Fix tests with Git 2.37.
* Fix bug with tags or remote refs in the local Git repository that
  point to missing commits.
* Mark Mercurial 6.2 and 6.3 as supported and tested.

Thanks to Pierre Augier and Aay Jay Chan for contributing to this
release!

hg-git 1.0.0 (2022-04-01)
=========================

This is the first stable release in the 1.0 series. In addition to all
the features and fixes in the betas, it includes:

* Handle errors in ``.gitmodules`` gracefully, allowing the conversion
  to continue. (#329)
* Don't die with an error when ``.hgsub`` contains comments. (#128)
* Suppress errors on export related to history editing of certain
  commits with unusual authorship and messages. (#383)
* Fix tests with Git 2.35.

Other changes:

* Increase test coverage by using different versions of Alpine Linux
  and Dulwich.

This release requires Mercurial 5.2 or later and Python 3.6 or later.

hg-git 1.0b2 (2022-03-10)
=========================

This is a follow-up to the previous beta, that fixes the following
bugs:

* Fix tests with Mercurial 6.1.
* Avoid prompting for authentication after a successful push, by
  storing the authenticated client. (#379)

This release requires Mercurial 5.2 or later and Python 3.6 or later.

hg-git 1.0b1 (2022-01-26)
=========================

This is a preview of an upcoming major release that contains changes
to user-facing behaviour, as well as a fair amount of internal
changes. The primary focus is on adjusting the user experience to be
more intuitive and consistent with Git and Mercurial. The internal
changes are mainly refactoring to make the code more consistent and
maintainable. Performance should also be much better; a simple clone
of a medium-sized repository is about 40% faster.

This release requires Mercurial 5.2 or later and Python 3.6 or later.

Changes to behaviour:

* When a pull detects that a Git remote branch vanishes, it will
  remove the corresponding local tags, such as ``default/branch``.
  This is equivalent to using ``git fetch --prune``, and adjustable
  using the ``git.pull-prune-remote-branches`` configuration option.
* Similarly, delete the actual bookmarks corresponding to a remote
  branch, unless the bookmarks was moved since the last pull from Git.
  This is enabled by default and adjustable using the
  ``git.pull-prune-bookmarks`` configuration option.
* Speed up ``pull`` by using a single transaction per map save
  interval.
* Similarly, speed up ``hg clone`` by always using a single
  transaction and map save interval, as Mercurial will delete the
  repository on errors.
* Change the default ``hggit.mapsavefrequency`` to 1,000 commits rather
  than just saving at the end.
* Abort with a helpful error when a user attempts to push to Git from
  a Mercurial repository without any bookmarks nor tags. Previously,
  that would either invent a bookmark ãàÈä *once* ãàor just report that
  nothing was found.
* Only update e.g. ``default/master`` when actually pulling from
  ``default``.

Enhancements:

* Add a ``gittag()`` revset.
* Print a message describing which bookmarks changed during a pull.
* Let Mercurial report on the incoming changes once each transaction
  is saved, similar to when pulling from a regular repository.
* Remove some unnecessary caching in an attempt to decrease memory
  footprint.
* Advance phases during the pull rather than at the end.
* With ``hggit.usephases``, allow publishing tags and specific remotes
  on pull, as well as publishing the remote ``HEAD`` on push.
* Change defaults to drop illegal paths rather than aborting the
  conversion; this is adjustable using the ``hggit.invalidpaths``
  configuration option.
* Allow updating bookmarks from obsolete commits to their successors.

Bug fixes:

* Adjust publishing of branches to correspond to the documentation.
  Previously, e.g. listing ``master`` would publish a local bookmark
  even if diverged from the remote.
* Handle corrupt repositories gracefully in the ``gverify`` command,
  and allow checking repository integrity.
* Only apply extension wrappers when the extension is actually
  enabled rather than just loaded.
* Fix pulling with ``phases.new-commit`` set to ``secret``. (#266)
* Detect divergence with a branch bookmark suffix.
* Fix flawed handling of remote messages on pull and push, which
  caused most such messages to be discarded.
* Report a helpful error when attempting to push or convert with
  commits missing in the Git repository. Also, issue a warning when
  creating a new Git repository with a non-empty map, as that may lead
  to the former.
* Ensure that ``gimport`` also synchronises tags.
* Address a bug where updating bookmarks might fail with certain
  obsolete commits.
* Handle missing Git commits gracefully. (#376)

Other changes:

* Require ``setuptools`` for building, and use ``setuptools_scm`` for
  determining the version of the extension.
* Refactoring and reformatting of the code base.

hg-git 0.10.4 (2022-01-26)
==========================

This is a minor release, focusing on bugs and compatibility.

Bug fixes:

* Fix compatibility with the ``mercurial_keyring`` extension. (#360)
* Add missing test files to the source archive. (#375)
* Fix tests with Git 2.34.

hg-git 0.10.3 (2021-11-16)
==========================

This is a minor release, focusing on bugs and compatibility.

Enhancements:

* Add support for Mercurial 6.0.

hg-git 0.10.2 (2021-07-31)
==========================

This is a minor release, focusing on bugs and compatibility.

Enhancements:

* Add support for Mercurial 5.9.

Bug fixes:

* Fix the ``git.authors`` configuration option, broken in Python 3.

hg-git 0.10.1 (2021-05-12)
==========================

This is a minor release, focusing on bugs and compatibility.

Enhancements:

* Add support for Mercurial 5.8.

Bug fixes:

* Fix some documentation issues.
* Don't overwrite annotated tags on push.
* Fix an issue where pushing a repository without any bookmarks would
  push secret changesets.

Revision 1.20 / (download) - annotate - [select for diffs], Fri Jan 14 11:37:24 2022 UTC (2 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.19: +2 -2 lines
Diff to previous 1.19 (colored)

py-hg-git: fix EGG_NAME

Revision 1.19 / (download) - annotate - [select for diffs], Tue Jan 4 20:53:10 2022 UTC (2 years, 3 months ago) by wiz
Branch: MAIN
Changes since 1.18: +2 -1 lines
Diff to previous 1.18 (colored)

*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.18 / (download) - annotate - [select for diffs], Wed Mar 24 09:25:09 2021 UTC (3 years ago) by hauke
Branch: MAIN
CVS Tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1
Changes since 1.17: +3 -3 lines
Diff to previous 1.17 (colored)

Update package to 0.10, fixing an "AttributeError: 'bytes' object has
no attribute 'encode'" during 'hg clone'.

From upstream's changelog:

hg-git 0.10.0 (2020-02-01)
The 0.10.x series will be the last one supporting Python 2.7 and
Python 3.5. Future feature releases will only support Python 3.6 and
later and Mercurial 5.2 or later.
Enhancements:

Add support for proper HTTP authentication, using either
~/.git-credentials or just as with any other Mercurial remote
repository. Previously, the only place to specify credentials was in
the URL.
Add --git option to hg tag for creating lightweight Git tags.
Always show Git tags and remotes in hg log, even if marked as
obsolete.
Support {gitnode} keyword in templates for incoming changes.
Support HTTP authentication using either the Mercurial
configuration, git-credentials or a user prompt.
Support accessing Git repositories using file:// URIs.
Optimise writing the map between Mercurial and Git commits.
Add debuggitdir command that prints the path to the cached Git
repository.

Bug fixes:

Fix pulling changes that build on obsoleted changesets.
Fix using git-cleanup from a shared repository.
Fix scp-style ÒÕRIson Windows.
Fix hg status crashing when using .gitignore and a directory
is not readable.
Fix support for .gitignore from shared repositories and when
using a Mercurial built with Rust extensions.
Add brotli to list of modules ignored by Mercurial's
demandimport, so urllib3 can detect its absence on Python 2.7.
Fix the git protocol on Python 3.
Address a deprecation in Dulwich 0.20.6 when pushing to Git.
Fix configuration path sub-options such as remote:pushurl.
Fix pushing to Git when invalid references exist by disregarding
them.
Always save the commit map after an import.
Add support for using Python 3 on Windows.
Mark gimport, gexport and gclear as advanced as they are
either complicated to understand or dangerous.
Handle backslashes in .gitignore correctly on Windows.
Fix path auditing on Windows, so that e.g. .hg and .git
trigger the appropriate behaviour.

Other changes:

More robust tests and CI infrastructure.
Drop support for Mercurial 4.3.
Updated documentation.

Revision 1.17 / (download) - annotate - [select for diffs], Sat Jan 16 20:26:56 2021 UTC (3 years, 3 months ago) by maya
Branch: MAIN
Changes since 1.16: +6 -4 lines
Diff to previous 1.16 (colored)

py-hg-git: bump PKGREVISION for being python3-only because of py-dulwich.

Appease pkglint by not setting PKGVERSION.

Revision 1.16 / (download) - annotate - [select for diffs], Sat Jan 16 20:21:40 2021 UTC (3 years, 3 months ago) by maya
Branch: MAIN
Changes since 1.15: +3 -1 lines
Diff to previous 1.15 (colored)

Mark all py-dulwich users as being python 3 only, it dropped python 2.

net/Radicale would have been problematic if py-ldap was still py2 only,
but it doesn't appear to be.

pointed out by adam, thanks.

Revision 1.15 / (download) - annotate - [select for diffs], Sat Jan 16 15:15:30 2021 UTC (3 years, 3 months ago) by maya
Branch: MAIN
Changes since 1.14: +6 -9 lines
Diff to previous 1.14 (colored)

py-hg-git: update to 0.9.0. python 3 support.

No changes available.

Revision 1.14 / (download) - annotate - [select for diffs], Sat Jan 18 23:30:37 2020 UTC (4 years, 3 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.

Revision 1.13 / (download) - annotate - [select for diffs], Sun Nov 3 10:18:28 2019 UTC (4 years, 5 months ago) by rillig
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.12: +2 -2 lines
Diff to previous 1.12 (colored)

devel/py-*: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.

Revision 1.12 / (download) - annotate - [select for diffs], Mon Sep 2 13:19:37 2019 UTC (4 years, 7 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.11: +2 -2 lines
Diff to previous 1.11 (colored)

Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for future Python 3.8

Revision 1.11 / (download) - annotate - [select for diffs], Fri Apr 26 13:13:52 2019 UTC (4 years, 11 months ago) by maya
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.

Revision 1.10 / (download) - annotate - [select for diffs], Tue Jul 3 05:03:11 2018 UTC (5 years, 9 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4, pkgsrc-2018Q3-base, pkgsrc-2018Q3
Changes since 1.9: +2 -2 lines
Diff to previous 1.9 (colored)

extend PYTHON_VERSIONS_ for Python 3.7

Revision 1.9 / (download) - annotate - [select for diffs], Tue Nov 7 15:14:58 2017 UTC (6 years, 5 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4
Changes since 1.8: +3 -3 lines
Diff to previous 1.8 (colored)

py-hg-git: update to 0.8.10.

Compatibility with mercurial 4.4.

Revision 1.8 / (download) - annotate - [select for diffs], Sun Sep 3 14:16:43 2017 UTC (6 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3
Changes since 1.7: +3 -3 lines
Diff to previous 1.7 (colored)

Updated py-hg-git to 0.8.9.

hg-git 0.8.9 has just been tagged and uploaded to PyPI. This release
is compatible with the just-released Mercurial 4.3.

This release includes a fix for CVE-2017-1000116. From the Mercurial
release announcement:

Mercurial was not sanitizing hostnames passed to ssh, allowing shell
injection attacks by specifying a hostname starting with -oProxyCommand.
This is also present in Git (CVE-2017-1000117) and Subversion
(CVE-2017-9800), so please patch those tools as well if you have
them installed. All three tools are doing their security release
today.

Revision 1.7 / (download) - annotate - [select for diffs], Sun Jan 1 14:43:33 2017 UTC (7 years, 3 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Add python-3.6 to incompatible versions.

Revision 1.6 / (download) - annotate - [select for diffs], Fri Sep 9 06:24:19 2016 UTC (7 years, 7 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.5: +3 -3 lines
Diff to previous 1.5 (colored)

Updated py-hg-git to 0.8.5.

init: mark Mercurial 3.7 as supported and prepare for 0.8.5
test-help: fix for Mercurial 3.7
test-renames.t: don't use "seq"
push: better formatting of messages from the server
git_handler: use util method for writing bookmarks
util: add method for writing bookmarks
util: regularize mercurial imports
ignore: add .testtimes to ignored files
version: bump up to 0.8.4
all-version-tests: test Mercurial 3.6.3
git_handler: work around dulwich using unicode for ref names Dulwich treats ref names internally as unicode strings (probably because of Python 3?), which means that at some points it tries to do os.path.join between the repo path and the unicode of the ref name, which fails miserably if we construct the repo with a str and not a unicode. Kludge around this problem. Fixes issue 172. This is a roll-forward of a593069575bb, which should be valid now that thhgrepo: ensure all git-origin tags are bytes If we don't do this we might end up with unicodes being written using ui, which then breaks in popbuffer in test-encoding.t. This appears to be an academic concern until we start passing unicode paths to git repos, which we need to do in order to resolve some other problems. Yay.
all-version-tests: wrap to 80 columns and test 3.{5,6}.2
Makefile: respect HGTESTFLAGS environment variable
test-push.t: clean up compat cruft
testutil: clean up compat cruft
test-subrepos.t: clean up compat cruft
gitdirstate: fix up compat comment pathutil isn't in 2.8.
gitrepo: clean up compat cruft
merge
overlay: regularize mercurial imports
gitdirstate: regularize mercurial imports
ssh: regularize mercurial imports
hgrepo: regularize mercurial imports
hg2git: regularize mercurial imports
init: regularize mercurial imports
git_handler: regularize mercurial imports
bookmarks: use bookmarks.recordchange instead of bookmarks.write if available bookmarks.write is deprecated and it was showing warning messages in test-hg-branch.t with the latest test runner from core mercurial. Tested with both hg 2.8 and hg tip.
init: handle AttributeError in addition to ImportError If a module doesn't exist, it yields an ImportError, if an attribtue doesn't exist on a module, it yields an AttributeError
ssh: fix breakage again with dulwich update dulwich 0.12.x changed the way they pass parameters around, so we reformat that to what hg-git expects. This is just plain ridiculous.
push: print messages from the server Some servers, for example, Bitbucket, output helpful messages. This patch reports the output, if any exist, to the user.
init: only activate git ignore logic in reposetup This will massively speed up 'hg status' on repos that are not git based. On my macports repo, status went from Before: 0m0.591s After: 0m0.297s
Backed out changeset a593069575bb This was causing test-encoding.t to fail.
git_handler: work around dulwich using unicode for ref names Dulwich treats ref names internally as unicode strings (probably because of Python 3?), which means that at some points it tries to do os.path.join between the repo path and the unicode of the ref name, which fails miserably if we construct the repo with a str and not a unicode. Kludge around this problem. Fixes issue 172.
readme: document the specific behaviors of hg author translation Particularly the odd ext:(%xx) feature.
manifest: include test and test data Closes issue #154.
determine_wants: deal with refs being None Not clear how this is happening, but this should fix it. Resolves issue #166.

Revision 1.5 / (download) - annotate - [select for diffs], Sat Jul 9 13:03:41 2016 UTC (7 years, 9 months ago) by wiz
Branch: MAIN
Changes since 1.4: +2 -2 lines
Diff to previous 1.4 (colored)

Remove python33: adapt all packages that refer to it.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Dec 5 21:25:37 2015 UTC (8 years, 4 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

Extend PYTHON_VERSIONS_INCOMPATIBLE to 35

Revision 1.3 / (download) - annotate - [select for diffs], Wed Nov 11 11:59:28 2015 UTC (8 years, 5 months ago) by wiz
Branch: MAIN
Changes since 1.2: +4 -4 lines
Diff to previous 1.2 (colored)

Update py-hg-git to 0.8.3.

Compatible with latest mercurial (3.6).

Change summary not found, commit list at
https://bitbucket.org/durin42/hg-git/commits/tag/0.8.3

Revision 1.2 / (download) - annotate - [select for diffs], Mon Jul 27 09:34:41 2015 UTC (8 years, 8 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3
Changes since 1.1: +2 -2 lines
Diff to previous 1.1 (colored)

Merge MAINTAINER from hg-git.
No real differences except using official master site and py- prefix.

Revision 1.1 / (download) - annotate - [select for diffs], Mon Jun 8 21:29:00 2015 UTC (8 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2015Q2-base, pkgsrc-2015Q2

Import py27-hg-git-0.8.1 as devel/py-hg-git.

This is the Hg-Git plugin for Mercurial, adding the ability to push
and pull to/from a Git server repository from Hg.  This means you can
collaborate on Git based projects from Hg, or use a Git server as a
collaboration point for a team with developers using both Git and Hg.

The Hg-Git plugin can convert commits/changesets losslessly from one
system to another, so you can push via an Hg repository and another Hg
client can pull it and their changeset node ids will be identical -
Mercurial data does not get lost in translation.  It is intended that
Hg users may wish to use this to collaborate even if no Git users are
involved in the project, and it may even provide some advantages if
you're using Bookmarks.

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>