[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-hg-evolve

File: [cvs.NetBSD.org] / pkgsrc / devel / py-hg-evolve / Makefile (download)

Revision 1.29, Tue Mar 8 11:06:36 2022 UTC (2 years, 1 month ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q1-base, pkgsrc-2022Q1
Changes since 1.28: +2 -3 lines

py-hg-evolve: update to 10.5.0.

This is a feature release. The most notable changes are: a new
command:  fixup, which is used to add changes from the working
directory to an arbitrary revision. An issue with histedit not
preserving topics in certain situations was also fixed, see
https://bz.mercurial-scm.org/show_bug.cgi?id=6550. Evolve is now
compatible with the upcoming Mercurial 6.1, which includes head
computation code that is obsolescence-aware (adapted from the evolve
extension). With an up-to-date client and server you should expect
hg push to take much less time. Also compatibility with Mercurial
4.7 was dropped in this release.

# $NetBSD: Makefile,v 1.29 2022/03/08 11:06:36 wiz Exp $
#
# Release notes:
# https://www.mercurial-scm.org/pipermail/evolve-testers/

DISTNAME=	hg-evolve-10.5.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/post//}
CATEGORIES=	devel scm
MASTER_SITES=	${MASTER_SITE_PYPI:=h/hg-evolve/}

MAINTAINER=	joerg@NetBSD.org
HOMEPAGE=	https://www.mercurial-scm.org/doc/evolution/
COMMENT=	Experimental Mercurial extensions from Facebook
LICENSE=	gnu-gpl-v2

DEPENDS+=	${PYPKGPREFIX}-mercurial>=5.4nb1:../../devel/py-mercurial
DEPENDS+=	${PYPKGPREFIX}-sqlite3>=0:../../databases/py-sqlite3
TEST_DEPENDS+=	curl-[0-9]*:../../www/curl

USE_TOOLS+=	bash:test

post-install:
	rm -f ${DESTDIR}${PREFIX}/${PYSITELIB}/hgext3rd/__init__.py*
	rm -f ${DESTDIR}${PREFIX}/${PYSITELIB}/hgext3rd/__pycache__/__init__.*

# Test status as of 10.1.0 with mercurial 5.6:
# Failed test-check-compat-strings.t: output changed
# Failed test-check-debian.t: output changed
# Failed test-evolve-content-divergent-case-A2.t: output changed
# Ran 194 tests, 4 skipped, 3 failed.

.if 0
HG_WRKSRC=	cd ../py-mercurial && ${MAKE} show-var VARNAME=WRKSRC

do-test:
	HGROOT=${HG_WRKSRC:sh}; cd ${WRKSRC}/tests && ${PYTHONBIN} $${HGROOT}/tests/run-tests.py ${_MAKE_JOBS:Q}
.endif

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"