Up to [cvs.NetBSD.org] / pkgsrc / devel / py-hamcrest
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.4 / (download) - annotate - [select for diffs], Sun Nov 27 10:41:35 2022 UTC (9 months, 3 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2023Q2-base,
pkgsrc-2023Q2,
pkgsrc-2023Q1-base,
pkgsrc-2023Q1,
pkgsrc-2022Q4-base,
pkgsrc-2022Q4,
HEAD
Changes since 1.3: +4 -4
lines
Diff to previous 1.3 (colored)
py-hamcrest: updated to 2.0.4 Hamcrest 2.0.4 -------------- Bugfixes - ``has_properties`` now returns ``Matcher[Any]`` type, which addresses type checking errors when nested as a matcher. Features - Added Python 3.11 testing 2.0.3 (2021-12-12) ------------------ Features - * Adds the tests to the sdist. - * Update the CI to test Python 3.10 - * Add pretty string representation for matchers objects Bugfixes - Test coverage is now submitted to codecov.io. - Change to the ``has_entry()`` matcher - if exactly one key matches, but the value does not, report only the mismatching value. - * Fix is_() type annotations Version 2.0.2 ------------- Various type hint bug fixes. Version 2.0.1 ------------- * Make hamcrest package PEP 561 compatible, i.e. supply type hints for external use. Version 2.0.0 ------------- Drop formal support for 2.x Drop formal support for 3.x < 3.5 Fix: raises() grows support for additional matchers on exception object. * Made has_properties() report all mismatches, not just the first. * Silence warnings. * Type fixes. * Remove obsolete dependencies.
Revision 1.3 / (download) - annotate - [select for diffs], Tue Oct 26 10:18:32 2021 UTC (22 months, 4 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base,
pkgsrc-2022Q3,
pkgsrc-2022Q2-base,
pkgsrc-2022Q2,
pkgsrc-2022Q1-base,
pkgsrc-2022Q1,
pkgsrc-2021Q4-base,
pkgsrc-2021Q4
Changes since 1.2: +2 -2
lines
Diff to previous 1.2 (colored)
archivers: Replace RMD160 checksums with BLAKE2s checksums All checksums have been double-checked against existing RMD160 and SHA512 hashes Could not be committed due to merge conflict: devel/py-traitlets/distinfo The following distfiles were unfetchable (note: some may be only fetched conditionally): ./devel/pvs/distinfo pvs-3.2-solaris.tgz ./devel/eclipse/distinfo eclipse-sourceBuild-srcIncluded-3.0.1.zip
Revision 1.2 / (download) - annotate - [select for diffs], Thu Oct 7 13:43:14 2021 UTC (23 months, 2 weeks ago) by nia
Branch: MAIN
Changes since 1.1: +1 -2
lines
Diff to previous 1.1 (colored)
devel: Remove SHA1 hashes for distfiles
Revision 1.1 / (download) - annotate - [select for diffs], Tue Jul 24 15:08:19 2018 UTC (5 years, 2 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2021Q3-base,
pkgsrc-2021Q3,
pkgsrc-2021Q2-base,
pkgsrc-2021Q2,
pkgsrc-2021Q1-base,
pkgsrc-2021Q1,
pkgsrc-2020Q4-base,
pkgsrc-2020Q4,
pkgsrc-2020Q3-base,
pkgsrc-2020Q3,
pkgsrc-2020Q2-base,
pkgsrc-2020Q2,
pkgsrc-2020Q1-base,
pkgsrc-2020Q1,
pkgsrc-2019Q4-base,
pkgsrc-2019Q4,
pkgsrc-2019Q3-base,
pkgsrc-2019Q3,
pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3
py-hamcrest: added version 1.9.0 PyHamcrest is a framework for writing matcher objects, allowing you to declaratively define "match" rules. There are a number of situations where matchers are invaluable, such as UI validation, or data filtering, but it is in the area of writing flexible tests that matchers are most commonly used. When writing tests it is sometimes difficult to get the balance right between overspecifying the test (and making it brittle to changes), and not specifying enough (making the test less valuable since it continues to pass even when the thing being tested is broken). Having a tool that allows you to pick out precisely the aspect under test and describe the values it should have, to a controlled level of precision, helps greatly in writing tests that are "just right." Such tests fail when the behavior of the aspect under test deviates from the expected behavior, yet continue to pass when minor, unrelated changes to the behaviour are made.