[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-gobject-shared

File: [cvs.NetBSD.org] / pkgsrc / devel / py-gobject-shared / Makefile (download)

Revision 1.5, Fri Sep 15 15:13:55 2006 UTC (17 years, 6 months ago) by jmmv
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3
Changes since 1.4: +2 -2 lines

Update py-gobject and py-gobject-shared to 2.12.1:

2.12.1 4-september-2006
       - Corrected version check (Sebastian Dröge, #354364)

2.12.0 4-september-2006
      - Install the html files even when using --disable-docs (#353159, Johan,
        Matthias Clasen)

2.11.4 27-august-2006
      - Include pre-generated html docs in the tarball  (Johan)
      - Fix bug in do_set_property called from constructor (Gustavo, #353039)
      - Fix type registration involving interfaces with signals and/or
        properties (Gustavo)

2.11.3 21-august-2006
      - Documentation updates (John)
      - Documentation build fixes (Johan, John, Gian Mario Tagliaretti)
      - PyGObject can now be compiled using a C++ compiler (Murray Cumming)
      - Type registration bug fix (Gustavo)

2.11.2 8-august-2006
      - Add fixxref.py from PyGTK (Johan)
      - Fix parallel build (#350225, Ed Catmur)

2.11.1 4-august-2006
      - Add John Finlay's reference manual (Johan, John)
      - Fix GOption mem leak (Gustavo)
      - Infrastructure for lazy type registration (Johan)
      - Enum/Flags fixes (Gustavo, John)
      - Eliminate some GCC warnings (Johan)

2.11.0 12-july-2006
      - Add GOption support (#163645, Johannes Hölzl)
      - GObject metaclass converted to Python code (Gustavo)
      - Register GType constants from Python-land (Johan)
      - Distutils updates (John Ehresman, Cedric Gustin)
      - Add support for signal emission hooks (#154845, Johan)
      - g_spawn_close_pid support (Gustavo)
      - Add new APIs do add or disable log redirections (Muntyan, #323786)
      - "sub-sub-type" bug fixed (Gustavo)
      - Coverity report code fixes (Johan)
      - Support retrieving signal and property info from interfaces (Finlay)
      - Support parameters of type G_TYPE_GSTRING in signals (Gustavo)
      - Wrap a few g_filename_* APIs (Gustavo)

# $NetBSD: Makefile,v 1.5 2006/09/15 15:13:55 jmmv Exp $

PKGNAME=		py-gobject-shared-2.12.1

.include "../../devel/py-gobject/Makefile.common"

PYTHON_FOR_BUILD_ONLY=	yes
INSTALLATION_DIRS=	include/pygtk-2.0 lib/pkgconfig

do-build:

do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/include/pygtk-2.0
	${INSTALL_DATA} ${WRKSRC}/gobject/pygobject.h ${PREFIX}/include/pygtk-2.0
	${INSTALL_DATA_DIR} ${PREFIX}/lib/pkgconfig
	${INSTALL_DATA} ${WRKSRC}/pygobject-2.0.pc ${PREFIX}/lib/pkgconfig

.include "../../lang/python/application.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"