The NetBSD Project

CVS log for pkgsrc/devel/py-future/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-future

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.9: download - view: text, markup, annotated - select for diffs
Fri Jan 13 13:50:38 2023 UTC (2 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2025Q1-base, pkgsrc-2025Q1, pkgsrc-2024Q4-base, pkgsrc-2024Q4, pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, HEAD
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -3 lines
py-future: updated to 0.18.3

What's new in version 0.18.3 (2023-01-13)
=========================================
This is a minor bug-fix release containing a number of fixes:

- Backport fix for bpo-38804 (c91d70b)
- Fix bug in fix_print.py fixer (dffc579)
- Fix bug in fix_raise.py fixer (3401099)
- Fix newint bool in py3 (fe645ba)
- Fix bug in super() with metaclasses (6e27aac)
- docs: fix simple typo, reqest -> request (974eb1f)
- Correct __eq__ (c780bf5)
- Pass if lint fails (2abe00d)
- Update docker image and parcel out to constant variable.  Add comment to update version constant (45cf382)
- fix order (f96a219)
- Add flake8 to image (046ff18)
- Make lint.sh executable (58cc984)
- Add docker push to optimize CI (01e8440)
- Build System (42b3025)
- Add docs build status badge to README.md (3f40bd7)
- Use same docs requirements in tox (18ecc5a)
- Add docs/requirements.txt (5f9893f)
- Add PY37_PLUS, PY38_PLUS, and PY39_PLUS (bee0247)
- fix 2.6 test, better comment (ddedcb9)
- fix 2.6 test (3f1ff7e)
- remove nan test (4dbded1)
- include list test values (e3f1a12)
- fix other python2 test issues (c051026)
- fix missing subTest (f006cad)
- import from old imp library on older python versions (fc84fa8)
- replace fstrings with format for python 3.4,3.5 (4a687ea)
- minor style/spelling fixes (8302d8c)
- improve cmp function, add unittest (0d95a40)
- Pin typing==3.7.4.1 for Python 3.3 compatiblity (1a48f1b)
- Fix various py26 unit test failures (9ca5a14)
- Add initial contributing guide with docs build instruction (e55f915)
- Add docs building to tox.ini (3ee9e7f)
- Support NumPy's specialized int types in builtins.round (b4b54f0)
- Added r""" to the docstring to avoid warnings in python3 (5f94572)
- Add __subclasscheck__ for past.types.basestring (c9bc0ff)
- Correct example in README (681e78c)
- Add simple documentation (6c6e3ae)
- Add pre-commit hooks (a9c6a37)
- Handling of __next__ and next by future.utils.get_next was reversed (52b0ff9)
- Add a test for our fix (461d77e)
- Compare headers to correct definition of str (3eaa8fd)
- Add support for negative ndigits in round; additionally, fixing a bug so that it handles passing in Decimal properly (a4911b9)
- Add tkFileDialog to future.movers.tkinter (f6a6549)
- Sort before comparing dicts in TestChainMap (6126997)
- Fix typo (4dfa099)
- Fix formatting in "What's new" (1663dfa)
- Fix typo (4236061)
- Avoid DeprecationWarning caused by invalid escape (e4b7fa1)
- Fixup broken link to external django documentation re: porting to Python 3 and unicode_literals (d87713e)
- Fixed newdict checking version every time (99030ec)
- Add count from 2.7 to 2.6 (1b8ef51)

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Jan 5 15:41:04 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +4 -2 lines
python: egg.mk: add USE_PKG_RESOURCES flag

This flag should be set for packages that import pkg_resources
and thus need setuptools after the build step.

Set this flag for packages that need it and bump PKGREVISION.

Revision 1.7: download - view: text, markup, annotated - select for diffs
Tue Jan 4 20:53:07 2022 UTC (3 years, 3 months ago) by wiz
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -1 lines
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS

Revision 1.6: download - view: text, markup, annotated - select for diffs
Sat Dec 14 10:58:37 2019 UTC (5 years, 4 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +4 -4 lines
py-future: updated to 0.18.2

What's new in version 0.18.2:
=============================
This is a minor bug-fix release containing a number of fixes:
- Fix min/max functions with generators, and 'None' default
- Use BaseException in raise_()
- Fix builtins.round() for Decimals
- Fix raise_from() to prevent failures with immutable classes
- Make FixInput idempotent
- Fix type in newround
- Support mimetype guessing in urllib2 for Py3.8+

Python 3.8 is not yet officially supported.

What's new in version 0.18.1:
=============================
This is a minor bug-fix release containing a fix for raise_()
when passed an exception that's not an Exception (e.g. BaseException
subclasses)

What's new in version 0.18.0:
=============================
This is a major bug-fix and feature release, including:

- Fix collections.abc import for py38+
- Remove import for isnewbytes() function, reducing CPU cost significantly
- Fix bug with importing past.translation when importing past which breaks zipped python installations
- Fix an issue with copyreg import under Py3 that results in unexposed stdlib functionality
- Export and document types in future.utils
- Update behavior of newstr.__eq__() to match str.__eq__() as per reference docs
- Fix raising and the raising fixer to handle cases where the syntax is ambigious
- Allow "default" parameter in min() and max()
- Implement __hash__() in newstr
- Future proof some version checks to handle the fact that Py4 won't be a major breaking release
- Fix urllib.request imports for Python 3.8 compatibility
- Fix future import ordering
- Fixed bug in fix_division_safe fixture
- Do not globally destroy re.ASCII in PY3
- Fix a bug in email.Message.set_boundary()
- Implement format_map() in str
- Implement readinto() for socket.fp

As well as a number of corrections to a variety of documentation, and updates to
test infrastructure.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Oct 31 10:54:39 2018 UTC (6 years, 6 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3, pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +6 -8 lines
py-future: updated to 0.17.1

What's new in version 0.17.1:
This release address a packaging error because of an erroneous declaration that
any built wheels are universal.

What's new in version 0.17.0:
This is a major bug-fix release, including:
- Fix from collections import ChainMap after install_aliases()
- Fix multiple import from __future__ bug in futurize
- Add support for proper %s formatting of newbytes
- Properly implement iterator protocol for newrange object
- Fix past.translation on read-only file systems
- Fix Tkinter import bug introduced in Python 2.7.4
- Correct TypeError to ValueError in a specific edge case for newrange
- Support inequality tests betwen newstrs and newbytes
- Add type check to __get__ in newsuper
- Fix fix_divsion_safe to support better conversion of complex expressions, and
  skip obvious float division.

As well as a number of corrections to a variety of documentation, and updates to
test infrastructure.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Sep 4 18:00:52 2017 UTC (7 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1, pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Comment out dead sites.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Mon Feb 6 01:06:05 2017 UTC (8 years, 2 months ago) by markd
Branches: MAIN
CVS tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +8 -2 lines
Add version suffix to binaries to allow multiple alternatives at once.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Tue Jan 17 17:14:14 2017 UTC (8 years, 3 months ago) by fhajny
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -2 lines
Update devel/py-future to 0.16.0.

This release removes the configparser package as an alias for
ConfigParser on Py2 to improve compatibility with Lukasz Langa's
backported configparser package. Previously python-future and the
configparser backport clashed, causing various compatibility issues.

This releases also fixes these bugs:

- Fix newbytes constructor bug.
- Fix semantics of bool() with newobject.
- Fix standard_library.install_aliases() on PyPy.
- Fix assertRaises for pow and compile` on Python 3.5.
- Fix return argument of future.utils.ensure_new_type if conversion to
  new type does not exist.
- Add missing cmp_to_key for Py2.6.
- Allow the old_div fixer to be disabled.
- Improve compatibility with Google App Engine.
- Add some missing imports to the tkinter and tkinter.filedialog package
  namespaces.
- Fix raise_from on PY3 when the exception cannot be recreated from its
  repr.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Sun May 8 07:22:24 2016 UTC (8 years, 11 months ago) by wen
Branches: MAIN
CVS tags: pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Import wip/py-future as devel/py-future.

future is the missing compatibility layer between Python 2 and Python 3.
It allows you to use a single, clean Python 3.x-compatible codebase to
support both Python 2 and Python 3 with minimal overhead.

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>