Up to [cvs.NetBSD.org] / pkgsrc / devel / py-flufl.i18n
Request diff between arbitrary revisions
Keyword substitution: kv
Default branch: MAIN
py-flufl.i18n: fix PLIST for latest pdm Bump PKGREVISION.
python/wheel.mk: simplify a lot, and switch to 'installer' for installation This follows the recommended bootstrap method (flit_core, build, installer). However, installer installs different files than pip, so update PLISTs for all packages using wheel.mk and bump their PKGREVISIONs.
py-flufl.i18n: fixup wrong WHEEL_INFODIR
py-flufl.i18n: update to 4.1.1 4.1.1 (2022-09-05) Improvements to the GitLab CI integration. Several minor updates to work better with the latest pdm. 4.1 (2022-08-25) The standard substitution pattern now ignores the trailing dot on $-string placeholders. I.e. $foo. is now recognized as $foo. Update to pdm 1.3. Update dependencies. Make sure the doctest teardown gets run. Add support for Python 3.11. 4.0 (2022-01-11) Use modern package management by adopting pdm and pyproject.toml, and dropping setup.py and setup.cfg. Build the docs with Python 3.8. Update to version 3.0 of Sybil. Adopt the Furo documentation theme. Use importlib.metadata.version() as a better way to get the package version number for the documentation. Drop Python 3.6 support. Update Windows GitLab runner to include Python 3.10. Update copyright years. 3.2 (2021-05-29) Add a py.typed file to satisfy type checkers. Improve some QA by re-adding diff-cover, Gitlab SAST during CI, and testing on Python 3.10 beta (except for Windows) The master branch is renamed to main. 3.1.5 (2021-02-14) I blue it! 3.1.4 (2021-01-01) Update copyright years. Include test/__init__.py and docs/__init__.py 3.1.3 (2020-10-22) Rename top-level tests/ directory to test/ 3.1.2 (2020-10-21) Small documentation fix. 3.1.1 (2020-10-21) Fix the site-packages pollution. 3.1 (2020-10-20) Improve the documentation. Reorganized docs and tests out of the code directory. Fix the Windows CI job. 3.0.1 (2020-07-28) Fix pytest 6.0.0 compatibility Add CI for Python 3.9 on Windows 3.0 (2020-07-12) Drop support for Python 3.4 and 3.5. Add support for Python 3.9. Translator.catalog property is now exposed. New abstract classes for defining the types in this library: TranslationContextManager, RuntimeTranslator, TranslationStrategy When expand() gets an exception, the original exception is re-raised. This used to inadvertently return None. Add type annotations and API reference documentation. Other internal improvements.
*: bump PKGREVISION for egg.mk users They now have a tool dependency on py-setuptools instead of a DEPENDS
Rewrite PYTHON_VERSIONS_ACCEPTED to PYTHON_VERSIONS_INCOMPATIBLE
More packages wave bye-bye to python34 and python35
extend PYTHON_VERSIONS_ for Python 3.7
devel/py-flufl.i18n: Update to 2.0.1. 2.0.1 (2017-11-14) - Restore Python 3.4 support. 2.0 (2017-07-24) - Add _.defer_translation() context manager for marking, but not translating a string at the point of use. - Drop Python 2, 3.3, and 3.4 compatibility; add Python 3.5 and 3.6. - Switch to the Apache License Version 2.0 - Use flufl.testing for nose2 and flake8 plugins.
Import flufl.i18n 1.1.3 as devel/py-flufl.i18n. The ``flufl.i18n`` library provides a convenient API for managing translation contexts in Python applications. It provides facilities not only for single-context applications like command line scripts, but also more sophisticated management of multiple-context applications such as Internet servers.