[BACK]Return to distinfo CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / devel / py-flexmock

File: [cvs.NetBSD.org] / pkgsrc / devel / py-flexmock / distinfo (download)

Revision 1.11, Tue Nov 29 21:14:10 2022 UTC (16 months, 2 weeks ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4
Changes since 1.10: +4 -4 lines

py-flexmock: updated to 0.11.3

Release 0.11.3

Added

- Add PEP 561 `py.typed` marker file.

Changed

- Remove documentation and test files from wheels build.
- Re-organize unit tests.

Documentation

- Add a warning about the usage of `.new_instances()` method in the documentation.

Release 0.11.2

Fixed

- Fix subunit testrunner integration is broken.
- Fix: TeamCity (PyCharm) testrunner integration is broken.

Infrastructure

- Run tests with testtools, subunit, TeamCity, and doctest testrunners using tox.

Documentation

- Test flexmock API examples using doctest.
- Re-add Sphinx support for generating man pages.
- Fix 404 page not loading CSS and Javascript resources in documentation.
- Small fixes to documentation.

Release 0.11.1

Fixed

- Fix Zope testrunner integration is broken.

Infrastructure

- Run tests with Zope testrunner using tox.

Release 0.11.0

Added

- Add Python 3.8, 3.9, 3.10, and 3.11 support.
- Add type annotations.

Changed

- **BREAKING CHANGE**: Flexmock needs to be imported explicitly using `from flexmock import flexmock`.
 The hack that allowed flexmock to be imported directly using `import flexmock` did not work well with static analysis tools.
- Many error messages have been improved.
- Undocumented methods `Expectation.reset`, `Expectation.verify`, and `Expectation.match_args` that were unintentionally left public are now private methods.
- Undocumented attributes in `Mock` and `Expectation` are now private. These attributes were never meant to be accessed directly.

Removed

- Drop Python 2.7, 3.4, 3.5 support.
- Drop Pytest 4.x support.
- Remove unittest2 and nose integrations. unittest2 and nose are not maintained anymore.
- **BREAKING CHANGE**: Removed support for calling `once`, `twice`, `never`, and `mock` methods
 without parentheses. This allows code completion and static analysis to work with these methods.

Fixed

- Fix `should_call` is broken if called on a fake object.
- Fix `and_raise` allows invalid arguments for an exception.

Infrastructure

- Run linters and tests using Github Actions.
- Add coverage reporting using Codecov.

Documentation

- Add contribution documentation.
- Use Mkdocs instead of Sphinx to build the documentation.

$NetBSD: distinfo,v 1.11 2022/11/29 21:14:10 adam Exp $

BLAKE2s (flexmock-0.11.3.tar.gz) = 6d6f45a838fd23bfc9014cf75a6de220e7bc37042fb7fa12d29ab4a121d3790d
SHA512 (flexmock-0.11.3.tar.gz) = 38387529d8b7e359cf6e578c9be8ae028cd28929567267bce1bb7f44032c00480520335315bb1c510229728e1101aa379b809fb89aeddafd19590e38e7ebdcf2
Size (flexmock-0.11.3.tar.gz) = 52509 bytes